Introduction

Help >

Introduction

The Orion2 Manual is a complete document which have all the information regarding the product, accessories, installation drawings, instructions and software. It will teach you the do's and don'ts, installation tips and tuning guidelines. It has all the different product software and installation like ECU, TCU TxW etc.

Some drawings may refer to software settings to help a customer to select the correct settings. Each product has its range of features and are sold on different price levels for that reason. So do make sure there are firmware available for that type of connection before you install the system. See the ECU Program Numbers or TCU Program Numbers for features and hardware class reference.

Orion2 harnesses are developed for different applications and products. Each harness has a part number label that is placed at the connector side. This is important as drawings are made for specific harness and wire colours. Always make sure your drawing and harness match up. Each drawing will have its harness numbers in the top label. The manual is based on the E22, E33 and E36 harness which is the popular choice. Other harness options are displayed in the GP Priority sheet to verify colours. These harnesses are adopted from older products and are displayed to make backwards compatible colour tracing easy.

In the harness drawings you will also find a layout of each harness. Other drawings will explain each item as it is connected to the Orion2 controller.

If there is any confusion or lack of information, please let us know and it will be updated regularly. Always make sure you have the latest update from our Web. The date is part of the manual name.

Copyright © 2013. All rights reserved.


About the Manual

Help > Introduction >

About this Manual

The Orion2 Manual is a comprehensive informative manual which includes all the relevant information and drawings. Due to the type of product and functionality there is a lot of information, so please read the instructions below on how to promptly navigate to the section you require.

Always start with the Terms & Conditions of this product displayed in this folder. You need to know how this product is presented to the public should you have any queries later. It is also by Law that these T&C's must be visible and read by you and your valued customer. Failure to comply with this legislation may lead to legal action and/or undesirable complications.

Work through the Product Selection and understand the differences between the products and how to select the best one for your application. (See the Selection charts .) If you still have difficulty, please feel free to email us under Support found on www.spitronics.com and we'll be glad to assist you.

Note: It is detrimental that you start with the Safety Precautions for Orion2 before you begin installation. This will prevent unnecessary costs, mistakes and negligence and prevent time from being wasted. The FAQ came about from common mistakes that customers have made in the past. Remember these are electronic products and they can be damaged if not installed correctly and/or used in the prescribed manner.

How to use the manual.

Contents

This is the main contents list. All the information is categorized and speaks for itself. Browse through each section so you get a feel for where the information is stored.

Search

To find a subject, click on the Search tab and type the word, click on List Topics. Then click on the Items displayed and it will guide you to the specific document.

The Back key (or Alt+Left Arrow) will take you back to the previous view.

You may print parts of this document with the Print button.

These buttons will take you in and out of sub folders in the menu.

Quick Links

The last topic in the manual is Quick links . This may be the handiest page to find items quickly. each product firmware has its own links. The list is in alphabetical order. It has relevant Software or Hardware topics. When you click on a link it will open the manual on the relevant page. If you click on the [image] button then it will show you where it is in the list and you can view data from there.

Below some of the pages you will find related links to guide you to information that may also relevant at that stage or for that specific application. Use the Back key to go to the previous page. (See above links as example of the related links as explained.)


Getting Started

Help > Introduction >

Getting Started with Orion2 and Hyperspace Tuning Software

About the product.

Spitronics products are developed for the DIY market and are mostly sold through dealers and to handy customers in and outside the RSA boundaries. This makes it a more cost effective product as the company overheads are held to a minimum. Spitronics rather makes use of the extensive infrastructure of dealers that specialize in this type of business. The Spitronics devices are not plug & play devices but must be customized by the dealer for specific applications. These products are very versatile and can be adapted to most engines, transmissions etc. The dealer is responsible for after-sale service which is a third party company that Spitronics don't have control over. So make sure about the dealer service and capabilities before you buy from him. Spitronics is not responsible for poor service from him. Please read our terms and conditions found on our website. All the information, software and manuals are freeware on our website www.spitronics.com See also Compiling an ECU Product or Compiling a TCU Product for guidlines on putting the right firmware, product and drawings together.

How does Spitronics Products Work

Each Spitronics product is Micro based which requires specific firmware programs to initialize the hardware for each type of engine or transmission. It then has tuning Maps that adjust parameters and graphs for that engine or transmission. To alter the Maps, require tuning software, so that the tuner can adjust fuel and timing etc. for that application. The product needs to be activated before it will operate.

1. The firmware will initialize the hardware to work on a specific engine or transmission. This firmware is fixed code and is pre-loaded into the product with the Firmware Programmer or BootLoader. Only the manufacturer requires a programmer and from there on it use the Bootloader and normal USB tuning cable as illustrated in Step 1. The firmware files is freeware on our website and has the extension of .HEX for products that require a programmer and it has the extension of .FIRM for products with a bootloader. This process is illustrated in step 1 of Fig 1.

2. Spitronics developed an internet activation system to allow dealers abroad to carry stock at a reduced price. Then when the dealer sells to a customer, he will activate the unit in a specific hardware class according to the required firmware for that application. He will then do a payment for the rest of the amount. He will load the correct firmware and startup Map for the customer and guide him to the correct drawings and settings. He will test the unit on a simulator and verify that everything is in order as to assist the customer. This feature makes the product counter ready without the delay of ordering the product on demand. This procedure is illustrated in the steps of Fig 1.

3. The Hyperspace tuning software will allow the tuner to adjust his engine or transmission to his requirement. This could be performance, economy, automatic or tiptronic etc. This tuning data is saved in the product and also in a file called a data Map or a Tune with the extension .SPIECU or .SPITCU etc.

Block Diagram of Product interfacing

Step 1 - Programming

The dealer must program the relevant firmware file into the device. Orion2 use a bootloader and the normal USB tuning cable. The file extension is .firm and is downloaded from Spitronics website. It may also be supplied on a CD in the box.

Step 2 - Activation

The dealer must allocate the device for the customer on the Portal and then the dealer or customer must Assign the allocation to the device. The laptop must have internet connection to do the assign process.

Step 3 - Setting up

The dealer or customer must load a relevant startup map for the customer and then he can start setting up his device. Some startup maps may be on the website or can be supplied by the dealer.

What you need to get started.

1. The product hardware and accessories for the specific application. This will be the ECU / TCU, control modules such as idle control and Coil Igniters, harnesses, MAP sensors etc. for that specific application. The product is sold in different classes and priced according to the features and outputs used. There is a selection chart in the manual under Products indicating the different classes for different features. Or you may ask a dealer in your area or send a mail to sales@spitronics.com

2. The USB / UART communication cable to connect the device on to a laptop for tuning purposes. This cable is sold separate as you only need one for tuning all our products. The communication electronics is put in the cable which means the product becomes cheaper as each device does not require those components. This USB Cable has Windows drivers that needs to be installed before it will operate. See further in the manual for instructions.

3. The Hyperspace Tuning Software to interface with the products. The software is only Windows based and works on all versions. You need a Laptop of Tablet for this. The software is separate for each product to simplify operation.

4. A Startup map which helps with the setup of the specific engine. Each engine differs in minor changes so these MAP's still requires some refining. A MAP or Tune is a data file that is saved on the hard disk and differs for each type of engine. If you don't get a specific map for your engine, you may adapt any map to suit your engine.

5. The Orion2 Manual for explaining wiring and tuning. These manuals became bulky with all the information but once you browse through them you will get to your info quickly. They are available on the web and is updated from time to time.

Optional requirements.

1. The Bluetooth and Wi-Fi module. This is handy products to connect the device to dashboard products from third parties.

2. The Simulator helps dealers to setup and test customer's devices. It is recommended for the dealer that carries stock and help customers over the counter. The latest Simulator3 works on all our products with the exception of different connecting harnesses. Note that the product requires test firmware that works with the simulator.

3. The Firmware Programmer. Only required by the manufacturer to load the Bootloader.

Useful links and direction of info on the website.

The USB / UART communication cable.

·

·

·

· https://support.spitronics.com/downloads/

The Ver 3 Hyperspace Tuning software.

·

·

·

·

· Due to regular updating of software we will not include a link here. Select the software you require. ECU, TCU, TxW etc. The Read Me file has more information regarding the software. The link below will take you to the folder.

· https://support.spitronics.com/downloads/#download-filesTuning-SoftwareHyperspace-Software

The Orion2 Manual

·

·

· Due to regular updating of manuals we will not include a link here. Select the manual you require. The Read Me file has more information regarding the manuals. The link below will take you to the folder.

· https://support.spitronics.com/downloads/#download-filesManuals

The Firmware Programmer (USB Debug Adapter)

·

·

·

· https://support.spitronics.com/downloads/#download-filesFirmware-ProgrammerBootLoader

Installation of Software, Drivers and Manual

Manuals

Orion2 Manual

Select the manual. The browser should download the Manual in the downloads folder on your PC. Sometimes the antivirus programs will block the content of HTML files or ask you if you want to keep the content. Say yes to keep content. The file is compressed with WinRAR which is freeware software. Un-compress the file. If you open the file and the data is not complete, close it and right click on the manual icon, and give it permissions to open the data. Again this is a windows virus protection feature. Then open the file and it should look like this:

USB Drivers

The browser should download the drivers in the downloads folder. The drivers file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a folder created as below.

Go into the folder and you should see the following.

If you have a 64bit computer then run the file called

For 32bit computer run the file called

After you installed the driver plug the USB /UART cable into the computer and the cable will be activated. In the device manager you should see the block below in com ports. This means the drivers are installed correctly.

Tuning Software

Select the software you require. The browser should download the file in the downloads folder on your PC. The file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a file created as the example below.

Run the file and Hyperspace will be opened.

After it is opened and indemnity was done as well as manuals opened in the software you should end up with a file set like below:

The Hyperspace software can detect if you open the wrong software type or version and then open the correct version for you instead. This requires that you do install all your software in the following structure.

Then you need to use sub folders like below:

Firmware Programmer

In the manual is a complete description of how to install and operate the Firmware Programmer. Again very important is the Precautions. Read them carefully. Never press the Erase All Code Space button. It will render the product useless and it will have to be returned to the factory. Below is a screen shot of where you can find it in the Hyperspace ECU Manual.

Connecting a Product to Hyperspace for the first time.

By now you should be familiar with the product and information around it. The chapters you should read before attempting to install is the Safety Precautions . This will help to prevented making the obvious faults that could damage the unit or components of the engine. Below is a screenshot where you can find it in the Orion2 Installation manual.

Always follow the Startup Procedure step by step as it is explained in the manual. Do not attempt to take shortcuts and try to start. If you missed some points in the setup, the ECU or engine components could be damaged. Each Product differs and has its own unique way in the Startup Procedure. Each point is numbered and you can reference this number to the dealer to ask him for advice. If the number does not function correctly do not go further until it is solved. Failing to do so may damage the unit and inflict repair costs for your account. Below is a screenshot where you can find it in the Hyperspace manual.


Abreviations

Help > Introduction >

Abbreviations

AC Alternating Current
AFR Air to Fuel Ratio
ATDC After Top Dead Centre
Basic Coil Coils without Built in drivers
BDC Bottom Dead Centre
BTDC Before Top Dead Centre
CAS Crank Angle sensor
COP Coil On Plug
DC Direct Current
DP Differential Pressure
Drv Driver
ECU Engine Control Unit
EFI Electronic Fuel Injection
EGR Exhaust Gas Recirculation
EGT Exhaust Gas Temperature
F/S Full Sequential
GS Galaxy Software
GP General Purpose
HOME Pulse on a camshaft sensor that comes once every second revolution
HS Hyperspace Software
HT High Tension (spark plug leads)
HV High Voltage
IAC Idle Air Control
IAT Intake Air Temperature
Imp Impedance
Int Internal
MAP Mean Absolute Pressure
N/C Not Connected
NOS Nitrous Oxide System
OEM Original Engine Management
PWM Pulse Width Modulation
RPM Revolutions Per Minute
Seq Sequential
Smart Coil Coils with Built in drivers
TCU Transmission Control Unit
TDC Top Dead Centre or Pulse on a crank that comes once every revolution
TOT Transmission Oil Temperature
TPS Throttle Position Sensor
TSS Transmission Speed Sensor
TxW Throttle by Wire
V Volt
VE Volumetric Efficiency
VSS Vehicle Speed Sensor
VVT Variable Valve Timing
VVT-I Variable Valve Timing with Intelligence
VVTL-I Variable Valve Timing with Lift and Intelligence

WOT Wide Open Throttle

W/S Wasted Spark


Terms & Conditions

Help > Introduction >

Click on the link below:

Terms & Conditions


Product Selection

Help >

Orion2 is a low cost Engine Control Unit (ECU) or Transmission Control Unit (TCU) which replace the whole of our economy range products. With slight changes in some harnesses it is backwards compatible with all the ECU range products. It has negative, positive and coil drivers to cover most applications and reduce costs. It can connect to most sensors found on engines and transmissions. The biggest advantage is that it has a bootloader and firmware can be downloaded with the tuning cable. No special firmware programmer is required. See Compiling an ECU Product for guidelines on putting the right firmware, product and drawings together.

See the sub folders for more details.

Orion2 Overview

Orion2 Features

Orion2 Specifications


Orion2 Overview

Help > Product Selection >

Orion2 Overview

This versatile Automotive Controller is designed to be a low cost durable effective replacement for high tech Vehicle Electronic Units. It can be used on most engines, transmissions and other products in the motor vehicle industry. It uses unique and easy features which are easy to install and tune. It is designed with the novice and professional installer in mind.

This universal South African made product can easily be customized for various engines, transmissions etc. It can be used for many applications such as racing engines, vehicle conversions, custom built vehicles, replacement parts for production vehicles etc. It is a compact reliable system which can be epoxy filled to make it rugged and water tight for harsh environments and is easy to mount in the driver's compartment.

The Orion2 can be reprogrammed remotely by a software bootloader. No need for expensive equipment like programmers or separate cables. This will allow a dealer to have less inventory on his floor and customize this product on demand. This product is also sold in different classes which makes it more viable to use for smaller applications. It may also be bought at reduced prices in un-activated status. This will allow the dealer to have better control over his cash flow management in his business. Activations of features can be done over the internet making the unit viable to keep in stock at dealers. Activation will then require the rest of the unpaid amount.

The Orion2 unit is designed to connect directly to most sensors and drive units that is found on engines, transmissions and other products. No need to modify them. It consists of the latest in high speed micro controllers with surface mount technology. These units are machine soldered to minimize human error.

The Orion2 cover features like Lambda control, idle control, launch control, Anti-Lag Control, Flat Shift control, Rapid Fire Exhaust Control, cam control, stepper motor control, throttle by wire control, boost control, line pressure control, tiptronic and lots more. It can drive basic coils, smart coils, injectors, solenoids, throttle by wire motors etc. directly. Due to the versatility some devices may require external resistors or diodes which is supplied with the Orion2. It can read signals from sensors like water & air temperature, throttle position, manifold pressure, crank angles, cam angles, lambda, fuel pressure etc. directly.

The Hyperspace tuning software is user-friendly and makes all the above features customizable by the tuner. This makes the Orion2 adaptable for most applications on site.

To learn more about this amazing package browse through the features and specifications in the sub folders.


Orion2 Features

Help > Product Selection >

Orion2 Features

Note that these are all the current features covered by the Orion2. There are some on the charts that is in the process to be developed in the future. The hardware has the capability for it. Also note that not all of the features may be included on the same unit as there are a limited amount of drivers available. Some of the hardware classes may not include certain features due to the price range. See the selection chart for the ability of the different classes.

Fuel Delivery

· Accurate fueling such as Batch, Split Batch, Split Sequential and Full Sequential injection gives better performance and fuel consumption due to constant atomization on each cylinder.

· Fueling is done in graph or matrix method for the tuners preference.

· All graphs or matrix data are interpolated to smooth fuel calculation accuracy for best performance though the operating ranges.

· Fuel is calculated with MAP sensor or TPS sensor versus RPM signals or a combination of the 2. This will accommodate most engines ranging from street to racing and from economy to performance.

· Other sensors that are used to alter the fuel mixture are Water, Air, Altitude, Lambda, Fuel Pressure, Battery Volts and throttle response.

· Fuel injection timing is adjustable on gear type crank angle sensors as low as 12 pulses per revolution.

· Adjustable MAP sensor reading angle on gear type crank angle sensors for multiple throttle body systems.

Ignition Spark & Timing

· The ECU can do Single, Wasted Spark Coil pack and Coil On Plug (COP) Full Sequential Spark Systems

· It use the standard coil packs on the engine.

· Can be connected to most coils with or without internal drivers directly. No pull-up resistor required.

· Very accurate ignition timing especially with the gear type triggers.

· Timing is calculated with MAP sensor or TPS sensor versus RPM signals or a combination of the 2. This will accommodate most engines ranging from street to racing.

· Other sensors that is used to alter the Ignition Timing is Water, Air and Altitude.

· Battery Volts is used to compensate for coil charge time.

Sensors

· The ECU use most standard sensors on the engine No need to do modifications on distributors or converter boards.

· Custom Bolt-On Timing Gears may be used for older engines that run carburetors or engines with incorrect setups. Gear type triggers do make timing more accurate and responsive during blip conditions. This is the preferred method for racing applications.

· Sensors can be calibrated to accommodate the different types found on the engines.

Idle Control & Cold Start - This functions will ease with starting a cold engine and keep the RPMs constant when air conditioners or automatic transmissions draw power from the engine. Idle control is included on board for one and two wire idle valves. The Spitronics stepper control units can be connected to control quad and bipolar stepper motors.

Launch Control - This feature will increase boost pressure during pull-off to eliminate Turbo Lag. Various methods are available to activate launch like buttons clutch switches TPS position etc.

Launch Delay Recover - This feature will restore full power with an increasing ramp delay which will help the vehicle with traction control during launch.

Dual Injectors - The Orion2 has positive drivers that can be used to activate duel injectors with the help of the electronic relay from Spitronics. Fuel can be added bay Ratio which is always available and then also by another fuel graph that is available for 4 cylinder engines.

Anti-Lag - During deceleration this feature will retain boost pressure to be readily available for accelerating again. It uses the same principle as Launch control except it also has an output to activate a bypass valve for the task.

Rapid Fire - This feature will make a bang-bang sound in the exhaust for excitement during the launch features. The frequency is adjustable for different sound effects.

Flat-Shift - This feature will momentarily cut spark to allow faster shifting of gears.

Dual Maps - This ECU can be tuned for 2 different fuel and performance setups. Ideal for the weekend racing enthusiast. On TCU there is 4 maps available.

Map Change on the fly - This feature will allow the driver to change to a different map during driving.

General Purpose Outputs - This can be used for injectors, fan control, shift light, Aircon Cut-Out on Pull-Off or Up-Hill etc. The amount of GP outputs varies between firmware and features activated on the device. All drivers that is not used by the firmware will be available as General Purpose Outputs.

Connection Layout Print - This feature will allow the dealer to print a layout of the connections of the Orion2 after he set it up in software. It will help new customers to finish their wiring with less time.

Standard Harness - No need to keep several harnesses in stock for different engines. There are however custom harnesses for certain engines that will ease installation time. All the input wiring harnesses use screened cables for neatness of installation and to prevent electromagnetic interference which may cause erratic behavior of the ECU. On the TCU we have slight variations in the Add-On boards to accommodate the different transmissions.

Internal 3Bar Map Sensor - This optional sensor can be added to use as Altitude sensor or internal Map sensor. It may save cost and time to do connections to an external map sensor.

Compact Electronics - This will make the Orion2 easy to install under the dashboard as it takes very little space. It is also very suitable for Motor Cycles and boats.

Complete Kits for Most Engines and Transmissions etc.

Cost Effective - No need to buy expensive systems as all the necessary features are included with the Orion2.

Rotary Systems - The 2 rotor engines are covered by the Orion2.

Dynamic Injection Angle - This feature is for Rotary engines where the injection angle is adjusted during rpm change. It has 2 graphs for 360° for Primary and Secondary injectors to adjust separately.

External Map Sensor is easy to change between 1Bar, 2.5Bar, 3Bar & 4Bar configurations External sensors are used to reduce the delay in the vacuum signal. It makes the ECU more versatile to adapt to standard MAP sensors found on engines. OEM map sensors can be used and calibrated under the Custom selection.

Altitude Compensation - This feature is important as the ECU will automatically compensate for differences in pressure. The Sensor is optional and must be soldered on the board when it is ordered.

Critical Settings Warning - With Orion2 all the settings that may change wiring connections are now protected by a warning so that the tuner may not accidently change the setup of the device.

Standard Tuning Software - The features that is not used or allowed in the tuning software will be blanked out.

Easy DIY Instructions - Save a lot of money on installation if you are a person who is up to the challenge.

Start-Up Maps included - This will make for easy start-up & tuning with the help of a Lambda sensor

User Friendly - Tuning Software which is extensively explained in the manual.

Tuning map can be locked to prevent tampering. Useful for engine builders who give guarantees.

No Dyno Required - Tune your own vehicle and save some more money. Just following the instructions in the manual carefully with the use of the Hyperspace Data logger.

(Note that the last four points are for the person who is handy with tools and understand wiring and operation of an engine. If you are not sure, download the software, Map, manual and drawing and experiment with it first. It's free of charge!)


Orion2 Specifications

Help > Product Selection >

Orion2 Specifications

Power Supply

12V Ignition power 200mA, filtered by reverse polarity Diode, 700mA Poly switch and 25V Tranzorb

2.5mm2 Earth Strap

12V Driver Power up to 14 amps depending on power used by items driven.

Fixed Inputs

2x Digital Inputs for Magnetic, Hall or Optic sensors. (Jumper selectable)

3x Analog Input 0-5V (May be used by firmware as digital)

1x Built in 3 Bar MAP Sensor input 0-5V (Optional. Sensor is sold Separately)

1x Water Temperature Input 2K NTC Resistance Sensor with 1K pull-up resistor Jumper selectable

1x Air Temperature Input 10K NTC Resistance Sensor with 7K5 pull-up resistor Jumper selectable

3Pin USB D-Bug Connection

Fixed Outputs

4x 18A 500V Ground / Floating output

4x 6A 36V +12V / Floating Overcurrent Protected

5x 19A 41V Ground / Floating

1x 19A 41V Ground / Floating, 1K pull-up resistor to 12V Jumper selectable

5V 600mA Power Output for TPS & Map Sensor and Magnetic Pickups

General Purpose I/O

These GP I/O can be used as one of the following features. Note that they are software selectable and requires Jumper settings on the board.

I/O 1

18A 500V Ground / Floating output

Digital Input to Ground

Analog 0 to 5V with 10K Pull-up to 5V

Serial Bus1

I/O 2

18A 500V Ground / Floating output

Digital Input to Ground

Analog 0 to 5V with 74K Pull-up to 5V

Serial Bus2

Communication

Software UART Connection via USB2 converter cable

Universal Serial Bus (Optional)

Bootloader installed for firmware programming via the USB cable

Dimensions

Size 144 x 68mm x 22mm

Weight 187g Non Resin filed *

5 x Connector Type Plastic Molex 12, 10, 8, 6, 4

* This unit can be resin filled. Weight will increase depending on the type of resin.


Backwards Compatibility

Help > Product Selection >

Backwards Compatibility

This document highlights all the factors to consider when using Orion2 on older product harnesses such as Orion, Saturn, Pluto2, Pluto, Venus and Titan. Orion2 was developed with new technology and is an improvement on Orion. It can cover more engines and transmissions with the extra features. In most cases it is backwards compatible with Orion except when it comes to coils. See the notes below.

Neptune2 was also discontinued due to Orion and Orion2 that can now do TCU as well. However, the harnesses and drivers are too different to be backwards compatible. Neptune2 is no longer sold.

Basic Coils (No Drivers)

On most firmware Orion2 will drive basic coils without external drivers the same way as the older products. Orion has a total of 6 HV coil drivers. 2 are shared with inputs like Dual map and Potentiometer input.

Saturn had 6 high voltage coil drivers that were used in combination with injectors where Orion2 has 4 HV drivers and 2 low voltage high current drivers on those same pins. Injector drivers are smaller and less expensive and perfect for injectors. The downside is that if a program used more than 4 coils then the coils must be connected on two other pins. There was very few firmware for Saturn like the Spark only ECU. It could drive 6 coils.

Smart Coils (Built in Drivers)

For coils with built in drivers there is no drop in replacement. Orion2 use 4 positive drivers to drive intelligent coils directly don't require 220 ohm pull-up resistors. If you select Basic Coil or Smart Coil this will move the coil connections to different pins on the Orion2. On Saturn and older products, it would use the same pin but invert the signal. You also need to add a Clean Power relay to bring power into the Orion2 to supply the positive drivers. Do not use the coil relay as it may damage the drivers. See the drawings for wiring of the relay.

Injectors

Orion2 can drive 4 Injectors by using the 2 GP outputs on the P2 connector. When you select Smart Coils then injectors are moved to the more robust HV Coil drivers. There are also 4 GP outputs in total like Saturn. Some firmware did use this connection method but driver placement may be different. Confirm with the drawings and GP layout that you are on the same connections.

Power

Due to the difference in driver voltage it became important to add a 6 Amp diode on the power relays from pin 87 to earth to prevent driver damage. See the wiring diagrams for details.

Jumpers

Orion2 and Saturn jumpers sit in the same position but the Hall/Magnetic selection is swopped around. This made PC Board layout better but it catches old Saturn customers out. Do make a note when you set up a box for a customer.

Harnesses

Orion2 are sold with the latest design in automotive harnesses. Older harnesses became obsolete and are not featured in the manual. If you use Orion2 on older harnesses, then compare drawings in the old manuals to the Orion2 drawings to verify wire colours.

Firmware Programmer

Orion2 has a BootLoader and does not use the USB Debug Adapter to load firmware. It is now done via the USB cable.


Orion2 Ver 3.6A Changes v/s Orion Ver3.5B

Help > Product Selection >

Orion2 Ver 3.6A Changes v/s Orion Ver3.5B

Orion2 is a big improvement over Orion. It has 4 more outputs from the processor due to the flash memory that is not used anymore. This let us use the 4 Positive drivers separately from the 4 Coil drivers. The other big improvement is new software Ver 3.6A which addressed new features and terminology for better understanding of the product. Below follows a list of changes. If you knew the older Orion well this would be a good document for you. The new Orion2 manual will hold all the information in more details.

Coils

The biggest hardware change is coils. On Orion there were 4 Positive and 4 Coil drivers that shared the same output from the processor. This mean they could not be used separately. If you had Basic coils, then you connected them to the Coil drivers and if you had Smart coils then you connected them to the Positive drivers. This means there were 8 pins on the Orion occupied where only 4 could be used at any one time. This was an improvement over Saturn which used the same Coil drivers for both applications. The software then inverted the signal for Smart coils and you had to wire in a pull-up resistor for the coils. The drivers or coils were damaged if you had this setting wrong. On Orion2 we can now use all 8 drivers separately resulting in more functions that became available like Cam Control, Anti-Lag valve output and full sequential injection and spark control on 4 cylinders.

The names distinguishing coils has changed. The best we could come up with that has short names is Basic and Smart coils. Basic is coils without drivers and Smart is coils with built in drivers. Dumb or Intelligent coils is not recognized in the international market and is not correct either. Electronic names is Passive and Active coils but that is not familiar either.

Injectors

On Orion2 injectors is moved between the low voltage Negative drivers and the high voltage Coil drivers. If you connect Smart coils, then it means that the Stronger Coil drivers is available. Then Injectors is moved to these outputs. The drawings are marked as Option2. If you use Basic coils, then it means the Coil drivers are occupied and the injectors is placed on the Negative drivers and the drawings are called Option1.

Ultimate Firmware

The requirement in the market made us decide to add Ultimate features of Mercury2 on Orion2. Keep in mind it has less drivers so it may not have all features for 6 and 8 cylinder engines. Depending on features used it may be limited due to drivers. Below is a list. The Orion2 will suit 4 Cylinder engines perfectly as there are enough drivers to do full sequential injection and ignition. It also saves the customer a lot of money due to the built in coil drivers. Fuel Control of Mercury2 could not be added due to the lower amount of drivers and inputs required.

· Full Sequential Fuel - 4Cyl Only

· Injector Trimming - 4Cyl Only

· Full Sequential Spark - 4Cyl Only

· Launch Timing to 30° ATDC

· Launch Delay

· Flat Shift

· Anti-Lag with Output for EGR Valve

· Micro Fuel or Dual Injectors

· 2x Cam Control

· Output Layout Print feature for wiring connections

Speed

The Orion2 Processor runs 40% faster than Orion. This is needed for the extra features.

Drivers

The four positive drivers can now operate independently from the HV coil drivers. This means Orion2 has effectively four more drivers for output functions.

Orbit

Orion2 can house an optional orbit on board. It will come in effect with future development.

Dead band

The injector offset is now used for injector dead band. This value will add injector time at the end of calculations to compensate for the time it takes to open and close the injector. It will not affect the total real-time value displayed on the software. So make sure it is zero if you don't use it. The big advantage of this is for Altitude compensation. On older versions altitude compensation took dead band into calculations and caused a slight error by going leaner at higher altitude. The dead band value is now also added on Micro Fuel graph where previous versions did not have it.

Fuel accuracy

There is a small change in fuel accuracy so that tuned values and displayed values are accurate. This means that if you do upgrade from older map you may need to adjust fuel slightly.

Lambda read range

The read range is increased from 1000 - 6000 RPM to 500 -15000 RPM. This will help cars with wide band Lambda sensor to compensate through the whole range.

Check Limits

A limits check in the firmware were added to ensure that out of bounds values are forced for each firmware type at start-up. This will have no effect on tuning. This feature will fix values that are out of speck when you load new firmware even before the software is connected.

Minimum charge time

This value was effected by the charge time compensation graph. Which means your min time could be less than the value set on the software. It is now fixed. It should not affect any maps as nobody use a negative coil charge compensation for battery voltage.

Injection Angle

The Injection teeth setting will now advance injection timing from engine TDC for 360 or 720 degrees. This is more understandable to the tuner. The old system retarded injection timing from the slot or TDC pulse for 360 or 720 degrees. Do note that injection teeth are adjusted in the same degrees as the gear's pitch. Ex 10 degrees for 36 tooth gear. You may need to change this value if you used an older map.

Rotary Adjustable Injection Angle Graph

Two graphs are implemented on Rotary firmware to change the injection angle with RPM changes. One graph for Primary injectors and one graph for Secondary injectors. The primary graph is activated when the normal Injection Teeth setting is set to zero. The secondary graph will come on when you put Micro Fuel on Graph.

Accelerator pump Prime pulse

A change was made here that will help with full sequential injection. If the accelerator pump is activated it will pulse all the injectors once for the same value as the ACC Pump Enrichment setting. The advantage is that fuel is more readily available for cylinders that was pre calculated. This should address the flat spot issue when you blip the engine. It works with TPS and MAP settings.

Anti-Lag

An output was added for an EGR valve. This valve will be activated when Anti-Lag is activated and will enable bypass air from the turbo to be added in the exhaust to enable the fuel to burn. It is only available if the driver is available and deal maps selection are not used.

Graph Map and Matrix TPS

On Graph Map and Matrix TPS selection the compensation range on the boost graph were increased from 250% to 500%. This will cater for high boost engines above 2.5 bar boost.

Matrix Software Interpolation

In the software you can now select a block in the matrix and let the software interpolate the 4 corner values to assist in setting up a map.

MAP and ALT sensors

A 3 Bar sensor must be soldered onto the PC board for Altitude. If you do a MAP/ALT Swop, then you must add a 2.5 Bar sensor external for Altitude.

Prime Pulse

Full sequential prime pulse will only come once Home pulse is established. This will have the fuel ready once cam degrees are established. For split sequential the prime pulse is activated when the crank trigger detects crank movement.

Idle Valve

When the TPS is in run mode the idle valve will be kept open same value as the Minimum Duty opening. Previously it fell shut. This will assist in preventing the engine from stalling during blip conditions.

Critical Settings

All the critical settings that will make wiring differences are marked with a warning sign, and when you click on them a warning message will indicate that you are about to change the wiring of the unit. If it is on a live engine you may break things in the ECU or engine. This feature allows the Orion to move drivers around to cater for extra features.

Wiring Layout Print Function

When you finished to do the setup of the ECU you can now print a layout from the software which will then indicate which driver to use for each item. This will help installation considerably due to the many different connection options. This is an Excel spreadsheet and can be copied over the wiring color information sheet.

Coil Charge time when cold

The coil will now stay on max charge time until the engine reaches 60°C. Before it looked at the water graph and stay at maximum charge time until fuel enrichment was below 5%. Problem came when you enrich the mixture at high temperature to cool the engine off. Then timing will go to max and heat up the coils.

Errors

Many new error numbers were implemented. See the manual for a description.


Orion2 Aplication Selection

Help > Product Selection >

Orion2 Application Selection

The Orion2 can be used in many applications like ECU, TCU, TxW etc. It is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the Internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. Harnesses for different applications will vary so the selection section will guide you on what and how to combine.

See the sub folders for more information.

ECU Application

TCU Application

Other Applications


ECU Selection

Help > ECU Engine Managment >

Orion2 ECU Selection

The Orion2 is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance, Ultimate, Commercial and Racing. Not all the products have firmware for all the hardware classes but if a product has n higher hardware class, then all the lower firmware classes will operate on it.

In the sub folders are charts for each product with guidance to what each class can do. To be more secure look at the firmware available for the Orion2 and which class is required. Or speak to one of our dealers. Blow is a link that take you to the list on the firmware.

ECU Program Numbers

Note that the Program Number list compare Mercury2 vs Orion2 features. Below is a sample entry in the list.

You can click on the program number (28) if it is blue. This means that firmware is developed for Mercury2 or Orion2 or both. This will open a feature comparison chart between Mercury2 and Orion2 and then also a hardware class comparison for each product. The Red and Green X indicates for which product the firmware is available. If the block is gray, then it means that product will not have that firmware. If it is open, then firmware may be developed in the future. See below.

If you click on the red or green hardware class (Ult / Adv / Int) in the list it will open the GP Priority Layout for that program. This will indicate where each input and output is connected to the device because it differs for each firmware program. It will also show harness colors for the standard harnesses supplied. See example below:

Wire Colors |  |  |  | Software Selectable |  |  | Orion2 4Cyl Layout |  |  |  | Software Selectable |  |  |  | Wire Colors
 |  |  | Sim leds | Pr3 | Priority2 | Priority1 | Pin Name |  |  | Pin Name | Priority1 | Priority2 | Pr3 | Sim leds |  |  |
 | E24 CR-Only | E22 CR+TDC |  |  |  |  | P1 - 12 Way Input |  |  |  |  |  |  |  | E24 CR+TDC | E24 CR-Only |
 | Green | Green |  |  |  |  | Water Temp | 7 | 1 | Air Temp |  |  |  |  | Yellow | Yellow |
 | Red | Red |  |  |  |  | Lambda | 8 | 2 | TPS |  |  |  |  | Blue | Blue |
 | Red | Red |  |  |  |  | .+5 Volt Out | 9 | 3 | MAP |  |  |  |  | Blue | Blue |
 | Red | Red |  |  |  |  | .+12 Volt Ign | 10 | 4 | GND |  |  |  |  | Black | Black |
 | N/C | Yellow |  |  |  |  | TDC Sensor | 11 | 5 | TDC Power |  |  |  |  | Blue | N/C |
 | Blue | Green |  |  |  |  | Crank Sensor | 12 | 6 | Crank Power |  |  |  |  | Red | Red |
 |  |  |  |  |  |  |  | Internal |  | 3Bar Alt Sensor | Altitude Sensor | Map Sensor |  |  |  |  |
E33 Adv | E32 Std | E31 No Rel |  |  |  |  | P2 - 10 Way Output |  |  |  |  |  |  |  | E31 No Rel | E32 Std | E33 Adv
Black/Red | Black/Red | Black/Red | N5 |  | Inj Drv 1 | Basic Coil Drv 1 | Coil Negative 1 | 6 | 1 | Coil Negative 2 | Basic Coil Drv 2 | Inj Drv 2 |  | N6 | Black/Purple | N/C | Black/Purple
Black/Brown | N/C | Black/Brown | N7 | GP5 | Inj Drv 3 | Basic Coil Drv 3 | Coil Negative 3 | 7 | 2 | Coil Negative 4 | Basic Coil Drv 4 | Inj Drv 4 | GP6 | N8 | Black/Orange | N/C | Black/Orange
Black/Yellow | Black/Yellow | Black/Yellow | N2 | GP4 | Cam 1 | Inj Drv 2 | Negative 2 | 8 | 3 | Negative 1 | Inj Drv 1 | Cam 2 | GP3 | N1 | Black/White | Black/White | Black/White
Green | Green | Green | RPM |  |  | RPM Out | Negative 4 | 9 | 4 | Negative 3 | Relay Out |  |  | Relay | Blue/Black | Blue | Blue
Blue/White | Blue/White | Blue/White | N4 | GP2 | Idle Valve | Inj Drv 4 | Negative 6 | 10 | 5 | Negative 5 | Inj Drv 3 | Dual Idle | GP1 | N3 | Blue/Orange | Blue/Orange | Blue/Orange
 |  | E36 |  |  |  |  | P3 - 8 Way Output |  |  |  |  |  |  |  | E36 |  |
 |  | Red/White | P1 |  | Idle Vlave | Smart Coil Drv 1 T | Positive 1 | 5 | 1 | Positive 2 | Smart Coil Drv 2 T | Dual Idle | Cam 2 | P2 | Red/Yellow |  |
 |  | Red/Orange | P3 | GP7 | Cam 1 | Smart Coil Drv 3 T | Positive 3 | 6 | 2 | Positive 4 | Smart Coil Drv 4 T | Micro Fuel | GP8 | P4 | Red/Green |  |
 |  | Red |  |  |  |  | .+12 Volt In | 7 | 3 | .+12 Volt In |  |  |  |  | Red |  |
 |  | White | GP1 | GP9 |  | Anti-Lag | Coil Negative 5 | 8 | 4 | Coil Negative 6 |  |  | GP10 | GP2 | Blue |  |
 |  |  |  |  |  |  | P4 - 4 Way Serial |  |  |  |  |  |  |  |  |  |
 |  |  |  |  |  |  | SDA | 3 | 1 | SCL |  |  |  |  |  |  |
 |  |  |  |  |  |  | .+5 Volt Out | 4 | 2 | GND |  |  |  |  |  |  |
 | P05-P3 | USB |  |  |  |  | 6 Way USB |  |  |  |  |  |  |  | USB | P05-P3 |
 | Green | N/C |  |  |  |  | Tuning Pot | 4 | 1 | Dual Map Sw |  |  |  |  | N/C | Yellow |
 | Yellow | Yellow |  |  |  |  | Receive | 5 | 2 | Transmit |  |  |  |  | Green | Green |
 | Red | Red |  |  |  |  | .+5 Volt Out | 6 | 3 | GND |  |  |  |  | Blue | Blue |

This Sampel is a bit too large to be displayed with all the relevant information and can be seen under GP Priority Layout for more details.

See the sub folders for more information.


Compiling an ECU Product

Help > Product Selection > Orion2 Aplication Selection > ECU Application >

Compiling an ECU Product

This document guides you to put a working product together from scratch. It will link you to the sections in the manual that your application requires, and how to set the product up correctly and print the relevant drawings for that installation. This legwork will save you or your customer time and eliminate lots of support calls. As this is a DIY product, the dealer must do this for his customer. If you carry stock then you will do it when the customer request a specific system.

Selecting a Product

There are 2 Spitronics ECU products currently in production namely Orion2 and Mercury2. Each one has Pro's and Con's and it is wise to take time out to know the differences. Selecting the wrong one may affect the price or the features that is required. Each ECU has its own manual and the Product Selection of its manual is the section to read for this information. You may also look at the ECU Comparison Chart and ECU How to Choose section. Note that these documents are the same for both manuals.

Choosing Firmware

After you have decided on the product type then read this section in that products manual. If you are choosing Orion2, then you are in the right place.

Now you will need Engine Information from the customer to decide which firmware must be used. Firmware are developed according to the crank and Cam sensor patterns. So you will need to know what senor pattern on the engine is like 60-2, 24+TDC etc. Second parameter required is number of cylinders. Firmware are also grouped in cylinder categories.

Now you can view the Program Number Chart and see if firmware exists for that product. Orion2 does not have the amount of inputs that Mercury2 has so it may be that it is impossible to run such engines with it like the V12 and other complex engines.

In the Program Number Chart, you will find the Firmware Features according to its hardware class and the GP Priority Layout for that specific firmware. Orion2 Selection section will explain this chart and how to get the relevant information from it. With this information you know if firmware exists and what hardware class is required as well as how the ECU connections are laid out for that firmware. Remember different firmware will have different connections to the ECU.

Example of Firmware Features 28

Example of GP Priority Layout Adv / Int

You can also view the Orion2 GP Priority Layouts on a combined section for easy comparison on wiring.

To program the Orion2 ECU see the BootLoader section.

Printing documents

Installers prefer drawings on paper as they can make notes on customising and different wire colours etc. Also mark what is not used and what is already done. Note that this document only guides you on connections and does not have OEM specific drawings of sensors etc. For that you will have to consult the Service manuals.

Crank and Cam Sensors comes in different types and connections. See Crank and Cam Sensor Options . All the options are on one page so mark the correct one for the customer.

The other Sensors on an engine have a connection diagram and description for each one. This is like water and air temperature sensors, TPS, MAP etc. Do go through them and print and mark what is relevant to your install. There are plenty of wiring options to activate different firmware features. On some of the drawings are also software settings that instruct the firmware on the type of wiring you have selected. See the right hand bottom corner of this Drawing example.

Coils are sorted by number of cylinders for easy grouping. Then they are grouped in 2 main groups like Standard or Dumb Coils that have no built in drivers, and then Intelligent Coils that has built in drivers. Then They are grouped according to coil types namely Single, Wasted Spark or COP coils. Take care to understand the differences and then select the correct drawing to print. There are settings of what the software must be selected for the specific drawing.

Injectors are sorted by number of cylinders for easy grouping. Then they are grouped according to low or high impedance. The connection for low impedance differs as their resistance is too low to be connected directly. They may also be connected in Split or full sequential configuration.

Other drawings you may need are Idle Control, General Purpose Outputs and Tachometer.

Precautions and Installing

Before attempting to start an install it will be wise to read the Precautions . This section outlines general wiring mistakes customers make that will cause operation problems like interference later.

Start-up

When you start an engine for the first time do follow the Start-Up Procedure. This will take you step by step through the process of checking everything. In some cases, you may damage a unit if your setup in the software does not match your wiring on the engine. Drivers from the ECU may have different tasks. Then it may not be controlled in the right manner. You may over fuel a cylinder resulting in a bent con-rod etc.


ECU How to Choose

Help > Product Selection > Orion2 Aplication Selection > ECU Application >

How to choose the right ECU

Choosing the right ECU the first time is important to save time and confidence. Please read this part with an open mind to help you choose wisely. Sometimes the cheapest option is not the best one and it may end up costing u more. There are two group choices to be made. Firstly, which product to choose and secondly which hardware class to choose for that product. Work through each point and narrow down your final choice.

Product Choice.

1. You need to consider your budget. Spitronics has the economy Orion2 and the high quality Mercury2. Mercury2 is more expensive due to protected drivers, epoxy filled enclosure, more inputs and outputs and external firing modules for coils with no intelligence. Some applications are only available in Mercury due to the complexity of the number of sensors and drive items. Orion2 also has a bootloader and can be reprogrammed with firmware without the need of a programmer.

2. If you have people installing the unit that does not have lots of experience, Mercury2 is definitely the choice. It does not damage easily if short circuits are made. If installed properly, Orion2 performs just as well as the Mercury2.

3. If you are abroad or far from Spitronics' home base, it is also best to go for the Mercury2 option. Courier and time lost could be far more expensive than the money saved with the low cost products.

4. If you require the unit to be installed under harsh conditions like an off-road vehicle with lots of vibration and dampness it is best to go for the Mercury2 unit. It is epoxy-filled for vibration and moisture. Orion2 can be epoxy-filled by yourselves after tuning and setting the jumpers inside should you require to do so.

5. If it is a complex engine with lots of drivers and sensors the economy range may not be adequate and you need the Mercury2 anyway. Browse through the product comparison chart to see if the product will be the right one.

6. The Orion2 unit, depending on the type of damage, are repairable as these units are not sealed. We do have a one year reduced exchange rate guarantee should any of the ECU's or TCU's be damaged. See the pricelist for more info or contact our dealers.

7. Coils also need to be considered. If you go for Mercury2, coils with built-in drivers are connected directly. Coils without built-in drivers require the Mercury2 Coil Driver. See how many coils you have and buy the right combination of the Coil Driver. If you decide on Orion2 which has built-in coil drivers, it can connect to coils with or without built-in drivers directly. Not that the connections for the different types of coils is on different wires in the harness.

Hardware Class Choice

1. If your engine has more than 1 coil or a wasted spark coil pack, you will require an Advance or Ultimate ECU. If not your engine should house a distributor with rotor to distribute the spark. Mostly older type engines.

2. If it has a distributor and more than 4 cylinders you need the Intermediate ECU for correct fuel distribution with Split-Sequential or Full-Sequential delivery. A 3 cylinder will also require the Intermediate. If you are really on a tight budget you may use a Standard system and share the injectors on the 2 drivers. Note that there is a different way to connect low and high impedance injectors. Note also that standard systems can only do trigger per event signals.

3. If your trigger in the distributor is one pulse per spark event, then you may use the Standard or Intermediate. If it has a crank trigger with TDC slot or complex distributor signal with Home pulse you will require the Intermediate ECU.

4. Make sure that there is firmware for your application for the specific ECU. Some firmware requires the abilities of Mercury2 and is not available on Orion2.

5. Should you plan to do upgrades in the future buy the Advance or Ultimate ECU. You may also consider the programmer to change the firmware in the future for Mercury2.

6. Note that higher class ECU's will operate with lower class firmware for the same product. So if you buy an Advance ECU, you may start off with Standard or Intermediate firmware.

7. These hardware classes could be changed over the internet in the future following an upgrade payment. So you may buy a Standard ECU and upgrade it later to an Advance ECU. You may also consider the programmer to change the firmware in the future for Mercury2.


ECU Comparisson Chart

Help > Product Selection > Orion2 Aplication Selection > ECU Application >

ECU Features Comparison Chart

 | Orion2 | Mercury2 |
Hardware Inputs |  |  |
Map Sensor | 1 | 1 |
TPS Sensor | 1 | 1 |
Built In Altitude/Map Sensor (Optional) | 1 |  |
External Altitude Sensor |  | 1 |
Water Temp Sensor 2K NTC | 1 | 1 | Note 1
Air Temp Sensor 10K NTC | 1 | 1 | Note 1
Lambda | 1 | 1 |
Tuning Pot | 1 | 1 | Note 2
Fuel Pressure Sensor |  | 1 |
Dual Map Switch | 1 |  | Note 2
Battery Volts | 1 | 1 |
Crank Angle | 1 | 1 |
Cam/Home | 1 | 1 |
VVTI Cam 1 |  | 1 | Note 3
VVTI Cam 2 |  | 1 | Note 3
USB/Programmer 6Pin Molex | 1 | 1 |
Hardware Outputs |  |  |
Injector Drivers Negative Out | 4 | 8 |
Internal Coil Drivers Negative Out | 6 |  | Note 4
External Coil Triggers Positive Out | 4 | 8 |
RPM Output | 1 | 1 |
Electronic Relay Output |  | 1 |
Relay Output | 1 | 1 |
GP Outputs | 10 | 10 | Note 5
Features |  |  |
Graph Tuning | 1 | 1 |
Matrix Tuning | 1 | 1 |
Idle Control | 1 | 1 | Note 6
Dual Maps | 1 | 1 |
Micro Fuelling or Fazed Injector | 1 | 1 |
Full Sequential Injector Control | 1 | 1 |
Injector Trimming | 4 | 8 |
Fuel Pressure Control |  | 1 |
V-Tech Cam Control | 1 | 1 |
VVTI Cam Control | 1 | X |
Launch Control | 1 | 1 |
Launch Delay | 1 | 1 |
RapidFire | 1 | 1 |
Anti-Lag control | 1 | 1 |
Flat-Shift control | 1 | 1 |
Boost control | X | X |
Throttle x Wire control | X | X |
RPM Calibration | 1 | 1 |
Power Management | 1 | 1 |
Epoxy filed |  | 1 |
Can be Epoxy filed | 1 |  |

Notes

Note 1 - Orion2 has removable pull-up jumpers for tap-in feature.

Note 2 - These inputs share pins with HV Coil 5 and Coil 6 Which also share with 2 GP outputs. .

Note 3 - These inputs do not have jumpers for hall sensor pull-ups. They will require external resistors.

Note 4 - There are 2 drivers that are shared by inputs of Note 2.

Note 5 - The number of GP drivers depends on available drivers that is not used.

Note 6 - For Stepper motors an external Stepper Idle Control Unit is required

X - Capable - Firmware not yet developed or freely available in your country


ECU Class Comparrison

Help > Product Selection > Orion2 Aplication Selection > ECU Application >

ECU Selection

Note that the classes that are not used by the ECU firmware is not displayed to simplify the chart. If firmware is developed they will be added.

Orion2 Hardware | STD | INT | ADV | ULT |
Hardware Inputs |  |  |  |  |
External Map Sensor | 1 | 1 | 1 | 1 |
Built In Map Sensor (optional) | 1 | 1 | 1 | 1 |
TPS Sensor | 1 | 1 | 1 | 1 |
Water 2K NTC or Tap-In | 1 | 1 | 1 | 1 |
Air 10K NTC or Tap-In | 1 | 1 | 1 | 1 |
Lambda Narrow or Wide Band | 1 | 1 | 1 | 1 | Note 1
Battery Volts | 1 | 1 | 1 | 1 |
Crank Trigger Pulse | 1 | 1 | 1 | 1 |
TDC/Home Pulse |  | 1 | 1 | 1 |
UART Comms Port | 1 | 1 | 1 | 1 |
USB/Programmer 3Pin PCB Con | 1 | 1 | 1 | 1 |
Bootloader | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |
Low Volt Negative Drivers | 2 | 4 | 4 | 6 |
Low Volt Positive Drivers | 1 | 1 | 4 | 4 | Note 2
High Volt Negative Coil Drivers | 1 | 1 | 4 | 6 | Note 2
General Purpose Input / Output | 10 | 10 | 10 | 10 | Note 3
Features |  |  |  |  |
Graph Tuning MAP | 1 | 1 | 1 | 1 |
Matrix Tuning MAP or TPS | 1 | 1 | 1 | 1 |
Altitude Compensation | 1 | 1 | 1 | 1 | Note 4
Idle Control | 1 | 1 | 1 | 1 | Note 5
Dual Maps | 1 | 1 | 1 | 1 | Note 6
Full Sequential Injection |  |  | 1 | 1 |
V-Tech /Vanos Cam Control | 1 | 1 | 1 | 1 | Note 7
VVTI Cam Control |  |  | 1 | 1 |
Launch Control |  |  | 1 | 1 |
Launch Delay |  |  | 1 | 1 |
RapidFire |  |  | 1 | 1 |
Anti-Lag control |  |  | 1 | 1 |
Flat-Shift control |  |  | 1 | 1 |
RPM Calibration | 1 | 1 | 1 | 1 |
Power Management | 1 | 1 | 1 | 1 |
Can be Epoxy filed | 1 | 1 | 1 | 1 |

Notes

Note 1 - Wideband requires external electronics to provide 0-5V signal

Note 2 - These drivers share the same Micro driver and cannot be used separately

Note 3 - All drivers that is not used by the firmware become GP outputs

Note 4 - Requires the optional on board MAP sensor

Note 5 - Stepper motors require the external Idle2 Controller

Note 6 - These drivers share features and may not be available

Note 7 - This feature operates in Open loop as there is no cam sensor inputs available

NB! Some of the firmware may still be under development. This is merely indicating the capabilities of the different classes. Make sure if such firmware are available before buying or quoting your customers


ECU Program Numbers

Help > ECU Engine Managment > ECU Selection >
ECU Program Numbers
Last Update 03_08_2020
 |  |  |  | No Firmware for this Model |  |  |
 | X |  |  | Firmware Exist |  |  |
 |  |  |  | Planed Development | For GP Layout click on the hardware class of the program
 | Mercury2
No |  | Orion | Orion2 |  | Hardware Class Required
Ver | 3.5E | 3.5B | 3.5B | Description | Mercury2 | Orion | Orion2
1 |  | X |  | Standard Pulses | Adv / Int / Std | Int / Std |
2 |  |  |  | Fuel Only |  |  |
3 |  |  |  | 4/6 Combo |  |  |
4 |  |  |  | Crank Signal Converter |  |  |
5 |  |  |  | Cam Controler |  |  |
6 |  |  |  | Trotle by Wire |  |  |
7 |  | X |  | 12-1 4Cyl |  | Adv / Int | Ult / Adv / Int
8 | X | X |  | 12-1 6Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
9 |  | X |  | 18-1 4Cyl |  | Adv / Int | Ult / Adv / Int
10 |  |  |  | 18-1 6Cyl |  |  | Ult / Adv / Int
11 |  |  |  | 36-1 1Cyl |  |  |
12 |  |  |  | 36-1 2Cyl |  |  |
13 |  | X |  | 36-1 3Cyl |  |  |
14 | X | X | X | 36-1 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
15 | X | X | X | 36-1 6Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
16 | X | X | X | 36-1 8Cyl | Ult / Adv / Int | Ultimate | Ult / Adv / Int
17 | X |  |  | 60-2 10Cyl | Ultimate |  |
18 |  |  |  |  |  |  |
19 |  |  |  | 36-2 Beams VVT |  |  |
20 | X | X | X | 36-2 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
21 | X | X | X | 36-2 6Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
22 | X | X | X | 36-2 8Cyl | Ult / Adv / Int | Ultimate | Ult / Adv / Int
23 |  |  |  | 36-2 12Cyl |  |  |
24 |  |  |  | 36-2 6Cyl 2JZ VVTI |  |  |
25 |  |  |  | 60-2 1Cyl |  |  |
26 |  |  |  | 60-2 2Cyl |  |  |
27 |  |  |  | 60-2 3Cyl |  |  |
28 | X | X | X | 60-2 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
29 | X |  |  | 60-2 5Cyl | Ult / Adv / Int |  |
30 | X | X | X | 60-2 6Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
31 | X | X | X | 60-2 8Cyl | Ult / Adv / Int | Ultimate | Ult / Adv / Int
32 |  |  |  | 60-2 12Cyl |  |  |
33 |  |  |  | 24-2 4Cyl |  |  | Ult / Adv / Int
34 |  |  |  | 24-1 4Cyl |  |  | Ult / Adv / Int
35 | X | X | X | 24+TDC 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
36 | X | X | X | 24+TDC 6Cyl | Ult / Adv / Int | Adv / Int |
37 |  |  |  | 24-2 6Cyl |  |  | Ult / Adv / Int
38 |  |  |  | 24-1 6/3Cyl |  |  |
39 | X | X | X | Nissan 4 Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
40 | X | X |  | Nissan 6 Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
41 |  |  |  | Nissan 8 Cyl |  |  |
42 |  |  |  | Nissan 6 Cyl 350Z 36-6 |  |  | Ult / Adv / Int
43 | X |  |  | Nissan 36-1-1 8 Cyl VVTI | Ult / Adv |  |
44 | X | X |  | Subaru 6T+7T 4Cyl | Ult / Adv | Adv / Int | Ult / Adv / Int
45 | X | X |  | Subaru 36-6 4Cyl | Ult / Adv | Adv / Int |
46 | X |  |  | Subaru 36-6 6Cyl EJ30 |  |  | Ult / Adv / Int
47 | X |  |  | Subaru 36-6 6Cyl EJ33 |  |  | Ult / Adv / Int
48 | X | X |  | 4+2Home 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
49 | X | X |  | Mitsubishi 6Cyl 3+4Home | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
50 |  |  |  | Daihatsu 36-6 3Cyl |  |  |
51 |  |  |  | 2 Rotor Renesis |  |  |
52 | X | X |  | 2 Rotor 36-1 | Advance | Advance |
53 | X |  |  | 2 Rotor 36-6 |  |  |
54 | X | X |  | 2 Rotor 24+TDC | Advance | Advance |
55 |  |  |  | 3 Rotor 36-1 |  |  |
56 |  |  |  | 3 Rotor 36-6 |  |  |
57 |  |  |  | 3 Rotor 24+TDC |  |  |
58 |  |  |  |  |  |  |
59 |  |  |  | Lexus V12 1GZ 36-2 VVTI |  |  |
60 | X |  |  | 36-1 8 Cyl 2Coil | Ult / Adv |  | Use Prog 16
60 |  | X |  | 36-1 8 Cyl Dizzy |  | Adv / Int | Use Prog 16
61 |  |  |  | 36-1 Lexus Racing |  |  |
62 | X |  |  | 36-2 Lexus VVT | Ult / Adv |  |
63 |  |  |  | 36-2 6Cyl VVT |  |  |
64 |  |  |  | 36-1 4Cyl 1Coil 1 Inj Nissan |  |  |
65 |  |  |  | STD 4Cyl 1Coil 1 Inj |  |  |
66 | X |  |  | BMW V12 60-2 2Coil | Ultimate |  |
67 |  |  |  | Chev V8 LS2 60-2 | Use Program 38
68 | X |  |  | 12+1 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
69 | X |  |  | Chev V8 LS1 24+Home | Ult / Adv |  |
70 |  |  |  | BMW 6Cyl M3 E46 |  |  |
71 |  |  |  | Ford 8 Slots & 1Large |  |  |
72 |  |  |  | 36-4 4Cyl Rover |  |  |
73 |  |  |  | 36-1-1 Almera |  |  |
74 |  |  |  | Mercedes 4Cyl |  |  |
75 |  |  |  | Mercedes 6Cyl |  |  |
76 |  |  |  | Mercedes 8Cyl |  |  |
77 | X |  |  | 60-2 12Cyl | Ultimate |  |
78 |  |  |  | 60-2 8Cyl VVTI |  |  |
79 |  |  |  |  |  |  |
80 |  |  |  | Rotax 2Cyl 36-2 |  |  |
81 |  |  |  | 36-1 6Cyl Weber 2Inj |  |  |
82 | X |  |  | 24-1 Dizzy 3/6 Cyl Full/Seq | Ult / Adv / Int |  |
83 |  |  |  | 24-2 Dizzy 4Cyl Full/Seq | Ult / Adv / Int |  | Ult / Adv / Int
84 | X |  |  | 24-1 Dizzy 4Cyl Full/Seq | Ult / Adv / Int |  | Ult / Adv / Int
85 | X | X |  | 4+Home Dizzy 4Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
86 |  |  |  | 6+Home 6Cyl |  |  | Ult / Adv / Int
87 |  |  |  | 6+1 Dizzy 6Cyl |  |  | Ult / Adv / Int
88 |  |  |  | Mazda Etude 4+2Home 4Cyl | Use Program 48
89 |  |  |  | 30-2 4Cyl |  |  | Ult / Adv / Int
90 |  |  |  | 60-6+Home 3Cyl |  |  |
91 |  |  |  | 36-4 3Cyl Suzuki 10T/22T |  |  |
92 |  |  |  | Honda V2 4Cyl 12+3TDC |  |  |
93 |  |  |  | Quad |  |  |
94 |  |  |  | 24+3Home |  |  |
95 |  |  |  | Golf4 20V VVTI 60-2 4Cyl | Use Program 28
96 |  | X |  | 18-6 + TDC 6Cyl Jeep |  | Adv / Int | Ult / Adv / Int
97 |  |  |  | 24-2 Spark Only 1-6Cyl |  |  |
98 |  |  |  | 36-1 Spark Only 1-6Cyl |  |  |
99 |  |  |  | 36-2 4Cyl 2Coil 4Inj |  |  |
100 |  | X |  | 60-2 8Cyl Dizzy | Use Prog 31 | Adv / Int | Use Prog 31
101 | X |  |  | 8W+Home Jeep 2.4 4Cyl | Ult / Adv / Int | Adv / Int |
102 |  |  |  |  |  |  |
103 |  | X |  | 60-1 6Cyl |  | Adv / Int | Ult / Adv / Int
104 |  | X |  | 60-1 6Cyl 6Coil |  | Ultimate |
105 |  | X |  | 36-2 6Cyl 6Coil |  | Ultimate |
106 |  | X |  | 60-2 6Cyl 6Coil |  | Ultimate |
107 | X |  |  | 60-4 6Cyl | Ult / Adv / Int |  |
108 |  | X |  | 60-2 BMW 1200GS |  | Advance |
109 | X | X |  | Daihatsu 4+1 Dizzy 4 Cyl | Ult / Adv / Int | Adv / Int | Ult / Adv / Int
110 |  |  |  | Fan Control |  | Micro |
111 |  |  |  |  |  |  |
112 | X |  |  | 60-2 4Cyl Fuel Booster Only | Standard |  | Ult / Adv / Int
244 | X |  |  | Recover Upgrade Ver E |  |  |
245 | X |  |  | Recover Downgrade Ver A |  |  |
246 | X |  |  | Upgrade Program |  |  |
247 | X | X |  | Recover Program |  |  |
248 | X | X |  | Test Program |  |  |
249 |  |  |  | Reserved |  |  |
250 |  |  |  | Reserved |  |  |


Engine Information

Help > Product Selection > Orion2 Aplication Selection > ECU Application >

Engine Information

Before you can set yourself or a customer up with a product, you need to get some critical information from the engine. Firmware and hardware is designed as universal devices but it may require specific firmware of hardware attachments. The following items influences the product.

1. Engine Type: (e.g. Toyota 1UZ non VVTI)

Not critical but it may save you time if you need some information on the web or have done this type before.

2. Number of cylinders: (e.g. V8, Straight 6)

This will select the type of firmware.

3. Number and Type of coils: (e.g. 1 x Distributor, 2 x Distributor, 2 x W.S, 8 x COP)

This will indicate if the specific product can handle all the coils and will influence what group of firmware to select next.

4. Does the coil or coils have built in drivers or not?

Orion2 has up to 6 coil drivers while Mercury2 has none. It uses external coil drivers.

5. Crank Trigger Type and Pattern

(e.g. Standard Pulses Distributor with Hall Sensor, Crank Trigger 60-2 pattern with Wheel Magnetic Sensor, 24+TDC Distributor with magnetic sensors). This is very important as firmware are grouped according to crank trigger pattern.

6. Cam Trigger Type and Pattern: (e.g. 2 x Teeth with Magnetic Sensor, 1 x Teeth with Hall Sensor)

This does not necessary change the firmware and are adjustable in most cases. Some firmware may be developed for a specific engine which means it is preprogrammed.

7. Turbo or Normally aspirated and what is the maximum boost pressure.

This is important as units are shipped with a 2.5Bar sensor. If you require more than 1.5Bar boost, then you need the next level sensor.

8. Idle control and type (e.g. 2 pin idle valve, 4 pin GM stepper, 6 pin Toyota stepper)

Stepper motors require a separate module to be connected

9. VVT or VVTI Camshafts (e.g. 1 VVT cam, 2 VVTI cams with sensors, Vanos or V-Tech)

Cam control is done in open loop and can be done with GP2 or the cam blocks in the software.

10. Throttle by wire or a petrol cable (e.g. Cable, TxW)

TxW require an external device to control. It is not done by the engine ECU.

11. Automatic Transmission (e.g. 4 Speed 4L60E, 5 Speed 5HP24 or 4 Peed Jatco RE4R01A)

Transmissions also require and external device to control it. See the TCU part in the manual.

12. Does the installer know how to fit and Tune Spitronics Devices?

This point will indicate the level of support required by the customer and then ultimately the price to the customer.

Firmware File names

Now you can select the firmware. Below is a Typical firmware file name and the description of it. Notice that Mercury2 has HEX files and Orion2 has Firm files. This is due to Mercury2 that requires a programmer to load the files and Orion2 uses a boot loader which is imbedded in the Hyperspace software.

Mercury2 ECU Combo 28 60-2 4Cyl Ver 3.5E 16_04_2019.HEX

Orion2 ECU Combo 28 60-2 4Cyl Ver 3.6A 01_07_2020.OTFirm

Mercury2 / Orion2 - The firmware always starts with the product name and they cannot be mixed.

ECU / TCU / TxW - Description of the type of firmware.

Combo - The Class of the firmware. Combo means it will run on different hardware classes like Advance, Intermediate etc. but with limited features in the lower classes.

60-2 - Crank Trigger Pattern

Ver 3.6A - Version number. Note that on the GP layout version numbers are important as they may differ in wiring layout.

Date - Indication of file age. Some fixes may only change the date so make sure you always use the latest versions on our Website.


Purchasing an Orion2 ECU

Help > Product Selection > Orion2 Aplication Selection > ECU Application >

Purchasing an Orion2 ECU

Orion2 is a universal controller which has multiple options with the accessories like harnesses, sensors and firmware. It is not easy to make a price for advertising as each engine may require different items. The installer also have choices on economy harnesses to save money or easy install harnesses to save on install time. Below is an example on how to select your product and explanations on each item if you are not sure. Just click on the links for more information. This manual does not have prices included but a similar form with prices can be found on our website. From there you can send it as an order to one of our wholesalers or as a quotation to a customer. Note that the Red text is required or recommended to an application while Green is optional and not necessary needed on all applications.

Item | Selection | Price | QTY | Check | Description
Orion2 ECU (Hardware Class) |  |  |  |  |
 | Ultimate |  |  |  | Racing Features - Multi Coil
 | Advance |  |  |  | Advance Features - Multi Coil
 | Intermediate |  |  |  | Complex Trigger - Distributor
 | Standard |  |  |  | Simple Trigger - Distributor
USB Tuning Cable |  |  |  |  |
 | USB/UART Comms |  |  |  | Required to connect with the Tuning Software
Map Sensor |  |  |  |  |
 | 2.5 Bar Plastic |  |  |  | Required to Measures Manifold Pressure up to 1.5 Bar Boost pressure
 | 3 Bar Aluminium |  |  |  | Required to Measures Manifold Pressure up to 2 Bar Boost pressure
 | 4 Bar Aluminium |  |  |  | Required to Measures Manifold Pressure up to 3 Bar Boost pressure
Altitude Sensor |  |  |  |  |
 | 3 Bar Plastic |  |  |  | Optional to Measure Altitude Pressure for Baro Compensation
Recommended Harnesses |  |  |  |  | Engine connectors are not included.
 | E22-P1 |  |  |  | Contains the wiring for Crank, Cam and other sensors. Crank and Cam is joined in one cable
 | E24-P1 |  |  |  | Contains the wiring for Crank only and other sensors
 | E29-P1 |  |  |  | Contains the wiring for Crank, Cam and other sensors. Crank and Cam is separate cables
 | E33 V2-P2 |  |  |  | Contains all the wiring relays and fuses.
 | E36 V2-P3 |  |  |  | Contains only the wiring on the pins.
Older Harnesses |  |  |  |  | Engine connectors are not included.
 | E31-P2 |  |  |  | Contains only the wiring on the pins. No relays and fuses.
 | Relays |  |  |  |
 | Fuse Box |  |  |  |
Stepper Idle Control |  |  |  |  |
 | Type1 |  |  |  | Required if the engine has a 4 Pole Common Stepper Idle Control
 | Type2 |  |  |  | Required if the engine has a 4 Pole Bi-Polar Stepper Idle Control
 | Harness SO3 12Pin |  |  |  | Required for connecting a Stepper Idle Control
Coil Driver |  |  |  |  |
 | MC1-P1 |  |  |  | Required for any of the following Mercury Coil Drivers
 | 2 Way Coil Driver |  |  |  | Required for 2 Basic Coils with no built in Igniters
 | MC2-P2 |  |  |  | Required for connecting the 2 Way Coil Driver
 | 4 Way Coil Driver |  |  |  | Required for 4 Basic Coils with no built in Igniters
 | MC4-P2 |  |  |  | Required for connecting the 4 Way Coil Driver
 | 6 Way Coil Driver |  |  |  | Required for 6 Basic Coils with no built in Igniters
 | MC6-P2 |  |  |  | Required for connecting the 6 Way Coil Driver
Electronic Relay 45Amp |  |  |  |  | Optional Solid State Relay to replace Mechanical Relays
Firmware Programmer |  |  |  |  | Optional for changing or updating Firmware
Simmulater3 |  |  |  |  |
 | Controller |  |  |  | Optional for dealers to test Spitronics Devices
 | Harnesses |  |  |  | Required for each product that must be tested on the Simulator
Connectors and Pins |  |  |  |  |
 | 4 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 6 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 8 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 10 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 12 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses


TCU Selection

Help > TCU Transmission Management >

Orion2 TCU Selection

The Orion2 is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance, Ultimate, Commercial and Racing. Not all the products have firmware for all the hardware classes but if a product has n higher hardware class, then all the lower firmware classes will operate on it.

In the sub folders are charts for each product with guidance to what each class can do. To be more secure look at the firmware available for the Orion2 and which class is required. Or speak to one of our dealers. Below is a link that take you to the list on the firmware.

TCU Program Numbers

Note that the Program Number list compare Mercury2 vs Orion2 features. Below is a sample entry in the list.

You can click on the program number (7) if it is blue. This means that firmware is developed for Mercury2 or Orion2 or both. This will open a feature comparison chart between Mercury2 and Orion2 and then also a hardware class comparison for each product. The Red and Green X indicates for which product the firmware is available. If the block is gray, then it means that product will not have that firmware. If it is open, then firmware may be developed in the future. See below.

If you click on the red or green hardware class (Ult / Adv ) in the list it will open the GP Priority Layout for that firmware. This will indicate where each input and output is connected to the device because it differs for each firmware program. It will also show harness colors for the standard harnesses supplied. See example below:

See the other folders for more information.


Compiling a TCU Product

Help > Product Selection > Orion2 Aplication Selection > TCU Application >

Compiling a TCU Product

This document guides you to put a working product together from scratch. It will link you to the sections in the manual that your application requires, and how to set the product up correctly and print the relevant drawings for that installation. This legwork will save you or your customer time and eliminate lots of support calls. As this is a DIY product, the dealer must do this for his customer. If you carry stock, then you will do it when the customer requests a specific system.

Selecting a Product

There are 2 Spitronics TCU products currently in production namely Orion2 and Mercury2. Each one has Pro's and Con's and it is wise to take time out to know the differences. Selecting the wrong one may affect the price or the features that is required. Each TCU has its own manual and the Product Selection of its manual is the section to read for this information. You may also look at the TCU Comparison Chart and TCU How to Choose section. Note that these documents are the same for both manuals.

Choosing Firmware

After you have decided on the product type then read this section in that products manual. If you are choosing Orion2, then you are in the right place.

Now you will need Transmission Information from the customer to decide which firmware must be used. Firmware are developed according to the transmission model number. TCU does not have modular drawings and are specific for each application. However, the customer does have the possibility to combine other shifters and components with this product. In these cases, he may look into the description for general drawings as guidelines. This will be connections like TPS, RPM, Shifter, Tiptronic Buttons , Map Selection Switch and Speed sensor .

Now you can view the Program Number Chart and see if firmware exists for that product. Orion2 does not have the amount of inputs and outputs that Mercury2 has so it may be that it is impossible to run certain transmissions.

In the Program Number Chart, you will find the Firmware Features according to its hardware class and the GP Priority Layout for that specific firmware. Orion2 TCU Selection section will explain this chart and how to get the relevant information from it. With this information you know if firmware exists and what hardware class is required as well as how the TCU connections are laid out for that firmware. Remember different firmware versions will have different connections to the TCU.

Example of Firmware Features 7

Example of GP Priority Layout Adv / Int

To program the Orion2 ECU see the BootLoader section.

Printing documents

If you have a Model number for the transmission then you go to Transmission drawings and look in the sub folders for that transmission. Here you will find all the relevant information that you require.

Installers prefer drawings on paper as they can make notes on customising and different wire colours etc. Also mark what is not used and what is already done. Note that this document only guides you to connections on the transmission that we have found. There may be other versions of the same transmission on other vehicles. For that you will have to consult the Service manuals and please forward variations to us for updating the current documentation.

For Explanation we use the Aisin A343E transmission. If you look at the information on the sheet you will find the following.

Main Drawing

This will open the full wiring diagram of the transmission with its standard connections. Note that ECU application and Stand Alone application use a different harness hence the two drawings. You will see the drawing has 2 pages so you need to scroll down inside for the other half.

Use with ECU withMTWX02/2 Harness

Orion2 Aisin A343E Drawing

Use as Stand Alone with MTSX02/2 Harness

Orion2 Aisin A343E Stand Alone Drawing

Default Harnesses

These links will take you to the design drawings of each harness. If you do manufacture your own harnesses do make sure that you comply to wire thickness and screened wires.

OT01 - P1 Input Harness (ECU Connections)

OT02 - P Input Harness Stand Alone

OT03 V2 - P2 Output Harness

E36 V2 - P3 Output Harness

OT20 - Comms Buttons Harness

Diode Board.

The TCU applications require external diodes to prevent spikes or interference from the pulsing inductive loads. These boards com in positive or negative configuration. They are built into the harness and sealed properly with silicon and heart shrink to prevent water damage. If you don't have these boards there is a schematic on how to connect normal diodes onto the solenoids. They are not always built in due to the number of connection options for different transmissions.

DB1 Positive Diode Board

A343E Freewheel Diode Schematic

Shifter Converter Board

This board is required for digital switches in the shifter so that only one input on the TCU is required. They come in 2 varieties' namely Serial and Parallel Digital to Analog converters.

CON2 Serial A/D Converter

GP Priority Layout

This link will take you to a connection sheet that indicates where each wire must be connected for that firmware as well as the wire color.

Aisin A343E 4Speed Connection Layout

Hardware Class Comparison

This will compare the features of the different classes as well as Mercury2.

Aisin A343E

Tyre Calculator

This helps to set up a starting map for the customer.

Tyre Calculator Aisin A343E (Excel)

Packing List

This guides dealers and customers to see which items is required for this application.

Orion2 Aisin A343E Packing List (Excel)

Old Harness Layout

This is not recommended for Orion2 but merely for backwards compatibility explanations. Some are discontinued.

RPM and Speed Sensors comes in different types and connections. Do note that these connections differ for different harnesses for. Use the correct harness link to view the data and print it for the customer. There are 2 main groups for transmission connections. A harness to use with an ECU product or a harness to use as a standalone product like for a diesel or carburetted engine. The main difference is that RPM and TPS sensor connections have long screened wires that go to the engine bay end connects on custom sensors. Also note if you are tapping into a system you may need a filter to eliminate interference.

Other drawings you may need are TPS, RPM, Shifter, Tiptronic Buttons , Speed sensor, Map Selection, Oil Temperature , General Purpose Outputs and Speedometer.

Precautions and Installing

Before attempting to start an install it will be wise to read the Precautions for Orion2. This section outlines general wiring mistakes customers make that will cause operation problems like interference later.

Start-up

When you start an transmission for the first time do follow the Start-Up Procedure for Orion2. This will take you step by step through the process of checking everything. In some cases, you may damage a unit if your setup in the software does not match your wiring on the transmission.


TCU How to Choose

Help > Product Selection > Orion2 Aplication Selection > TCU Application >

How to choose the right TCU

Choosing the right TCU first time is important to save time and confidence. Please read this part with an open mind to help you choose wisely as sometimes the cheapest option is not the best one and may end up costing you more. There are two choices that you can make. Which product and options and which hardware class is required for that specific product and its features. Work through each point and narrow down your optimal choice.

Product Choice:

1. You need to consider your budget, Spitronics has the economy Orion2 and the high quality Mercury2. Mercury2 being the more expensive due to protected drivers, epoxy filled enclosure and consisting of more input and outputs. Some applications are only available in Mercury due to the complexity of the number of sensors and drive items. Orion2 also has a bootloader and can be reprogrammed with firmware without the need of a programmer.

2. If you have people installing the unit that does not have lots of experience, Mercury2 is definitely the choice. It does not damage easily if short circuits are made. If installed properly, Orion2 performs just as well as the Mercury2.

3. If you are abroad or far from Spitronics' home base, it is also best to go for the Mercury2 option. Courier and time lost could be far more expensive than the money saved with the low cost products.

4. If you require the unit to be installed under harsh conditions like an off-road vehicle with lots of vibration and dampness it is best to go for the Mercury2 unit. It is epoxy-filled for vibration and moisture. Orion2 can be epoxy-filled by yourselves after tuning and setting the jumpers inside should you require to do so.

5. If it is a complex transmission with lots of drivers and sensors the economy range may not be adequate and you'd need to consider the Mercury2. Browse through the product comparison chart to see if the product will be sufficient.

6. The Orion2 unit, depending on the type of damage, are repairable as these units are not sealed. We do have a one year reduced exchange rate guarantee should any of the ECU's or TCU's be damaged. See the pricelist for more info or contact our dealers.

7. The best way to choose your product is to see is if the unit can handle the transmissions and if there is firmware available for it. Transmissions differ more than engines and some have complicated operations. They also have different harnesses that has built in components to make installation easier for the customer.

Hardware Class Choice:

1. Only the Orion2 is sold in Standard Intermediate or Advance configuration, to make a low cost solution for the very common transmissions like A343E found on the 1UZ. The Standard can do 4 solenoids and does not have a speedo output for speedo calibration. The Intermediate can do 6 solenoids and speedo calibration. Advance can measure oil temperature and do line pressure compensation for temperature.

2. Mercury2 can do up to 12 solenoids with speedo calibration. It is only sold in Intermediate and Advance firmware.

3. Make sure that firmware is available for your application regarding the specific TCU. Some firmware requires the abilities of Mercury2 and is not available on the Orion2.

4. Should you plan to do upgrades in the future, the Advance TCU is the obvious choice. You may also consider the programmer to change the firmware in the future for Mercury2.

5. Higher class TCU's will operate with lower class firmware for the same product. So if you buy an Intermediate TCU, you may start off with Standard firmware.

6. These hardware classes could be changed over the internet in the future following an upgrade payment. So you may buy a Standard TCU and upgrade it later to an Intermediate TCU. You may also consider the programmer to change the firmware in the future for Mercury2.


TCU Comparisson Chart

Help > Product Selection > Orion2 Aplication Selection > TCU Application >

TCU Features Comparison Chart

 | Orion2 | Mercury2 | Notes
Hardware |  |  |
TPS Sensor | 1 | 1 |
RPM Sensor | 1 | 1 |
Speed Sensor | 1 | 1 |
Oil Temp Sensor | 1 | 1 |
Low Range Sensor | 1 | 1 |
Shifter Selection Switch | 1 | 1 |
Tuning Maps Selection Switch | 1 | 1 |
Tiptronic Up Switch | 1 | 1 |
Tiptronic Down Switch | 1 | 1 |
GP Outputs | 2 | 2 | Note 1
Solenoid Drivers Negative Out | 6(10) | 8 | Note 2
Solenoid Drivers Positive Out | 4 | 8 |
Speedo Output | 1 | 1 | Note 1
Electronic Relay Output |  | 1 |
Relay Output | 1 | 1 |
Battery Volts | 1 | 1 |
Features |  |  |
Tiptronic Function | 1 | 1 |
4 Tuning Maps | 1 | 1 |
Individual Gear Shift Profiles | 1 | 1 |
Duty Cycle Control | 1 | 1 |
Speedo Calibration | 1 | 1 |
Lockup Control | 1 | 1 |
Lockup Selectable / Gear | 1 | 1 |
Transfer Box Ratio Adjustments | 1 | 1 |
Retard Request | 1 | 1 | Note 1
Number of Gears Capable | 10 | 10 |
Power Management |  | 1 |
Epoxy filed |  | 1 |
Can be Epoxy filed | 1 |  |

Notes

Note 1 - Depends on features selected

Note 2 - These drivers are shared outputs


TCU Class Comparrison

Help > Product Selection > Orion2 Aplication Selection > TCU Application >

TCU Selection

Note that the classes that are not used by the TCU firmware is not displayed to simplify the chart. If firmware is developed they will be added.

Orion2 Hardware | STD | INT | ADV | ULT | Notes
Hardware |  |  |  |  |
TPS Sensor | 1 | 1 | 1 | 1 |
RPM Sensor | 1 | 1 | 1 | 1 |
Speed Sensor | 1 | 1 | 1 | 1 |
Oil Temp Sensor |  |  | 1 | 1 |
Low Range Sensor |  |  | 1 | 1 |
Shifter Selection Switch | 1 | 1 | 1 | 1 |
Tuning Maps Selection Switch | 1 | 1 | 1 | 1 |
Tiptronic Up Switch | 1 | 1 | 1 | 1 |
Tiptronic Down Switch | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |
Low Volt Negative Drivers | 6 | 6 | 6 | 6 |
Low Volt Positive Drivers | 4 | 4 | 4 | 4 | Note 1
High Volt Negative Coil Drivers | 6 | 6 | 6 | 6 | Note 1
GP Outputs | 2 | 2 | 2 | * | Note 2
Speedo Output |  | 1 | 1 | 1 |
Electronic Relay Output |  |  |  |  |
Relay Output | 1 | 1 | 1 | 1 |
Battery Volts | 1 | 1 | 1 | 1 |
Features |  |  |  |  |
Tiptronic Function | 1 | 1 | 1 | 1 |
Overdrive Function |  |  | 1 | 1 |
2nd Start Function |  |  | 1 | 1 |
4 Tuning Maps | 1 | 1 | 1 | 1 |
Individual Gear Shift Profiles | 1 | 1 | 1 | 1 |
Duty Cycle Control | 1 | 1 | 1 | 1 |
Speedo Calibration |  | 1 | 1 | 1 |
Lockup Control | 1 | 1 | 1 | 1 |
Lockup Selectable / Gear | 1 | 1 | 1 | 1 |
Transfer Box Ratio Adjustments |  |  | 1 | 1 |
Number of Gears Capable | 10 | 10 | 10 | 10 |
Epoxy filed |  |  |  |  |
Can be Epoxy filed | 1 | 1 | 1 | 1 |

Notes

Note 1 - These drivers share the same Micro driver and cannot be used separately

Note 2 - * All drivers that is not used by the firmware become GP outputs

NB! Some of the firmware may still be under development. This is merely indicating the capabilities of the different classes. Make sure if such firmware is available before buying or quoting your customers


TCU Program Numbers

Help > TCU Transmission Management > TCU Selection >
TCU Program Numbers
Last Update 08_11_2019
 |  |  | No Firmware for this Model |  |
 | X |  | Firmware Exist |  |
 |  |  | Planed Development | For GP Layout click on the hardware class of the program
 | Mercury2
No |  | Orion |  | Hardware Class Required
Ver | 3.3D | 3.3C | Description | Mercury2 | Orion
1 | X | X | Lexus A343E 4 Speed | Adv / Int / Std | Adv / Int / Std
2 | X |  | Lexus A650E 5 Speed | Adv / Int / Std |
3 |  |  | Aisan U340E U441E 4 Speed |  |
4 | X |  | AB60 A761E 6 Speed | Adv / Int / Std |
5 |  |  | Aisin A750E 5 Speed |  |
6 | X |  | GM 4L60E 4 Speed | Adv / Int |
7 | X | X | GM 4L80E 4 Speed | Adv / Int | Adv / Int
8 |  |  | GM 5L40E 5 Speed |  |
9 | X |  | AC60 AWR6B45 |  |
10 |  | X | GM 4L30E 4 Speed |  | Adv / Int
11 |  |  | Ford E40D 4 Speed |  |
12 |  | X | Ford AODE 4R70W 4 Speed |  | Adv / Int / Std
13 |  |  | Ford 5R55E |  |
14 |  |  |  |  |
15 |  |  |  |  |
16 | X |  | Jatco JR405E 4 Speed | Advance |
17 | X |  | Jatco RE4 OEM 4 Speed | Adv / Int / Std |
18 | X |  | Jatco RE4R01A 4 Speed | Adv / Int / Std |
19 | X |  | Jatco RE5R05A 5 Speed | Advance |
20 |  |  |  |  |
21 |  |  | Mitsubishi GTO 4 Speed |  |
22 |  |  | MitsubishiV5A51 5 Speed |  |
23 |  |  | Mitsubishi V4A R4A F4A 4 Speed |  |
24 |  |  | Mitsubishi GT3000 V6 4 Speed |  |
25 |  | X | ZF 4HP18 4 Speed |  | Adv / Int / Std
26 | X | X | ZF 4HP22/24 4 Speed 5 Sol | Adv / Int / Std | Adv / Int / Std
27 | X | X | ZF 4HP22/24 4 Speed 4 Sol | Adv / Int / Std | Adv / Int / Std
28 |  |  |  |  |
29 |  |  | ZF 5HP19 5 Speed |  |
30 |  |  | ZF 5HP24 5 Speed |  |
31 |  |  | ZF 5HP30 5 Speed |  |
32 |  |  |  |  |
33 |  |  |  |  |
34 |  |  |  |  |
35 |  |  | VW 096 4 Speed |  |
36 |  |  | Mercedes 722.6 5 Speed |  |
37 |  |  | Suzuki Gimny |  |
38 |  |  | Honda 4 Speed |  |
39 | X |  | Toyota AA80E 8 Speed | Advance |
40 |  |  |  |  |
41 | X |  | Subaru 4EAT 4 Speed | Adv / Int / Std |
42 |  |  |  |  |
43 |  |  |  |  |
44 |  |  | Chrysler A604 A606 4 Speed |  |
45 |  |  | Ford Falcon |  |
46 |  |  |  |  |
47 |  |  |  |  |
48 |  |  |  |  |
49 |  |  |  |  |
50 |  |  |  |  |
244 | X |  | Recover Upgrade Ver E |  |
245 | X |  | Recover Downgrade Ver A |  |
246 | X |  | Upgrade Program |  |
247 | X | X | Recover Program |  |
248 | X | X | Test Program |  |
249 |  |  | Reserved |  |
250 |  |  | Reserved |  |


Transmission Information

Help > Product Selection > Orion2 Aplication Selection > TCU Application >

Transmission Information

Before you can set yourself or a customer up with a product, you need to get some critical information on the transmission. The hardware is designed as universal devices but the firmware is specific for a certain model of transmission. The following items influences the product.

1. Transmission Model Number: (e.g. 4 Speed 4L60E, 5 Speed 5HP24 or 4 Speed Jatco RE4R01A)

If you can't get a model number, you may send photos of the case connectors or harness connector of that transmission so we may be able to identify it for you. Or you may browse through all our drawings and see if you can find a match there.

2. Stand Alone application or use with ECU application

This will select the type harness required.

3. Application details for setting up a Startup Map

This will help the customer to set up his TCU quickly. There is a Tyre calculator that helps to determine shift points.

Number of engine Cylinders

Max Speed

Max RPM

Idle RPM

Stall Speed

Tire Size - Width/Aspect/Rum

Diff Ratio

4. Does the installer know how to fit and Tune Spitronics Devices?

This point will indicate the level of support required by the customer and then ultimately the price to the customer.

Firmware File names

Now you can select the firmware. Below is a Typical firmware file name and the description of it. Notice that Mercury2 has HEX files and Orion2 has Firm files. This is due to Mercury2 that requires a programmer to load the files and Orion2 uses a boot loader which is imbedded in the Hyperspace software.

Mercury2 TCU Combo 1 Lexus A343E Ver 3.3D 16_09_2019.HEX

Orion2 TCU Combo 1 Lexus A343E Ver 3.3C 16_09_2019.Firm

Mercury2 / Orion2 - The firmware always starts with the product name and they cannot be mixed.

ECU / TCU / TxW - Description of the type of firmware.

Combo - The Class of the firmware. Combo means it will run on different hardware classes like Advance, Intermediate etc. but with limited features in the lower classes.

Lexus A343E - Transmission Model number

Ver 3.3D - Version number. Note that on the GP layout version numbers are important as they may differ in wiring layout.

Date - Indication of file age. Some fixes may only change the date so make sure you always use the latest versions on our Website.


Purchasing an Orion2 TCU

Help > Product Selection > Orion2 Aplication Selection > TCU Application >

Purchasing an Orion2 TCU

Orion2 is a universal controller which has multiple options with the accessories like harnesses, sensors and firmware. It is not easy to make a price for advertising as each transmission may require different items. The installer also have choices on economy harnesses to save money or easy install harnesses to save on install time. Below is an example on how to select your product and explanations on each item if you are not sure. Just click on the links for more information. This manual does not have prices included but a similar form with prices can be found on our website. From there you can send it as an order to one of our wholesalers or as a quotation to a customer. Note that the Red text is required or recommended to an application while Green is optional and not necessary needed on all applications.

Item | Selection | Price | QTY | Check | Description
Orion2 TCU (Hardware Class) |  |  |  |  |
 | Advance |  |  |  | Advance Features - Speedometer Calibration, 2nd Pull off, Drive-Overdrive select, 4x4 etc.
 | Intermediate |  |  |  | Basic Functions + Speedometer Calibration
 | Standard |  |  |  | Basic Functions
USB Tuning Cable |  |  |  |  |
 | USB/UART Comms |  |  |  | Required to connect with the Tuning Software
Recommended Harnesses |  |  |  |  | Engine connectors are not included.
 | OT01-P1 |  |  |  | Use with ECU Application. Contains all the sensor wiring.
 | OT02-P1 |  |  |  | Stand Alone Application. Contains all the sensor wiring.
 | OT03 V2-P2 |  |  |  | Contains all the wiring, Relay and Fuse.
 | E36 V2-P3 |  |  |  | Contains only the wiring on the pins.
 | OT20-Comms |  |  |  | Contains the wiring for Tiptronic Buttons and Comms Extension
 | OT21-Comms |  |  |  | Contains the wiring for Remote Tiptronic Buttons and Comms Extension
Older Harnesses |  |  |  |  | Engine connectors are not included.
 | Relays |  |  |  |
 | Fuse Box |  |  |  |
Diode Boards |  |  |  |  |
 | DB1 Positive |  |  |  | Required for PWM Solenoids which is driven by a Positive Signal with Common Earth
 | DB2 Negative |  |  |  | Required for PWM Solenoids which is driven by a Negative Signal with Common Positive
Shifter Converter A/D Board |  |  |  |  |
 | CON1 Parallel |  |  |  | Required to convert Parallel Digital Switches from the Shifter Range switch to an Analogue signal
 | CON2 Serial |  |  |  | Required to convert Serial Digital Switches from the Shifter Range switch to an Analogue signal
Electronic Relay 45Amp |  |  |  |  | Optional Solid State Relay to replace Mechanical Relays
Firmware Programmer |  |  |  |  | Optional for changing or updating Firmware
Simmulater3 |  |  |  |  |
 | Controller |  |  |  | Optional for dealers to test Spitronics Devices
 | Harnesses |  |  |  | Required for each product that must be tested on the Simulator
Connectors and Pins |  |  |  |  |
 | 4 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 6 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 8 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 10 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 12 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses


Other Applications

Help > Product Selection > Orion2 Aplication Selection >

Orion Other Applications

The Orion is often used for other applications like Converters or Throttle by Wire systems etc. It is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance, Ultimate, Commercial and Racing. Not all the products have firmware for all the hardware classes but if a product has n higher hardware class, then all the lower firmware classes will operate on it.

In the sub folders are information for each application with guidance and instructions. To be more secure look at the firmware available for the Orion and which class is required. Or speak to one of our dealers.

See the sub folders for more information.


Converter Programs

Help > Product Selection > Orion2 Aplication Selection > Other Applications >

Converter Selection

This firmware will take a normal RPM pulse and convert it into different triggers like 60-2, 36-1, 24 plus TDC etc. for OEM managements. This will keep them active so that they can run other functions still required like Dash board tacho's etc. Note that the classes that are not used by the converter is not displayed to simplify the chart. If firmware is developed they will be added.

Orion2 Hardware | MIC
Hardware Inputs |
External Map Sensor |
Built In Map Sensor (optional) |
TPS Sensor |
Water 2K NTC or Tap-In |
Air 10K NTC or Tap-In |
Lambda Narrow or Wide Band |
Battery Volts | 1
Crank Trigger Pulse | 1
TDC/Home Pulse |
UART Comms Port | 1
USB/Programmer 3Pin PCB Con | 1
Bootloader | 1
Hardware Outputs |
Low Volt Negative Drivers | 2
Low Volt Positive Drivers |
High Volt Negative Coil Drivers |
General Purpose Input / Output |
Features |
Graph Tuning MAP | 1
Matrix Tuning MAP or TPS | 1
Altitude Compensation |
Idle Control |
Dual Maps |
Dual Injectors |
Split Sequential Injection |
Full Sequential Injection |
Fuel Pressure Control |
V-Tech /Vanos Cam Control |
Launch control |
Anti-Lag control |
Flat-Shift control |
RPM Calibration |
Can be Epoxy filed | 1


TxW Throttle by Wire

Help > Product Selection > Orion2 Aplication Selection > Other Applications >

TxW Selection

This firmware will take a normal RPM pulse, TPS and pedal signal and water temperature and control the electric throttle by wire. Note that the classes that are not used by the converter is not displayed to simplify the chart. If firmware is developed they will be added.

Orion2 Hardware | BAS | STD
Hardware Inputs |  |
External Map Sensor |  |
Built In Map Sensor (optional) |  |
TPS Sensor | 1 | 1
Water 2K NTC or Tap-In |  | 1
Air 10K NTC or Tap-In |  |
Lambda Narrow or Wide Band |  |
Battery Volts | 1 | 1
Crank Trigger Pulse | 1 | 1
TDC/Home Pulse |  |
UART Comms Port | 1 | 1
USB/Programmer 3Pin PCB Con | 1 | 1
Bootloader | 1 | 1
Hardware Outputs |  |
Low Volt Negative Drivers | 2 | 2
Low Volt Positive Drivers | 2 | 2
High Volt Negative Coil Drivers |  | 2
General Purpose Input / Output |  | 2
Features |  |
Graph Tuning MAP | 1 | 1
Matrix Tuning MAP or TPS |  |
Altitude Compensation |  |
Idle Control |  | 1
Dual Maps | 1 | 1
Dual Injectors |  |
Split Sequential Injection |  |
Full Sequential Injection |  |
Fuel Pressure Control |  |
V-Tech /Vanos Cam Control | 1 | 1
Launch control |  |
Anti-Lag control |  |
Flat-Shift control |  |
RPM Calibration |  | 1
Can be Epoxy filed | 1 | 1


Orion2 Simmulater Test Program

Help > Product Selection > Orion2 Aplication Selection >

Orion2 Simulator Test Program

This firmware will allow dealers to test Orion2 and see if all inputs and outputs are functional. It is for use on a Spitronics Simulater2 or 3. It is required before you accept Test 2 on the Portal. Note that this test is not 100% fool proof as the simulator does not have the proper loads like coils etc. connected to them. But it will show the obvious faults that come during manufacturing. This firmware will not alter map data unless you load a new map in. This program is used for all firmware types like ECU, TCU, etc. After the test procedure make sure you load the same firmware in for the customer. This program has firmware lockout if it is loaded in the wrong device.

This process will require the following:

· Orion2 Device

· USB/UART Spitronics cable to connect to Orion2 with Device Manager 4

· Computer or laptop with internet connection.

· Device Manager Ver 4.01 Software

· Simulator2/3 with power

The firmware for a device is called:

Orion2 Simulater2 30 Test Program Ver 4.0A 24_01_2019.firm

· Orion2 - device that is tested

· Simulater2 or 3 - the model of simulator that the firmware is developed for

· 30 - Program number to be selected on Simulater2

· Test Program - Description of firmware

· Ver 4.0A - firmware version

· 24_01_2019 - the date of the firmware

· firm - a file type extension used by the Bootloader

Steps:

· Ensure that all the jumpers are in the prescribed positions. This may affect the outcome of your test 2 results. See further in the manual the default Jumper settings.

· Connect the simulator to the Orion2 and use the correct simulator harness

· Connect the USB/UART Spitronics cable and switch on

· Load the Test firmware in the device with the Bootloader.

· Open the Device Manager Ver 4 software and connect to the Orion2

Portal

No action is required on the Portal. The Portal may be used for confirmation of Test 2 procedure if you are a dealer and the device is not yet allocated.

Device Manager

Now need to log into the device manager

.

The information on the device and firmware is displayed.

· Device Serial Number is a unique code in the microprocessor and cannot be altered. Once serialized, this code will be saved on the Portal.

· Flash Serial Number is no longer used and is a copy of the last 9 digits of the device serial number.

· Hardware Type confirms the device and its photo is displayed.

· Hardware Class

· Firmware Type Locked

· Firmware number Locked

· Brand Code

· Firmware Type

· Firmware Number

· Firmware Class

· Firmware Version

Click on Tester to go to the Test screen.

With this screen you can test each input to the device. On the simulator is LED's for each output. Further below is a description of each I/O to be tested.

The flash memory value is always [image] for a new device. Note that it will change after a map is loaded. That will indicate that the memory chip is functional and can save tuning maps.

You may load a map into the device from the Device Manager 4. Take note that this will be a clone action so all settings in the device will be the same as the map file. Click the load button [image] and browse to where the map is.

Select the map and click Open [image]. It will be saved in the device and then the File button disappears and the serialize button become visible which will be used after the testing of the Orion2.

Note that the Flash Memory block has another value than 255.

This verify that the flash chip is functional.

Testing the inputs of the Orion2 Device

All the analogue bars must be tested for low and high scale. The POT or potentiometer must represent low and high limits. With other words when the POT is close or open the bar must be zero or full scale. Then movement from the POT must indicate movement from the bar. No dead band before the bar moves. That will be a fail.

or

Note that the bar may not reach 255 exactly as it may be variance in simulator voltage.

MAP Potentiometer

TPS Potentiometer

LAMBDA Potentiometer

WAT Potentiometer

AIR Potentiometer

Batter Voltage - must be confirmed at ECU input and GND with multi meter.

RPM indicator - it has 2 scales selectable by the PROG button. Low is 2100 max and high is 15600 max. Note that program 30 must be selected on the simulator.

Memory chip operation test. 255 means failure after map is loaded.

Now focus on the Simulator2 and on the ECU for LED flashes. Below is a pattern and each LED must light up in this sequence. If there is a short between outputs, then other LED's out of sequence will flash.

If you are a dealer and this is a new device, you can confirm that these tests were successful with TEST 2 on the portal. Should the results be different later then I will be traced back to you. So make sure it is correct.

You may now load back the customer firmware program and load another map. This will confirm that the flash memory is also working.


Frequently Asked Questions

Help > Product Selection >

Frequently Asked Questions

1. Is this unit a Plug-In replacement for my car's standard computer? No the Spitronics products are unique with its own connecters and operation. Some of the signals can be interfaced with the standard units to maintain other functions like instruments etc.

2. Which product will suit my application? It is easy to determine by the How to Choose and Comparison Chart topic further in this chapter. Read through all the points and narrow down which unit is suitable for your application.

3. What do I get with the kit? All kits come with harnesses to connect onto existing engine or transmission connectors. It does not include the engine or transmission connecters as there are too many variations. You simply solder the harness onto your existing connecters. We do stock some of the connecters but will only quote them on enquiry. Then the ECU kits come with a 2.5 Bar Map sensor which may be changed on request to a different type. Note that dealers pack kits according to your requirements so it may not be the same as the basic kit setup in the main photo due to the variations in applications.

4. What do I need to buy extra? Any sensors not included in the kit like Air & Water temperature sensor, Oxygen sensor etc. that is not on the engine or has to be replaced due to failure or service date expire. The USB communications cable is sold separately because you only need one as a tuning tool. It is a must-have component for the setup and tuning of the products. The Programmer is optional for Mercury2 to change the firmware or install upgrades afterwards. It is recommended for customers abroad were you are far from support. If you buy Level 1 harness you may need a fuse box and automotive wiring and some dress-up components like lugs etc.

5. Is the unit Plug & Play No it is more like Wire & Play. Meaning that there is a certain amount of installation time soldering and wiring to be done before the unit can be switched on. Then you may need to tune it to your engines parameters due to minor variation differences between engines.

6. Can I install and tune this unit successfully? These products were developed for the DIY market. But you do need a fair bit of knowledge and hand skills to complete this project. Most auto electrical people should be able to assist if you have difficulties. If you study the manual properly you should be able the get your engine reasonably drivable with fair consumption and performance.

7. Does the unit need to be Dyno-Tuned after install? Some tuners found a way to tune it on the road quite successfully especially if there are no Dyno's available. If you do have a facility and a recommended tuner it is advisable to have it tuned properly. Some units that is engine-specific may come with a tuned MAP on it for that engine. Then minor tuning is required and not necessary for a Dyno Tune. High performance racing and turbo engines is recommended for a dyno tune as they can brake easily under heavy load. Road tune also become problem some due to handling the power.

8. Is the unit pre tuned? No but we do put a startup MAP on the unit. These units are universal for different engines and it cannot cater for all variations in sensor and driver setup like injector sizes, fuel pressure etc. in some units that is engine-specific we will load a tuned MAP on it for that type of engine. It should start and be drivable around 90%. But some fine setup will make it more efficient.

9. Can this unit work for diesel engines? No Spitronics is busy to develop a Diesel version but it will only be finished in the near future.

10. Can this unit work for direct injectors? No but it is under development with the Diesel development which will be finished in the near future.

11. Can this unit work for Throttle by Wire systems? Throttle by wire is in the testing phase and sold using ECU software. Throttle by Wire software will follow soon.

12. Is this a piggy back system? No this is a standalone computer and does not require any other electronic units apart from its own units and the sensors on the engine. But with clever connections and sharing of the OEM signals it can be used with the OEM ECU to add fuel or do some different tasks.

13. Can this unit control my VVTI cams? It can control cams in open loop at this stage. Loop control is under development which will be finished in the near future.

14. Does this unit do Knock sensing? No, knock sensing may be developed in the near future.

15. Does this unit do self-tuning? No the units do have loop control with the oxygen sensor and idle valve, but all tuning is done in open loop and these systems will fine adjust in real time to optimize fuel mixtures. It is on development in the near future

16. Can this unit be used for racing fuels? Yes, it does have two selection MAP's to tune the engine for different fuels. These maps can be selected with a switch at startup. It can also run duel injectors with different fuels on the 2 injectors.

17. Can these units interface to my vehicle' ECU via the CAN BUS No, these devices do not have CAN BUS capability.


Mercury Coil Driver

Help > Product Selection >

Mercury Coil Driver

The MERCURY Coil Driver is a quality high performance spark generator designed for plain coils without built-in drivers. The Mercury ECU can drive coils with built in drivers directly but you have to use the external Mercury coil driver for basic coils.

This driver comes in 2x2, 4x4 and 6x6 driver configuration. This means each driver has a trigger signal. If you have for example a 4 cylinder with 4 coils you will require the 4x4 driver. The mercury coil driver may be configured for wasted spark or single coil. See the wiring diagrams on these connections.

The Mercury coil drivers use a specialized component that can drive the primary up to 360 Volts creating a 36 Kilo Volt output on most coils. The driver is current limited to 10 Amp and has a soft discharge feature should the ECU not trigger it within a certain time. It has over temperature protection that will prevent overheating of the driver in long charge time duty cycles. It also has an overload LED that comes on at 4 amperes and can be used as an indication to set up charge times. See the charge time section.

Mercury Coil Driver Specifications

Coil maximum primary voltage 360 Volt

Coil maximum charge current 10 Amp protected

Coil lockout against accidental trigger when charge signal is too long

LED Indication

Yellow Power on indication

Green Trigger indication for input signal on Channel 1

Red Overload indication for output signal on Channel 1

Power required

12V 100mA

Inputs

2, 4 or 6 Coil Drivers

1 to 12 volt On Charging, 0-1 volt Off (Discharging).

Outputs

2, 4 or 6 Trigger Outputs 10A 360V to ground protected

Dimensions

Size 95 x 60mm x 21mm

Weight 120g Epoxy Filled

2 x Connector Type Plastic Molex 8, 6


Wi-Fi Module

Help > Product Selection >

Wi-Fi Module

The Wi-Fi module is a third party module and is used for Apple dash application software from a third party dealer www.realdash.net It can also be used to connect to the Hyperspace tuning software but is not very user friendly. That option will not be supported by Spitronics due to the difficulty. Wi-Fi is faster than Bluetooth but are still used in serial communication mode. Wi-Fi is also more stable and can cover longer distance.

NB!! When connected to the Wi-Fi module the tablet of smartphone will not have access to any data service. Wi-Fi module runs at standard 2.4mhz

Wi-Fi setup

Connect the Wi-Fi module to the device Comms connector. It will receive power from the device when it is switched on. The red LED on the module will light up. This will indicate that the module has power and are ready for pairing.

Open windows Bluetooth manager of your laptop or mobile device. Go to settings, Wi-Fi and select the "Spitronics-00x" module.

The module will ask for a password; password is "12345678".

Step 2: Connect RealDash. Open RealDash. Tap on the screen and a tab will appear from the top.

Select settings and this screen will appear:

On the Connections tab select Add. Select Spitronics ECU or TCU depending on what is connected to the module.

Select "WIFI/LAN".

Insert this IP Address "192.168.4.1" and keep the port "8080".

Complete the remaining settings depending on unit settings.

Select done. The connection is now complete and this will be displayed.

Just go back to main screen and RealDash will now respond to the unit.

Setup is now complete.


Bluetooth Module

Help > Product Selection >

Bluetooth Module

The Bluetooth/UART module is used for Android dash application from a third party dealer www.realdash.net It can also be used to connect to the Hyperspace tuning software. Bluetooth is not as fast and direct as the USB cable so there is a setting that has to be made in the tuning software. It is however used with great results. However, some phones do have an issue. That is why we also stock a third party Wi-Fi module for the Apple series products.

Bluetooth setup

Connect the Bluetooth module to the device Comms connector. It will receive power from the device when it is switched on. The blue LED on the module will start flashing. This will indicate that the module has power and are ready for pairing.

Open windows Bluetooth manager of your laptop or mobile device, it can either be found in the taskbar bottom right, or by going to the control panel. (NB! Make sure your laptop or mobile does have Bluetooth capability)

Turn the Bluetooth on if not on and select the device, the module will read as "SPITRONICS". (it may read it as unknown device at first but give it a while or just pair with it anyway)

It will now ask you for a pairing code, this code will stand on the side of the module and is also the serial number of the module. (example BT0022) Every module has their own code. Ignore the BT and leading zeros. So the example's pairing code is 22.

Now that the module is paired, open the Hyperspace software. See if the software detected the unit on the bottom left corner.

If not try closing the software and opening it again.

Now open the Tuning and Settings menu on top and go to Device settings.

You will see the software communication LED will flash green then red. This means it loses communication.

Now increase the Max Poll Error counter till it only flash green.

Press close and you are ready to tune.

You only need to set this once. If you are using the USB cable again you may do the same process and make the value zero again. It will make for faster communication and error detection.


Electronic Relay

Help > Product Selection >

Mercury Relay Overview

The Mercury Electronic is used as a fuel pump driver when fuel pressure control is activated. It is the PWM controlled to change the power to the fuel pump. It is driven by a positive signal from the ECU.

Note that a fuse before this relay is required to protect the circuits from over current. 45 Amp can melt thinner wires causing a fire hazard.

Specifications

Relay Maximum current - 45 Amp protected

LED Indication

Yellow Power on indication

Power required

12V 45 Amp

Inputs

1x Relay Trigger input - 5 to 18 volt for On condition, 0-1 volt for Off condition.

Outputs

1x 12 Volt output 45 Amp

Dimensions

Size 49 x 45mm x 21mm

Weight 50g Epoxy Filled

4 x Fly Leads


Stepper Idle Control

Help > Product Selection >

Stepper Idle Control

The Mercury Idle Control is designed to control small stepper idle motors. There are 2 types namely Type 1 for 4 coil common steppers mostly found with Toyota engines and Type 2 for Bi-Polar steppers mostly found on GM engines. This unit is micro based and receive an open or close signal from the ECU. Idle control is done in loop mode by the ECU. It is used as an add-on to expand the ECU' outputs.

Specifications

LED Indication

Yellow Power on indication

Power required

12V 5 Amp

Inputs

1x Trigger input - 0 to12 volt duty controlled.

Outputs

Type 1

4x ground outputs 3.5 Amp protected

Open collector configuration

Type 2

4x ground outputs 3.5 Amp protected

4x 12 outputs 3.5 Amp protected

Push Pull Configuration

Dimensions

Size 49 x 45mm x 21mm

Weight 50g Epoxy Filled

1 x Connector Type Plastic Molex 8


Map Sensor

Help > Product Selection >

MAP Sensors

The Map Sensor is designed to measure the manifold's intake pressure and use that signal as a fuel mixture control parameter. This sensor is enclosed in a plastic holder to protect it in the engine compartment. They come in 2 versions, 1.1 Bar in a red enclosure and 2.5 Bar in a black enclosure. The accuracy of these sensor makes it possible to use the 2.5 Bar sensor for normal aspirated engines. It will be scaled by the software

The 1.1 Bar is still preferred for altitude compensation sensor when the external Map sensor is used for altitude.

Specifications

Power required

5V 50 mA

Pressure Range

Red = 1.15 Bar Max

Black = 2.5 Bar Max

Outputs

1x Analogue 0 to 5V

Dimensions

Size 49 x 45mm x 21mm

Weight 50g Epoxy Filled

3 Core Fly Lead

Aluminum MAP Sensor Overview

The quality Aluminum Map Sensor is designed to measure the manifold's intake pressure and use that signal as a fuel mixture control parameter. This sensor is enclosed in an aluminum holder to protect it in the engine compartment. They come in 4 versions, 1.1 Bar, 2.5 Bar, 3 Bar and 4 Bar. The accuracy of these sensor makes it possible to use the 3 Bar sensor for normal aspirated engines. It will be scaled by the software. In some cases, the 4 Bar sensor is also used as a fuel pressure sensor for normal aspirated engines.

The 1.1 Bar is still preferred for altitude compensation sensor when the external Map sensor is used for altitude.

Specifications

Power required

5V 50 mA

Pressure Range

1.15 Bar Max

2.5 Bar Max

3.0 Bar Max

4.0 Bar Max

Outputs

1x Analogue 0 to 5V

Dimensions

Size 44 x 40mm x 25mm

Weight 30g

3 Core Fly Lead


USB Communication Cable

Help > Product Selection >

USB Communication Cable

Communication between devices and the Galaxy Software is done via a USB Cable manufactured by Spitronics. The reason for this is to reduce production cost and board space. These components are only used during tuning and you do not need the cable once the ECU/TCU are tuned. The electronics in the cable consist of the USB converter as well as isolation devices. This cable will protect the laptop during high voltage interference.

This cable requires drivers to be installed to operate. They can be downloaded from the Spitronics website under Downloads - USB Drivers. The baud rate to all products are 19200.

As development progressed over the years these products were upgraded as well. So keep in mind that cables between the products do differ. In some cases, you may require an adapter to use the USB cable on older products.

Connection Diagram

Installing the USB Drivers

Related Links

History


Firmware Programmer

Help > Product Selection >

Firmware Programmer

The USB Debug Adapter or Firmware Programmer as we call it in the manual, are used to recover the BootLoader and Firmware of the Orion after a corrupt failure, or for starting a new device at the manufacturer. It is not a regular program to be used. See the BootLoader for loading firmware.

This software to be installed and can be downloaded from www.spitronics.com under the following path. You may click on the bottom link to download the software.

Firmware Programmer Software

http://www.spitronics.com/downloads/Firmware Programmer/mcu_ide.exe

This manual can be found under the sub folders. NB! Read through the precautions part before attempting to program your device.

See the sub folders for further information:


Introduction

Each product has a selection of firmware programs. These programs are the heart of the microprocessor that initialize the product to operate in a specific way. Each engine has different sensors and electrical accessories and requires different programs. The firmware programmer allows the users to change the Firmware program in the ECU for different engines or applications. The programmer is also used for upgrading to the latest version of the manufacturers firmware. The programmer is bought optional and not a requirement. It is very useful if the agent is far from the manufacturer. The firmware software is freeware after development. Read the Precautions first to prevent damage.

See the other folders for further explanation.


Precautions

1. Do NOT program the incorrect product firmware in your product. This could lock the microprocessor for operations and destroy the hardware. Each products firmware starts with the product name to minimize mistakes. Most of the firmware do have hardware lockout protection but the Test Programs and the older products do not have this protection feature. So do take care on this action.

2. Do NOT press the [image] button at any time in the Programmer Software. This will erase the product ID Code rendering it useless. This product will then have to be reprogrammed by the manufacturer resulting in courier charges and time loss.

3. Disconnect all the output harnesses from the product. The programmer will switch the outputs to the high state which means that coils and injectors will be switched on. This may damage the coil drivers or coils and fill the engine with fuel.

4. Follow the Startup Procedure to make sure that the right firmware and settings is loaded into your product to prevent damage. Some agents may neglect or misunderstand you on your application. It is your responsibility to check for mistakes.

5. After programming check the information screen to see if the right firmware is loaded. Note the program number and description.


Installation

After downloading the Firmware Programmer software run the file mcu_ide.exe to install the software program. Follow the onscreen instructions till you are asked for the following.

Click on Custom and uncheck Examples and Utilities.

You will not need these and they will only take up unnecessary disk space. No harm if you install the complete programmer.

Connect the USB programmer to the PC only and start the program at the start button, activate Silicone Laboratories and click on Silicone Laboratories IDE.

Now click on Options, Connect Options and select USB Debug Adapter and also C2 interface.

Click OK and you are all set to use the Programmer.


Operation

To program your Product, first connect the Programmer to the Product's Com Port. Connect only the P1 12-Way connector and earth the Product. Switch the ignition on. Click on the [image] button to connect.

The download [image] button will become active, click on it.

Now use the Browse button to select the correct HEX file on the hard disk or CD. Do not at any stage press the Erase all code space button.

Select the Files of Type to be Intel Hex (*.hex) then go to Look in: to search for the correct file.

Click Open when it is selected.

Click Download to program the Product.

Click the disconnect [image] button when it is finished and switch the ignition off. Disconnect the programmer and connect the USB/UART Converter cable. Do not connect the output cables before you run through the startup procedure. This will ensure that load the right firmware and not to damage the product.


Error Messages

Help > Product Selection > Firmware Programmer >

Error Messages

The Silicon Laboratories IDE Software display different messages when it cannot connect to the device or the Debug Adapter. Fast way to verify if the equipment is correct is to see if you can get connection to another device if you have one. Below is a description of the messages.

This message appears when the debug adapter Connection Options settings is incorrect. See the example below.

This message appears when the Silicon Laboratories IDE Software and the debug adapter are not the same version. If you press Ok it will be updated and never ask this question again until you load newer version Silicon Laboratories IDE software on the laptop.

This message appears if the debug adapter is not connected to the laptop. If it connects the Run and power LED's will light up on the debug adapter. It may also be a faulty debug adapter.

This message appears when the debug adapter is not connected to a Spitronics device. It may be a broken wire between the debug adapter and device. It may also be a faulty device. Usually when the Micro Processor of the device is blown. It may also be a damaged USB debug adapter. On some products the programmer inputs have duel tasks. It is then selected via jumpers. Make sure the jumpers are set for program mode.

This message appears when the debug adapter makes only partial connection to the device. Usually a damaged Micro Processor of the device.


Harnesses

Help > Product Selection >

Harnesses

The Harness is a very important part of and ECU/TCU. This will connect the electronics with the cars components to make the engine or transmission operate correctly. Over the years development made many improvements resulting in many harnesses. Each harness has a part number to identify its wire colors, layout, thickness, length and type to the design drawing and connection drawings.

Harnesses came in many categories and some are discontinued due to improved versions. Two main groups are easy install or export harnesses and economy harnesses. The first type came later years when installers required a more complete harness to save on install time. This is very handy for new customers or employees to minimize faults during installations. The second group is the economy series. This has all the wires on the connectors to the ECU/TCU because that is a difficult connection to make for installers. It does not include power wires from the battery and relays. This will save the installer money on initial purchase and will add it later. It allow him to customize his harness on each engine to make it neat. Another group is the wire type. First all harnesses were made with shielded computer core 0.5mm2 wire. Later the demand grow for more high quality automotive wires. This was mainly on the output side to coils and injectors etc.

In this manual you will find a design drawing and overview of each harness. Harnesses not in production will not have an overview. The manuals are based on the easy install harnesses so if you use the economy series you may need to look at the other drawings and make your install on those recommendations.

The link below will take you to the harness section.

Harness Explanations


Safety Precautions

Help >

Safety Precautions

The following guidelines in this manual will ensure proper product operation the first time. Failure to install the product correctly may damage it or other equipment permanently. These failures will solely be the responsibility of the installer and no guarantees will be given by us. Make sure you have read the Terms and Conditions in this manual or on the website www.spitronics.co.za before you install this product. By installing the product you automatically agree to these conditions. All equipment is tested before it leaves the factory. We accept no liability for malfunctioning of the equipment, or to injury that may result from installation or the use of the equipment. We also accept no liability for costs of traveling of transportation of the equipment or parts or vehicle recovery due to failures of any equipment. Please read the instructions and drawing and make sure you understand before you begin.

2.1 Operator Safety

  • Use only proper tools and products suited for auto installations. Substandard products and installation procedures may cause failure to the equipment having your customer break down in dangerous areas.
  • Use correct thickness of wire to carry the entire current requirement for that circuit. Too thin wires will heat up and may start a fire causing injury.
  • Use fuses to protect each circuit separately. Joint circuits require large fuses which may heat and melt lesser circuits causing fires.
  • Solder joints, and cover it with shrink sleeve to prevent loose connections which may cause fires. Space solder-joints so that they do not sit next to each other in the harness thus minimizing the chance of a short circuit.

See the individual Safety Precautions for each product.


Orion2 Installation Precautions

Help > Safety Precautions >

Orion Safety Precautions

Connecting

Never connect an Orion on other harnesses that have the same connecters.

Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

Leave the output connectors P2, and P3 disconnected when you switch the ECU on the first time.

Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

Make sure that the coils and injectors get there power from the Orion power relays. This relay will only switch on after the ECU has select the logic level for the driver. Powering them from the vehicles power will damage the drivers and coils.

Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

The TPS must be connected correctly as it may damage the ECU or TPS permanently.

Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

Do not connect the ECU outputs directly to solenoids or fuel pumps unless it is shown on a drawing. Check the current rating or the outputs in the Specifications.

Test the coil resistance to see which type coil you are using and if it is still functional. This is important to program the correct parameters. See Coil Selection. If you are not sure take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

Never connect direct injection injectors to the ECU. Their resistance are very low and will damage the ECU and the Injector.

The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

Make sure about the correct Jumper Settings before you switch the ignition on.

Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU harness and damage it.

Power

Ensure that fuses are the minimum value required value to hold the current. Too large fuses will not blow resulting in driver or coil destruction.

Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops will cause lean mixtures.

Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

Do not connect screen wires on the engine. The starter will draw current through then melting the harness. It will also bring all the engine interference in the ECU.

Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

Ensure that all connections from the battery and alternator are secure.

Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This cause voltage spikes on the common wire.

Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programming

If you are reprogramming the Orion via the bootloader, never switch the power off before programming is finished. it will hange the ECU and then it is a tedious process to get it running again.

Interference

Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. See the drawings for correct connections.

Connect screen input wires as close to the sensor wires to minimise exposure of open wires to electro-magnetic noise.

The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability
The wiring is critical for reliable operation of the ECU. The following points will help to ensure that the wiring is reliable:

Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is properly done. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity gently touch the side of the terminal only.

Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice ensure that wire movement near the splice is avoided because a fracture might occur at the stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These type of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


ECU Engine Managment

Help >

ECU Engine Management

This chapter explains all the drawings instructions and tuning around Engine Management. View the sub folders for different sections.


TxW Hardware Description

Help > TxW Controller >

Drawings and Explanations

This chapter has all the wiring diagrams and explanations on how to connect the device with the default harnesses. Make sure which drawings suit your application. Print them and work from them to eliminate confusion. Some pages require input from you like firing order. Be sure to use the right specifications of your engine to compile your documents.

Note: If a Hyperlink is not attached to a drawing or file, please ask your dealer or look on the Web if the firmware is available before wiring. This manual will include future development as well.

See the sub folders for explanation.


Orion2 Layout

Help > TCU Transmission Management > TCU Hardware Description >

Orion2 Layout

1. PWR LED - 5 Volt Power on

2. INFO LED - Information

3. Coms - Communication Connecter 6 Way - USB Cable & Programmer

4. P1 - Input Connector 12 Way

5. P4 - Serial Link Connector 4 Way (Not Used)

6. P3 - Positive Output Connector 8 Way

7. P2 - Ground Output Connector 4 Way

8. Mounting Holes 5mm


Inputs and Sensors

Help > TCU Transmission Management > TCU Hardware Description >

Inputs and Sensors

This chapter contains all the information and wiring of the Inputs and sensors.

See the sub folders more information.


P1 Sensor Inputs

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Inputs and Sensors

P1 Input connector contains wiring of the following Sensors. Below is a drawing of all the sensors. For more detailed connections see the sub folders.

Map Sensor

TPS Sensor

Water Temperature Sensor (Sensor included)

Air Temperature Sensor (Sensor included)

Lambda Sensor

Crank Sensor

Cam Sensor

E22 P1 Sensor Input Drawing

E22 P1 Crank and Cam Sensor

E24 P1 Crank Sensor


Comms Sensor Inputs

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Inputs and Sensors

P5-Comms Input connector contains wiring of the following sensors and output.

Tuning Potentiometer (POT)

Dual Map Switch

USB/UART Communication Cable

P05-Comms Sensor Input Drawing

USB Communication Cable


Crank and Cam Sensors

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Crank and Cam Sensors

The Orion2 ECU is a universal controller designed for most types of Optic, Hall or Magnetic reluctor sensors. It can read 2 sensors in total. Mostly Crank and Cam or Speed sensors. Below is a link to a drawing with the different connect options for the Orion triggers.

E22 P1 Crank and Cam Sensor.pdf

E24 P1 Crank Sensor.pdf

Crank and Cam Sensor Tap In E22_P1

Crank Sensor Tap In E24_P1

The crank and cam angle sensors on an engine is used to determine crank and cam angles. (See the sub folders for more information.)

A crank angle sensor can be used alone for non VVTI engines, but this can only give information relative to 360 degrees. This engine will only run with split sequential injection and wasted spark coil firing. If full sequential injection is selected, injection is not in sink per engine stroke. It means you may sometime inject on the bottom deck of exhaust stroke and sometimes on bottom end of compression stroke. The aim is to always go for injection angle at bottom stroke just after the intake valve closes. Here atomization will be at its best and also consistent even if the stroke is not in sink. Full sequential spark is not possible in this scenario.

The cam angle sensor will give the ECU information over 720 degrees. This will indicate the 4 strokes for sequential injection or coil firing. Depending on the trigger wheel designs, some engines may need up to 2 revolutions cranking before the ECU can sink properly. Some programs may start in split sequential injection and fire the injectors in split sequential to enhance starting. Thereafter it will go to full sequential mode and stay there.

VVTI engines may have additional cam angle sensors that indicates the cam angle relative to the crank angle. This will let the ECU calculate and manipulate the cam angle for RPM and load variances. There may be intake cam control, exhaust cam control and also lift control. Then V type engines have all this in dual banks.

There are three types of sensors. The Magnetic reluctor sensor, Optic sensor and Hall type sensor.

The Magnetic reluctor sensor is a coil wound over a magnet. The teeth on the crank gear will disturb the magnetic field and that will generate a voltage spike over the 2 wires. The sensor is normally located on the engine block and picks up from a toothed wheel on the crankshaft. The physical position of the sensor may vary from front pulley, inside block and flywheel.

Hall and optic sensors both give a square wave outputs and are treated exactly the same. They have electronic components in the sensor which convert the signals to square wave. The Hall sensor uses magnetic field where optic sensor uses infrared light. In both cases a beam is broken and detected. The sensor output is usually an open collector transistor which means it will require a pull-up resistor normally situated in the ECU or TCU. This sensor is normally located on the valve cover and picks up protruded teeth from the camshaft. The physical position of the sensor may vary. The VVTI sensor will be positioned on the actual camshaft and not on the cam pulley to measure cam movement.


Testing Magnetic Sensors

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

Testing Magnetic Crank Triggers

Work through each point below to find your problem.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 connector, and on Orion2. The other connectors must be open, except for the Comms cable. Open the Hyperspace ECU software and connect to the ECU.

2. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

3. Make sure the Jumper settings are set for magnetic sensors. On Orion2 it must be set to 5-volt position and the 2 pin jumper must be open. Note that Orion2 and Saturn jumpers is the other way round. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of 1 Volt peak to peak. Note: If it falls below 10 see chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors work through each one to solve them. See Error codes.

6. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU read them as trigger pulses.

7. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

8. Make sure you use the correct sensor size with your crank trigger wheel size. If the magnet of the sensor is larger than the gap in the teeth, then your signal will be very week. Rather use a gear with less teeth for the diameter or a sensor with a smaller sensing diameter. If you can't see the magnet protruding from the sensor, put a bit of iron filings on the tip. The magnetic field will show the diameter of the internal magnet immediately. In this case you may enlarge the sensing distance it the signal is strong enough. See the illustration below.

Testing the sensor.

1. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses are also tied to this point. We call this junction Test Point A

2. Disconnect P1 from the ECU. Now use a multi meter and set it on 2000-ohm scale.

3. For Orion2 measure resistance between pin 12 and 6. You should get a resistance of 300 to 2000 ohm depending on the sensor. If you swop the meter wires you must read the same ohm measurement. If you don't get a reading it means your sensor is not connected correctly. Check your wiring connections. NB! Do not press too hard on the female pins as you may damage them resulting in poor contact later.

Harness Pin view

4. If you do get a reading put the meter on AC volts and measure on the same points. Use the lowest scale or 20 volts. Now crank the engine. The sensor will generate AC volts. Orion2 will require a voltage of more than 1 Volt peak to peak for correct operation. If this voltage is lower, it means the signal is too weak and the ECU will not sense it properly. This could be due to a dirty sensor or the gap is too wide between the sensor and the gear. The gap is normally below 1 mm. It could also be that the sensor magnet inside the sensor is wider than the width in the teeth if it's a custom installation.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and force it to restart. There will be an error indicating that the device was restarted. This may be due to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU.

3. Errors that comes at higher RPM's may be due to a trigger wheel that is not balanced or is buckled. Sensing distance may be too large. It could also be due to a small gear teeth pitch, or a sensor with a large sensing magnet. The 2-pin jumper is on and it should be off.

4. Ensure that the test signal next to the crank sensor is off.

5. The RPM on the sensor signal could fade, this could be due to the gap between it and the trigger wheel been too close or too far apart.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked lead also play havoc. A trick is to look at them in the dark while it idles. It will show flashes in the dark. The crank sensor wires are too close to the HT leads.

Related Links

Jumper Settings

Power Connection

Error Codes


Testing Hall or Optic Sensors

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

Testing Hall Crank Triggers

Work through each point below to find your problem.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 connector, and on Orion2. The other connectors must be open, except for the Comms cable. Open the Hyperspace ECU software and connect to the ECU.

2. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

3. Make sure the Jumper settings are set for Hall sensors. On Orion2 it must be set to 12-volt position and the 2 pin jumper must be closed. On Mercury2 the 2-pin jumper must be closed. Note that Orion2 and Saturn jumpers is the other way round. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of the specific ECU. Note: If it falls below 10 see chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

6. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

7. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

8. Make sure you use the correct sensor size with your crank trigger wheel size. If the magnet of the sensor is larger than the gap in the teeth, then your signal will be very week. Rather use a gear with less teeth for the diameter or a sensor with a smaller sensing diameter. If you can't see the magnet protruding from the sensor, put a bit of iron filings on the tip. The magnetic field will show the diameter of the internal magnet immediately. In this case you may enlarge the sensing distance it the signal is strong enough. See the illustration below.

Testing the sensor.

1. The hall or optic sensor requires power to operate. So it cannot be dry tested like a magnetic sensor.

2. First measure continuity from the ECU ground to the sensor ground. There should be 0 ohms as the earth comes from the thin black wire coming from the harness to the thick black earth of the ECU.

3. Measure continuity from the sensor power to the ECU ignition power that comes from the key. There should be 0 ohms.

4. Now measure continuity from the sensor signal to the ECU input for that sensor, see the drawing. You can disconnect P1 and measure on pin 12. NB! Do not press too hard on the female pins as you may damage them resulting in poor contact later.

5. The fastest way to test it is while it is powered in the circuit. While P1 is connected switch the ignition on.

6. Measure at the power at the sensor between negative and positive. You should measure around 12V DC.

7. Now unbolt the sensor from the engine. Measure DC volts between sensor negative and signal. It should be 12 Volt and if you bring a metal object to the sensor it should go to 0 volt. The logic may be reversed for some sensors. As long as you see the step change. On optic or some hall sensors you may need to move a plate between the sensor and transmitter part. If the voltage doesn't go to less than 1 Volts, then it means the ECU will not detect the change.

8. If you don't measure the 12 volt on any condition on the sensor signal, it may be the pull-up jumper is not in closed position. If the jumper is on, then disconnect the sensor signal wire and measure at the ECU side for the 12 volt. If you measure 12 Volt, it means the sensor output is damaged and short the signal wire to ground. If you don't measure 12 Volt, then the ECU does not provide power through the pull-up resistor.

9. Now bolt the sensor in place and measure on the sensor signal and negative with AC volts. Crank the engine and you should see 12 volts AC.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and force it to restart. There will be an error indicating that the device was restarted. This may be due to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU.

3. Errors that comes at higher RPM's may be due to a trigger wheel that is not balanced or is buckled. Sensing distance may be too large. It could also be due to a small gear teeth pitch, or a sensor with a large sensing magnet. The sensor may require an extra pull-up resistor. Add a 1 K resistor between sensor signal and sensor positive.

4. Ensure that the test signal next to the crank sensor is off.

5. The RPM on the sensor signal could fade, this could be due to the gap between it and the trigger wheel been too close or too far apart.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked lead also generates interference. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Related Links

Jumper Settings

Power Connection

Error Codes


ECU Crank and Cam Signal Tap-In

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Crank and Cam Sensor Tap-in

The Orion2 controllers can be tied into existing OEM circuits. There are a few rules around this to ensure that both systems operate correctly and is not damaged. It varies for the different products and sensors.

Controllers that share a sensor has to share a common earth connection. Differences in earth will have an effect on the sensors signal. So make sure you connect the Orion2 earth to the OEM earth.

Never connect the reference voltage of the Orion2 controller to any wire of the OEM sensor. Only the signal wire is connected. It may damage either controller. The sensor already has power or reference voltage from its own OEM controller. See the drawings below.

Isolate the Orion2 wires that are not used. They will have power on them and may short circuit damaging the Orion2 or harness.

If the OEM sensor is not screened it is best to tie in close to the sensor and use the Spitronics screened harness. It may reduce some interference from coils. Remember Orion2 inputs need to cater for all kinds of sensors and cannot cater for week signals with interference. If you still have interference, then you may add a 100uF and 100nF cap as filtering on their reference line. See drawings below. NB. Do make sure which line is signal and which is reference. Crank the engine and measure AC volts to ground of each point on the sensor. The one with the highest value will be the signal line.

The blue Reference volts comes from the OEM controller and differs between car manufacturers. Some use earth as a reference, other 2.4 volt, 5 volts and even 12 volts. The isolating capacitor will block the DC volts from flowing and only let AC signal volts through. Orion2 reference its sensor to 5V. Note that Orion2 requires a minimum 1-volt peak to peak signal.

Below are the basic connections. Some cars may have a magnetic crank sensor in combination with a Hall speed sensor. Connect them accordingly. All the Orion2 P1 connectors has the same pattern for Crank (Pin 12) and Cam (Pin 11) input signal. Note that harness colours differ and should be verified on drawings or GP Priority charts.

Crank Sensor Tap In E24-P1.pdf

Crank and Cam Sensor Tap In E22-P1.pdf


Rotor Phasing

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Setting Distributor Rotor Fazing

This setup for distributors with rotors requires you to align the rotor with actual crank degrees. Rotor fazing is a mechanical adjustment to ensure that the Rotor is under the relevant high tension pole during the spark distribution. If not, the spark will have to jump the gap in the distributor which will cause less energy at the spark plug. It will also generate interference on the sensors causing erratic misfires. As most cars operate between 14 and 36 °BTDC you must ensure that the Rotor is under the pole during this span. Put the engine on 25°BTDC and place the rotor under the center of the pole. Then it can advance a total of 11 degrees, up to 36° or retard a total of 11 degrees, down to 14° and still have contact between rotor and pole. Lock the distributor nut properly and ensure that wiring is tied in the correct manner to prevent damage or strain due to engine movement.

NB! Do not adjust the distributor again. Rotor fazing is now complete.

(See Illustration below.)

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Setting Crank Gear Timing

This crank trigger is a single sensor and some form of crank gear like 60-2, 36-1, 12-1 etc. the more teeth on the gear, the more accurate timing is during blip conditions. This setup requires 2 settings which will indicate TDC accurately to the ECU. One is a course gear teeth number and the other is a degree setting between the teeth.

Gear not visible.

If you can't see the gear you can enter speculative values in Gear Teeth. Best is to disconnect the fuel pump and use a timing light. Start with a teeth value of 1 and timing sensor value of 0.

Set the Maximum Timing on zero.

Put the timing light on zero degrees. Crank the engine and look at the timing. Adjust the Gear Teeth till the mark is just past TDC. Then adjust the Timing Sensor till it is on TDC. Put the Maximum Timing back to its value. Save the settings and connect the fuel pump. Start the engine. Once the engine is stabilized and idle fueling is adjusted, repeat the above process to fine tune timing.

Gear Visible.

If you can see the gear, put the engine on TDC. Count the number of teeth from the slot to the sensor in an anti-clockwise direction. Enter this number of teeth plus one in the software under Gear Teeth. Enter 0 in Timing Sensor °BTDC field. The car should start unless it is a low teeth count. If it is a 12 tooth gear then you could still be out 30 degrees. Rather make an estimate by following the visual sample below.

To determine what degrees is between the teeth compare the center of the pickup to the 2 teeth it falls between. Use the last edge of the tooth as the reference. The sample below is a 36-1 gear which means it has 10 degrees between the teeth. This one seems like it is close to 6 degrees from the last tooth that will pass the sensor. Enter 6 in Timing Sensor.

This engine should start and idle if the fuel is correctly set. Check with the timing light to see if the software timing correlates with the engine timing. If the difference is less than the tooth pitch degrees, adjustments can be made on the Timing Sensor °BTDC field. Otherwise add or subtract one tooth and try again.

If a magnetic pickup is used, ensure that the positive and negative of the magnetic sensor are correct. If they are connected wrong way round, the timing will retard instead of advance and the fazing will be wrong. Sometimes the engine will start but it may not rev up. Look for errors indicating pickup problems.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Cam Angle 24T + Home

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Cam Angle 24T + Home

The popular 24+TDC configuration from the Toyota, Mazda Rotary, Honda etc. engines can be used in many different ways. The 24 tooth gear gives a pulse every 30 degrees of crank rotation. Some distributor encoders use a combination of TDC and Home triggers with this gear. Below are explanations of the different types and also the modifications that could improve stability and simplicity in wiring when using the Spitronics ECU's.

Toyota usually have one tooth on a separate space in combination with two sensors. Each sensor provides a home pulse on a different revolution of the engine. This allows the ECU to sink injection and timing to a specific stroke of the engine every time it starts. This setup requires three inputs from the ECU. The ECU could sync in one revolution. Some ECU's have only one home input which means then engine may have to turn sometimes two revolutions before crank angle can be established.

Using the sensors without modifications is possible but due to the differences in sensor that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. See the drawing below.

The Reference wire is usually common in these encoders. The older ones used these colours and white is common. Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. Usually we use only Home1 sensor. You may add the Home2 sensor on the same connection as shown in optional jumper settings. If the sensor signal is strong this will work perfectly. If it is week then it cannot be used. This method is only for Split sequential injection. For full sequential only use Home1 sensor. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible, move the sensors closer to the tooth gears but they must not touch. Ensure a paper can move between them easy. It they touch it will make more interference.

These 24 tooth trigger wheels can be modified and used with different firmware if it is available for that product. Make sure about this before you proceed. This means that the home sensors are not required. The interference with the 24 tooth gear is very little as the sensor is constantly exited by the many teeth. If you are going to fuel the engine with Split-sequential injection you may grind out two opposing teeth on TDC and BDC. This will then convert to the 12-1 programs which is available. NB. Engine must be on TDC in the drawing below. Note that the Home pulses on the Toyota CAS units have a gradual build-up of metal in front of the sensor as it turns. This is to prevent interference on the sensor due to no excitement. The Mercury2 style input cannot sense this configuration successfully so you may need to modify the sensor as described below.

If you want to do full sequential then only take 1 tooth out under the sensor when the engine is on TDC. The firmware for this gear is Program 84 24-1 Dizzy 4Cyl Full/Seq. It is not popular and may be supplied on request. See the drawing below.

Mazda Rotary engines are 2 stroke and don't require a home pulse. They opted for the pattern below.

Using the sensors without modifications is possible but due to the differences in sensor that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. See the drawing below.

The older ones used these colours. Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible, move the sensors closer to the tooth gears but they must not touch. Ensure a paper can move between them easy. It they touch it will make more interference.

Honda use a 3 level crank angle sensor like below. The 4-point wheel is handy to start quickly because spark does not need to be synced to the stroke of the engine due to the distributor cap that does the syncing. Spitronics only use the crank 30° and the Home 720° sensors.

Using the sensors without modifications is possible but due to the differences in sensor that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. See the drawing below.

The older ones used these colours. Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible, move the sensors closer to the tooth gears but they must not touch. Ensure a paper can move between them easy. It they touch it will make more interference.

These 24 tooth trigger wheels can be modified and used with different firmware if it is available for that product. Make sure about this before you proceed. This means that the home sensors are not required. The interference with the 24 tooth gear is very little as the sensor is constantly exited by the many teeth. If you are going to fuel the engine with Split-sequential injection you may grind out two opposing teeth on TDC and BDC. This will then convert to the 12-1 programs which is available. NB. Engine must be on TDC in the drawing below.

If you want to do full sequential then only take 1 tooth out under the sensor when the engine is on TDC. The firmware for this gear is Program 84 24-1 Dizzy 4Cyl Full/Seq. It is not popular and may be supplied on request. See the drawing below.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Crank Angle 12T + 2Home

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Crank Angle 12T + 2Home

The 12+2home configuration has the same signal pattern as the old 24+TDC configuration from the Toyota. Here there is no CAS but only sensors on the crank and cam directly. The 12 tooth gear gives a pulse every 30 degrees of crank rotation. There are 2 separate Home sensors. Usually one on each cam and they are 360° out of phase. Sometimes they also act as VVTI movement detection sensor. This allows the ECU to sink injection and timing to a specific stroke of the engine every time it starts. This setup requires three inputs from the ECU. The ECU could sync in one revolution. Some ECU's have only one home input which means then engine may have to turn sometimes two revolutions before crank angle can be established. Below are explanations and also the modifications that could improve stability and simplicity in wiring when using the Spitronics ECU's.

Using the sensors without modifications is possible but due to the differences in sensors that the Spitronics ECU's have to cater for, this one needs a bit of external filtering. If your harness has all the wires in one cable, then you need to make an adapter cable from the crank or cam sensor to the other one. They may be far apart so the connecting lead must be screened and the screen wire must be connect to the screen wire of the original loom. Do not connect the screen to the engine. See the drawing below.

Then Crank and Home are connected to P1 pin 12 and 11 respectively. Check the drawings for wire colours. Usually we use only Home1 sensor. You may add the Home2 sensor in parallel to the Home1 sensor. Positives together and reference together. If the sensor signal is strong this will work perfectly. If it is week then it cannot be used. This method is only for Split sequential injection. For full sequential only use Home1 sensor. If you find interference during cranking or at higher revs add the optional resistor A to the circuit. Resistor B is seldom required due to constant excitement of the crank sensor. If it is possible you may grind the teeth under the sensor out when the engine is on TDC and use this with the 12-1 split sequential program. Then you don't need the cam sensors.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Optic CAS Cam Anfle Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Optic CAS Cam Angle Sensor

This chapter discuss the connection and settings for the Optical CAS. For fault finding and testing see the Testing Magnetic Crank sensor chapter in this manual.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 connector on. The other connectors must be open, except for the Comms cable. Open the software and connect to the ECU.

2. On the CAS there is a 360 slot output and a home or TDC slot output. The Spitronics ECU's only use the Home slots. Connect it to the crank sensor input. These sensors the Crank is forced to rising edge and the Cam is disabled. In older software use the same settings. Gear Teeth is locked on 1 and Timing Sensor is usually between 60 and 65 degrees BTDC. Make sure the CAS is in its original mounting position where the bolt slides in the slotted groove. See the illustrations below:

3.

4. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

5. Make sure the Jumper settings are set for Hall sensors. On Orion the crank sensor jumper must be set to 12-volt position and the 2 pin jumper must be closed. The cam sensor input is not used. Leave the jumpers open. You may now crank the engine without the other connectors.

6. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of the specific ECU. Note: If it falls below 10 see chapter about 'Power Connection'.

7. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

8. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

9. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

Testing the sensor.

1. The optic sensor requires power to operate. So it cannot be dry tested like a magnetic sensor.

2. First measure continuity from the ECU ground to the sensor ground. There should be 0 ohms as the earth comes from the thin black wire coming from the harness to the thick black earth of the ECU.

3. Measure continuity from the sensor power to the ECU ignition power that comes from the key. There should be 0 ohms.

4. Now measure continuity from the sensor signal to the ECU input for that sensor, see the drawing. You can disconnect P1 and measure on the pin.

5. The fastest way to test it is while it is powered in the circuit. While P1 is connected switch the ignition on.

6. Measure at the power at the sensor between negative and positive. You should measure around 12V DC.

7. Now unbolt the CAS from the engine. Make a proper mark so you can install it in the exact position. Measure DC volts between sensor negative and signal. It should be 12 volt and if you turn the shaft slowly it should go to 0 volt. If the voltage doesn't go to less than 1 volts, then it means the ECU will not detect the change.

8. If you don't measure the 12 volt on any condition on the sensor signal, it may be the pull-up jumper is not in closed position. If the jumpers are correct, then disconnect the sensor signal wire and measure at the ECU side for the 12 volt. If you measure 12 volt, it means the sensor output is damaged and short the signal wire to ground. If you don't measure 12 volt then the ECU does not provide power through the pull-up resistor.

10. Now bolt the sensor in place and measure on the signal negative and positive with AC volts. Crank the engine and you should see 12 volts AC.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU. A restart error will come up.

3. Errors that comes at higher RPM's may be due to a weak pull-up signal. The sensor may require an extra pull-up resistor between the sensor signal and the sensor positive. Use a 1K resistor.

4. Ensure that the test signal next to the crank sensor is off.

5. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked leads also make interference. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Jumper Settings

Help > TCU Transmission Management > TCU Hardware Description >

Jumper Settings

The Spitronics ECU's are universal products that cater for all kinds of sensors and features. Therefore, it has Jumpers that is switched which will expand the universality of these products. Most jumper settings are around the crank and cam angle sensors to select between hall or magnetic sensors. Orion2 has more options than other products. See the detailed explanation drawing below.

Click on the link below:

Orion2 ECU Jumper Settings

Orion2 TCU Jumper Settings


Water Temperature

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Water Temperature Sensors

E22 P1 Inputs Drawing

The water temperature sensor is mostly used by the ECU for cold-start and run enrichment, engine over temperature limit and thermostatic radiator fan control. They come in different shapes and resistance values.

Operation
The resistance of the temperature sensor changes in relation to the temperature it senses. It has a negative temperature resistance co-efficiency (NTC). Each sensor has a preprogrammed curve to indicate its resistance to temperature. Note: The Spitronics ECU uses a 2K resistance NTC and this value is measured at 25°c. (See below a sample of such a curve.)

Image result for NTC sensor graph

Electronics sensors

Spitronics build and supply small sensors for customers to build into their own units. There are 2 sizes but it does the same work. Note: These sensors require a pull-up resistor to let a constant current through them. (See below a picture of what these sensors look like in their raw form.)

How to measure a sensor
Use a multi-meter set to the 10,000 ohm (10 K) range. With the sender unit at approximately 25°c, measure the resistance. It should be between 1800ohm and 2200ohm at 25°c. Those two pins will be used for the ECU. The remaining two pins are normally used for the dash cluster and measure in the region of 3500ohm at 25°c. This same test can be done on engines with multiple sender units to determine which sender unit will be used for the ECU. Example: Toyota 1uz-fe, where there is three water temperature sender units.

Multiple Devices on One Sender Unit.
Do not share temperature sender units between two devices. Only one device may be coupled onto a sender unit at any one time. Both devices will excite the sensor with current which in turn will change the signal value and then both will display the wrong temperature. In such a case you may need to add an extra sensor for the Spitronics ECU. The only exception for this rule is when a data logging device is used that has no internal pull up resistor. Example: Race Technology DL1.

Sensor Location.
The ideal location for the temperature sender unit is on the engine side of the thermostat as this side will show the exact temperature at all times. The radiator side of the thermostat will show lower temperatures and take longer to react.

Air Cooled Engines
For air cooled engines it is better to measure cylinder head temperature for cold start compensation as the oil takes too long to pick up temperature. A simple cylinder head temperature sender unit can be made by clamping an NTC 2k ohm thermistor on a lug terminal and bolting it onto the cylinder head.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Air Temperature

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Air Temperature Sensor

E22 P1 Inputs Drawing

The air temperature sensor is used by the ECU to correct air density changes due to air temperature variation. This input can also be used for general purpose output controls like Intercooler fans or water spray pumps.

Operation
The resistance of the temperature sensor changes in relation to the temperature it senses. It has a negative temperature resistance co-efficiency, ( NTC). Each sensor has a preprogrammed curve to indicate its resistance to temperature. Note that the Spitronics ECU uses a 10K resistance NTC and this value is measured at 25°c .(See below for a sample of such a curve.)

Electronics sensors

Spitronics build and supply small sensors for customers to build into their own units. There are 2 sizes, both do the same work. Note: These sensors requires a pull-up resistor to enable a constant current through them. (See below a picture of what these sensors look like in their raw form.)

How to measure a sensor
Use a multi-meter set to the 20,000 ohm (20 K) range. With the sender unit at approximately 25°c, measure the resistance. It should be between 8000ohm and 12000ohm at 25°c.

Multiple Devices on One Sender Unit.
Do not share temperature sender units between two devices. Only one device may be coupled onto a sender unit at any one time. Both devices will excite the sensor with current which in turn will change the signal value and then both will display the wrong temperature. In such a case you may need to add an extra sensor for the Spitronics ECU. The only exception for this rule is when a data logging device is used that has no internal pull up resistor. Example: Race Technology DL1.

Sensor Location
The ideal sensor location is before the butterfly and after the intercooler if turbo charged. Mount away from fuel "stand-off" to avoid the sensor being cooled by the fuel vapor. Use a High Speed Air Temp sensor on turbo applications where the intercooler comes out as temperature varies quickly.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


TPS Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Throttle Position Sensor

E22 P1 Inputs Drawing

The throttle position sensor is used by the TCU to determine what the driver's intent is. The TCU will use the TPS, engine RPM and road speed to calculate a shift pattern to use. This sensor is very important and must be a stable signal. Most of the time the TCU will operate side by side to the ECU. The TCU can tap into the signal from the existing TPS or as with Spitronics ECU's there is a yellow wire that is installed in the harness for this signal. Do not connect any supply or earth to existing TPS connections. Just the signal wire is connected. See the drawings on this.

Operation:
The TPS is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Which Pin is which?
Use a multi-meter set to the 20,000 ohm (20 K) range.

· With throttle closed, find the two pins with the lowest resistance between them. They are C & B. The remaining pin is the 5 V pin A.

· With one probe on the 5 V pin A, find the pin whose resistance changes when the throttle moves. This is the Signal pin B.

· The remaining pin is the earth pin C.

This same route can be used on a four pin throttle position sensor, note that only three of the four pins will be connected or one pin may be a switch to ground or 5 Volt as an idle activation switch. The Spitronics ECU does not require this pin.

Pre-load the Sensor
The sensor has a dead band at either end so it must be rotated slightly to move the wiper into the operating range of the sensor.

Connecting the TCU TPS to an existing ECU TPS sensor.

TPS Sample Pin outs:

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


ECU MAP Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

MAP Sensor

E22 P1 Inputs Drawing

The Mean Absolute Pressure (MAP) sensor provides instantaneous manifold pressure information to the ECU. The data is used to calculate air density and determine the amount fuel required for optimum combustion. This sensor influences also the advancement or retardation of ignition timing. This sensor is a reliable replacement for the Mass meter type sensors.

This Aluminum model comes in 1.1 Bar, 2.5 Bar, 3 Bar and 4 Bar versions.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to the sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The manifold take off point should be at a position that best represents the average manifold pressure with minimum pulsations. A filter can be fitted inline to reduce manifold pressure pulsations. Do not T-off idle or brake booster fittings etc. The take-off pipe must be direct to the manifold. When mounting the MAP sensor, face the intake port down and mount it above the take-off point. This will prevent moisture to build up so it can drain out. Ensure that the hose runs downhill all the way to the manifold if possible.

MAP sensor types
The MAP sensors available from Spitronics is the Motorola series sensors that come in two packaged styles; Sealed plastic enclosure or Aluminum machined enclosure. The MAP sensors are rated at 1.1 bar, 2.5 bar, 3 bar and 4 bar respectively. Be sure to order the correct map sensor for your application. In some cases, the vehicle's existing MAP sensor can be used, ensure that you have the sensor wired and calibrated correctly.

Map Sensor Calibration
The MAP sensor is pre calibrated to the specifications of the 4 models. If you use another map sensor you may select custom and calibrate it yourself. Make sure you use the correct altitude pressure value from your altitude level in order for this to function correctly. Calibration needs to be done with the ECU switched on, but the engine must not be running.

Sample Sensor Pinouts

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


ECU Lambda

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Lambda Sensor

E22 P1 Inputs Drawing

The Lambda Sensor or Oxygen Sensor is used by the ECU to display Air Fuel Ratios AFR and optimize the fuel economy after the vehicle has been tuned. Note: In the ECU software it shows a voltage signal and not the actual AFR value. The reason is that the ECU is not a tuning tool with calibration software. It is merely using the sensor for control purposes which is tuned to the correct mixture.

Different Lambda sensors
1 to 4 wire sensors are normally narrow band sensors. Their signal could be used directly in the ECU as it is a 0.1 volt to 0.9-volt signal. The 5 and 6 wire sensors require driving electronics and give a 0 to 5-volt signal out for the ECU. This wideband signal could be used by the ECU.

Testing a Lambda sensor for the correct Pin-outs
Test the resistance with an Ohm Meter between two pins at a time. The heater element normally has the same colors and has a resistance of 6 to 12 ohm. Connect the element wires to earth and 12 volts as above. The element does not have a specific polarity. The sensor output can only be measured while the engine is running. Connect the two remaining wires to the ECU signal input wires as indicated on the drawing. The sensor will only give an output when the engine has achieved some temperature. If the sensor is not working, swop the signal and earth wires and test again. The sensor will not be damaged if the earth and signal output has been swopped.

Life expectancy.
The life expectancy of a lambda sensor varies due to fuel type and application. On unleaded fuel around 500 hours. Very rich mixtures will shorten sensor life. Lambda sensors can be damaged by gasket sealants, anti-seize and some fuel additives.

Position
The ideal position for mounting the lambda sensor is at least half a meter from the engine and after the exhaust collector or turbo down pipe. The lambda should be orientated on the top or side of the pipe. Never at the bottom!

Sample Sensor Pin outs

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


ECU Tuning POT

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Tuning POT

P05_Comms Inputs Drawing

The multi-function variable resistance potentiometer can be configured in the software to perform numerous features. These features include making changes to the fueling, ignition angle or adjusting the launch RPM without having to connect a laptop computer.

Operation
The POT is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Sample sensor Pin out

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


ECU Altitude Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Altitude Sensor

The altitude pressure sensor provides instantaneous altitude pressure information to the Orion ECU. It will allow the Orion2 to calculate air density, which in turn determines the required fuel compensation for optimum combustion. It also adjusts ignition timing with altitude changes. Orion2 uses an optional built in internal 3 Bar map sensor or an external 2.5 Bar map sensor. You may swop the map and altitude sensors around to take advantage of the 3 Bar sensor onboard for normal MAP sensor operation.

Operation

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Launch Control

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Launch Control

P05_Comms Inputs Drawing

The launch control input is an analogue input that combines a digital switch with a resistor to make a dual function input. It is used for Launch and Retard functions. There are different ways to activate launch but most methods use the switch on the dashboard. Same cases a push button is used and other an on/off switch. This function is mainly used on racing applications to keep the engine RPM at the desired RPM before taking off. It also helps to spin the turbo before taking off or during cornering. This increases boost pressure at startup.

The clutch switch is a whisker switch that will deactivate launch the moment the clutch pedal is released.

Wiring

Option 1

Dashboard launch will only be activated as long as the button is pressed.

Option 2

Dashboard pushbutton with resistor and clutch pedal switch. This method will latch the launch action and deactivate it the moment the clutch pedal is released. This method is more automatic and will let the driver focus on other things.

Option 3

Dashboard on/off switch is used for the TPS 90% method. When switched on, this method will activate Launch up to 90% TPS value, and cancel it above 90% TPS value. Revs must fall below 3000 RPM to re-activate the launch feature.

Option 4

Use the tuning POT with TPS 90% to make an adjustable Launch RPM for different traction. To disable this function turn it clockwise so that launch RPM is very high.

Tuning Adapter

You can make an adapter for using the Launch while you have the tuning software connected.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Dual Map Switch

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Dual MAP Switch

P05_Comms Inputs Drawing

The Dual MAP and Flat Shift selection switch is a normal on/off or push button switch that is connected to the ECU. When it is on it will connect the input to earth, this indicates to the ECU which map is required at startup and if flat shift is activated during driving. Note: If you want to switch between maps on the fly then the flat shift feature could not be used.

Wiring

The input for the Dual MAP selection switch is situated on the 6 Pin Molex Comms connecter pin 1. You can make an adapter for this dual MAP switch if you have the tuning software connected. Spitronics also supply these cables pre-made.

Selection Switch

Dashboard on/off will select which map will be used. If not connected it will default to Map 1 at startup. If the switch is on it will be Map 2.

Tuning adapter

The tuning adapter cable will let you use a switch while tuning. If you do not have this cable start the ECU on Map 2 and then connect the Comms cable.

Related Links

Software

Jumper Settings

Power Connection

Error Codes


Outputs and Drivers

Help > TCU Transmission Management > TCU Hardware Description >

Output Drivers

The Spitronics ECU's and TCU's were designed to drive most standard components found on engines and transmissions directly. Some drivers can handle high voltage inductive loads like ignition coils. Some are positive 12 volt drivers to switch solenoids etc. Some are low voltage negative drivers for injectors etc. The firmware may do pulse width modulation when it is required or just on off status.

See the sub folders for explanation on each different type.


High Impedance Injectors

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

High Impedance Injectors

These drawings explain how the injectors are connected for each injector driver. The amount of connections will vary with engine size. (See specific drawings for your application.)

Batch & Split Batch Wiring

With this method you always combine 2 injectors in Parallel. In this drawing A1 is on cylinder 1 and A2 is on the cylinder that moves with it.

Batch & Split Sequential Wiring with Dual injectors

With this method you still combine 2 drivers in parallel. The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. Note: Make sure that the driver can take the combined current for the 4 injectors. Mercury2 can handle 6 Amp per driver. A diode large enough must be wired-in for each bank from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For 2 high impedance injectors the diode must be 3A or higher. In this drawing A1 & A2 is the primary injector and A3 & A4 is the dual injectors. A1 & A3 is on cylinder 1 and A2 & A4 is on the cylinder that moves with it.

Full Sequential Wiring

With this method only one injector is connected per driver.

Full Sequential Wiring with Dual injectors

The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. Some applications have enough drivers and then the dual drivers are connected (as above) onto its own driver. No electronic relay will be required. A diode large enough must be wired in for each injector from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For high impedance injectors the diode must be 3A or higher. In this drawing A1 is the primary injector and A2 is the dual injectors.

Related Links

Software


Low Impedance Injectors

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Low Impedance Injectors

Explanation

First you need to understand what is a low or high impedance injector. Most injectors nowadays are high impedance. They have a resistance of around 15 Ohm or even higher. This means they draw a current of about 1 amp which makes it very suitable for todays ECU's. No need to use complicated drivers or high current components. Typical injector drivers is around 40 volt which is found in the low voltage injector drivers of Orion2.

High performance injectors or large volume injectors are still manufactured with a low impedance. They are around 2 to 5 Ohm in resistance. These injectors use more energy which means they open faster and can handle higher fuel pressure. The correct driver for these injectors is what they call a Peak and Hold driver. It means the driver will start with a high voltage and send a lot of current through the driver to open quickly and strongly. Then after about 1 milliseconds the voltage is reduced by as far as 3 volt to have just enough retaining current to keep it open. Then when the driver switch the injector off, the current will subside quickly and the injector close fast without delay or high voltage spikes. Due to the complexity of these Peak and Hold drivers we did no include them in Orion2.

How to use Low Impedance Injectors with Orion2 Ver 3.6B

Orion2 was designed with cost in mind so it has Low Voltage drivers for high impedance injectors and High Voltage High Current drivers for basic coils. However if you select Smart Coils then the coils is connected to Positive Drivers and the Injectors utilize the High Voltage Coil Drivers. These drivers are stronger and more suitable for Low Impedance Injectors.

If you have Smart coils then the wiring on the High voltage drivers can be done as follows.

Series Connection

This method works most of the time correctly, but it can only be used with High Voltage Drivers. This is due to the larger inductance that makes a high voltage spike when the injectors is switched off.

One injector acts as a load resistor for the next and the current is shared. The driver should not heat up. However in some cases the injector requires the higher current to open constantly then this method does not work effectively.

Parallel Connection

This method works most of the time correctly, but it can only be used with High Voltage Drivers which has a higher current rating like the Orion2 Coil Drivers. This is due to the larger current required for 2 injectors.

If the resistance is 4 ohm and above you can try a direct connection like with high impedance.

If the resistance is lower you may add a series resistor to each injector the get the combined resistance to 4 ohm and above. Use a 10 Watt resistor and mount them on a heatsink so that they can cool down. They will generate quite an amount of heat. The injector is cooled by the fuel so they don't heat up too much. Below is a wiring example.

If you have Basic coils and low impedance injectors then you can use the Mercury Coil driver for the coils. This driver will use the positive drivers with Smart coils selection and free up the internal coil drivers for the injectors.


Injectors

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Injectors

This folder contains all combinations of wiring options for injectors on Orion2. These drawings are made for the E33 and W36 harnesses and may differ in wire colors to other harnesses. Consult your harness layout further in the manual.

Orion2 use 2 different sets of drivers. This is determined by the coil types that is connected to the ECU. If you use Basic Coils then the Negative drivers are used for injector drivers. If you select Smart Coils then the Coil drivers will be used for injectors. The reason is that mos engines today have Smart Coils and then the Coils drivers are stronger and is the preferred injector driver.

The main choices for injectors are, Number of cylinders, High or Low impedance Injectors, Smart or Basic Coils, Single or Dual injectors per cylinder and lastly the type of injection namely Batch, Split-sequential or Full sequential injection. Each folder contains its different variations for your engine. Note that the drawings are generic and you have to fill in your own firing order to see which wire color goes to which injector. Print the document and write on it before you begin. Also note that combinations included in this manual may or may not be available for the hardware class or Brand type.

See the sub folders more information.

Fuel Injector explanations

The fuel injector outputs drive the fuel injectors to allow measured amounts of fuel into the engine. These signals are on/off control signals that are varied by duty cycle. The more fuel is required the higher the duty cycle will be. The injectors are connected to common positive and the drive signals from the ECU is ground signals.

Operation
The injectors are solenoid valves that are opened by current to let fuel pass through the nozzle. The nozzle has a spray pattern that will help in atomizing the fuel with air. This in turn will make a combustible mixture.

Injection types

Batch Injection

With this method, injector drivers are being pulsed at the same time once or twice per revolution. Very rare firmware from Spitronics, although not preferred, can use this method. However, fuel metering and timing is done very accurately and should still give excellent results. Split the injectors in groups to divide the current evenly between the available driver outputs. For bigger engines keep the mean supply current below the current capability of the drivers of that product. (See specifications.) Note: More outputs are available in the intermediate and advance units. (See specific wiring diagram.) The biggest disadvantage with this method is the fuel pressure pulses due to uneven tapping. Advantage is easy wiring.

Split Batch Injection

With this method, two injector drivers are being pulsed 180° out of faze. Although not preferred, fuel metering and timing is done very accurately and should give excellent results. Split the injectors in two groups to divide the current on the 2 driver outputs. Put alternate numbers on the firing order together to ensure a more even fuel distribution. For bigger engines keep the mean supply current below the current capability of the drivers of that product. Note: More outputs are available in the intermediate and advance units. (See specific wiring diagram.)

Split Sequential Injection

This method will inject on the two cylinders that move up and down together simultaneously and then in sequence on the other cylinders at the same position. Injecting once per revolution and will start at BDC or it may be adjusted otherwise. Fuel is injected very accurately and excellent CO adjustments can be achieved. The advantage of this method is that each cylinder receives its fuel under the same conditions, resulting in very smooth idling and revving. It is definitely better on power and consumption than the batch injection method. Injectors are wired in the same sequence as wasted spark. The fuel is distributed more evenly from the fuel pump and pulsing of fuel pressure comes to a minimum. The ECU only requires half the amount of drivers than cylinders on the engine. (See driver selection chart on how to combine these injectors.)

Full Sequential Injection

With this method each injector requires a driver. Fuel is injected once in 2 revolutions and normally starts at Bottom Deck Center (BDC). Note: This feature is mainly for 4 cylinders engines. Disadvantage is that this method does require the Cam or home pulse to sink injection with fazes and low impedance injectors require a ballast resistor. Advantages are better fueling at lower RPM and longer duty cycle makes for more accurate measuring on large injectors. If you don't have a home pulse it can still do full sequential injection but injection is not sinked on stroke. In these cases, start injection degrees can be set at BTDC just after the intake valve closes. (See wiring diagram on how to combine the injection methods.)

Throttle Body Injection

With this method, injectors are situated at the throttle body. The first generation injection systems used this method. It is important to inject in the right sequence especially on the 4 barrel systems. Some injectors are aimed at certain ports and must be pulsed in sequence to get a smooth distribution of the fuel mixture. (See specific wiring diagram to ensure the correct injectors are on the correct drivers.) Advantage of this method is easy to convert carburetor engines to fuel injection.

Injector Sizing
Sizing example: 5 cc fuel is required for every 1 HP. This means that an 8 cylinder 600 HP requires 600 HP x 5 cc / 8 injectors = 375 cc/min. This is assumed at Lambda 1.00 (14.7 AFR) so if you are running richer, the desired Lambda reading needs to be taken into account. This calculation is based on information from the Internet and should be researched with other manufacturers. It is merely as an example.

Resistance & Current
Different injectors have different resistance from 0.5 ohms to 16 ohms. This means that they require different operating currents and wiring circuits to open them. The Spitronics ECU's were designed for high impedance injectors. They draw 1 Amp each and can be connected together on the drivers in parallel. (See specifications on how much current the drivers can handle between the different products.) Low impedance, 3 to 5 ohm injectors, require current limited drivers to peak and hold drivers. With a minor wiring difference, the ECU's can do low impedance injectors connected in series. They draw 4 Amp each but in series they draw 2 Amp. Again, see the specifications on the ratings of the ECU's. If you want to do full sequential you need to add a 3.3 Ohm 10 Watt resistor in series to limit the current. Injectors with lower resistances like direct injection drivers cannot be used with the ECU's.

Dead Time
Dead time is the amount of time the injector takes to open from when the injector pulse starts. This varies with battery voltage and fuel pressure. Also varies between different kinds of injectors but is usually about 1 milliseconds or less at 14 volts. This dead time needs to be accounted for with Battery Voltage Compensation. But it is tuned in when the engine is mapped on the Dyno or street.

Spray Patterns
Some injectors have better spray patterns and atomize the fuel better than others. Injector position can dictate what type of spray pattern is required. Cycle, Duty Cycle and Pulse Width

A fuel injector is continuously powered by battery positive. The ECU output switch to ground to turn the injector on.

Frequency Number of complete cycles in one second, measured in Hertz. 1 Hz = 1 cycle/second. It is engine RPM / 60.

Cycle: Time from when an injector is turned on until the next time it is turned on.

Pulse Width: The time in seconds the injector is on.

Duty Cycle: Percentage of time the injector is on in one cycle.

Most injector ratings are to be used within 85% duty cycle. You may get more fuel through with higher fuel pressure but stay within the working limits of the injector.

(See sub folders for explanation on wiring and connections.)


1 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 1 Cylinder

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 1Cyl High Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 1Cyl High Imp Injector Option2

Low Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 1Cyl Low Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 1Cyl Low Imp Injector Option2


2 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 2 Cylinders

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 2Cyl Full Seq High Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 2Cyl Full Seq High Imp Injector Option2

Low Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 2Cyl Full Seq Low Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 2Cyl Full Seq Low Imp Injector Option2


3 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 3 Cylinders

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 3Cyl Full Seq High Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 3Cyl Full Seq High Imp Injector Option2

Low Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 3Cyl Full Seq Low Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 3Cyl Full Seq Low Imp Injector Option2


4 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 4 Cylinders

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 4Cyl Full Seq High Imp Injector Option1

· 4Cyl Split Seq High Imp Injector Option1

Dual Injector Per Cylinder

· 4Cyl Full Seq High Imp Dual Injector Option1

· 4Cyl Split Seq High Imp Dual Injector Option1

Smart Coils

Single Injector Per Cylinder

· 4Cyl Full Seq High Imp Injector Option2

· 4Cyl Split Seq High Imp Injector Option2

Dual Injector Per Cylinder

· 4Cyl Full Seq High Imp Dual Injector Option2

· 4Cyl Split Seq High Imp Dual Injector Option2

Low Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 4Cyl Full Seq Low Imp Injector Option1

· 4Cyl Split Seq Low Imp Injector Option1 - No Longer Recommended

Smart Coils

Single Injector Per Cylinder

· 4Cyl Full Seq Low Imp Injector Option2

· 4Cyl Split Seq Low Imp Injector Option2


6 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 6 Cylinders

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 6Cyl Split Seq High Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 6Cyl Split Seq High Imp Injector Option2

Low Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 6Cyl Split Seq Low Imp Injector Option1 - No Longer Recommended

Smart Coils

Single Injector Per Cylinder

· 6Cyl Split Seq Low Imp Injector Option2


8 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 8 Cylinders

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 8Cyl Split Seq High Imp Injector Option1

Smart Coils

Single Injector Per Cylinder

· 8Cyl Split Seq High Imp Injector Option2

Low Impedance Injectors

Basic Coils

Single Injector Per Cylinder

· 8Cyl Split Seq Low Imp Injector Option1 - No Longer Recommended

Smart Coils

Single Injector Per Cylinder

· 8Cyl Split Seq Low Imp Injector Option2


2 Rotor

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 2 Rotor

Below are links for Orion2 on all the different variations of injector driver connections. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

If you have Basic Coils use Option1 Drawings.

If you have Smart Coils use Option2 Drawings.

High Impedance Injectors

Basic Coils

Dual Injector Per Rotor

· 2Rotor High Imp Injector Option1

Smart Coils

Dual Injector Per Rotor

· 2Rotor High Imp Injector Option2

Low Impedance Injectors

Basic Coils

Dual Injector Per Rotor

· 2RotorLow Imp Injector Option1 - No Longer Recommended

Smart Coils

Dual Injector Per Rotor

· 2Rotor Low Imp Injector Option2


Standard Firmware

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors Standard Firmware

Below are links for Orion2 on all the different variations of injector driver connections for the Standard Pulses Firmware of Program 1. Note that this firmware does not alter injector drivers positions when you change coil type like the normal firmware. The software will also indicate where to connect your injectors.

If you have the Standard Hardware Class then you will only have access to 2 injector drivers then use the 4 Cylinder Drawings. Remember to pair your injectors in an equal manner to distribute fuel more evenly.

If you have the Intermediate Hardware Class then you will only have access to more injector drivers and can make use of Split-sequential injection. Then use the correct drawings for your application. There may also be other features that will be active in this class. Injection Teeth and Injection Type my be selected.

If you have the Advance Hardware Class then you will only have access to more injector drivers and can make use of Split-sequential injection. Then use the correct drawings for your application. There may also be racing features that will be active in this class. Features like Micro Fuel, Anti-lag Launch retarded timing and launch delay are included. Injection Teeth and Injection Type my be selected.

Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

High Impedance Injectors

4Cyl High Imp Injectors (Use with all Standard Class Firmware)

5Cyl High Imp Injectors (Use with Intermediate Class and higher Firmware)

6Cyl High Imp Injectors (Use with Intermediate Class and higher Firmware)

8Cyl High Imp Injectors (Use with Intermediate Class and higher Firmware)

Low Impedance Injectors

4Cyl Low Imp Injectors (Use with all Standard Class Firmware)

5Cyl Low Imp Injectors (Use with Intermediate Class and higher Firmware)

6Cyl Low Imp Injectors (Use with Intermediate Class and higher Firmware)

8Cyl Low Imp Injectors (Use with Intermediate Class and higher Firmware) - No Longer Recommended


Coils

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Coils

This folder contains all combinations of wiring options for Coils. The main choices are, Number of cylinders, Basic Coils without drivers or Smart Coils with built-in drivers, Wasted spark or COP coils and the type of spark required namely Distributor, Wasted Spark or Full sequential spark. Each folder contains its different variations for your engine. Note that the drawings are generic and you have to dill in your own firing order to see which wire colour goes to which coil. Print the document and write on it before you begin.

Abbreviations in this section.

F/S - Full Sequential

W/S - Wasted Spark

COP - Coil On Plug

See the sub folders more information.

Ignition Coils

Distributed Spark System
With this system, which was popular in the older cars, there is only one ignition coil for all the cylinders. The spark is distributed to the spark plugs with a rotor and distributor cap. Here only one driver is required from the ECU. The disadvantage of this system is that the coil has to charge and discharge a couple of times in one revolution. With high revving and performance motors this means that spark quality will deteriorate with increased RPM's. Another problem is spark deterioration with the gap between rotor and cap. It also has a higher maintenance service. Very important for these systems is the rotor fazing. Advantage is one coil and driver and full sequential spark system. (View it further in the manual.)

Wasted Spark System
With this system there is one coil for the two cylinders that move up and down simultaneously. The cylinders that are 360 degrees apart are paired. These coils have two High Tension towers which spark on the two plugs simultaneously, one on compression stroke and the other on exhaust stroke. Each dual coil is being driven by its own driver in sequence from the ECU. The advantage is less drivers and coils and better spark than distributors. This method only requires a crank gear with TDC slot. Disadvantage is the coils energy is divided between 2 spark plugs. Also the fact that current is reversed through on plug. This deteriorate copper cored sparkplugs unevenly.

Multi Coil Spark system

With this system there is one coil for every spark plug. The coils must be driven by separate drivers from the ECU. This makes the ECU larger and more expensive. The coils are fired in full sequential or wasted spark method. The advantage is more spark energy per cylinder. Disadvantage is the number of coils and drivers required.

Different Types of Coils

Coil Selection

It is important to know which coil on the engine has a faulty setting as this may destroy the ECU driver or coil. Always start the ECU with a disconnected output connecter till you set the trigger level output to the correct setting, or alternatively wire the ECU correctly. Start with a 5A Fuse in the coil positive circuit which will blow quickly if you have an error. If you have coil packs with a common positive, insert 5A fuses in each driver signal to protect the coil against damage.

Oil filled coils

The point-condenser coil has a resistance of +/- 1.5 ohm and a charge-time of 7 m/s. the spark on this coil will be weak. Should you need to use it do not connect the ballast resistor. If the coil has a resistance of 3 to 3.5 ohms it has a built in ballast resistor and will produce poor spark. It is not recommended to use these coils.

Electronic ignition coils were designed for variable dwell systems to improve spark at high Rpm's. They have a resistance of +/- 0.8 ohm. and a charge time of 3 to 3.5 ms. they can be used effectively but are being phased out by manufacturers. Some coils go as low as 0.4 ohm and need charge times of 1.5 to 2ms. Orion can drive these coils directly.

Epoxy filled Basic coils

These hard resin coils and consist of single, wasted spark, COP or combinations of coils in a single housing. Some have built in driver electronics. If it has no driver there is usually a common pin and one pin for each coil. To measure this coil put the meter on Ohms and measure all the points. You should get a 0.8 Ohm reading for each coil. If you measure over the two coils it should read 1.6 Ohm. Orion can drive these coils directly.

Epoxy filled coils with built in drivers

If you measure high resistances on open circuit, then the coils have an internal driver. These coils normally have a positive, ground and trigger input for each coil. These coils are normally charged with a positive pulse and fired with a negative going pulse. Orion can drive these coils directly. These Coils with internal drivers can be connected two coils per output. You must make sure on the firing order to connect the two cylinders of these coils that move up and down simultaneously.

Spark Plugs and Leads

Use high quality inductive suppression leads such as Bougi Cord. Don't use wire leads: Possible interference.

Be careful when changing spark plug type. Always consult the vehicle's owner's manual first. Some ignition coils are sensitive to the type of spark plug used. If the ignition system uses resistive type plugs from the factory NEVER use non-resistive plugs as it may result in coil failure.

Run high tension leads as far from the ECU wiring as possible (especially sensor signals). Otherwise reconsider the wiring loom and layout. If the loom must cross the ignition wiring it should do so at 90° angles to minimize the interference.

(See the sub folders for explanation on wiring and connections.)

Related Links

Software


1 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coil 1 Cylinder

Below are links for the Orion2 connections on the different connection of a Basic Coil without driver or a Smart Coils with built-in driver. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coil - No Drivers

Single Basic Coil Distributor

E36

Smart Coil - Built-in Driver

Single Smart Coil Distributor


2 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 2 Cylinder

Below are links for the Orion2 connections on all the different variations of Basic Coils without drivers or Smart Coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coils - No Drivers

2 Cyl Single Basic Coil Distributor

2 Cyl COP Basic Coils

E36

Smart Coils - Built-in Driver

2 Cyl Single Smart Coil Distributor

2 Cyl COP Smart Coils


3 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 3 Cylinder

Below are links for the Orion2 connections on all the different variations of Basic Coils without drivers or Smart Coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coils - No Drivers

3 Cyl Single Basic Coil Distributor

3 Cyl COP Basic Coils

E36

Smart Coils - Built-in Driver

3 Cyl Single Smart Coil Distributor

3 Cyl COP Smart Coils


4 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 4 Cylinder

Below are links for the Orion2 connections on all the different variations of Basic Coils without drivers or Smart Coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coils - No Drivers

4 Cyl Single Basic Coil Distributor

4Cyl COP Basic Coils

4Cyl Wasted Spark Basic Coils

E36

Smart Coils - Built-in Driver

4 Cyl Single Smart Coil Distributor

4Cyl COP Smart Coils

4Cyl Wasted Spark COP Smart Coils

4Cyl Wasted Spark Smart Coils


6 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 6 Cylinder

Below are links for the Orion2 connections on all the different variations of Basic Coils without drivers or Smart Coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coils - No Drivers

6 Cyl Single Basic Coil Distributor

6 Cyl Wasted Spark Coils

6 Cyl Wasted Spark COP Coils

E36

Smart Coils - Built-in Driver

6 Cyl Single Smart Coil Distributor

6 Cyl Wasted Spark Coils

6 Cyl Wasted Spark COP Coils


8 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 8 Cylinder

Below are links for the Orion2 connections on all the different variations of Basic Coils without drivers or Smart Coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coils - No Drivers

8 Cyl Single Basic Coil Distributor

8 Cyl Wasted Spark Coils

8 Cyl Lexus 1UZ 2Coils

E36

Smart Coils - Built-in Driver

8 Cyl Single Smart Coil Distributor

8 Cyl Wasted Spark Coils

8 Cyl Wasted Spark COP Coils


2 Rotor

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coil 2 Rotor

Below are links for the Orion2 connections on all the different variations of Basic Coils without drivers or Smart Coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. It is advisable to do the setup in Orion2 first and then print out the connection layout and compare it to your drawings. If you don't have a Simulator, then connect only P1 12-Way connector and do the setup in the software.

Always disconnect P2 and P3 before switching the ECU on for the first time.

E33

Basic Coils - No Drivers

3 Basic Coils - Wasted Spark Leading Coil

4 Basic COP Coils

E36

Smart Coils - Built-in Driver

4 Smart COP Coils


Idle Control

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Idle Control

There are different methods to cater for most types of idle control motors found on the different engines. Make sure you select the correct wiring procedure for positive or negative driver outputs. When a certain type is selected the software will indicate on which output it must be connected. You can also view this on the GP Priority spread sheets available for different firmware. Note that on the stepper controllers there are an ID wire to select between positive or negative input from the ECU. Below is an example:

Click on the links below:

Single Idle Valve with Spring Return

Dual Idle Valve with Spring Return

Dual Idle Valve without Spring Return

Idle Control2 Type 1 Stepper 4 Pole

Idle Control2 Type 2 Stepper Bipolar

Toyota Black Idle Valve


General Purpose

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

General Purpose

The general purpose outputs could be used for numerous control on the engine. Each option requires different wiring. The outputs of the ECU may be strong enough to drive certain units directly and others may require a relay or amplifier.

Click on the link below for the different wiring diagrams.

Electric Fan Control

Variable Intake Solenoid Control

Lamp Control

V-Tech Solenoid Control


Tachometer

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Tachometer

The Tachometer can be connected on the ECU and be calibrated in software. There are a few different ways to connect it as there are many different tachometers. Types are Digital Magnetic and Coil connections. Make sure you chose the correct option as it may damage the tachometer. Note that coil connected tachometers require a special adapted and it is sold separately.

Click on the link below for the wiring diagram.

Tachometer Options


Fuel Supply

Help > ECU Engine Managment > ECU Hardware Description >

Fuel Supply

The fuel supply is mostly a basic mechanical system which is not controlled by the ECU except for switching and controlling the power of the fuel pump. some of the Ecu's have the ability to do fuel pressure control. Below is a few schematics on basic fuel flow systems.

The basic fuel rail and pressure regulator system.

External Fuel Pump

In this system the fuel pump is supplied from the tank via a petrol filter through a thick pipe at gravity feed pressures. The pump pressurizes the fuel through the high pressure fuel filter into the fuel rail with injectors. A fuel pressure regulator will bleed fuel back to the tank if the pressure is higher that it calibrated bypass diaphragms. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. The return fuel also cools the fuel pump. The fuel pump is always on full power.

Internal Fuel Pump

In this system the fuel pump is mounted inside the tank with a sift as a pre-filter. The pump pressurizes the fuel via a high pressure fuel filter through the fuel rail with injectors against a fuel pressure regulator. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. This is done by returning the excess pressure and fuel via a return line straight back to the tank. The fuel in the tank cools the fuel pump. The fuel pump is always on full power. Some systems have the pressure regulator built into the tank and then there is only one fuel line to the fuel rail and injectors. No return line.

Pressure controlled Fuel Pump

In this system the fuel pump is mounted inside or outside the tank with a pre-filter. The pump pressurizes the fuel via high pressure fuel filter through to the fuel rail and injectors. In the fuel rail a fuel pressure sensor will relay the pressure to the ECU. The ECU will speed control the fuel pump with PWM to increase or decrease the pressure. There is no return line or mechanical fuel pressure regulator. The fuel DP fuel pressure sensor also senses the manifold pressure.


Fuel system Trouble Shooting

Help > ECU Engine Managment > ECU Hardware Description > Fuel Supply >

Fuel system Trouble Shooting

Fuel supply line to the pump is too thin. This will cause the fuel pump to draw a very low pressure on the inlet. When the fuel becomes hotter it will percolate due to the low pressure. This gas will then enter the pump making the pressure erratic. The gas is then pressurized at the injector tip and will reduce petrol flow and cause lean mixtures. The gas bubbles can also damage the pump.

Fuel pump heats up. It could be mounted too close to the exhaust or the pump is too large for the fuel rail system. The fuel flowing through it is too little to cool it off. It could be a dirty fuel pressure filter down stream that causes the pump to pump at too high pressures. If the pump is hot it will also cause the fuel to percolate and make gas bubbles. Do not bring the return line to the front of the fuel pump. The fuel must be cooled off in the tank.

Mechanical fuel pressure failure. Inside is diaphragms that could rupture or become soft with heat. Then accuracy may be a factor in cold and hot conditions. The vacuum line to the intake manifold can leak causing pressure differences.

Fuel lines are too thin. If the line to the fuel rail is too thin, the fuel pressure will drop before it reaches the injectors. If the return line is too thin the fuel pressure regulator cannot regulate properly and the pressure will be too high.

Erratic fuel pressure. This is usually caused by batch fueling as all the injectors open and close all at once. This makes for differences in pressure and fuel supply between the cylinders upstream and downstream.

Fuel pump is noisy and makes uneven sounds. These pumps get damaged by dirt, water and air bubbles. It is good practice to put an inline filter in front of the pump to ensure that dirt does not go through the pump. This will also indicate if air is in the system as most filters are see-through. It may pull in air through the connections.


Handshake ECU with TCU

Help > TCU Transmission Management > TCU Hardware Description >

Handshake ECU with TCU

The Orion2 ECU can be interfaced with Orion2 TCU to make wiring less complex. Sensors like TPS could be shared. The TCU also requires an RPM signal and it is connected to the RPM output of the ECU. This is calibrated in the ECU and TCU. The TCU can indicate to the ECU to retard timing during automatic transmission shifts. This will soften the shift making driving more pleasurable. Note how these connections ate interfaced with the TCU.

The TPS input of the ECU is connected to a yellow wire to supply the signal to the TCU input. The ECU will supply the power and ground to the TPS sensor.

The RPM is processed in the ECU and then output to the TCU.

The TCU negative Retard output is taken to the ECU POT input. When the signal goes to negative then the ECU will retard timing to a set level.

Click on the link below for the different wiring diagrams.

Orion2 Handshake ECU with TCU


Harness Layout

Help > TCU Transmission Management > TCU Hardware Description >

Harness Layout

Orion2 is a universal controller and has many options with firmware like ECU,TCU,TxW,etc. This calls for different harness options. It is based on the old pinout structure started wit Titan way back. However it has more conectors and features. Although older harnesses can be used with Orion2, it is not reccomended. Below is a list of harnesses that is reccommended and also ones that are still in production. There is also a list of old harnesses that we added in the manual for backwards compatability should a installer want to upgrade from and older product.

This manual is based on the most complete harness for explanation purposes. Some harness do not contain all the wires so make sure on your harness' part number to view the correct wire colours. ECU and TCU harnesses are featured here due to the overlapping of harness in use. Note that some design drawings have 2 or 3 pages. If a harness has a V2 (Version 2) behind it then it means, there was alterations or improvements done on it. There may be components added to reduce interference so compare your old harness one to the latest version to see if you need to do the modifications. Always select the Reccomended harnesses for new installations.

NB! Orion2 is not completely backwards compattible to Orion or older products. Make sure that you are familiar with the changes or rather install the reccommended harnesses.

For more information, click on the links below:

Harnesses in Production

Reccomended

E22 - P1 Input Harness.pdf (Drawing) - E22 P1 (Overview) - Crank and Cam Sensors.*

E24 - P1 Input Harness.pdf (Drawing) - E24 P1 (Overview) - Crank Sensor only.

E33 V2 - P2 Output Harness.pdf (Drawing) - E33 P2 (Overview) - All wires only.*

E36 V2 - P3 Output Harness.pdf (Drawing) - E36 P3 (Overview) - All wires only.*

OT01 - P1 Harness.pdf (Drawing) - OT01 P1 (Overview) - Use with ECU.*

OT02 - P1 Input Harness.pdf (Drawing) - OT02 P1 (Overview) - Use in Standalone applications.*

OT03 V2 - P2 Output Harness.pdf (Drawing) - OT03 P2 (Overview) - All wires only.*

OT20 - Comms Buttons Harrness.pdf (Drawing) - OT20 Comms (Overview) - All wires only.*

OT21 - Remote Buttons Harrness.pdf

* The manual information is based on this harness for wire colors.

Not Reccomended

E31 V2 - P2 Output Harness.pdf (Drawing) - E31 P2 (Overview) - All wires only.

E32 V2 - P2 Output Harness.pdf (Drawing) - E32 P2 (Overview) - 1x Relay and limited wires only.

Old Harness Layout

This is not recommended for Orion2 but merely for backwards compatibility explanations. Some are discontimued or manufactured on request only for repairs.

P1 - Input Harness

E28 Input Harness

E29 Input Harness

E34 Input Harness

E35 Input Harness

OT01 Input Harness

OT02 Input Harness Stand Alone

P2 - Output Harness

E21 Output Harness

E23 Output Harness

E23 V2 Output Harness

E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness

E36 Output Harness

OT03 Output Harness

P3 - Input / Coms Harness

P03 Input Harness

P05 Input Harness


Power Connection

Help > TCU Transmission Management > TCU Hardware Description >

Power Connection

When an ECU does not have proper connections to Power or Earth it will generate spikes and erratic behavior. The starter and alternator needs to be wired correctly.

Earth straps can cause interference and is usually a problem during cranking. The starter draw around 60 amp during cranking. Its current flow is a thick strap from battery negative directly to the engine. Then form battery positive to the starter solenoid to the starter motor. You do not want to share these wires with sensitive electronics. The chassis also needs to be earthed. The best way is another earth strap from battery negative to the chassis. Do not earth the chassis and engine to each other to simplify wiring. This cause a common wire that will share the starter spikes and will cause interference. The Alternator is also a source of interference. It is best to connect the charge wire which is the thick one directly to the battery positive. Remember the battery acts as a damping source for interference. So it is best to connect all different supplies to the poles.

Testing for earth problems.

1. Make sure all earth points are properly earthed. Sometimes paint of the chassis will prevent a good electrical connection.

2. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses is also tied to this point. We call this junction Test point A

3. First ensure that the setup in galaxy is done according to the startup procedure. This means you will only have P1 connecter and on Mercury2 also P4. The other connecters must be open except the comms cable.

4. Now use a multi meter and put it on AC volts. Now measure on test point a to battery negative pole. Now crank the engine. The reading should be less than 0.2 volt. If it is higher it means a bad earth. See the advice above.

5. Now do the same test for the ECU positive. Measure between the ECU power pin 10 that comes from the key to battery positive terminal. Here you may find a slight more voltage due to other electronics that draw current from the ignition. Again if the volts is more that 1volt then you may need to put a relay in to bypass ignition key voltage drops. Remember the key does not supply much current and is only low amperage power to activate relays. Below is a circuit of a bypass relay.

Related Links

Power Relay Wiring

Safety Precautions


ECU Power Relay Wiring

Help > ECU Engine Managment > ECU Hardware Description >

Power Relay Wiring

The ECU controls the power to all the hardware via the power relay circuit. These relays also act as a safety cutout for the fuel pump in case of engine stalls. When you switch the ignition on, the ECU will switch the relay output on for 3 seconds. If the engine is not cranked in that time it will be shut off again. This is to prime the fuel rails. In case of an accident these relays will be shut down in one second after the engine has died. This will stop the fuel pump from pumping fuel in ruptured lines. Note: Do not connect control hardware like coils and pumps to other power sources other than the Orion relays, as they will feed back power after the ECU is switched off. They must be connected to the control relays.

Mechanical Relays

Always use at least 2 mechanical relays. For 3 or more coils you may add a relay in parallel with relay 2 to share the load. do not connect coils, injectors, or fuel pump with relay 1 if the positive drivers is used. this may cause interference with the drivers' operations. On large systems like 8 coils or more, you may add a fourth relay to share the load. Use Relay 1 for clean power for the ECU and lambda sensor. Use Relay 2 for injectors and fuel pump. This will prevent uneven voltage drops on the line that will cause the injectors to open unevenly resulting in fuel mixtures variation. Use Relay 3 for coils which create high voltage inductive spikes. Always make sure there is a 6-amp diode on each relay specially if there are inductive loads on them like coils, injectors and fuel pump. The stripe must be on 87 and the other side on earth.

Pin 86 of the Relay 1 is tied to batter positive. Note that some of the older Mercury2 units had a built in freewheel diode which prevented the ECU from switching off when the key is switched off. In these cases, connect Pin 86 to ignition power that feed the ECU power on the P1. See the drawings for more instructions.

Note: There is a diode on Relay 1 pin 86 and 85 that will prevent spikes and relay buzz. Do not use this relay for other inductive loads.

Click on the links below to open the relevant drawings.

Orion2 Power Distribution E33

Related Links

Power Connection

Safety Precautions


GP Priority Layout

Help > ECU Engine Managment > ECU Hardware Description >

Orion2 ECU GP Priority Layout

The Orion2 is a universal controller that can have many variations of wiring. This manual is a modular drawing manual where you have to decide on wiring and print different section of drawings. The GP Priority sheet will explain where each Input or output is, and for convenience the wire colour is next to it for the different harnesses available. Make sure on your harness part number at the connector end. For wiring at the other end you need to print your own combination from the different drawings.

This manual is a modular drawing manual where you have to decide on wiring and print different section of drawings. The GP Priority sheet will explain where each Input or output is, and for convenience the wire colour is next to it for the different harnesses available. Make sure on your harness part number at the connector end. For wiring at the other end you need to print your own combination from the different drawings in the manual.

Click on one of the links below and print this section.

8 Cylinder Connection Layout

8 Cylinder Lexus 1UZ 2Coil Layout

6 Cylinder Connection Layout

6 Cylinder 6 Coil Connection Layout

4 Cylinder Connection Layout

3 Cylinder Connection Layout

2 Rotor Connection Layout

Firmware Prog 1 Standard Pulses

All Cylinders Standard Class Layout

6 Cylinder Intermediate Class Layout

8 Cylinder Intermediate Class Layout

Wiring Templates (Excel)

8 Cylinder Wiring Template.xlsx

6 Cylinder Wiring Template.xlsx

4 Cylinder Wiring Template.xlsx

2 Rotor Wiring Template.xlsx


ECU Software Desciption

Help > ECU Engine Managment >

ECU Software Description

This software is used to adjust all parameters in the ECU. There is information, setup, graph, matrix and real time screens. Please read the sub folders for more information on this software.


Startup Screen

If you open the software without a live device connected, you will come to the main pallet or screen which forms the framework of the Hyperspace software. It looks the same for all the devices. From here you can open map files, connect to devices and set basic settings required for the software to operate. See below all the functions that can be set from here.

At the top bar is the start instructions to manipulate the software.

See the Sub folders for more detailed information.

At the bottom left corner is a connect button and also a tab that show the status and ECU that are connected.

At bottom right corner is connection information. This will indicate which Comms Port is being polled for a device. If you have changed the USB cable to another one, then this Comms Port may not be the Port number that the software remembered. Click on the Connect button then the software will look on all the available Ports for a device. Once a device is found, this will be saved in the Config file to cut down on start time for the next connection.

See the sub folders for detail explanations.


Top Toolbar

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen >

Top Toolbar

Like any Windows program you will find standard menus and buttons which relate to program settings and preferences. Offline Map files could also be selected and edited with the file button.

Notice the Version and Date in the name. this will help dealers to see if you have the latest software installed. Make sure from time to time that you have the latest version which is free from our website. Especially if you find something in the software that may function incorrectly. We fix these errors immediately and replace the version on our website.

This software is Version 3.6.1 The last 1 is a sub release as fixes etc. are made.

2020-08-06 17:20:54 is the date and time this version was released

See the sub folders for detail explanation on the Tuning, Device, File and Help menus.


Tuning Menu

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen > Top Toolbar >

Tuning Menu

Settings is to set up units, software and device communications and auto map save settings.

Exit is to quit the software.

Connect is to connect or dis-connect to the ECU,

Settings

Unit selection

Select Metric or Imperial units.

Language

Select Language if it is available.

Matrix Mode

Select the RPM Axis you prefer for matrix tuning.

Styles

Custom your own tuning pallet to suit the collars and font size that works for you. Remember these settings is saved in the Config file. If you upgrade versions, then rename your Config file to carry your settings over.

Device Settings

Max Poll error count:

This is the time it takes to read the real time values from the device via the Blue Tooth serial port. Blue tooth communication is not as smooth and fast as USB communication. It requires a tolerance setting to ignore short intervals of no communication. Increase this value till the flashing LED stops flashing RED. For USB cables keep this value at 0.

Blue Tooth Delay

This setup will add a delay that some blue tooth modules will require to operate. Leave it at zero if not used.

Save Settings

The software will do Auto saves at time intervals. The intervals can be adjusted here. It will also have a max display list on the open file menu. Then the software will also make a backup copy of each download to ECU and it is called Device Saves. File location for these maps is in the folder where the Hyperspace is saved on the hard disk.

Hotkeys

These settings let you customise quick keyboard keys to fast track moving between screens and functions. They are completely customisable. In the factory we will set up basic keys for your convenience. You may restore to default when you chose to. Remember these settings is saved in the Config file. If you upgrade versions, then rename your Config file to carry your settings over.

Close will save your selections in the Config file and go back to the tuning pallet.


Device

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

Device

Assign Device

For your convenience Assign Device is built into the Hyperspace Tuning Software. If a system is upgraded or activated on the Portal, the customer only need to have internet connection to activate his system. When you click Assig and there is an active allocation on the Portal, this message will appear:

Click Yes and the device will be activated.

If there is no allocation change on the Portal, then the following message will appear:

Load Device Firmware

Orion2 has a built in bootloader and you may load firmware from the Hyperspace tuning software. Click on Load Device Firmware and a browser will come up. Select your firmware file to load and click open. All Orion2 Firmware ends with a OTfirm extension. This will prevent you from loading the wrong firmware in the different devices.

As you can see from the message do Not put the power off while the BootLoader is running. It will lock the device and then it is another process to open it again. Click Yes and the file will be loaded.

Pin Layouts

This feature will allow you to export the setup of Orion2 connection to an Excel spreadsheet. I will ask you to enter a File name in a browser and save. Below is an example of such a layout. This will tell the customer where all his connections are on the Orion2. Note that this is still Phases and not actual firing order. For that you must fill in the blocks on the respective drawings. This Layout can then be pasted in a wiring Template that look like this.

 | Orion2 In/Out Layout |  |  |  |
Output Name | Pin Name |  |  | Pin Name | Output Name
 | P1 - 12 Way Input |  |  |  |
 | Water Temp | 7 | 1 | Air Temp |
 | Lambda | 8 | 2 | TPS |
 | .+5 Volt Out | 9 | 3 | MAP |
 | .+12 Volt Ign | 10 | 4 | GND |
 | TDC Sensor | 11 | 5 | TDC Power |
 | Crank Sensor | 12 | 6 | Crank Power |
 |  | Internal |  | 3Bar Alt Sensor |
 | P2 - 10 Way Output |  |  |  |
Injector Driver 1 | Coil Negative 1 | 6 | 1 | Coil Negative 2 | Injector Driver 2
Injector Driver 3 | Coil Negative 3 | 7 | 2 | Coil Negative 4 | Injector Driver 4
Cam 1 Output | Negative 2 | 8 | 3 | Negative 1 | GP 3 Output
RPM Output | Negative 4 | 9 | 4 | Negative 3 | Relay Out
Idle Valve | Negative 6 | 10 | 5 | Negative 5 | Dual Idle Valve
 | P3 - 8 Way Output |  |  |  |
Coil Driver 1 | Positive 1 | 5 | 1 | Positive 2 | Coil Driver 2
GP 7 Output | Positive 3 | 6 | 2 | Positive 4 | Micro Fuel Output
 | .+12 Volt In | 7 | 3 | .+12 Volt In |
Anti-Lag Valve | Coil Negative 5 | 8 | 4 | Coil Negative 6 |
 | P4 - 4 Way Serial |  |  |  |
 | SDA | 3 | 1 | SCL |
 | .+5 Volt Out | 4 | 2 | GND |
 | 6 Way USB |  |  |  |
 | Tuning POT | 4 | 1 | Dual Map Switch |
 | Receive | 5 | 2 | Transmit |
 | .+5 Volt Out | 6 | 3 | GND |

This Layout can then be pasted in a wiring Template that look like this.

You will select the block in Excel and paste it where the Red letters indicate Paste Here.


File Menu

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

File Menu

This menu is to open the different saved maps or to save a map from a device onto the pc. The software will save periodic files in Auto Saves folder and also when you do a Device save it will make a copy in the Device Save folder.

Open is to open Map files offline

Open Recent is to open the last previous map files

Auto Saves is to open the last auto saved files

Device Saves is to open the last device saved files

Save is to save Map files on the PC

Save As is rename Map files on the PC


Help Menu

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

Help Menu

This menu holds information. About will indicate all the release fixes and changes between versions released. It also unlocks the embedded manual and will save a copy of it in the Hyperspace folder where the software was saved initially. You may also update the software from this menu.

About

Information on version changes of the software.

Manual

A copy of the software manual is imbedded in the software.

Check for Updates

If new releases are available, then Hyperspace will download it for you from the Website.


TCUToolbar

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen >

Toolbar

Toolbar Shortcut Buttons guide you to basic operations. Some of them also have Hot-keys that activate or deactivate them with one key stroke. Green background means activated.

Hide button - H

This button is used to show all lines on a graph or hide the ones that is not selected. It is handy if graphs are on top of each other to see each one separately.

Easy tune - E

This is a very handy feature if you have to lift graph dots simultaneously. There are different algorithms. That will only move dots from the tuning bar.

Initialise will make the whole line the same value as where the green tune bar cross

When easy tune is on then SHIF-Z will initialise every dot with the same selection to the same value as the bar.

Mouse on - M

This is handy to use mouse tuning on the graphs or disable it for arrow tuning.

Real-Time tracking - R

This is a very handy tool to move the green tuning bar with the real time bar of a graph. It is used with or without Easy Tune to adjust the same value that the device use at that time.

Data Logger

This feature is used for logging signal and tuning on the road. See the sub folder for explanation on its operation.

Connect Button

This indicates if the unit is connected. If you click on it then it will toggle to the other option.

Map Lock Option

This is handy to lock tuning maps so that the customer cannot change parameters. It is also a feature to clone the device with calibrations from another device. See the sub folder for explanation on its operation.

Open Map file

This is to load a Map file from the hard disk into the device.

Save Map file

This is to save a Map file from the deviceonto the hard disk.

Save to device

If you made changes you can save them permanently in the flash with these buttons. You can also press CTRL-S for save or click on the yellow flashing LED.

Upload device memory

This is used with the simulator and when firmware is flashed to the device. It will refresh the software with restarting it.

Quit button

Enough said

Communication LED

This indicates the status of the device.

Flashing green means the device flash memory and PC memory are the same. No save is required.

Flashing yellow means you have changed parameters in the device but you have not made them permanent by saving to the flash memory.

Flashing red means no communication to the device.

Copyright © 2013. All rights reserved.


MAP Lock feature

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen > ECUToolbar >

MAP Lock feature

Locking a device means entering a 6-digit password into the device. It will then require that password to unlock it and retrieve the tuning information. There is no master password so ensure you save a copy of that MAP or password for future reference in case of a device fail and you need to clone it with the same data Map.

If a device is locked and you don't have the password, you may load another map into the device to enable tuning again. Note: The previous maps will then be cleared from flash memory. It is not retrievable.

When you are finished tuning and you want to lock your ECU you can click on the Lock button. Enter your 6-digit password twice and press ok.

Your device is locked. Close the software.

When you connect to an ECU that is locked the software will require this password. It does not matter in which map the ECU is at the time.

If you enter the password, it will unlock the ECU for as long as the software is connected to the device. If you save to device, then the password will be cleared and the ECU will be open for future connections. If you don't save to device the password will be reinstalled.

If you don't have the lock password, press Cancel. You now have the opportunity to load a new map and cloning the ECU. Note that this will clone the device to that map, meaning that your existing data will be gone. Then all settings will have to be reset. As a precaution, disconnect all the output cables from the device to minimize damage due to incorrect output layout.

You may load an open map into the device to unlock it. Remember to go through all your settings as with a Start-up Procedure.

Click the connect button

Click Download to Device

Click Yes

The device will now be unlocked as well as cloned to the exact map you used. This feature is handy if you want to make a carbon copy of a device. Or a spare unit for backup.


Real Time Display

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen >

Real-Time Display

This block displays all the analogue sensor values as they change in the ECU. You may change the appearance of some of the signals as well as the colors in the settings tab. Double click on certain fields will toggle between 2 types of views. Below is a description of the meaning of each signal.

Lambda Sensor

This is the Lambda sensor value displayed in %. Notice on the graph that the rich and lean is inverted between wideband and narrowband.

MAP Sensor

This value displays the manifold pressure and is scaled according to the MAP range setting.

Injection Time

This value displays the total injection time that is applied after all calculations are done. It is in 0.1 milliseconds resolution.

Injection Duty

This value displays the ratio of injection time to revolution time in %.

TPS Sensor

This value displays the throttle position opening in %.

POT Sensor

This input can be connected to a potentiometer or other connections to achieve functions like launch control etc.

RPM

This value indicates engine revolutions per minute.

Ignition Timing

This value displays the total ignition timing that is applied after all calculations are done. It is in 1 degree's resolution.

Water Temperature Sensor

This value displays the current engine water temperature.

Altitude Sensor

This value displays the altitude pressure of your location.

Air Temperature Sensor

This value displays the current air temperature at the air intake.

Battery Voltage

This value displays battery voltage that is connected to the ECU.


Status Bar

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen >

Status Bar Display

This block at the bottom of the software displays all kinds of status, information and fault codes. Below is a description on types of messages.

When no device is connected, the connection button may be open and an indication that no device is recognized. If you use a different USB cable, you may need to click on the connect button to tell the software to search other Comms ports as well. Once a port is found with a recognized device the software will lock onto that port to minimise start up times. It will then display the device type and COM port as below.

On the right bottom corner the software will indicate which ports it is scanning to search for a device. If you use a different USB cable, you may need to click on the connect button to search other ports as well.

Orion2 has a BootLoader to load firmware. This indication will show if it is active on that device.

This message indicates if the unit is mobile software capable or not. Some mobile applications will run only if this is set. Contact your supplier for activation.

The software will also give occasional indications on tasks like if the map was saved successful or not.

This message will indicate Errors, Warnings and Information. This is helpful to the user to find errors in the setting up of the device. If you click on the [image] button left of the error, a list of the errors will appear with the last one on top. If you go out of the error list it will be cleared. See the list of errors in the sub folders.

See the sub folders for the different error messages displayed on the Status bar:


Error Codes

The ECU software has Error, Warning and Information codes displayed in the Status tool bar at the bottom. These codes will help the tuner to find problems during startup and tuning, also to see if the ECU is functioning correctly. Some of the functions on the ECU will indicate to the tuner what is happening. He can then see if these functions are operating correctly.

The codes are displayed at the right hand bottom corner. The code list [image] will display a list of accumulating codes so that the tuner can see what the codes were and in which order. The bottom indication will only show the last code. Also note that a code is only updated once, until it disappears and when it appears again the code will be logged again. This is to prevent the list from being too long. This does not apply to the angle sensor error codes during cranking. They will increment the counter as each one occurs.

Press the ''C'' key to clear the error codes. This is handy as you will not be able to see is the code is still present or if it was only listed once.

Note: If you crank an engine and it does not start, there will be one error code, error code 6 for Emergency Engine Shutdown. This is normal and not an actually an error. The ECU was expecting more trigger pulses but pulses were stopped. Therefore, the ECU goes into a safe shutdown of coils and injectors etc. A tip, press C then crank the engine. There should be no error and it will read 200 RPM's on the rev counter until the key is released.

The blue codes are for crank, cam and other sensor related errors. The red codes are warnings like over temperature etc. The green codes are for information of functions that were activated. The colors are only for explanation in this document.

The following list explain the different error codes

1 - Missing crank pulses - The crank sensor senses too little teeth per revolution

2 - Too many crank pulses or spikes - The crank sensor senses too many teeth per revolution

3 - Incorrect crank TDC slot - The crank sensor did not sense a TDC slot. (Maybe incorrect wiring)

4 - Missing TDC pulse - The TDC pulse is not present

5 - Missing home pulse - The Home pulse is not present

6 - Emergency engine shutdown - Safe shutdown of engine due to lack of or incorrect signals

7 - Fuel pressure safety cut-out - The fuel pressure sensor low limit has been reached

8 - Economy fuel cut-out - The fuel economy cut is implemented

9 - RPM limiter reached - The engine RPM limiter has been exceeded

10 - Max boost limiter reached - The boost pressure limit has been exceeded

11 - Water hot/cold temperature limiter reached - The water temperature limit has been exceeded

12 - Launch limiter reached - The launch limit RPM has been exceeded

13 - Lambda control limits reached - The lambda control limit has been reached

14 - Battery low voltage limit reached - The battery voltage falls below a critical limit

15 - Selection refreshed. Confirm driver placement - The ECU changed driver output configurations

16 - Timing retarded - Ignition timing is retarded during an automatic transmission shift procedure

17 - Flood control injector cut-out - Fuel is cut by injectors during cranking when the throttle is fully opened

18 - Flat-shift activated - Ignition or fuel is cut for a moment to enhance gearshift for racing engines

19 - Ignition power switched off - Ignition key power is switched off

20 - Sponsor counter depleted - The sponsor counter is depleted for sponsored ECU's

21 - Anti-Lag activated - Anti-Lag is activated on the Launch features

22 - Hardware Class don't support this feature - Incorrect firmware loaded

23 - Speed Limit Reached - Speed Limit was exceeded

24 - Bootloader Not Present - This indicate if the BootLoader firmware was not loaded in the newer products

25 - Overcharge Limit Reached - This error will come when the charge time plus graph times exceed the maximum charge times

26 - Test Mode is Selected - This is used for calibrating TxW firmware

27 - Map was Reloaded - This indicate that a Ma was reloaded from memory and installed in RAM to be used.

28 - Map Sensor Error - This indicate MAP Sensor failure

29 - TPS Sensor Failure - This indicate TPS Sensor failure

30 - Lambda Sensor Failure - This indicate Lambda Sensor failure

31 - Water Temperature Sensor Failure - This indicate Water Temperature Sensor failure

32 - Air Temperature Sensor Failure - This indicate Air Temperature Sensor failure

33 - Altitude Sensor Failure - This indicate Altitude Sensor failure

34 - Fuel Pressure Sensor Failure - This indicate Fuel Pressure Sensor failure

35 - Potentiometer Sensor Failure - This indicate Potentiometer Sensor failure

36 - Micro Fuel Activated - This indicate that the Micro Fuel or Dual injector control were activated.


Selection Refreshed

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Status Bar >

Selection Refreshed

This feature is initiated by the firmware to force the software to refresh its database. It happens when the tuner makes selections that are not legal for that specific firmware or when GP outputs are re-arranged by the features. The software will refresh and change the setting of the tuner to a safe level or disable other features. The messages below will then appear:

When you see this then you must go through the setup and see which devices have been changed and set them accordingly.


ECU Information

The device information screen displays vital information regarding the Spitronics ECU that has been connected. Note: Firmware is the program that is loaded into the ECU to make the electronics operate in a specific way. This is normally Firmware file which is loaded into the product by a USB debug programmer or BootLoader. Software is the tuning interface that runs on the computer and it is used to tune the product's parameters.

Device Information

Device Serial Number

There is a unique number assigned to each product. It is saved on maps and recognized by the database on its status etc.

Hardware Type

Displays which type of device has been connected to the software. In this case and an Orion2 Engine Control Unit.

Hardware class

Displays the Hardware class of the product that has been connected to the software. The hardware class will determine which firmware can be uploaded onto the product. This feature allows the unit to open certain or all functions of the electronics. The amount of features determines the price of the unit. This feature can be changed over on the internet to allow for remote upgrades of the unit. The hardware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

7. Commercial

8. Racing

Firmware Type Locked

This block will indicate which type of firmware are allowed on the unit. If it indicates No Restriction, it means that any Type of Firmware for Orion2 can be programmed into the unit like ECU, TCU TxW etc. This feature is for sponsored units or specials which was approved by the manufacturer.

Firmware Number Locked

This block will indicate which firmware number in the firmware range are allowed on the unit. If it indicates No Restriction, it means that any firmware number for Orion2 can be programmed into the unit. This feature is for sponsored units or specials which was approved by the manufacturer.

Brand Code

This represent a specific brand like Spitronics which is 1. Orion2 may also be rebranded to large distributors which means this code will change. Once a brand is changed the unit will only connect to the software of that brand. This will bring exclusivity to that brands customers.

Firmware Loaded Information

Firmware Type

This block will indicate which type of firmware are loaded on the unit like ECU, TCU TxW etc.

Firmware Number

This block will indicate which firmware number is loaded and a short description.

Firmware Class

Displays the class of the firmware that has been downloaded onto the device. Each firmware program supplied will have a certain class according to the features used. You may load any firmware for a specific product into the unit as long as the firmware class does not outrank the hardware class of the Orion2. The firmware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

7. Commercial

8. Racing

Program Number

Displays the current firmware program that has been downloaded onto the device. The program is identified by a program number and description. See the firmware list of programs for the ECU.

Protocol Version

Displays the current protocol version number between the firmware and the PC software. This must be the same for the hardware and software to communicate. The firmware will indicate to the software which version of the program to open.

Firmware Version

This block displays the software version as well as the firmware version that is loaded into the Orion2. In the example 3.6 is the software version which is required to communicate with the Orion2 and A is the firmware version.

The firmware version no effect on the software version. Always use the latest versions available.

On the top bar you will find the product software version. Note that version 3.6 will be standard with the Firmware version 3.6.

The first 3 is version 3 PC Software.

The second 6 is the protocol version between the PC software and the firmware. When new features are programmed into the unit, this protocol version will change in the PC software and in the Firmware.

The .1 at the end is a sub version and has no effect on the firmware. This version will indicate corrective or improved PC software. Always use the latest version available.


ECU Setup

Help > ECU Engine Managment > ECU Software Desciption >

ECU Setup

General Settings

or [image] Engine Settings

Timing Settings

Injection Settings

Sensor Settings

Turbo Settings

This blocks are where all the setup values for the ECU are grouped so that the tuner can setup his engine.

See the sub folders for explanations.


General Settings

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup >

General Settings

See the sub folders for explanations.


Map Information

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > General Settings >

MAP Information

The Map information screen, Name Model and Engine, contains info for the ECU application for a specific vehicle. This helps the tuner to recognize previous work and tuning data. It is saved in the ECU and also in PC maps. It does not affect any tuning on the engine.

Map Number

The firmware can save up to 2 maps for different fuel setups or tuning algorithms. This is only an indication and the map cannot be forced on this page. This block is updated when the ECU is switched on. If no selection switch is connected, the ECU will default to Map 1. Note: The maps cannot be changed whilst the engine is running. The power of the ECU has to be cycled for the new Map to be loaded. The reason is the time it takes to load and populate a map in software will let the engine cut out. If you populate in real time settings of one map will be implemented momentarily on another map and then time and fuel values may be out of limits and damage an engine under load.

Save Setup Data

This feature is handy if you want to load a map to change the tuning graphs without altering the setup data. If it is on it will load the setup settings and the graph and matrix data. If it is off it will only load the graph and matrix data. Note: The critical settings and calibrations are not altered in map load. A useful tip is to leave this setting off. Any changes on the setup while the ECU is connected is saved as normal. This feature is permanently saved in the ECU and can only be changed on the screen when the ECU is connected. Note. Never load a map while an engine is running.

Dual Map Selection

The map loaded in the ECU is determined by the Dual Map Selection switch. Orion2 has a dedicated input which is hard wired for Map selection. The input can also be used for other tasks and this setting in software will indicate if it is used as dual map input. On Orion2 Maps may be changes on the while driving. Do not swop Maps at full power as there may be setting that clash with graphs as the map are loading. They load in about 1 second.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or components on the engine.

Tuning Mode

This feature allows the tuner to select variations of tuning according to his skills. The firmware will enable more features as the level of progress is made and hide features on lower levels so that confusion for beginners is kept to a minimum.

Novice

This level is set up as the first generation of Spitronics ECU's. There are however new features which is explained further in the manual. This mode is used for graph tuning and were developed by Spitronics. It is also easier for road tune where a Dyno is not present.

Moderate

This level is more for tuners with Dyno facilities. Here the matrix tuning is present as well as the graph method for fuel and timing. There is also a selection for MAP or TPS tuning versus RPM. Included in this level is a mixture, possibly for racing engines with poor vacuum but with turbo chargers where MAP pressure needs to be compensated for. The tuner can select his preferred option. Note: The graph and matrix data uses its own memory space and both types could be tuned without losing the data on selection changes. This allows the tuner to tune both options and chose the best for his application.

Expert

This level is to assist the tuner to tune racing engines and different fuels where more refined parameters are required. Here parameters like Start Prime Pulse, Start enrichment, and the two Accelerator pump Enrichment values are tuned on a graph versus temperature. This is very useful for methanol cars also in extreme cold conditions when fuel does not ignite easy.

Related Links

Dual Map Switch Wiring


General Purpose Outputs

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > General Settings >

General Purpose Outputs

Output selection

Version 3.5 can handle up to 10 General Purpose (GP) outputs to configure for several different functions. These outputs can be configured to use any of the analogue signals to switch relays on or off when certain limits are reached. Due to the number of GP outputs this block was developed to be generic. That means there is a dropdown menu to choose which one is adjusted by the tuner. Not all firmware has the ability for 10 GP outputs so the number of selections may be limited. This depends on which features are activated in the ECU. Note the operating current and requirements of each product in the electrical drawings, so that damage to the ECU will not occur. See the GP Priority register and the wiring of the specific output for that ECU. Some drivers may be positive output and some negative output.

If an output is available, the software will show the location of the driver that is used with this GP output.

Should an output not be available the driver will be blank and the Output settings will be locked on not used.

Selections

The tuner has a number of selections to use in the GP output. Use the drop down menu to display the others.

Not used - this saves processor time

RPM - RPM/min 100rpm increments

Vacuum - pressure 0.1 Bar increments

TPS - percentage at 1% increments

Water temperature - degrees at 1°C increments

Air temperature - degrees at 1°C increments

POT value - percentage at 1% increments

Battery voltage - voltage 0.1volt increments

Altitude - pressure 0.01 Bar increments

Fuel pressure - pressure 0.1 Bar increments

Lambda - percentage at 1% increments

Timing - degrees at 1° increments

Injector - fuel at 0.1milli second increments

The GP outputs can be used in different ways.

First we do water temperature as it operates in a unique way on all the GP outputs. In this example we will setup the water temperature to operate the electrical cooling fans.

The water output will come on when the temperature goes above the Max setting at 98 degrees C and will stay on until below the Min setting at 92 degrees C. This will give the fan a dead band of 6 degrees before switching off.

All other types.

If tou want to use a GP output to switch on a shift light. The light must come on at 5000 RPM and switch off at 7000 RPM.

Note that the GP limits are only, 'bigger and smaller than'. This is to prevent shuddering due to a small dead band. This means if the light must come on and off on the rising limits, you may need to change the value a slightly. In this example on rising RPM's the output will come on at 5000 RPM and off on 7000 RPM and on falling RPM's it will come on at 6800 RPM and off on 4800 RPM. So the output is set on between the limits and off outside the limits.

If we swop the Min and Max settings around, (see below), it will change the logic to Off between the limits and On outside the limits.

V-Tech

There is one GP output, No2, that has the added V-Tech TPS limit added to the RPM setting.

In this method the output will switch on between the limits only if the TPS value is above 40%.

Note! If you don't use these outputs, select Not Used so that valuable processor time can be saved.

Related Links

GP Output Priority

GP Output Wiring


RPM Output

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > General Settings >

RPM Output

Pulses/RPM

This feature is used for Rev counter calibration. You can adjust the number of pulses per revolution for the RPM output. This is handy for engine conversions. A value of 1 to 60 pulses can be achieved with this function. On some firmware you may enter 61 which will then divert the crank angle signal onto the RPM output. This is also handy if the standard ECU is still active and doing other functions in the car. Note different electrical connections in the drawings to connect the different RPM gauges onto the Spitronics ECU. When you select 0 the software will refresh and free this driver for other functions like General Purpose output on specific firmware.

If this feature is not used select zero to free up some valuable microprocessor time.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or components on the engine.

This Auxiliary Values is used on certain firmware to achieve certain functions. It is only used in new development where the features were not yet developed in the Tuning Software. See the specific instructions for that engine type.

Related Links

Tachometer Wiring


Engine Settings

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup >

Engine Settings

See the sub folders for explanations.


Engine Configuration

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Engine Settings >

Engine Configuration

Engine Type

The ECU firmware will lock this selection for a Piston or Rotary engine. For Rotary it will enable a Trailing degree graph and also a Maximum trailing degree setting. For most firmware this block will be hidden.

Cylinders

Most ECU firmware will lock this selection for a specific number of cylinders. Other firmware like the standard unit will open this dropdown menu for the tuner to decide for which engine it is required.

Map Teeth (Gear Type Trigger Only)

This setting is used to synchronize the crank angle degrees where the manifold vacuum is sampled. This is very useful for engines with individual throttle bodies that has poor vacuum signal due to a common vacuum rail. This setting can be adjusted up to 180° of engine rotation after TDC. If it is a 36-1 gear as in this example, then 9 teeth will result in 90° after TDC. Start at 90° after TDC and adjust the teeth more or less at idling till the best vacuum signal is achieved. Start with the gear teeth divide by 4. For 60-2 it will be 15.

On multiple throttle bodies you only connect one cylinder to the Map sensor. It must be cylinder 1, or the one that shares the same TDC degrees with it. Do not use a common vacuum rail. Set the setting as below.

Map sensor

Spitronics have a selection of 4 Map Sensors to choose from. 1.1 Bar, 2.5 Bar, 3.0 Bar, 4.0 Bar and a Custom sensor option. Select the one that is supplied with the ECU. The most popular one is 2.5 Bar.

If you use an engine MAP sensor that is not standard with the 4 selection you may choose Custom and calibrate it yourself. Select the following.

Chose custom sensor and chose a map range. The range cannot be larger than the sensor capability.

Go to MAP sensor select and click the calibrate button.

Adjust the Offset value till the software reads the altitude at your level.

Click OK.

Map Range

Spitronics can use any MAP sensor to fuel even a normal aspirated engine. Note however, that it is best to use a sensor that is just higher than your maximum manifold pressure. It is more accurate because the sensor has better resolution over the 0 to 5-volt range. On this field you select the maximum boost pressure that you will use in the application. For example, if the engine is required to run at 0.8 Bar boost, select 1.9 Bar. This means at sea level you can run 0.8 Bar boost without running the tuning pressure off the scale. Making the scale too large will reduce valuable tuning space on the graphs or matrix. For normal aspirated engines always select 1.1 bar.

RPM Range

This setting is used to adjust the ranges of the RPM tuning graphs or matrix. Set it to a value of 500 RPM above the engine max RPM. If you use a higher value, you will reduce valuable tuning space.

Trigger Type

Selective firmware may let the user choose the crank angle sensor type. This program is written to minimise stock on the shelf for retail stores.

Two Stroke

This Setting will select between 2 or 4 stroke to correct the injector duty % indication bar. If it is on 4 stroke the injector time is calculated over 2 RPM's while on 2 stroke the injector time is calculated over 1 RPM. For example, on a split sequential setup, 10 milliseconds on 4 stoke means that the injector will inject 5 milliseconds each RPM to make up 10 milliseconds. While on 2 stroke 10 milliseconds will inject the full 10 milliseconds on each RPM. If you have an engine that does not rev high and the injectors are too small you may put it on 2 stroke to double the injector time. Note however, the injector duty % during tuning must not go over 100% as this will occur at a lower RPM. 85% Max is a recommended maximum duty cycle as the injector may stay open after that.

Engine Shutdown

This setting will select how the engine is shut down. Fuel first means that the ECU will run normally but stop injecting fuel when the key is turned off. This will let the spark burn all the unwanted fuel from the cylinder. That is handy for rotaries where the injectors are far from the intake valve. It may sound as if the engine keeps going for a moment after the key is switched off. Fuel & Spark cuts both immediately when the key is turned off. There may be unburned fuel on the cylinder but the engine dies immediately. Note: This feature is only available with cetain products that have Power management capability.

Related Links

Map Sensor


Timing Settings

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup >

Timing Settings

See the sub folders for explanations.


Coil Charge times

Help > ECU Engine Managment > FAQ Frequently Asked Questions >

Timing Configuration

Maximum trailing

This is for rotary engines and prevents the trailing degrees from being adjusted to far from the leading plugs. In piston engines this block is hidden.

Maximum Timing

This is the maximum combined timing allowed in degrees by all the timing maps combined. If the graphs are tuned for more degrees, it will be limited by this value. On the Timing Matrix this will also prevent the tuner from selecting higher values there.

Minimum coil time

This is the minimum coil charge time which the tuner can select. The ECU will vary the charge time automatically according to engine load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is about 60% from the maximum value. Example if Max value is 3ms then make min 1.8ms. see the Maximum Coil Time to determine the right setting.

Maximum coil time

This is the maximum coil charge time which the tuner can select. The ECU will vary the charge time automatically according to engine load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is 2.5 to 3.5 milliseconds for coils of around 0.9 ohms but some new coils are lower resistance and may need shorter times. Normally the driver will heat up and may damage if it runs too hot. Always start with a min value if you are not sure. Start with 2.0 to 2.5ms. Coils with a lower resistance in the 0.4 to 0.5-ohm region, use a value of 1.5 to 2ms. Always a good idea to put a 5-Amp fuse in the power line of each coil. If you go too high the fuse will blow. If you use the Mercury Coil driver, then you can look at the overload LED. It comes on at 4-amp current. Most coils are rated at 5.5A. adjust maximum so that the OVL LED may come on at full load but not on at less than 70% load. During cold starting, this maximum value is used till the engine reaches 60°C. Thereafter spark control will commence.

Vacuum Timing Split

This value sets the RPM split between the Low & High Vacuum Timing maps. This value is selected about 500 to 1000 RPM's above idling.

Altitude comp.

This value sets the timing advance ratio for every 1000 meter above sea level. A value of 3 means that the timing will be advanced by 6 degrees at 2000 meter above sea level. If you tune the vehicle at a higher altitude, make sure this value is set. Then when the driver descends to lower altitude the ECU will retard the timing automatically.

Related Links

Tuning


Crank and Cam angle sensors

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

Crank and Cam angle Sensors

These inputs are required by the ECU to determine exact crank and cams angles so that spark and injection timing can be calculated.

Crank (TDC)

The crank angle sensor is used by the ECU to determine exact crank degrees as it rotates. This sensor could be situated on the crank or in a distributor or encoder called a CAS. If it is situated on the cam gear like a distributor, then it will have enough pulses for 2 revolutions to represent the crank signal. For example, Toyota uses what we called a 24+TDC pattern. If the sensor is on the crank there will be 12 teeth. If it is on the cam there will be 24 teeth. If a pulse is generated on a 36-1 gear on a crank for example, then the missing tooth is used as a TDC pulse. A TDC pulse represent a signal that comes once every revolution. It is not necessary at TDC of the engine. In a distributor it may have a TDC pulse or Home pulse. If a pulse come once in two revolutions it is called a home pulse.

The crank sensor has a test function. Each firmware file is programmed for a specific sensor pattern. The test function will activate a test procedure of the crank sensor pattern during cranking, to ensure that it is read correctly. If it is incorrect or has the wrong firmware, the software will show errors and not attempt to start the engine. In this mode the ECU will do two revolutions of the crank sensor before starting the engine if the trigger pattern is correct. These Errors have numbers indicating a fault code and description. This is a very useful feature for first time startup after the installation is done. See Setting Crank Sensor Timing below. Note. After setup put the test faction off. It may bother at high RPM's due to the calculations to determine correct patterns.

Cam (Home)

The cam angle sensor will always be situated on a cam shaft. It could be a lone sensor in the valve cover or in a distributor. This signal only came with later models when full sequential injection was introduced. Some distributors like Nissan and Toyota had both sensors in the distributor. The cam signal will give a unique pattern over two revolutions, allowing the ECU to detect which revolution is the firing stroke. This signal could be one pulse or a number of pulses. The ECU can compare it with the crank signal pattern and determine firing stroke.

This feature is not used in Orion2. It can only do open loop VVT cams by setting GP2 value.

Setting Crank Sensor Timing

This block is used to indicate to the ECU where the exact TDC point is on the crank. It works differently for the different style of crank angle sensors. These settings will allow the ECU to synchronize software timing with the actual spark timing on the engine.

On gear type trigger wheels, the Gear Teeth will indicate to the ECU the amount of teeth between the slot and TDC. The Timing Sensor will do finer adjustments to precisely set the timing in-between the teeth.

The example below explains, if you put the engine of a 36-1 trigger wheel on TDC, count the number of teeth from the slot anti clockwise to the pickup sensor plus the one just past the sensor. Put this value in [image] . Then you may adjust the Timing Sensor [image] from 0 to 9 degrees to precisely align the timing light to the tuning software. The example below should work out as Gear teeth 7 Timing Sensor 6 as the last edge of the teeth is in the center of the sensor.

With the engine running match the timing as close as possible by using the Gear teeth setting. For example; the ECU software indicates 10° advance on the real-time bar, but you see 12° advance on the engine. The Timing sensor °BTDC will now be adjusted to accommodate the difference which is 2. With the Timing sensor adjusted the Timing light and the ECU should now be matched.

Important!
When using an Advance / Retard timing light on a wasted spark system the timing light will read double the timing of the engine. So if the timing light reads 20° advance, the actual ignition timing is 10° advance. If you are not sure rather put the timing light on zero degrees and use the pulley marks. Remember that the COP systems are still fired in wasted spark sequence.

On single event triggers you will find that gear teeth are not adjustable only the degrees between the triggers. On a 4Cyl Nissan for example the timing sensor may be adjusted to 180 degrees.

Related Links

Crank and Cam angle Sensors

Error Codes


Timing Calculation

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Timing Settings >

Timing Calculation

This block will allow the tuner to choose different options to set up timing for this engine. Each of these methods will be discussed in detail under the tuning chapter further in the manual. You can see the Tuning section for detailed description on the tuning side.

Graph MAP

This method is for standard engines with a good vacuum signal and it allows for easy tuning in the street. It has a Dynamic timing map on top which is tuned at WOT. It has 2 vacuum tuning maps for pull-off and cruise timing adjustments.

Graph MAP+TPS

This method is used for engines with a poor vacuum signal at low RPM's and it still allows for easy tuning in the street. The ECU will use the TPS signal to calculate a MAP signal at low RPM's when there is no or little vacuum. It is used for engines where the vacuum signal is correct and above 1500RPM's. The graphs are the same as above with the addition of the following settings:

When the RPM's is below the RPM fuel cut off, then TPS idle is activated. The Vacuum Fuel Cut off setting then becomes the minimum manifold pressure value to start off from.

The TPS gain value will use the TPS signal to calculate a projected vacuum signal on the graph. When the actual vacuum is below the calculated vacuum then the ECU will use the lowest vacuum signal of the 2. Once RPM's are above the RPM fuel cut off, then TPS idle is de-activated.

Matrix MAP

This is for standard engines with a good vacuum signal and allows for easy dyno tuning. Here the MAP sensor versus RPM is used and the blocks are set in 1-degree resolution.

Matrix TPS

This is for normal aspirated engines with poor vacuum signal or throttle bodies and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes. TPS versus RPM does not compensate for pressure changes. Here the TPS sensor versus RPM is used and the blocks are set in 1-degree resolution.

Graph MAP + Matrix TPS

The Matrix is the same as TPS Matrix above. This is for turbo racing engines with a good or poor vacuum signal and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes in the TPS matrix. Here the normal aspirated tuning is done on the matrix and the boost timing tuning is done on the two Cruise timing graphs. They will become visible in this mode. Here the TPS sensor versus RPM is used on the matrix and the blocks are set in 1-degree resolution. Then Map sensor is used to modify timing in the cruise graphs.

Related Links

Tuning


Coil Combination

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Combination

This block indicates the type of coil combinations that can be used with this firmware. Firmware will block out the ones that is not allowed. On some if you select a wrong combination the software will refresh and cancel your selection. If you have an intermediate or lower hardware class ECU, it will also hide the multi coil settings. Most COP coil per cylinder engines are fired in wasted spark configuration and each coil will have its own driver. (See the wiring diagrams for connections.)

The combo files can be loaded into intermediate, advance or ultimate ECU's. In an intermediate ECU only the single Distributer option will be available. In an advance ECU the tuner my select between single and wasted spark. In Ultimate you may select Full Sequential on 4 Cylinder engines.

Note! On the Rotary programs the tuner may select between coil per cylinder or wasted spark. If the engine has the three coil setup where the leading spark plugs are on a wasted spark coil and the trailing are on coil per cylinder, this value is set on wasted spark. The two leading coil trigger wires must be tied together on the wasted spark coil negative. (See the connection diagrams). The charge time for the leadings will combine without overlapping and destroying the coil. Note that on high RPM's the leading spark will become weaker due to less time available to charge the coil. It has to charge twice per revolution.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or coils.

Dual distributor
Two ignition coil outputs will be activated and phased to run a dual distributor system as found on the Lexus 1uz-fe and BMW V12,

Single distributor
Only one ignition coil output will be activated and phased to run a single distributor. Old school engines use these types.

Wasted spark coil pack
Coil outputs equal to half the number of cylinders will be activated to run a wasted spark ignition coil. This is a very popular choice on smaller engines.

Wasted spark coil per cylinder
Coil outputs equal to the amount of cylinders, will be activated to COP coil per cylinder. They are fired in wasted spark sequence.

Full Sequential coil per cylinder
Orion2 have the capability to do Full Sequential Spark on 4 cylinder engines. This selection will require a Home pulse from a camshaft or distributor before the coils will be pulsed. You will need to set up the Home pulse signal.

Note that full sequential and wasted spark systems has no performance difference as both types will have a full load on the coil so spark is the same energy. It is merely required for overlap cams and NOS systems Also make sure that firmware is available for your application.

Related Links

Ignition Coil Wiring


Coil Driver Trigger Combination

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Driver Trigger Combination

This block selects the coil type connected to the ECU. There are Basic Coils that requires an HV Coil driver and then there are Smart Coils that has built in drivers.

Basic Coils require a negative pulse to charge the coil and a positive pulse to fire the coil. This requires a high voltage power MOSSFET to control the high voltage found in the coil primary during the fire cycle. Orion2 have a total of 6 of these drivers. Two of them are shares with the POT and Dual Map Switch. This means you can do Full Sequential Spark on 4 and 6 cylinder engines and Wasted Spark for engines up to 12 cylinders.

Smart Coils are coils with this high voltage driver built in. Most new cars come with Smart Coils. They require a positive pulse to charge and a negative pulse to discharge. Orion2 have a total of 4 of these drivers. This means you can do Full Sequential Spark on 4 Cylinder engines and Wasted Spark for engines up to 8 cylinders.

Note! Do check if firmware is available before you do the wiring.

NB! The coils must get their power from the ECU power relay. At startup this relay is kept off till the ECU can read the map to see what type is selected. Having this wrong will destroy the drivers or the coils.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or coils.

Related Links

Ignition Coil Wiring


Coil Driver Outputs

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Driver Outputs

On Orion2 with Hyperspace 3.6 Software the drivers are now also displayed. This will indicate how many drivers are allocated to coils and will change according to Coil Driver Trigger Combination. This will allow the installer to do a printout of the drivers after setting up his unit.

Note! This is the sequence of Coil Driver firing and not actual firing order. See the wiring diagrams on that.


Injector Settings

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup >

Injector Settings

See the sub folders for explanations.


Fuel Configuration

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Fuel Configuration

Start enrichment

This value will help an engine to stabilize after starting. This amount will be added to the injector time after the engine is started and reaches 500 RPM. It will then be phased out in a couple of revolutions. This value is also compensated with the water temperature %, and is not active in Expert mode. Then the Water Temperature graph is used. The value is set in milliseconds. In Expert mode this value for Start Enrichment will be blanked out and the graph value for that temperature interval will be used. See the graph sample below.

Maximum fueling

This setting is to protect against over fueling from all the graphs with accelerator pumps etc. It will limit the final injection time to this value if it is higher. This value can be calculated as the time it takes 1 revolution for 2-stroke engines, or 2 revolutions for 4-stroke engines. The calculation for 4 stroke engines at 7000RPM is seconds=60 * 2 / Max RPM=120/7000 = 0.017 = 17 milliseconds. For a 2 stroke it at 7000RPM is seconds=60 / Max RPM = 60/7000 = 0.085 = 8.5 milliseconds. The recommended injector time is 85% of that value which results in 14 and 7 milliseconds respectably. If your duty cycle of the injectors at full load max RPM reaches over 85% you may have to go for larger injectors or increase the fuel pressure to maximum safe pressures. On the Fuel Matrix this will also prevents the tuner from selecting higher values there. This value is set in milliseconds.

Start prime pulse

This setting is to assist in the starting of the engine. When the engine starts to crank and reaches 100 RPM a set amount of fuel is injected on all the injectors to get the first one with spark to ignite and turn the engine. A colder engine requires more initial fuel to start. This value is also compensated with the water temperature and is not active in Expert mode. Then the Water Temperature graph takes over this value. In Expert mode this value for Start Prime pulse will be blanked out and the graph value for that temperature interval will be used. Note that this value is x10 so 6.4 is 64 milliseconds. See the graph sample below.

The Spitronics ECU's have a manual prime function where you can press the accelerator pedal before starting to inject fuel in the system. This fuel is measured at 50% of the start prime pulse setting. It is injected each time the throttle is pressed more than 25 % opening.

Should the engine be flooded, you may keep the pedal fully pressed to the floor during cranking. This will indicate the ECU to cut injectors and only provide spark. Press the throttle in all the way before putting the ignition on. It will prevent the prime pulse from injecting more fuel when the pedal is pressed. Once the engine starts release the pedal and then injection will commence as normal.

Vacuum fuel cut off & RPM fuel cut off

This feature is useful in town and downhill driving and will save fuel. It will let the engine run against compression as you are decelerating. It will also prevent flaming in the exhaust during accelerator blip. Injectors will be cut when the MAP sensor value is below the vacuum setting and the engine RPM is above the RPM setting. There is a dead band feature built into these settings to prevent jerking when cruising close to the parameters. If you feel a jerk when the feature is activated or deactivated, adjust these settings till it changes over smoothly. This is normally where the change from positive to negative drive on the prop shaft is.

Injection teeth

This feature adjusts the start injection degrees. It is only available on gear type triggers as low as 12 teeth per revolution. Normal injection timing starts just after the intake valve closes. The warm valve helps atomizing the fuel and makes the engine use less fuel. Put the engine on the degrees where you want to start injection. Count the number of teeth from the slot or missing teeth in the gear, in an anti-clockwise direction, to the sensor. If the pickup is in the slot imagine the tooth there and count it as well. Even if it is 60. The firmware will move injection in the slot to the closest teeth as this is not as critical as spark timing. You may change this value during tuning to see if you get better atomization and performance increase. Usually this is best seen at idle. Find the spot where it runs rich and make idling leaner. Start with low teeth and move to larger numbers to see when the valve closes. It will go rich at that point.

TPS Gain

This setting will adjust the rate at which the TPS sensor will move the MAP bar to the right of the graph during Graph Map + TPS calculation mode. This will simulate a MAP signal and the gain adjustment will produce the right amount of fuel during pull-off. (For further details see the tuning section).

Related Links

Tuning


Accelerator pump tuning

Help > ECU Engine Managment > ECU Tuning >

Accelerator pump tuning

Accelerator pump selection

The accelerator pump setting is used to richen the fuel mixture when accelerating to avoid flat spots or bog. Here you can select not to use it, use either the TPS or MAP or both signals. Below is the selections to setup each pump for TPS and MAP.

Enrichment %

This is the amount of fuel that will be added momentarily when the accelerator pump is activated. This value is divided by the number of strokes and each stroke the value is reduced by the division value. It will start with 10 and reduce to zero so that fuel is gradually reduced. This value is also compensated with the water temperature graph value. In Expert mode this value for MAP and TPS will be blanked out and the graph value for that temperature interval will be used. See the graph sample below.

Sensitivity

The activation sensitivity can be adjusted from 1 to 10. The lower the value, the more sensitive the accelerator pump will be. If the accelerator pump is set too sensitive it will activate randomly and cause the vehicle to over fuel. Rather keep the activation sensitivity as high as possible to avoid this from happening. For the TPS signal this value can be lower as it is more stable than MAP value and it reacts faster.

Max RPM

This is the maximum RPM that the pump settings will be active. At high RPM you do not need an accelerator pump. A standard is 1500 to 3000 RPM for TPS and 1500 to 2200 RPM for MAP. If a value was initiated before this limit was reached it will finish the decay cycle.

Strokes

This is the number of engine strokes that the fuel must be applied to and then decayed over the amount of cycles. If it is a 4 cylinder engine, a value 0f 8 will inject 4 full revolutions of fuel. There are two firing strokes per revolution. If it was a 6 cylinder engine, a value 0f 12 will inject 4 full revolutions of fuel. Always tune for the lowest value to eliminate flat spots. If a value of example 10 is selected it means that the enrichment amount will be decayed by a tenth every cycle till the tenth stroke.

Related Links

Tuning


Fuel Calculation

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Fuel Calculation

This block will allow the tuner to choose different options to set up timing for this engine. Each of these methods will be discussed in detail under the tuning chapter further in the manual. You can see the Tuning section for detailed description on the tuning side.

Graph MAP

This is for standard engines with a good vacuum signal and allow for easy tuning in the street.

Graph MAP+TPS

This method is used for engines with a poor vacuum signal at low RPM's and it still allows for easy tuning in the street. The ECU will use the TPS signal to calculate a MAP signal at low RPM's when there is no or little vacuum. It is used for engines where the vacuum signal is correct and above 1500RPM's. The graphs are the same as above with the addition of the following settings:

When the RPM's are below the RPM fuel cut off, then TPS idle is activated. The Vacuum Fuel Cut off setting then becomes the minimum manifold pressure value to start off from.

The TPS gain value will use the TPS signal to calculate a projected vacuum signal on the graph. When the actual vacuum is below the calculated vacuum then the ECU will use the lowest vacuum signal of the 2. Once RPM's is above the RPM fuel cut off, then TPS idle is de-activated.

Matrix MAP

This is for standard engines with a good vacuum signal and allows for easy dyno tuning. Here the MAP sensor versus RPM is used and the blocks are set in 0.1 milliseconds resolution.

Matrix TPS

This is for normal aspirated engines with poor vacuum signal or throttle bodies and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes. TPS versus RPM does not compensate for pressure changes. Here the TPS sensor versus RPM is used and the blocks are set in 0.1 milliseconds resolution.

Graph MAP + Matrix TPS

The Matrix is the same as TPS Matrix above. This is for turbo racing engines with a good or poor vacuum signal and allows for easy dyno tuning. Note: It is recommended to add the altitude sensor to compensate for altitude pressure changes in the TPS matrix. Here the normal aspirated tuning is done on the matrix and the boost tuning is done on one Fuel Load graph. It will become visible in this mode. Here the TPS sensor versus RPM is used on the matrix and the blocks are set in 0.1 milliseconds resolution. Then Map sensor is used to modify fuel under boost. Notice how there is no fuel if there is no boost. This fuel is calculated as % boost compensation.

Related Links

Tuning

Injector Wiring


Injection Type

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Injection Type

This setting will allow different methods of fuel injection. The firmware in the ECU will blank out the methods that are not adjustable. In some firmware a refresh will be forced to reshuffle GP outputs or cancel an illegal setting.

Batch Injection

This method all the injectors are pulse at the same time. It is not good practice as the cylinders does not get the fuel under the same conditions or injection angle, and is poor on power and economy. Spitronics programs does not use the feature unless for specific tasks.

Split Batch Injection

This method will pulse two sets of injectors 180° apart from each other. It is used where the trigger has even pulses and no cam signal is present. It is used on the standard systems where budget is of importance. For a 4 cylinder, the injectors are paired so that each cylinder gets fuel under the same condition or injection angle.

Split Seq 2x Inj Per Driver

This method will pulse two injectors connected per driver for the two cylinders that moves together. There are up to 4 drivers in the sequence. This means it can do up to 8 cylinders in split sequential mode. The injectors will pulse once per revolution and the injection time on the software will be divided by 2. With other words for each revolution only half the calculated fuel is injected. This method does not require a home pulse and is the popular choice. There is very little difference in power and economy to a full sequential system. Note that driver sequence is not cylinder sequence. You need to wire according to your engines firing order. See the drawings for this.

Split Seq 1x Inj Per Driver

This method will pulse one injector per driver. There are up to 4 drivers in the sequence. This means it can do up to 4 cylinders in split sequential mode. The injection time on the software will be divided by 2. With other words for each revolution only half the calculated fuel is injected. This method does not require a home pulse and is the popular choice. There is very little difference in power and economy to a full sequential system. Note that driver sequence is not cylinder sequence. You need to wire according to your engines firing order. See the drawings for this.

Full Sequential Injection

This method will pulse one injector per driver. The injector will pulse once every two revolutions and it will inject all the fuel calculated on the software. Here a cam pulse or home signal is required to sink the injectors with a certain stroke one the engine. If there is no home pulse it will still do full sequential injection, but stroke phasing may vary from start to start. Note that an engine is normally started in split sequential mode and then goes over to full sequential after 500 rpm is reached or when a home pulse is established. This helps for faster starting. This feature can only be used on 4 cylinder engines. Note that driver sequence is not cylinder sequence. You need to wire according to your engines firing order. See the drawings for this. Tip: if you don't have a home pulse set injection angle to inject just after the intake valve has closed.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or fill cylinders with fuel which may bend conrods.

Related Links

Injector Wiring


Throttle Selection

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Throttle Selection

This setting is developed to use a MAP signal on multiple throttle body engines. The problem with them is there is no intake plenum where the vacuum could be measured. The vacuum signal only makes a spike when the valve opens. This spike is also there only once in two RPM's. This makes it important to read the signal on crank degrees when the vacuum signal is present. This setting is only available for gear type triggers as low as 12 teeth.

Single

Most engines have one throttle and an intake plenum where a map sensor is used. The map signal is read 2 or 3 times per revolution. It makes for a fast vacuum signal response. The map teeth can still be adjusted here as there is a small amount of pulsation in the intake plenum.

Multiple

To use this method a crank gear of min 12 teeth is required. The MAP sensor is only connected to cylinder 1 or the cylinder that shares the crank degrees on movement. With this feature the MAP sensor is read once per two RPM's when the vacuum signal is present. This makes for a slow response that may cause flat spots during blip. This however can be cured with the accelerator settings. One requirement is that the throttles are properly balanced as only one's vacuum is measured. The map teeth setting here is very important. When the engine idles it is adjusted to read the best vacuum. The more teeth on the crank gear the finer adjustment could be made to find the sweet spot. This sweet spot on the vacuum signal is around 90° after TDC. For a 36-1 gear 90° would be 9 teeth.

Related Links

Tuning


Injector Trim

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Injector Trim

This feature allows the tuner to trim each injector individually for the ultimate performance. This is done by individual Lambda or EGT sensor on the exhaust runner to measure individual air fuel ratios. It is only selected Orion2 firmware that has this feature.

Trim Count

This is the number of drivers selected by the tuner. The Orion2 has 4 injector drivers and can work full sequential for 4 cylinders. A setting of zero will disable this feature and free up valuable microprocessor time.

These tuning blocks allow the tuner to adjust the register from 90.0 to 110.0 % for each cylinder. Adjustments can be made in 0.5 % resolutions.

This block is to clear all the registers to 100.0 % to start with. First tune the engine is as good as possible, then do minor changes here to calibrate the injectors. A tip is to use the middle average of the injectors ant tune to that. Example if the injectors differ by 10 % between high and low. Then use the middle vale and some will be 5% high and some 5% low.

Related Links

Tuning

Injector Wiring


Injector Driver Outputs

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Injector Driver Outputs

On Orion2 with Hyperspace 3.6 Software the Injector drivers are now also displayed. This will indicate how many drivers are allocated to Injectors and will change according to Injector Type setting. This will allow the installer to do a printout of the drivers after setting up his unit.

Note! This is the sequence of Injector Driver firing and not actual firing order. See the wiring diagrams on that.


Sensor Settings

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup >

Sensor Settings

See the sub folders for explanations.


Active Sensors

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Active Sensors

This block lets the tuner select the different sensors that he requires for his application. Not all the sensors are used but each one has different features that makes the engine perform at its best. If a sensor is not used, leave the block unchecked. This will free up valuable microprocessor time. Also make sure the wiring to that sensor is properly isolated as there is power on the leads that could short circuit and damage the ECU as a result. Some of the sensors cannot be altered or will be forced on by the firmware.

Calibration

Some of the inputs can be calibrated by clicking on this calibrate button next to it. This allows for a wider range of sensors to be used and calibrated in the software.

Warning

This warning sign at certain critical settings will change wiring connections on the device. Do not change them in a working application. You could accidently connect a coil or injector to a GP algorithm which may damage the driver or coil or fill the cylinder with fuel. If you do change the setting a warning will pop up reminding you of the hazard.

All Critical settings will be saved separately in the Orion2 which means when you load a map they will not be changed. Except if you press the Clone button. Critiacal settings can only be altered on a live device or with the clone function.

See the sub folders for explanations.


TPS

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

TPS Sensor

This sensor indicates to the ECU what the driver wants to do. It is also used for many features in the ECU, such as fueling, accelerator pump, idling control, fuel cutoff, cam control, automatic transmission control, etc. It is possible to control the engine without this sensor but with limited drivability. If there is a TPS sensor on the engine, rather connect it. If not, un-select the check box and isolate the wiring.

For the ECU to operate correctly this sensor needs to be calibrated. Note: When pressing the throttle while calibrating, the Fuel Prime function may squirt some petrol on the cylinders. You may disconnect the P2 and P3 connectors so that these functions will have no effect.

Click on the Calibrate [image] button left of the TPS check box and do the following procedure:

The TPS value must increase with throttle depression. If it is decreasing, click on Polarity to select Negative. This feature is normally used where the original ECU is still connected and wiring cannot be altered. In this case you connect only the ECU TPS signal wire to the OEM signal wire. Do not connect the ground or 5-volt signal wires but isolate them to prevent shorts. Now click the Calibrate button. The current TPS value will be written into the two blocks Min and Max.

Press the fuel pedal in completely and release the pedal completely. The Min and Max values will be indicating the range of the TPS. Click the Save button. You may now test the TPS signal by pressing the pedal in and releasing it. The TPS real time value should operate from 0 to 100%. Then click on the 'Save to ECU' [image] button to make the changes permanent.

Show Graph

This checkbox will enable the TPS compensation graph [image] . With this graph it is possible to add fuel % with the TPS position. It is handy to enrich the fuel mixture at full throttle conditions. There is no timing compensation for this graph.

Related Links

TPS Sensor Wiring

Error Codes


MAP

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

MAP Sensor

This sensor measures the MAP (Mean Absolute Pressure) in the intake plenum. This is the main sensor for the ECU to calculate the fuel amount which is injected into the engine at different conditions and load requirements. This sensor, however, does have its shortcomings when it comes to engines with overlap cams where the intake vacuum falls away at low RPM's. Then the ECU need to rely on other type sensors like TPS or Mass volume in conjunction to air temperature, altitude and RPM's. For multiple throttles this sensor also is inadequate but there is a feature that the ECU can use to remedy this. (See multiple throttle bodies.)

This 'calibrate' button will only appear when the custom sensor is selected.

Only custom sensors can be calibrated. Click on it to adjust calibration.

If you click calibration this block will appear. The offset value will change the MAP reading. Adjust it to read the same as the barometric pressure of your altitude above sea level. Note: Remember to take temperature into account.

The Filtered checkbox can be used to smooth an erratic map sensor signal. It will average the current sample with the previous sample. The down fall is that it may create a minor flat spot under blip conditions. This needs to be corrected with the accelerator pump feature.

The sensor must to be set up correctly by selecting the Type and range under Engine Configurations.

Calibration is done in the firmware.

If the sensor is not used, uncheck it to free up valuable processor time.

Related Links

MAP Sensor Wiring

Error Codes


Altitude Tuning

Help > ECU Engine Managment > ECU Tuning >

Altitude Compensation

The ECU can compensate for altitude differences in pressure. It will adjust the fuel mixture and the timing in relation to altitude. Orion has an optional On-board 3 Bar MAP sensor which can be used for altitude. This is optional and has to be ordered separately. With Map/Alt Swop the 2 sensors can be swoped. Then the 3 Bar sensor on board is used as a Map sensor and an external 2.5 Bar sensor could be connected in the Map sensor's place for finer accuracy.

Select Altitude and click on Compensate. The Altitude sensor is pre-calibrated. You do however need a 2.5 Bar MAP sensor for external sensors unless the 3 bar sensor on board is used. The real time bar below will indicate the actual altitude pressure of your surroundings.

Fuel Compensation

This feature works differently for the different tuning methods. Below are descriptions of operation in each method.

Graph Map tuning - Normal Aspirated

This scaling feature is only for normal aspirated engines where the map range is set at 1.1 Bar. The ECU will calculate altitude in the background and rescale the MAP sensor value so that the map bar always reaches full scale at all altitudes. This is important because the normal MAP sensor will not reach the maximum scale on the tuning graph at high altitude. Put another way, full scale on the graph will always be compared to available altitude pressure outside.

In a typical Fuel Load graph for example, an engine that was tuned at sea level where the MAP sensor reached 1 Bar, will only reach 0.83 Bar at around 2000 meters above sea level. The full load fuel compensation that was set to be richer above 0.9 bar will not be reached. The ECU will then not have the advantage of the full curve that was mapped out during tuning.

Engine tuned at sea level up to 1 bar only reach 0.83 bar at 2000 meter. Note: The bar will not pass the red bar and take advantage of the WOT rom compensation graph or the extra hump in the full load graph above 0.9 bar.

In the above example the injector time was 11.9 milliseconds.

When compensation is checked by the ECU will it compare the available air pressure in the air cleaner with the actual pressure in the intake manifold. It will then scale the MAP sensor to read 1 bar when the value reaches the same value as the altitude sensor. (See the example below.)

The dark blue bar is the altitude value and the olive bar is the map value. Note how the MAP sensor is now reading 1 bar at 2000 meter.

Notice the difference in fuel due to the hump on the right hand side. Now the ECU still has the advantage of the graph profile even at high altitude.

Matrix Map - Normal Aspirated

The same system applies for the Matrix Map tuning as Matrix Graph tuning. They both operate the same way except that it is a matrix. Read the above section for explaining purposes.

Graph Map tuning - Boosted Engines

In this tuning method altitude compensation is disabled. The reason is that you are already using a MAP sensor and measuring the manifold pressure. Fuel and time is set accordingly and does not require additional altitude compensation.

TPS Matrix tuning

This is for normal aspirated racing engines where TPS versus RPM fueling is used. The altitude sensor becomes very important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel in ratio with altitude pressure differences to ensure a more accurate fuel mixture. For example, 10% less altitude pressure will result in 10% less fuel. The TPS versus RPM tuning is normally for engines with throttles or poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will be tuned with the reduced fuel, so that when you decent to sea level, the fuel will be added.

Graph MAP with TPS Matrix tuning

This is for boosted racing engines where TPS versus RPM fueling is used with a boost pressure graph. The altitude sensor becomes very important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel in ratio with altitude pressure differences to ensure a more accurate fuel mixture. For example, 10% less altitude pressure will result in 10% less fuel. This altitude compensation is done on the TPS matrix and then is compensated with the boost graph. The TPS matrix and boost graph tuning is normally for turbo engines with poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the reduced fuel so that when you decent to sea level, the fuel will be added. For detailed explanation see the Graph MAP and Matrix TPS Tuning section.

Timing Compensation

This feature is available and operates the same in all the tuning modes. If you don't want it to affect your timing, make the value 0.

Under Timing Settings set the Altitude Comp to 3 degrees per 1000 meter.

With timing compensation, the ECU will gradually add timing with increased altitude. The tuner can select the number of degrees' advance per 1000-meter increase in altitude. In this example we used 3 degrees which results in 1 degree for every 333 meters. Note: This will advance the calculated timing in total. There are no extra graphs to tune.

You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the added degrees so that when you decent to sea level, the timing will be retarded.

Related Links

Altitude Sensor Wiring

Error Codes


MAP/Alt Swop

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

MAP_Alt Swop

This function is for Orion to swop the external MAP sensor with the onboard Altitude sensor. This will enable the tuner use the On-board 3 bar sensor for a MAP sensor instead of an altitude sensor. It will also allow the altitude sensor to move to the external input.

Note: The external altitude sensor must be a 2.5 bar sensor.


Water Temperature tuning

Help > ECU Engine Managment > ECU Tuning >

Water Temperature tuning

The water temperature sensor is used mainly for cold start compensation with fuel and spark timing graphs. There is however a couple of functions that requires compensation with temperature like idle control, accelerator pump, prime pulse etc. Neglecting to wire the sensor in may result in the engine not being drivable when it is cold. All fuel injected engines have water temperature sensors mounted in the thermostat housing area. Not all are compatible with the Spitronics ECU but there are aftermarket sensors that can be fitted. Spitronics ECU's use a 2K NTC (Negative Temperature Co efficient) resistor. It is the standard under water sensors for most engine manufacturers. It has a fixed calibration curve which is programmed in the firmware and it cannot be altered. It can however be slightly calibrated by giving it an offset percentage. The normal setting is 100%. Click on the calibrate [image] button left of the Water sensor check box.

Reduce or increase the value to slightly shift the reading value. Do this at the critical temperature for instance where the fan must come on or off. If the error is too large you may need to replace it or get the correct sensor. These sensors are measured at 25°C with an ohm meter to see which type it is. If you have the wrong type you may need to change the sensor to a 2K sensor. Save to ECU [image] button will make the changes permanent.

You may be required to do adjustment tuning in the winter and then in the summer. Remember to enable it on the active sensors page. When the engine is used in the winter, you may advance the timing slightly as the fuel burns at a slower rate. The fuel must be increased till the engine runs properly. Especially for racing fuel It may even require a richer mixture for these conditions. In the hot engine condition, you may retard the timing and increase the fuel. A richer mixture helps to cool the engine down. The thermostat controls maximum temperature so it may be difficult to tune. Nevertheless, put some extra fuel and less timing in the graph.

Water temperature correction can only be done in the morning when the engine is at its coldest. To set this graph, start with the example below. Now start the engine and let it idle. Adjust the AFR to be on the rich side. You may later have to tweak prime pulse, start enrichment and accelerator pumps to get a smooth pull off and start when cold.

Water Temperature Graph

Related Links

Water Temperature Sensor Wiring

Error Codes


Air Temperature tuning

Help > ECU Engine Managment > ECU Tuning >

Air Temperature tuning

The Air temperature sensor is used to compensate with fuel and spark timing for density changes in warm or cold air. Neglecting to wire it in may result in the engine detonating when it is Hot. Not all engines have air temperature sensors mounted on them. Most sensors were incorporated in the MAS meter. This sensor deviates plenty between manufacturers so it is difficult to cater for all manufacturers. However, it can be installed and utilized effectively. Spitronics use a 10K NTC (Negative Temperature Co efficient) resistor. It has a fixed calibration curve which is programmed in the firmware and it cannot be altered. It can however be slightly calibrated by giving it an offset percentage. The normal setting is 100%. Click on the calibrate [image] button left of the Air sensor check box.

Reduce or increase the value to slightly shift the reading value. Do this at the critical temperature for instance where the engine is at running temperature. If the error is large you may need to replace it or get the correct sensor.

These sensors are measured at 25°C with an ohm meter to see which type it is. If you have the wrong type you may need to change the sensor to a 10K sensor. Save to ECU [image] button will make the changes permanent.

The Air Sensor is difficult to tune as you need controlled environment to do so effectively. Cold air is denser and requires more fuel and timing. You may be required to do adjustment tuning in the winter and then in the summer. The air temperature sensor is situated just before the throttle body (if installed). Remember to enable it on the active sensors page. When the engine is used in the winter, you may advance the timing slightly as the fuel burns at a slower rate. It may even require a richer mixture for these conditions. In the hot summer the engine may tend to detonate as a hot mixture burns more rapidly and the air is thinner. Then you may require to retard the timing slightly and lean out the air-fuel ratio. Remember if you tuned in the winter or summer your graph may tend to slope just on one side.

Air Temperature Graph

Related Links

Air Temperature Sensor Wiring

Error Codes


Charge volts tuning

Help > ECU Engine Managment > ECU Tuning >

Charge volts tuning

Battery and alternator voltage have a great influence on ECU systems. When an engine cranks, battery voltage can fall as far as 9 volts on cold days and when the engine is running, voltage can go up to 14.3 volts. This difference has a big influence in coil energy and injector opening speeds. So to compensate for that the Spitronics ECU's has 2 graphs. One graph is a fuel compensation graph which adds more fuel during cranking. The other is a charge time compensation graph that will act on the charge time of the coils. This will improve spark energy to help the engine start. It is not a clear cut tune as you need to put a variable power supply in place of the battery.

What you can do is look at spark quality when the engine is hot and compare it to spark when it is cold. You don't want to overcharge a coil as it may get damaged. Always a good idea on a cold morning to look at the ECU voltage during cranking. A healthy battery should crank no less than 11 volts. Below is an example of a typical graph.

Charge Voltage Graph

The blue graph adds a certain percentage to the injector time and the red graph adds a certain percentage to the charge time. This is not an easy one to tune but it is recommended to lower the values and see if the result is worse or does not make a difference in starting. Always go for the lowest values. You may also decrease the values with higher battery charge. This may help protecting the coil drivers. These graphs are interpolated.

Related Links

Relay Wiring

Power Connection

Error Codes


Lambda loop control tuning

Help > ECU Engine Managment > ECU Tuning >

Lambda loop control tuning

All Spitronics ECU's have the capability to do loop control with a lambda sensor connected. The tuner may set up parameters for lambda control and then the ECU will compensate the main air fuel ratio according to the lambda sensor in real time. This will result in the optimum mixture even if all the maps are not setup accurately or/and due to variations in environment which are difficult to tune in, such as moisture, air density etc. You need to tune the engine properly first and then activate this control afterwards.

To setup this feature, click on the Lambda and Show graph check box. If you only check Lambda, then it will display the values but not control AFR. This is handy while you do the base tuning.

Target Volts

This is the desired Stoic area where the sensor determines the best mixture of 14.7 air to fuel ratio. These narrow band lambda sensors have a voltage output of 0.1 to 0.9 volt. A voltage of 0.45 volt = 14.7 A/F ratio = 45%. Spitronics work in % as this is easier to simplify between the 1 volt and 5 volt signal. This unit can receive a wide band signal of 0 to 5 volts but the electronics for driving the sensor is not built in the ECU. It will require a separate electronic board. The ECU does not convert this volt signal in A/F ratio or lambda values as it is not required for control. There is a difference in volts for different type wide band sensors. The tuner uses an accurate test instrument to tune the engine and set his AFR correctly in real time.

Startup Delay

This will give the sensors' element time to heat up so that it can measure accurately. A normal setting here is 30 to 45 seconds. If the temperature of the engine is below 30°C, then lambda control will be disabled. When you start the engine time the sensor with a stopwatch till you can see that it measures correctly.

Control Percentage

This is the value of injector compensation. It can be adjusted from 0 to 20%. This means that if on 10%, the ECU will lengthen or shorten the injector signal by 10% to achieve stoic. Always try and tune the engine accurate in open loop and give the lambda just a little control to smooth it out. If you give it a large % and the sensor fails your engine may be out of AFR.

No. Samples

This Setting is the number of samples that is used as an average to prevent the control from becoming erratic. Because the sensor has a 0.6 seconds reaction time the ECU tends to over react. Increasing the number of samples will bring more stability to the control program.

The 3 limits

This will set the control range to where the narrowband sensor is accurate. A narrow band sensor cannot always control where a slightly richer or leaner mixture is required. The control will be active between the RPM limits and below the vacuum limit. Do not use this control at high RPM and high boost. It may be too slow to react when a mixture is lean. These settings are displayed on the graphs as short bars.

Sensor input

This input is used to select between a narrow band 1 volt signal and a wideband 5 volt signal. A wideband signal is linear and can cover a wider range of A/F measurements. It can be used for idling and high load readings. Notice that the rich and lean % change between the 2 sensors. Narrowband is inverted and wideband is linear.

Now click on the Lambda Graph [image] button.

Lambda Target Volts Graph - Manifold Pressure Compensation

You can manipulate these two graphs to alter the target voltage of the lambda sensor for control of the ECU. This means if you have a 10% increase on the graph and the target volts is on 45%, then the ECU will use 49.5% as the new target volts. Now, remember on a narrow band sensor this makes a larger difference in fuel as on a wide band sensor. Normally a car idling or under load requires a richer mixture. The top graph compensates according to load and the bottom graph according to RPM. These graphs are interpolated. Note for a wideband sensor the richer mixtures will be below the line.

When TPS Matrix is selected the ECU will use the TPS as load signal since there may be no MAP sensor.

Lambda Target Volts Graph - TPS Compensation

Lambda Target Volts Graph - RPM Compensation

This graph will adjust compensation in the RPM range. Outside the 2 limits will be no control.

When you drive the car you can set different target controls to obtain different AFR ratios to cater for load. For racing vehicles wideband AFR gauges are recommended with the signal connected to the ECU.

Related Links

Lambda Sensor Wiring

Error Codes


POT Input

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Tuning POT

This POT is a Potentiometer or variable resistor that lets the tuner or driver change settings in real time while the ECU is operating. It is a device that connects to the communication port plug for on one of the universal I/O. Note that other features will be sacrificed when you use this input. The following functions can be activated for it.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or components on the engine.

See the sub folders for explanations.

Related Links

Tuning POT Wiring

Error Codes


Injector

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > POT Input >

Tuning POT Injector

Injector setting will change the injector time with 10% richer or leaner in this example. The POT needs to be in the middle to have no effect on current fueling. This is handy in a race car if the driver has an A/F Ratio gauge installed. Then he can manipulate fueling and remember under which conditions he has to lean or richen the mix. Then he can make adjustments on the graph at a later stage.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or components on the engine.


Timing

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > POT Input >

Tuning POT Timing

Timing will advance or retard the ignition timing by 5 degrees in this example. The POT needs to be in the middle to have no effect on current timing. It is useful in racing for tuning time while driving. Ensure that the driver has a knock sensor and light fitted to the engine.

NB! This is a Critical setting that alters wiring connections. Do not change it on a running vehicle. It could damage drivers or components on the engine.


Launch

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Launch Control

· The Launch Control feature will spin a turbo to higher RPM's while the vehicle is stationary. This is done by adjusting the RPM limiter, enrich the fuel mixture and retard the ignition timing. This will create boost pressure so that when the driver launches, there will be no turbo lag.

· Launch Recover Delay will bring the launch limiter slowly back to normal revs. This will improve traction during pull off.

· It will also activate RapidFire for audible limiters of choice. This feature will keep the engine on power while spinning and make exhaust sounds like a machine gun.

Launch

The Launch parameters are implemented in different ways to suit the driver. These Launch settings will only be implemented the moment engine revs reaches Launch revs minus 500RPM. Example: If the limiter is set as 5000RPM then the timing and fuel compensation will only start above 4500RPM. This will help the engine to rev up to launch effortlessly. Should the engine revs go above 5000RPM the fuel or spark will be cut to limit the engine from over revving. If the engine limiter is set to Soft or Hard Cut, then fuel will be cut. If it is set to Spark Only, then the RapidFire feature will come in place and only spark will be cut.

See the Product Hardware description for different wiring options for the different activation methods like Clutch or TPS 90% options.

There are 2 methods to implement the Launch feature. One is with hardwire switches and the other, semi-automatic. For both methods set the Tuning POT selection on Launch.

Method 1 (Switch or Clutch and switch)

Select Clutch and set the desired RPM limit. This is variable depending on the grip at the racing track. Timing is set from 0 to 10 degrees depending of the turbo characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which will spin the turbo.

Now to activate this feature. If you have only wired the dashboard switch you only need to press the switch and press the accelerator pedal. The moment you need to launch just release the switch with the clutch.

If you have wired the dashboard switch and the clutch pedal switch with resistor combination, then press the clutch in to make the clutch pedal switch, press the dashboard switch once and launch is activated. No need to keep the dashboard switch pressed. Press the accelerator. The launch parameters will be activated. The moment the clutch is released the launch switch will break and launch is deactivated. To activate this feature again you need to repeat the procedure. This feature lets the driver concentrate on his pull-off and free his hands for other tasks.

Method 2 (TPS 90% - Semi-Automatic)

With this method there is no need for a clutch pedal switch. You do however need to install the dashboard On/Off switch or the Tuning POT. This method requires the driver not to press the pedal over 90% during launch activation. Pressing it deeper will deactivate launch to normal settings. The driver may need to practice this. He may also use a GP output to switch a light on at 80% TPS to ensure that he does not press it too deep. Both methods require the engine to rev lower than 3000RPM before activating the launch feature for the next launch. This will prevent the feature from activating during gear shift.

With the Dash Board switch do the following settings:

Select TPS 90% under Launch Deactivation. Set the desired RPM limit Timing and Fuel Enrichment.

Now to activate this feature, put the switch to 'On' position. Now press the accelerator no more than 90%. The launch parameters will spin the turbo. When the driver releases the clutch he also presses the accelerator 100%. This will deactivate the launch feature. To activate this feature again, the revs must be lower than 3000RPM. Note: To deactivate this feature put switch off.

With the tuning POT do the following settings:

Set the desired RPM limit to 0. This will indicate to the ECU that it must use the POT value to calculate a RPM limit value. Set the desired Timing and Fuel Enrichment.

Now set the POT register to the maximum allowable launch RPM. Example: 55 means 5500RPM. This will set the POT maximum clockwise value as 5500 RPM.

This feature is useful as different race tracks give better traction and allows for higher launch PRM's. To activate this feature, the driver simply presses the clutch and applies the accelerator till just below 90%. Now he adjusts the tuning POT till he sees the desired RPM on his rev-counter. When he releases the clutch he presses the accelerator 100%. Launch will then deactivate. This feature will activate automatically once the revs falls below 3000RPM because it does not have the Dash Board switch. If you want to cancel this feature set the launch revs 500RPM above the normal engine limiter. Then turn the POT fully clockwise. You can make increments on his tuning POT to calibrate it to his engines' revs.

Launch Recover Delay

This feature allows for a slow increase in Launch limiter RPM when the clutch is released. It will help with traction because then engine power is slowly returned to normal. This value set can be adjusted in 100 milliseconds resolution. A value of 30 will result in 3 seconds delay to rise 2000 rpm. Ex. If launch rpm is 4000 and you release the clutch, then the limiter will increase over 3 seconds to 6000 rpm. Another example if the value is 23 then it will take 2.3 seconds to raise the limiter from 4000 to 6000 RPM. It can be used during shifts to higher gears by touching the launch button. The rise time will be the same for all the gears.

For this feature to operate Tuning POT must be set to Launch and Launch Activation must be set to Clutch so that a launch button can be used.

RapidFire

This feature will randomly spark coils when you go above the Launch Limiter for up to 500 RPM above it. Example if the launch limiter is set at 5000RPM, then it will be active from 5100 to 5500 RPM. The advantage is that the occasional adjusted spark will ignite the fuel in the exhaust making a sound like a machinegun. To get this feature to work you need to put the engine limiter on Spark Only. This is ideal for the spinning guys when you want to keep power at a maximum. Note that your exhaust and silencers must be modified to accommodate the explosions in them. Normal systems will be damaged.

A value of 1 in the RapidFire block will then spark once in 2 rpms. A value of 2 will spark once in 4 rpms and so on till a maximum value of 10. The spark will be alternated so that each cylinder gets a spark in turn to clear the plugs from getting wet. Always go for the lowest count that makes the desirable effect. If the engine revs go to 5500 in this example, then increase the RapidFire setting to minimize engine power.

Related Links

Launch Options Wiring

Error Codes


Transmission Retard

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Transmission retard

This feature is for automatic transmissions to retard the engine timing during gear shift. This will make the shift smoother and protect the transmission. The launch control circuit will be used and this system will disable launch control.

Set the tuning POT on.

Set the POT on Retard.

Set the RPM limit on zero. Set the launch control timing on 5 to 15 degrees depending on the feel of the shift in the transmission. Launch deactivation must be on Clutch. Fuel enrichment is not used here.

Now connect the relevant wires from the TCU to the ECU. When the TCU makes a shift it will put a negative driver on. It will connect to the POT input of the ECU. The POT real-time bar will be high and the moment of shift it will go low, activating the retard feature.

Related Links

Error Codes


Idle Control

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Idle Control

The ECU has the feature to control different types of idle motors found on an engine. Before adjusting the idle control settings, you need to select which type of valve or stepper is on the engine. Note: The stepper types idle motor (4 to 6 wire), require the external electronic driver. Also note that the electronic unit differs between the 4 Wire bipolar type motor and the 6 Wire common supply type motor.

Type Selection

The Type Selection can select between the two-wire spring-loaded Idle Valve, the three-wire spring or non-spring loaded Dual idle valve, the Bipolar Stepper motor or common supply Stepper motor. Stepper motors do not use the Low Limit and High Limit settings as they keep their position when there is no signal present. If there is no idle control, select 'Not' used to free up valuable processor time and general purpose outputs.

Idle Valve

Two wire spring loaded idle valve only use one output from the ECU.

Dual Idle Valve

Three spring or non-spring loaded idle valve two outputs from the ECU.

Stepper Motor

Four or Six wire idle valves operate with a Spitronics Type 1 or Type 2 stepper motor controller, use one output from the ECU.

Settings

Drivers

This indication will show the installer which wires to connect on which outputs of the ECU. Driver 2 is only used for the dual valve to close. Note that positive and negative drivers may be used for idle control. If a valve is used, then make sure the Diode across it is wired correctly. (See the wiring diagrams and general purpose priority spreadsheet for correct installation.)

RPM

This setting is the target RPM's when the engine is on running temperature. When it is cold the ECU will automatically increase engine RPM's with up to 300 RPM's. This is calculated according to fuel enrichment on the water compensation map. Every 15% will increase 100 RPM on the Idle control.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve with this %. Note that on stepper controls it will activate 25% every time the key is switched on. If you don't start it, it may idle high at first then come back to idle target.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the air conditioner on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the solenoid against the spring in the idle valve so that the valve starts to open immediately when the ECU starts increasing the value. It can also be used to set minimum idling RPM for throttle valves that closes completely. To set the value start with a larger % and decrease until the desired idling RPM is reached.

High Limit duty cycle

This setting is used to limit the maximum idle RPM's. No need to open the valve more than necessary. It also allows for the use of large valves in smaller engines. Make sure that when the engine is cold, it can still lift the RPM up to approx. 1500 RPM. This can be tested by entering a large Idle RPM value and limit the ECU from increasing it too high.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a minimal amount of revs with slight throttle.

Related Links

Idle Control Wiring

Idle Control Tuning

Error Codes


Anti-Lag

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Anti Lag

The Anti-lag function will help to keep the boost pressure up when decelerating in corners on the race track. This function will use the launch control settings which will add fuel and retard the timing. The correct installation requires an EGR valve to bypass boost pressured air from the turbo before the throttle body, into the exhaust between the engine and turbo. The extra fuel with this air will ignite and the pressure will cause the turbo to spin creating boost. If the valve is not installed, then the min throttle setting must be opened slightly as to let air pass through the engine to burn the excess fuel. You may need to retard the timing further after TDC to prevent the engine from making power.

Settings

Enable the feature and set the minimum RPM setting. This RPM setting is the limit which will disable the function. If the engine revs fall below this value normal fuel economy cut will resume. During racing the driver will gear down keeping the engine revs high.

These two setting will activate the Anti-lag. When the boost pressure inside the intake manifold falls below the Vacuum fuel cut off value and the throttle position is below the TPS idle cut off value. When the boost pressure goes above the Vacuum fuel cut off the feature will be deactivated and normal functions will resume.

To disable the normal Econo Fuel Cut off function make this value higher than max RPM.

The launch settings Timing and Fuel Enrichment are also used for the Anti-lag feature. If it is activated, the timing will be retarded to the launch timing and the fuel will be enriched to improve burn pressure in the exhaust to spin the turbo.

For valve wiring and output connection on the ECU consult the specific firmware instructions and drawings.

Related Links

Error Codes


Turbo Settings

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup >

Turbo Settings

See the sub folders for explanations.


Launch Control

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

Launch

The Launch control feature can be used for Launch control or to retard the timing during transmission shifts. But not for both. The driver will have to set it up for one of them. These features came later than the hardware so plans were made to accommodate them in this hardware. Note: This feature is only available on specific firmware. ask your dealer on it before you buy.

See the sub folders for explanations.


Engine Limiter

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

Engine Limiter

This block has a few protection features. Setting them may prevent the driver from damaging the engine in normal and racing conditions.

Boost limiter

This feature will cut the injectors clean if the MAP sensor detects a manifold pressure that is higher than the set value. It is not a boost controller but it is to protect against boost controller or waste-gate failure. It can be adjusted in tenths of a bar resolution. The spark will not be cut.

Over temperature limit

This feature and the next one will protect the engine against over temperature. The injectors will be cut until the revs fall below the next setting.

Temperature RPM limit

This is the maximum limp mode RPM's when the engine is over temperature. If it is due to a burst hose it is better to switch off before the engine is damaged. If it is due to low water the lower revs will help to cool it down instead of disabling the engine.

RPM limit (>=60°)

This feature will prevent the engine from over-revving under normal temperature conditions. It can be adjusted in 100 RPM intervals. RPM limit can be achieved by three methods.

Soft

This mode will retard the timing in three stages and then cut the fuel completely. The result will be a smooth soft loss of power. Each 100 RPM over the limit, timing will be retarded further. First retard is 15 °BTDC, then 10 and then 5 °BTDC. Then during the third stage, fuel will be cut but not the spark. This will prevent fuel from entering the exhaust and backfire there. This is the preferred method for engine over-rev limiting. Note: The engine may reach 300RPM above the set value.

Hard

This mode will cut the fuel and spark completely. It has a jerk type feel and may result in small detonations in the exhaust.

Spark Only

This mode will cut only the spark. This will give the backfire sensation when unburned fuel is ignited in the exhaust. Note: Damage to the exhaust system might occur in this method.

RPM limit (<60°)

This feature will prevent the engine from over-revving under cold temperature conditions. It can be adjusted in 100 RPM intervals. This method will only cut the fuel and is just a protection.

Related Links

Error Codes


Flat Shift

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

Flat Shift

This feature will momentarily cut the fuel or spark or both for a pre-set time during shifting. This will slow the engine RPM momentarily to ease shifting process in the gearbox. It is initiated by a negative going transition pulse of a switch, or electronics or load cell that will give an earth contact. The switch is combined with movement of the gear lever. Note: This feature is only available on specific firmware. Ask your dealer on it before you buy.

Settings

The following settings is done to activate this feature. On Orion2 the input is shared with the dual map input. This means dual map will not be able to operate on the fly. It will load a Map only at start up. Then the input will be used for a flat shift input. After that it is used as the flat shift input during run conditions. Normally an open switch will mean Map 1 is loaded when the ECU starts. Then if this contact is earthed the flat shift delay will be activated. If you want to start in Map 2 hold the switch in and put the ignition on. Then Map 2 is implemented, from there on the flat shift work as normal.

A delay can be adjusted from 0 to 350 milliseconds. Zero will deactivate the feature. Zero will disable the flat shift feature. This feature is disabled at RPM below 2000.

You may select the type of engine cut which is the same as the normal rev limiter settings. Soft will cut only fuel, Hard will cut fuel and spark and Spark only speaks for itself.

Related Links

Dual Map Switch Wiring

Error Codes


Memory Handling

Help > ECU Engine Managment > ECU Software Desciption >

Orion2 ECU Memory Handling in Ver 3.6

The Memory handling in Ver 3.6 Firmware is changed to provide more GP outputs from the unused Coil and Injector drivers. The danger before was that when different Map files is downloaded into the Device, it may override critical setup values which could damage the device or components on the engine. Now the critical values cannot be changed by loading a map. It is saved in a separate space in the flash memory. These values can only be changed by adjusting them on a connected device or by Cloning a Map or Tune file into the device.

Below is a block diagram of the map memory and how map data is handled.

The memory is divided into 3 categories. Map setup data, Map Graph and Matrix data and Critical setup data. Below is a description of the different memory spaces:

Map Setup Data

In this block all the normal engine and tuning settings are saved. If you load a map file, this setup data can be overwritten or it can be retained by selecting or de-selecting the Save Setup Data. In most cases this check box is left on.

Note. This setting must be selected before opening the map. Once you open a map file then this setting is ignored as it is now part of the setup. There are values like sensor calibration that must be recalibrated if you load a new map.

Map Graph and matrix data

This memory house all the graphs and matrix data. This influences the actual tuning of individual engines. Graphs and matrixes may also be exported and imported individually so that you can add a previous tuned feature from one map to another. This is handy if you want to try a different algorithm for example between Graph and matrix.

Critical I/O setup data

The memory holds settings that will alter the inputs and outputs connections of the device. They are part of the normal setup data but are critical not to change during a map load function. This memory can never be overwritten by loading a map. One way to change these settings is online with the device connected, and then save it to the device. The other is by the Cloning function. So be careful if you load a map on a working engine not to use the clone functions. All these settings are protected by an indicator and warning message.

The ECU Critical settings are:

Save Setup Data

This setting determines if the setup block will be overwritten or not. Checked on means it will be overwritten. It does not have a warning because it is not dangerous if it is selected on a live engine.

Dual Map Selection

This setting will effect which map data is loaded at startup. It may also be used as a Flat-Shift input or Coil 5 Driver Output. Setting it on dual will influence the wiring connections.

RPM Output pulses

This setting is used by other devices like a tachometer or TCU input for RPM and should not change by loading a new map.

Coil Combination

This setting is critical because it could free up drivers that may be used for GP outputs. It will effect wiring connections. Having this wrong could damage Drivers or coils on the engine.

Coil Driver Trigger Combination

This setting will move coil outputs between HV Negative Drivers for Basic Coils or Positive Drivers for Smart Coils. The drivers have 2 or 3 functions and care must be taken to set it up before you connect the ECU to the engine.

Injection Type

This setting is critical because it could free up drivers that may be used for GP outputs. It will effect wiring connections. Having this wrong could fill a cylinder with fuel resulting in a bent con-rod.

Idle Control

This setting effects wiring connections and is combined with GP outputs. Some idle valves require 2 outputs from the ECU.

Tuning Pot

This feature controls the way the engine handles the Turbo or tuning of Fuel or Timing. It does not affect wiring but can be dangerous if it controls fuel or ignition timing.

Cam Control

This setting effect wiring connections and is combined with GP outputs.

Anti-Lag Control

This setting use a driver to activate a bypass valve. It is shared with other outputs and inputs.

Flat Shift Control

This feature shares the Dual Map selection and Coil Driver 5 output. It will effect wiring connections.

Duel Injector Control

This setting effect wiring connections and is combined with GP outputs,

Map Lock Password is also saved in this block. If you want to clear a password, you need to load a map and Clone it into the device. See the Clone function next. Note that all your critical values will be changes so you need to set the device up from the start. Disconnect all the output connectors as you may damage drivers or components on the engine. See locking a device below.

Cloning

Cloning means copying a device map exactly onto another device. This process will save all the settings including the critical setup data exactly as the device map that was saved. This is handy for builders that use the same engines and drivetrains in different builds. It is also handy to load a startup map of a similar engine in the device to assist new customers. It will also load the map in all the relevant maps for systems with Dual or quad maps.

TPS Calibration

This calibration is now also saved in the critical memory.

Related Links

Locking a Device


Data Maps

Help > TCU Transmission Management > TCU Software Desciption >

Data Maps

Data Maps or Tunes is the user settings of a device that can be saved as a file on a PC. This can be used later as backup in case a device failure or can be used to clone devices for similar applications. This section describes how to save, load and convert maps for other devices of the same product firmware.

See the sub folders for different functions.


Map Save to PC

Help > TCU Transmission Management > TCU Software Desciption > Data Maps >

Map Save to PC

First connect the device to the Hyperspace software so that it is live. To save a map from a device on your hard drive you can use the following methods.

Go to file menu and click on Save As.

Click on the Save Map file button on the top application toolbar.

Now type in a file name and folder where you want to save your data map. A good filename would be device type then engine type then version then description.

Your Map is now saved.


Load Map from PC

When you open a map from the hard drive the software will go offline. If settings in the device was not saved the software will ask you to save or cancel. Again there are 2 ways to load a map into the software. If you have opened the map recently then you can click on Open Recent which will bring a list from your last maps.

Go to file menu and click on Open.

Click on the Open file button on the top application toolbar.

Select your map from the hard drive.

The software will open the map and you can now work offline. If you want to change values, you can save it offline by repeating the Save Map function described in the previous heading.


Download Map into Device

Help > TCU Transmission Management > TCU Software Desciption > Data Maps >

Downloading a Map into a Device

To load a map into a device you first need to open one as described in the previous Load Map from PC section. Now you need to click on one of the 3 connect buttons.

Tuning Menus and Connect.

Connect Button on Top Toolbar

Connect button on left bottom information bar.

The selection block below will appear.

If you do not want to save the map and want to go live on the device again then press the Upload to PC button.

If you want to save the map in the devise, click on Download to Device.

This button will not save critical setup values. If the Save Setup data of the device was not set to On while it was live, then no setup values will be saved.

This is handy if your setup is right but you want to load matrix and graph data only. Note that it does catch you out sometime if it is not set.

If you want to Clone the Device, then press the Clone button called Dolly.

This will also load the critical values with setup and graph data end make the device exactly the same as the map of the device it was saved from.

NB! It is important to disconnect the output harnesses from the device and go through the setup before attempting to power it in the application. The warning below will appear to remind you.

If you want to Close and Exit without saving press this button.


Import and Export Graph or Matrix

Help > ECU Engine Managment > ECU Software Desciption > Data Maps >

Import and Export Graph or Matrix

Spitronics devices can be tuned in two different algorithms on fuel and timing. There is a graph tuning method and a Matrix tuning method. To combined different maps, we implemented and Export and Import feature. This will let you add a graph or matrix only of another Map into your Current Map without retuning all the other graphs or matrixes. This is also very useful to load a standard start up matrix and then tune it on the dyno.

First you need to export the graph or matrix from the saved map.
Open that map in offline mode. Right click on the graph or matrix. Click on Task and Export to Excel.

Select a file name and save the data to your Laptop.

Now open your current map or connect to the Device. Again go to the same Graph or Matrix and do the same routine except this time click Import. Select the file you saved and import it into the new map.

You may save your current matrix or click cancel and the new one will be imported. The LED will flash yellow and you can save to device or file to make the changes permanent.

Note that you will require Excel on your PC. You may also open the file and edit it in excel.


Recover Maps

Help > TCU Transmission Management > TCU Software Desciption > Data Maps >

Map Recover Feature

AutoSave

As a backup function the Hyperspace software will auto save maps periodically. The interval time could be set in the File save settings.

To open an Auto Saved map, click on Auto Saves.

The file name will be saved as #770010_20190104130620774.spiecu

The # indicate Auto save then serial number then date time group and extension. Find the latest map and open it. If the data seems to be your last work you may load it into the device.

Device Save

Each time you save to a device the software will also save a copy in the Device Save folder. The latest file will be your last saved map in the device.

To open a Device Saved map, click on Device Saves.

The file name will be saved as ~41162132_20181219171134827.spiecu

The ~ indicate Device save then serial number then date time group and extension. Find the latest map and open it. If the data seems to be your last work you may load it into the device.

Folders

These file can also be found in the folder where your Hyperspace was saved.


Convert Maps

Help > TCU Transmission Management > TCU Software Desciption > Data Maps >

Convert Maps

Due to the progress in development from Spitronics, file names and maps may also change. For your convenience we kept the file structure from Galaxy to Hyperspace the same in Ver 3.5. this is to make the transition easy. Galaxy has been discontinued and Hyperspace is the new platform for development.

On Galaxy a map file had an extension of .galaxy which meant there was no distinction between ECU or TCU files.

With Hyperspace the map extensions are .spiecu for ECU files and .spitcu for TCU files etc.

To convert a Ver 3.5 Map from Galaxy to Hyperspace simply change the extension.

To Convert a Ver 3.4 map to Hyperspace is not so easy as Hyperspace Ver 3.5A has a lot more settings tan the old Ver 3.4 firmware. Here you will have to set the Air and Water temperature graphs correct again and then all the other settings that Ver 3.4 did not have. Best is to open that map offline in Galaxy and then also connect the Device to Hyperspace. then load the same map into the device with hyperspace. Then compare your old settings and new ones to get it as close to as possible. Hyperspace Ver 3.5.5 and higher will allow you to open Galaxy files of Ver 3.4.

Alternatively, you may ask your Spitronics dealer to assist you with the file conversion by sending them the Ver 3.4 map file.


ECU Startup Procedure

Help > ECU Engine Managment >

Startup Procedure

This procedure is very important as this is a universal ECU that can cater for many combinations of engines. Setting incorrect values here may damage the ECU or some of the engine components permanently. The Maps supplied by the agents are a guideline and not guaranteed to be set up correctly for your application. It is your responsibility to make sure it is setup correctly. Common failures are short circuited wires in the installation. Coil drivers are set incorrectly for internal or external coils, resulting in damaged coils or ECU drivers. Injectors stuck in open condition causing fuel to flood a cylinder and resulting in bent connecting rods. Too larger fuses resulting in damaged electrical components.

See the sub folders for explanations.


Preperation

Help > ECU Engine Managment > ECU Startup Procedure >

Engine and system preparation.

Before connecting the ECU check the following:

1. Install new spark plugs on engines that was standing for a long time.

2. Service and test the injectors to ensure they all have the same fuel delivery and that the filters on them are clean.

3. First ensure that the installation is correct according to the Hardware Installation manual.

4. Test the electrical wiring with a multi meter according to the Installation Testing Procedure.

5. Power up the fuel pump by loosening the fuel pump positive from the relay circuit and connecting it to 12V battery positive. Check the fuel pressure is around 3.5 Bar and check for fuel leaks. Reconnect to the relay.


Connecting the ECU for the first time

Now you can proceed with the following steps. If any steps do not correlate with the ECU operation, stop and look for the faults. Ensure that the ECU is earthed!!!

1. Remove all the fuses. If it is an easy install harness with a common fuse on the main lead then disconnect the coils, injectors, fuel pump etc. from the power relay.

2. Ensure that the Jumper Settings are correct for that ECU.

3. Connect only the input connector P1 connector leaving the output connectors open. Switch the Ignition on. Do not start the engine. The yellow LED on the ECU must come on. Also the blue LED on the idle stepper control unit must come on, if it is installed. If the yellow LED does not come on switch the ECU off immediately as there may be a short on the 5 Volt output that will damage the ECU in time.

4. Now switch the Ignition off and connect the Laptop with the USB cable to the unit. Switch the ignition on. Start the PC software and connect to the ECU. The engine data like the water and air temperature sensors should be displayed. It should read more or less correctly for the cold engine.

5. Go through the setup pages one by one and ensure that all the settings are correct for this engine.

6. Ensure that the crank and cam angle sensors from the distributor or crank are set up correctly. Also their angle level selection must be rising or falling edge.

7. Check the Rotor Fazing if you have a distributor system. This will make electrical interference on the ECU and Laptop if it is set incorrectly.

8. Calibrate the TPS and Map sensors and save the calibration as described under active sensors.

9. Set the maximum RPM range and Map sensor type and range. Set the coil charge times to a lower setting if you are not sure what is required. Star with 2.0 min and 2.5 max.

10. The Map sensor value should be reading the atmospheric pressure of your region. Check the Altitude chart for the correct pressure in your area.

11. Make sure the Test function next to the crank sensor is on.

12 You may now crank the engine without the other connectors. Look at the RPM signal on the timing map. It should show 200 to 300 RPM constantly. If it shows erratic and runs wild, do not proceed. First find the fault. It must be constant with no errors. The vacuum bar should move slightly to the left of the graph while cranking at closed throttle.

13. Look if any error code is displayed at the bottom. If there are errors remedy the fault condition.

14. Save the data to the ECU if it has been changed.

15. Switch the ignition off and connect the other connectors.

16. Remove all the fuses. If it is an easy install harness disconnect the power on the injectors, coils fuel pump etc. Switch the ignition on. The relays will come on for three seconds then switch off again. If not, check the relay wire according to the drawing. If you have electronic relays, check that the LED on them must come on. Note on Mercury2 there are 3 relays with a free-wheel diode on pin 85 and 86.

17. Switch the ignition off and insert the fuel pump fuse. Start with 5A. If it blows check the wiring and try 7.5A as some pumps draw more power than others. Do not go to larger amp fuses as there may be a short somewhere.

18. Switch the ignition on, the fuel pump must start for three seconds and switch off.

19. Switch the ignition off and insert the coil fuses of 5A. If it blows check the wiring.

20. Now crank the engine with a timing light and check if the spark timing is in the 10°BTDC region. If not see the Calibrate Timing chapter for the correct setup. Do not attempt to start if the timing is not right or erratic. You may need to loosen the plug wire and make a small gap so that the timing light picks up the pulse of the spark plug. For coils that are bolted onto the plug, try using the trigger wire from the ECU. If this does not work, take a separate wire and wound it three times around the inductive pickup of the timing light and then insert this wire between the trigger wire and the coil input. This will amplify the signal three times so that it will trigger the timing light. Set the timing light to zero timing as wasted spark systems read double the degrees. This means if the timing light is adjusted to 20 degrees it is actually 10 degrees timing on the engine.

21. Switch the ignition off and insert the injector fuses of 5A. If it blows check the wiring.

22. Crank the engine. It should start. If the engine backfires or misses stop and do some checks. See the Trouble Shooting chapter to guide as to what the symptoms may be.

23. If your setup is correct the engine should start and idle smoothly.

24. Make sure the RPM is constant before revving the engine. If it jumps more than 300 rpm intervals, recheck the angle sensor's polarity. It must be steady. If it was error free during cranking without coils, it means the interference is now generated by the coils. See the precautions section on wiring tips.

25. Look at the exhaust. If there is black smoke, it is very rich. Try leaning it out on the water temp graph by lowering the dot closest to the yellow bar. The bar is interpolated.

26. Once the engine idles, calibrate the timing so that the Timing value on the software and the timing light on the engine is on the same degrees.

27. During the heating up faze, blip the accelerator from time to time. If the engine has a flat spot it may be lean and need some more fuel. Adjust the Fuel Graph till the flat spot reduces.

28. The blue LED in the idle control should go off once the target RPM is reached. If it keeps on flashing, then the ECU is trying to control the idling but nothing happens. It means the fault is on the idle side or motor. It may be a wiring fault or sticky stepper motor. It may also be a blocked airway or the throttle opening is too large. Remember for every 15% of enrichment on the water correction graph, the ECU will raise the set RPM's by 100.

29. As the engine heats up, the water sensor value must increase. Adjust the mixture on the water graph or by lowering the Fuel Graph till the engine is at normal temperature.

30. The water graph should now be around 85°C with no fuel enrichment. If it is not, you can calibrate the water sensor slightly on the setup page. The engine should rev up smoothly. If it has a flat spot it requires more fuel. Increase the Fuel Graph slightly till the flat spot is nearly gone. Also check that the timing is not the result of the flat spot. Check with the timing light that the timing increases as the software indicates.

31. Let the engine idle and adjust the Fuel Graph till it idles smoothly. Always try to make the mixture as lean as possible because it is difficult to see when it is too rich.

32. Save the data to the ECU. Also save a copy to the Laptop at this stage. The car may stutter and die. Restart again and proceed with tuning.


ECU Tuning

Help > ECU Engine Managment >

Tuning Basics

Tuning is all about getting fuel and fuel amount, spark and spark timing timing correct under all conditions. Understanding how the ECU works with these values is important to adjust them correctly. The Spitronics ECU's are designed to be easy and user friendly and will do many calculations in the back ground to simplify tuning.

A Dyno is always the best way to tune with and then do fine tune other settings on the road. In some cases, a Dyno Map from a similar engine could be used and tweaked on the road to near perfection. No two engines are exactly the same and will always need some refining. Main differences come in to play with fuel pressure from a mechanical regulator and then Injector sizes etc. The help of a Lambda in loop control usually sorts this out while driving.

For racing engines with different fuels and boost pressures it is always recommended to tune with a professional tuner on a Dyno. A good rule is, always if you hear detonation or see lean mixtures, back off the throttle and adjust the maps. The GP output could be set on lambda with a bright light to warn when mixtures are lean. For a Turbo or racing engine it is recommended to make use of one of our agents who has a Dyno and can tune your engine properly.

Instruments used for tuning is a timing light and wide band lambda instrument with display. If you have set knock ears this will also be very helpful. If you are just tweaking an existing map on the road you may use the lambda wired into the ECU. If you do not have a lambda sensor on the engine you need to put a temporary lambda tuning instrument in the exhaust.

Adjustable timing lights can be confusing due to the wasted spark firing of the ECU. It usually shows double the actual timing. On wasted spark rotary coils it shows 4 times the actual value. Rather mark the degrees on the engine pulley and put the timing light on zero. They are not always accurate especially the cheaper timing lights.

See the sub folders for detailed explanation of the different tuning sections. Before tuning make sure you set the ECU in the modes explained in Settings before Tuning.


Settings before Tuning

When you get to this point your engine should start and idle easily and the basic settings in the startup procedure should be set. Start with a warm engine at working temperature. Remembering you have a start-up map loaded from a running vehicle.

All the sensors such as TPS, MAP sensor, water temperature etc. should be calibrated.

If you are on dyno tuning, then certain graphs must be set to zero.

Disable or set the following features so that it does not influence your basic tuning.

General Settings

Make sure you are in the right tune mode.

Your outputs should be set to ensure that cooling fans etc. operate correctly.

Engine Settings

Set this value 500 RPM higher than your max tuning RPM.

Timing Settings

Set the Maximum timing and trailing degrees to a safe level. It will protect against too much timing on the graphs while tuning.

Set these values to a min. if you are not sure use 2 and 2.5 rather. Later when the engine miss you can increase them to see if it improves the miss. Too higher values may heat the Coil drivers to a critical level.

If you installed an altitude sensor these values must be set before tuning.

Select the right tuning method. Usually the same as fuel.

Fuel Settings

This setting will prevent over fueling while tuning the graphs.

These settings will prevent the engine from cutting unexpectedly. For a rotary use 2000 RPM.

The accelerator pump sometimes influences your fueling. Especially the MAP sensor compensation if the vacuum is erratic. Always start with minimum values. If you see erratic injecting time put it on TPS only.

Select the right tuning method. Usually the same as timing.

Sensor Settings

If you plan to use the Lambda sensor and one is installed, then these settings must be on and the sensor must show your altitude pressure.

If you are doing fuel pressure control you should have set this up already. See the fuel pressure control adjustment section. If not, put the Show Graph or the sensor off if it is not connected.

Disable the battery, Lambda and POT till the tuning is done. The sensor will indicate though. If the lambda is not connected, then put the sensor off as well.

If you can tune without idle control on it will be good. Then select Not Used. You will need to ensure enough idle air to maintain engine RPM. Or you could do this tuning beforehand. But if you adjust Fuel Offset and timing, you may need to adjust the idle control again. See the idle control adjustment section.

Turbo Settings

Set a maximum value 0.1 bar above your planned maximum boost to protect the engine during tuning.

Related Links

ECU Setup

Error Codes


Starting and engine for the first time

The ECU has a few sequences how to start the engine. An engine requires an initial prime pulse of fuel to start the moment the engine is cranked, then a richer mixture during cranking. Once it started, it also requires a certain amount of richer mixture than idling to get it going till normal idle settings can take over. For cold starting all these settings must be increased at a certain %. This is done automatically by the ECU by using the water temperature compensation Map. Adjust the following settings before starting and again when the engine is at normal operating temperature.

Start Prime Pulse

This setting will open the injectors for 20 milliseconds when the engine reaches 100RPM during cranking. This will ensure that the fuel is not cranked through the engine before ignition spark is started. When the engine starts look at the exhaust. If there is black smoke it is too rich. Try decreasing this value till the engine struggles to start. Then increase it slightly. If this pulse is too large, it may flood the engine.

Throttle Priming is a function to manually inject fuel into the engine on very cold days. The TPS must be connected for this feature. If you press the throttle more than 25%, the ECU will prime the injectors by half the value set in the Start Prime Pulse block. It will start the fuel pump for 1 second to get the fuel pressure up again. This function may be repeated if more starting fuel is required. It is handy to see if a stubborn engine requires more fuel or not.

Flood Control is a function that clears a flooded engine. It is activated when the accelerator is pressed more than 80% during cranking. The ECU will cut the injectors and no fuel will be injected into the engine. The spark and clean air will eventually dry and ignite the remaining fuel and clear the plugs. When the throttle is released the ECU resumes normal fueling.

Cranking Fuel is calculated from the graph or matrix where the MAP or TPS value and RPM is at the time. In TPS matrix the block on the matrix at low RPM is used for cranking fuel. The Rotary firmware will use the prime pulse graph in expert mode as a crank fuel setting. The reason is the amount of fuel and low vacuum signal during cranking.

Start %

If you have idle control, do not press the throttle as the idle control will ensure enough air at starting. This value determines how much air the ECU must add to the starting enrichment. If you don't have idle control it helps to open the throttle slightly for starting. Do not rev the cold engine as oil pressure is still low. Rather let it heat up gradually. For cold starting you may need to keep the engine running with the throttle as it requires more air.

Start Enrichment

This setting will enrich the idle fuel after the engine has started and reached 500 RPM. It will add 0.5 milliseconds to the injector time. This value will decrease with RPM counts, and should fade in about 8 seconds at idling to zero milliseconds. If you rev the engine after starting, it would be zero in 2 seconds. Try starting with a zero value. Do not press the throttle. If the engine dies after starting, increase this value till it keeps running.

The engine is designed for a certain torque and power curve. Inadequate mixtures and timing will only reduce performance. Timing is the easiest parameter to get in the right region, as you can use timing marks on the pulley and quality timing light. Also follow the guidelines for the specific type of pickup to get it more or less in the firing zone. If you are not sure try to go for a retarded time position. This will make the least damage and not break the starter.

Related Links

ECU Setup

Error Codes


Calibrate timing

Help > ECU Engine Managment > ECU Tuning >

Calibrate timing

This section discusses how to set the ECU timing to be accurate with Engine timing. This is important to see realistic timing values on the software and also settings that use the timing real-time bar to protect the engine.

First get the engine to start and idle smoothly as discussed in the Start-up Procedure. Make sure that you have the timing marks on the pulley checked for accuracy. If this is wrong it means timing will not be accurate on the software. Make a 10-degree mark or select a mark on the pulley that is close to that degree.

Now set the Maximum engine timing at 10 degrees or at the preferred mark on your pulley.

Make sure that the real time bar is on 10 degrees or you will need to lift it on the Dynamic timing graph.

Now take your timing light to the engine. Put it on the HT lead of cylinder 1. If it does not trigger on the light loosen the HT lead so that it creates a little gap on the spark plug tip. Not too much! You may also clip the sensor over the coil negative wire if it has COP coils. If that doesn't work, then wind the trigger wire 3 times in the same direction as the arrow around the sensor and close the clip. This will amplify the trigger signal. Sometimes you may need to use an extension wire piece to do this.

Put the timing light on zero and see where the timing flashes. It should be on the mark you set. If it is not there, then you need to make adjustments in the software. Do not adjust the distributor (if it has one.) It will adjust Rotor fazing which will then have a problem later.

You may ask someone to assist by looking at the light while you adjust the software. Start with the Timing Sensor setting.

Make small adjustment and see what happens at the front if you are going in the right direction. If not adjust to the other side. If you get to the end of the adjustment range, then you need to adjust the Gear teeth setting to make a course change. These settings react different for different firmware. On the gear teeth programs more teeth mean slower timing by the pitch of the teeth. For a 36-1 gear the timing will jump 10 degrees slower if you add a tooth. The Timing sensor wall advances with higher values. It can adjust from 0 to 9 degrees.

Once you get the timing light spot-on with software timing, you can check if your adjustable timing light works correctly. Put it on 10 degrees for a distributor then the flash should fall on TDC. If you have wasted spark or COP coils, then 20 degrees on the timing light will fall on TDC. If you have a Rotary with wasted spark leading coil the 40 degrees on the timing light should fall on TDC.

Now put your maximum timing back to where it was and save the data to the device. It is good practice that after setup of the software before tuning, save a base map. Should something go wrong then you save a lot of time.

Related Links

Software

Rotor Fazing


Fuel economy cut-off tuning

Help > ECU Engine Managment > ECU Tuning >

Fuel economy cut-off tuning

This feature will cut fuel to the engine under low load conditions. This will save fuel in town and downhill driving. The engine will run against compression as you are decelerating. It will also prevent flaming in the exhaust during accelerator blip.

The injectors will be cut when the MAP sensor value is below the Vacuum fuel cut off setting and the engine RPM is above the RPM fuel cut off setting.

The Vacuum fuel cut off setting is chosen as a value lower than idle vacuum. A good value is usually 0.08 bar for a standard street car. The RPM fuel cut off setting is about 500 RPM higher than idle RPM. Rotary and racing engines may need some extra RPM's.

There is a dead band feature built into these settings to prevent jerking when you are cruising close to the settings. When tuning these parameters use third gear at around 2000 rpm and release the throttle. Look at the real-time injection bar and you will see that it goes to zero value which means the injectors are switched off.

You will also notice in information code at the right-hand bottom of the screen indication that this feature is activated.

Now, let the car reduce speed by itself till injection is restored and the engine is running by itself again. This change over point must occur when the engine reaches idle RPM's. If it jerks in the car, reduce or increase one of the settings till it comes-in unnoticed.

Related Links

ECU Setup

Error Codes


Graph MAP tuning

Make sure all safety precautions are met as specified by the Dyno Safety rules from the manufacturer. Also remember to keep an eye on the water temperature of the engine. If at any time you hear detonation, back off the throttle immediately and lower the timing in that RPM range about 3 degrees. If at any time the RPM bar becomes erratic, back off the throttle and do faultfinding for interference or a faulty trigger signal. If the AFR shows lean, back off and make it richer in that load site. Especially turbo and racing fuel engines. They can become damaged in a very short time.

Ensure that the engine is at working temperature and all the sensors are calibrated. Disable Lambda Control until after the tuning is done. By now your engine should start and rev up and timing must be calibrated. See the Calibrate timing section. This section will discuss the final fuel and timing tuning. After this you still need to tune drivable features and cold starting. Ensure all the settings in the Settings before Tuning section is done. Now proceed to the map reset section.

Reset Maps

Zero both graphs on the Cruise Timing Graph.

Zero all 5 graphs on the Fuel Graph - RPM Compensation.

Zero both graphs on the Water Temperature Graph.

Zero both graphs on the Air Temperature Graph.

Zero the TPS Graph.

Set Maps

Now set a basic profile on the following maps.

This is a basic dynamic timing that should work for the average engine. Set a basic RPM timing map to start at 10°BTDC degrees and idle at 15 °BTDC degrees. Increase the timing from 1000RPM to 3200RPM up to 32°BTDC. Keep it flat till maximum timing. If you have a special engine with high compression, then lower the maximum timing to 28 degrees.

Your main fuel map should look something like this. This means engine idles at around 0.2 bar vacuum and requires 4 milliseconds of fuel to idle when hot. The slope will provide enough fuel to rev and ride the engine. If your injectors are larger than standard, then idle fuel would be lower and the slope less aggressive. Note: Fuel Ratio is set at 100% and Fuel Offset is as 0%.

Set the 5 tune markers in even space over the load of the engine. The green marker could be at idling and the red high bar at about 90% load. Space the other ones evenly.

If you have a Rotary engine also set the trailing degrees at a base timing of 7 degrees.

Make sure that fuel compensation is zero at operating voltage in the Charge Voltage Graph.

Start Tuning

Tune1. Fuel Load Graph - Manifold Pressure

Now start the engine and set the Dyno RPM at the middle of the engine max RPM, around 3200 RPM for a 6500RPM engine. First tune is to set the throttle flow profile on the Fuel Load Graph.

Set the easy tune feature to Tune All Right. Put the real time tracing function on. Now use the arrow keys to tune the graph.

Look at the AFR gauge closely all the time. Start with light throttle and increase it by pressing the pedal just a little at a time. First RPM will increase till it reaches 3200 on the Dyno. Then the Dyno will keep the engine RPM constant and you can proceed right through the load range.

Listen for detonation. If you detect any, back off and go to the timing graph and lower the graph in that RPM bracket. Also, remember the AFR should show slightly lean at light load, Stoic at cruise load and slightly rich at high load. Different engines will require different ratios so you need to tune accordingly. This manual is not written with specific AFR in mind, but merely for explaining. After tuning you should have a similar profile. See below.

Tune2. Dynamic Timing graph (WOT) - RPM

Now that you have the AFR set to a safe level you can proceed with the Dynamic Timing graph. For this tune you need knock ears or a Dyno with very fine torque measurements. Start with light throttle again. This tune is to determine wide open throttle timing. Keep the dyno control handy and start with the lowest RPM. at very low RPM's WOT may not fuel correctly so use a lither load tile as it is clean. Here, you now increase the timing till you see slight detonation or that power does not increase anymore. If you see knocking you can lower the timing by about 3 degrees. This should also be the limit where power break offs' occur if you decrease any further. Keep an eye out for the AFR gauge. Timing will influence the amount of fuel required at that RPM. If AFR goes to lean repeat the first tune again and come back to timing. Also, ask someone to look at the water temperature on the engine to be safe. A very hot engine requires less timing so try and tune at working temperature. Below is a sample of a Lexus V8 engine. Notice the timing dip at 4000 RPM. That is where VE is at its best and requires less timing.

After Tune 2 it is good practice to look at tune 2 quickly and see if it requires fine tuning.

Tune3. Cruise Timing Graph (High RPM) - RPM Compensation

Now, you need to set a cruise timing curve to proceed to cruise fuel tuning. Keep the dyno on 3200 RPM and again tune for timing up to detonation or power turn point like in test 2. Start from full load to light load using easy tune all left function. At light load you can keep the same value to the left. You will end up with a graph similar. See below.

Tune4. Fuel graph - RPM Compensation

Now that dynamic cruise timing is set it is time to proceed to the Fuel graph - RPM Compensation. Here there are 5 graphs. Start again with the green at lightest throttle and work to the high load. You can press the Hide function to isolate each graph. Keep the dyno control handy and start with the green bar. As you increase the RPM on the dyno from idling to high rpm, you need to load the throttle to keep the Map sensor value on the green bar on the Fuel Load Graph - Manifold Pressure. Tune all right will adjust the graph evenly. Remember that AFR is different for light load and full throttle. It should look like below. Again this graph may vary between engines. Notice how all the graphs come together at 3200 RPM. This was due to Tune1 step where all the graphs was set to 0.

Tune5. Cruise Timing Graph (Low RPM) - RPM Compensation

Now you need to set a low RPM timing. This is handy to get a slow engine up to speed quickly. See the graph below. This engine idles at 0.2 bar when hot and there is zero timing. The moment you press the accelerator, and the engine is below 1500 RPM, the bar will move to the right-hand side. This will add quick timing and get more power from the engine. If you blip the throttle it will still add 5 degrees till the engine reaches 1500 RPM.


Graph MAP with TPS tuning

Help > ECU Engine Managment > ECU Tuning >

Graph MAP with TPS tuning

This tuning is the same as MAP graph tuning with the added adjustment to get the engine to idle on TPS calculations. It is still easy to tune without going to TPS matrix. So first tune according to this method. The same principles will apply to the timing graph but it is not as critical as fuel. Now do these adjustments.

Idle Tuning for an engine with a hot or long duration Cam

When a cam has valve overlap, the manifold vacuum at idling is very erratic or none existing due to exhaust gasses that backflow into the cylinder and sometimes also into the intake manifold. As a result, the ECU cannot use the MAP signal effectively because it is no longer a representation of how much air is going into the cylinders. To correct this there are two ways to tune the ECU to compensate for these out of balance situations.

Option 1, RPM Compensation

In the example below the engine loses vacuum at 1500 RPM and lower. Then the vacuum bar on the top graph moves to the right. This means that the Low cruise and cruise Map below is active. Now, lower the graph below 1500 RPM to compensate for the over fuel condition. This option works well with mild cams. It is used for fuel calculation Maps only.

Option 2, TPS Blending

In this option we use the TPS signal for the fueling signal at low RPM's and the MAP signal for high RPM's. First determine at which RPM's the engine looses the vacuum signal. Put the engine in neutral and increase the RPM's till it has a good vacuum signal. Now reduce the RPM's while looking at the green bar on the Fuel Load Graph. The bar should move to the left until vacuum becomes a problem. It will then move to the right again. If it happens, let's say at 1600 RPM adjust the following settings on the Setup Fuel setting.

Put the Fuel Calculation on Map + TPS.

Put the critical RPM value in the RPM Fuel Cut-off block. Put the Vacuum Fuel Cut-off on 0.1 Bar. Start with the TPS Gain at 100. Now if the RPM signal falls below 1600 RPM, the TPS signal will be calculated as a MAP signal for the vacuum graph. When the TPS is at 0%. the MAP signal will stand on the 0.1 Bar position and move from there. If the RPM goes higher than 1600 RPM, the map signal will be used for fueling again. Should the actual MAP signal be lower than the calculated MAP signal at RPM's lower than 1600, then the actual MAP signal would be used. This will prevent the TPS signal from over fueling the engine.

Now adjust the fuel to increase as the TPS is increased so that the flat spot is corrected. If you don't find a sweet spot between the TPS fuel and MAP crossover, then you may need to move the Vacuum Fuel Cut-off higher to 0.2 Bar. This will have a higher value on the Fuel economy cut and result in harsh control on that feature.

Now press the throttle at different opening speeds with your foot. The vacuum bar will move from the 0.1Bar position to the right side of the graph. The speed of movement is adjusted by the TPS Gain value. If the bar moves to slow you will have a flat spot under acceleration. Increase the Gain value till a smooth acceleration is achieved. Start with a lower value to ensure that the mixture is not too rich.

Another tip to tune flat spots: Set the MAP accelerator pump to only work in the calculated range, and then make it sensitive and enough fuel. Note the 1600 RPM setting.

This is not a black and white setup but merely a guideline so you understand what you can do in the firmware. Trial and error will find a sweet spot.


Matrix Map Tuning

Help > ECU Engine Managment > ECU Tuning >

Matrix MAP Tuning

This tuning mode is the most popular Dyno tune method. It is easy because the Dyno locks the RPM's to a specific load site and the tuner can move the load through the other axis. Then he tunes specific intervals. The ECU will then interpolate points in-between his tuning points and get fuel and time accurate and smooth. Note that this mode is not available in Novice mode. See the Tips and Hotkeys section to understand how to manipulate all the data values.

Matrix tuning Pallet

This pallet is tuned in a 16x16 matrix. The MAP load range is on the vertical Y-axis and the RPM value is on the horizontal X-axis. The range will scale according to MAP sensor setting and the RPM Increment setting.

A Popular value is 500 RPM per column then it will end at 7500 RPM. Should the RPM's go higher than the right column, the ECU will keep that column value The load however will still increase on that last line.

Always start to tune with Ratio 100% and offset 0. If you add an offset remember it will be added to all your fuel values.

Easy tune and Real-time tracking

Easy tune and real time tracking are very useful tuning tools in this tuning pallet. It assists the tuner to tune where the load and RPM is without moving the tuning block with the arrows.

Focus window

The focus window guides the tuner to the centre of the block so that his tuning is accurate. Otherwise he will tune the wrong values in the active block. He will need to fine adjust the Dyno RPM's and adjust the load with his foot till the window turns yellow.

3D Display

The 3D window is a representation of the actual map. This is handy to see if there are irregularities in a block.

Tuning Preparation

See Settings Before Tuning, before you begin. If you have a start-up map it would make starting and idling easier to begin with. If not, set easy tune to Initialise and make the whole pallet 4ms. Then on the load rows increase the fuel gradually to 14ms max. It is a base map and will get you started. For a turbo engine with larger injectors start with smaller values and end with higher values. A turbo engine's injectors has to work over a wider range to cater for the higher fuel demand. See the pallet below.

Set a base timing map of min 10 degrees and max 32 degrees. If it is a turbo engine you may need to decrease the load timing. See the pallet below:

Tuning

To tune an engine from scratch you need to adjust fuel then timing then fuel again and then timing again. Fuel has a big influence on AFR and power while timing has a smaller influence on AFR and power. But they do have an effect on each other. When you tune fuel listen for detonation. If you have knock ears or some indication, it will be helpful. If at any time you hear detonation, back off and reduce the timing with 3 degrees in that field. Also look at Water Temperature not to damage the engine. Start with an engine on working temperature. Remember air and water temperature can alter your AFR settings, so keep a constant flow of cool air on the air filter.

Start as close to idle as possible. In this case 1000RPM's. Start with idle AFR at no load. Now set auto tune to [image] . That is the direction of tuning. Put Real-Time tuning on [image] . Your engine should idle at around 0.2 bar to 0.3 bar vacuum so adjust from there.

Tune low loads for lean AFR and then go richer as load increases. This manual will only explain basics of tuning. Now increase the load with the throttle to 0.3 until the focus window is yellow. Some dyno's may "Creep" as load increases so you may need to do adjustments. Increase the value till the right AFR is reached. Then go to 0.3 and so on. Remember at 1000 RPM the engine may not get top maximum boost range. Tune as far as is possible. Later you can predict sensible values for that part of the Matrix.

Remember at high boost detonation or timing this may start to play a big role. Some tuners will stay at 1000 RPM and do timing first. The reason is the tune up and right will also set timing more realistic for the next fuel load. It will save on repetitive tuning later. So for this section we will do timing next.

Adjust the timing and look at the power reading on the Dyno. Usually maximum power is 2 to 3 degrees before detonation. The power tends to level out in that region. So the trick is to find the avalanche where power breaks off, then you should be safe. If you hear detonation back off, reduce the timing 3 degrees. Now increase the load with the throttle to 0.3 until the focus window is yellow. Do the same as the previous block. You should see that the timing increase to 1 bar and then reduces again with high boost pressures. Again at high load on this low RPM the turbo may not reach high boost pressure.

Now release the throttle and set the Dyno on 1500 RPM. start with 0.2 bar load again on the fuel Matrix and repeat the previous exercise. Then go to Timing Matrix and do the same. Then next RPM column and so forth.

All that remain now is the space outside where the Dyno cannot reach. This is the load rows below idle vacuum and RPM columns lower than idle.

The load rows below idle vacuum can only be reached when the RPM's are high and you back off the throttle like on a downhill or decelerating stage. On the Dyno you can accelerate and release the throttle and look closely where the vacuum and RPM crossing point is at. Then decide on how you want it to give it fuel and timing. You won't be able to hold the focus window on yellow so make adjustments and try and see if your measurements improve. Here are some guidelines.

On timing give the lower Load rows on the high RPM side more timing than usual. Fuel will be lean due to low compression and it could be ignited earlier.

On the RPM columns make the whole row 10 degrees which is your cranking timing. This will ensure the engine starts easy without kick back on the starter.

On the fuelling rows side try and tune it close to correct value when you release the throttle. The reason is the interpolation will still calculate fuel. Don't use this as the Fuel Economy Cut-off feature.

On the fuelling column side use this as your cranking fuel. When the engine cranks it will use the block where the load is at. It will be compensated with the water temperature graph for cold starting.


Matrix TPS Tuning

Help > ECU Engine Managment > ECU Tuning >

Matrix TPS Tuning

This tuning mode is the most popular Dyno tune method for normal aspirated racing engines that have poor vacuum signal or throttle bodies. It is easier because the Dyno locks the RPM's to a specific load site and the tuner can move the load through the other axis. Then he tunes at specific intervals. The ECU will then interpolate points in-between his tuning points and get the fuel and time accurate and smooth. Note that this mode is not available in Novice mode. Requirements here is a good and accurate TPS signal and also the altitude sensor. This tuning method cannot cater for altitude and pressure differences due to temperature. See the Tips and Hotkeys section to understand how to manipulate all the data values.

Matrix TPS tuning Pallet

The only differences in this tuning method is that the vertical load Y-axis is TPS instead of MAP signal. The tuning is the same as described in Matrix Map Tuning. Note: When the throttle closes, the block will stand a 0% and not at atmospheric pressure. Also when the throttle is released it will stand on 0% right at the bottom.

All that remains now is the space outside where the Dyno cannot reach. This is the RPM columns lower than idle.

On the RPM columns make the whole row 10 degrees which is your cranking timing. This will ensure the engine starts easy without kick back on the starter.

On the fuelling column side use this as your cranking fuel. When the engine cranks it will use the block where the load is at. It will be compensated with the water temperature graph for cold starting.


Graph MAP and Matrix TPS Tuning

Help > ECU Engine Managment > ECU Tuning >

Graph MAP and Matrix TPS Tuning

This method is for Dyno tuning and used for racing engines with poor vacuum signal. Before reading this section please read Matrix MAP Tuning to understand how to tune from scratch. This section will only discuss the differences and types of Tuning options.

For this method you tune the normal aspirated part on the TPS matrix and then the turbo boost part on a graph. This feature is best to use with Altitude compensation sensor wired in. The Altitude sensor will modify the TPS matrix value before it is compensated by the Graph setting. This will give a more accurate calculation of the fuel per air. The trick is to tune normal aspirated fuel on the TPS matrix then add the boost compensation fuel on the graphs. TPS has no reference against pressure of the Turbo. Timing will also activate the two Cruise Timing Graphs for boost timing tuning.

There are two methods of tuning.

Method 1 is to disconnect the turbo and do the TPS matrix as previously discussed. Then connect the turbo and do the Fuel Boost Compensation graph. This method is good for low boost engines.

Method 2 is to add a predicted boost graph line and then tune the TPS Matrix with low boost to get a pattern on the Matrix. Then put the boost up and tune the Fuel Boost Compensation graph part complete.

Method 2 Fuel with Altitude sensor wired in.

Make sure the altitude sensor is switched on Compensate. Especially if you are not at sea level. Tuning will include the pressure difference and change the maps when you go to sea level. This graph will start at 0 pressure which is the current atmospheric pressure where you are. If you change altitude this zero point will move with the altitude pressure. This means that the moment boost pressure goes above altitude pressure the graph will indicate the difference. That will eliminate the need for the ECU from being retuned all different altitude levels.

Fuel Boost Graph with Altitude sensor.

Set a base graph as above. Note that at 1 bar boost it will be around 100% enrichment. With this method you can boost up to 2.5 bar above sea level. If you need higher boost you may have to add fuel on the matrix or add the dual injectors with Ratio or Graph method. The reason is this graph can only go to 250% enrichment. This graph is linear and it should curve up to make mixtures progressively richer at higher boost. So go for the lowest boost setting that you can. Maybe 0.5 bar boost. Now turn your attention to the Fuel matrix.

TPS Fuel Matrix

Note: Due to the turbo engine, the injectors will be bigger and the injection times will be shorter. The maximum set here is 8.7 and with 1 bar boost it will become 17.4 milliseconds. Which should be maximum at high RPM's. After you tuned at low boost then proceed to the graph again.

Now lock the dyno on a high RPM load site at full throttle. As you increase the boost adjust the graph to run at the right AFR mixtures. Once this line is set to maximum boost then change the RPM and check other load sites as well. They should be the same AFR. If you see a lean mixture you may correct it on the matrix map. Notice the graph below now has a slight curve to the top. This one runs out of tuning space because the injectors are too small.

Fuel Boost Graph with Altitude sensor.

Method 2 Timing with Altitude sensor wired in.

TPS Timing Matrix

Timing matrix is set like a normal aspired engine. See sample above. As for the boost part you need to tune the Cruise Timing Graphs.

Fuel Boost Graph with Altitude sensor.

Here only the red graph is of importance as normal liming comes from the TPS matrix. Set the blue one on 0% compensation so that it does not affect low RPM timing.

Method 2 Fuel with no Altitude sensor.

This method can be used if you don't use the vehicle on different altitudes. Remember air temperature has an effect on atmospheric pressure so there may be slight changes in your AFR from day to day. If possible, use it with the Lambda control. The main difference is the Lambda sensor don't effect the timing and you may get detonation at sea level.

Fuel Boost Graph with no Altitude sensor.

Notice that this method uses the actual MAP signal on the real scale. This example as tuned at sea level on 1.03 bar altitude pressure. At higher altitudes the graph will start to increase from that altitude.

Cruise Timing Graph with no Altitude sensor.

Same as above this starts to change from 1 bar.


Tuning for Automatic Transmission

Help > ECU Engine Managment > ECU Tuning >

Tuning for Automatic Transmission

Automatic transmissions, air conditioners and power steering uses a lot of energy and may cause engine RPM's to drop and may stall the engine. Usually idle control will cater for this but you will also need to set fuel and timing accordingly.

To adjust this start with a hot engine and put the transmission in park. The engine is now on free idling. When you put it in drive, the load will cause the engine to lose RPM and also vacuum. The Map sensor bar will move slightly to the right, now add a little timing and fuel to make the engine idle stronger. These settings will act very fast on the engine and capture the power loss.

Dynamic Timing graph (WOT) - RPM

Fuel Load Graph - Manifold Pressure


ECU Idle Control Tuning

Help > TxW Controller >

Idle control Tuning

Idle control is done with different methods. It could be external idle valve or stepper motor or it could be done with partial throttle motor or full drive by wire throttle. Due to the delay in mechanical control to stabilise idle, you need to tune the ECU and idle valve together. The reason is that the ECU can react faster than a mechanical air restrictor valve. And most of the times hunting is a result of incorrect engine tuning. If idle drops then the valve opens to correct. That adds more air resulting in a worst effect and it comes with a delay. Then the ECU will add fuel due to more air resulting in high rpm which in turn close the idle valve and this repeats out of control. Also after blip the idle valve must capture the engine rpm before it stalls. Again here the ECU can react faster by adding timing and fuel to assist in this process. This section describe what needs to be done on the ECU side to help smooth idle control. See the different types of idle control and how to adjust their settings in the idle control setup section.

Setting the Idle Jet for Time & Fuel

When an engine idles in neutral and is at working temperature, the idle timing should be around 15 to 18 degrees depending on altitude. This may vary from engines but this is a basic guideline. Increasing idling degrees usually result in higher RPM's. Do not confuse this thinking it is what the engine needs. All you will do is lowering the air volume to bring idle down. This will result in very poor power and engine will easily die off when you put a bit of load on it. The lower the engine timing the slower the engine idles and the more idle air it requires. It will also require a slightly richer mixture. Now if you put a little load on the engine you immediately add timing which will make more power due to the rich mixture with more air. Adjusting timing is immediate and there is no mechanical delay. Now when an engine wants to hunt you can effectively control power to it without the idle control valve or throttle movement. Below is some basic ECU settings.

First adjust the timing so that at idle there is 15 degree dynamic timing and no vacuum timing.

Adjust the Idle fuel so that the engine has just enough fuel to idle constant. Do not make it too rich. It should be close to avalanche point where if you go leaner the engine will lose power. The best way to see this point is where the vacuum signal will be at its lowest point for normal engines. Any more or less fuel will results in higher vacuum. Racing cams and matrix tuning will be saver to look at A/F ratio. Idling RPM's should be on your Target RPM value. In this example 800 RPM. Notice that the green and brown graph below on RPM compensation is at zero compensation. Only the main graph determine idle fuel. Also make sure water and air compensation is zer0.

Now when the engine hunts we will use timing to control it before the idle valve needs to act. First you must understand what happens in hunting. The engine will lose power resulting in an increase in manifold vacuum. The vacuum bar will move to the right and the RPM bar will move to the left. Due to our slower timing we can increase timing to add power which will increase RPM. Adjust the Low rpm timing graph as below.

Lower rpm also brings more air in the manifold which requires a bit more fuel to make the mixture a power mix. Adjust the green and brown graph on the RPM graph ay the lower rpm range to add a certain % fuel. Note on the fuel load graph we already should have a slight increase in fuel.

Now the above adjustments will capture falling RPM's and it may now cause the idle control valve to react as well adding air. This will increase RPM above target. There is an up and down response on the idle valve control settings. As a rule we make up response faster to ensure that the engine does not stall. Then we make down response slower to prevent hunting. Will result in more vacuum which makes the vacuum bar move left and the RPM bar moving right. First we use timing again to make it slower reducing engine power.

Then less air also needs less fuel. This time we adjust the fuel load graph as the engine don't use this part for normal riding. Note however, that deceleration will cause the vacuum to move in this region. If the mixture is too lean then the engine to being jerking due to too lean mixture.

Automatic Transmissions

For automatic transmissions tuning principles are the same as above. But there are two load steps that differs for neutral and drive. After you do the neutral tuning, then put the engine in drive. The load on the engine from the transmission will cause the vacuum bar to move to the right quite a bit. RPM is controlled and will stay the same. So you need to make sure that the idle fuel will increase for the added load.

Related Links

Idle Control Wiring

Idle Control Setup

Error Codes


ECU Trouble Shooting

Help > ECU Engine Managment >

Trouble Shooting

Faults and Remedies

The ECU yellow LED does not come on

  1. The ignition wire does not have 12Volt
  2. There is a short on the 5 Volt output from the ECU. The magnetic crank or distributor sensor, TPS and MAP sensor all use this 5 volt. Check the wiring.

The Software does not connect to the ECU with the USB Converter

  1. Ensure that the yellow led on the ECU is on. Check the cables are fully inserted.
  2. No Driver for this Device installed - The USB converter must have drivers installed in Windows before connecting the cable.
  3. Incorrect device settings in the Hyperspace software.
  4. Faulty USB converter.
  5. Faulty ECU.

The engine does not start for the first time

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Go through the Startup Procedure to ensure ECU operation is correct.
  3. If you crank the engine and it does not want to start, disconnect the high tension leads at the spark plugs one by one and check for spark on the plugs. Use another sparkplug in the lead and hold the earth onto the engine. If no spark:

a. Check on the laptop and see if there are no errors. Make sure there is 200 rpm while cranking. If not, check the crank or distributor signals. Air gaps of the magnetic sensors to gear may be too large.

b. Check if sensor polarity is correct.

c. Check if the fuel and coil relays pull in at ignition on. If not check that the numbers on the relays are correctly wired. Electronic relays have a LED that will come on at Ignition on.

d. Test if the coils have positive supply +12 Volt when cranking the engine.

e. Test the coil resistance from the relevant connector to see if there is an open circuit.

f. Test the coil to see if it is faulty.

g. If it is distributor type, check the spark at the coil HT pole.

  4. If there is spark, take out one of the spark plugs. If it is dry it means, there is no fuel. Check for:

a. Check on the laptop and see if there are no errors.

b. Look at the injector milliseconds bar. It should indicate that the ECU is injecting fuel at around 10 milliseconds during cranking.

c. Ensure the fuel pump is running during cranking. If you switch ignition on it should pump for 3 seconds.

d. If it shows zero milliseconds, check the map calibration, TPS calibration, fuel cut off function settings. There should be an error code helping you to identify which control program prevent the injectors from pulsing.

e. Test the fuel pressure by loosening a bolt on the fuel rail somewhere. Hold a rag over the joint to prevent spillage. Keep a fire extinguisher close by.

f. Ensure that the injectors were checked and serviced if the engine stood for a long time.

g. Put your fingers on the injectors and feel if they pulse during cranking.

  5. If the plugs are wet, it means there is fuel. Check the following:

a. It may be that the start fueling was too much and the plugs were flooded. Dry them and try again. You may also push the throttle in completely and crank the engine till it starts or the plugs becomes dry.

b. It may be that ignition timing is setup incorrectly. Then firing occurs at the wrong time and failing to ignite the fuel mixture. Check the timing setup again for the specific engine.

c. The plugs may be old or dead. Replace.

  6. If the engine tends to stop cranking suddenly, check the following:

a. It may be that the timing is too fast. Reduce timing by 10 degrees. Add more teeth if a crank gear is used.

b. If there is a magnetic crank or distributor sensor, check that positive and negative wires are not switched around.

c. If more than one coil is used, check for incorrect wiring or firing order.

Engine Backfires during Cranking

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. The engine backfires through the intake.

a. Faulty ignition timing or firing order. Check again the timing setup for the specific engine.

b. If there is a magnetic crank or distributor sensor, check that positive and negative wires are not switched around.

c. If more than one coil is used, check for incorrect wiring or firing order.

d. Check if the RPM bar jumps erratic in the PC software. If it does, the gap of the magnetic sensors may be too large or the signal is too weak or interference from the ignition coils.

e. If it is a distributor check rotor phasing and that it is on the correct cylinder at TDC.

  3. The engine backfires through the exhaust.

a. Too lean fuel mixture. Increase by 10 at a time on the fuel ratio adjuster.

b. Water temperature sensor or compensation map incorrect.

c. Some of the plugs may be old or dead. Replace.

Engine start but it stalls directly afterwards

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Check the map sensor in the fuel map field is operating. The olive color bar should be on your altitude pressure value. If not, it may be a calibrating error or faulty wiring.
  3. The fuel mixture may be too lean. Try to enrich using the fuel ratio adjuster.
  4. The temperature sensor may be faulty causing the cold engine to give a warm signal to the ECU. Thus leaning the mixture out.
  5. Incorrect Fuel Cutoff settings. A symptom will be that the milliseconds bar on the real time block will jump to 0.
  6. Incorrect Engine Limiter settings

Engine start but is very rich

  1. Check the map sensor in the fuel map field is operating. The olive color bar should be on your altitude pressure value. If not, it may be a calibrating error or faulty wiring.
  2. The fuel ratio adjuster is set too high. Start with 100%.
  3. Check if the water temp sensor is working. If not, it will keep on enriching the mix as if for a cold engine.
  4. Some of the plugs may be dead, and then the engine loses manifold vacuum resulting in enriching the other cylinders.
  5. Fuel maps tuned too high. Lower the values.
  6. Fuel pressure regulator regulates too high. Measure the pressure. It should be between 2.5 and 3.5 bar.

RPM signal very erratic.

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Incorrect magnetic trigger polarity.
  3. Interference on pickup. See also Precautions.

Engine start but do not rev up

  1. Check for error codes. This is always the first place to look and a good indication of the problem.
  2. Check the map sensor in the fuel map field is operating and calibrated. The olive color bar should move to the right if the throttle is pressed.
  3. Too lean mixture. Try increasing the main jet value.
  4. Rev limiter is set too low
  5. Check the micro fueling and boost limiter blocks and see if the settings there are correct. A symptom will be that the milliseconds bar on the real time block will jump to 0.
  6. The Fuel Cut-Off settings are wrong.
  7. Incorrect rotor fazing or timing. Check with a timing light.
  8. The magnetic crank or distributor sensor's negative and positive wires are changed around. The gap may be too large.
  9. Fuel pressure or flow rate to low. Dirty fuel filter.
  10. Faulty fuel pump.

Idle Control does not work

  1. Check if the wiring is correct as indicated on the drawing. If it is an idle valve, make sure the diode is intact. If it is a stepper controller, make sure the sequence is wired correctly. It may try to close instead of open.
  2. Faulty TPS setting. Make sure the TPS is calibrated correctly. It must go from 0 to 100% over the full range.
  3. Check the idle control settings according to the idle control explanation.
  4. Make sure that the throttle position is set correctly at idling. The idle valve can only close as much as this setting.
  5. Check if the idle valve or stepper motor is not stuck. The idle valve can be pulsed with 12Volt to see if it opens and the stepper normally vibrates when the ignition is switched on. It may still be stuck even if it vibrates. So take the stepper off and see if it opens.
  6. If the blue LED on the stepper idle controller is constantly on during idle, it means that the idle computer does not receive the RPM pulse from the ECU. Recheck the wiring.
  7. If the blue LED on the idle controller flash it means that the idle computer tries to adjust the RPM but nothing happens. The idle motor itself is sticky or wired incorrectly. Open it up and clean and lubricate. With the long shipment on ships it corrodes on the inside. The wiring to the idle motor may be incorrect. The airway of the idle motor is blocked.

The Automatic transmission does not shift

  1. Connect to the TCU and see if the TPS and RPM signals are present. If not, ensure the correct wiring connections between the TCU and ECU are correct.
  2. See the relevant TCU manual for information.

Spark plugs does not last

  1. Fuel mixture too rich.
  2. Wrong temperature plugs.
  3. Charge time too long. Reduce the time.

Flat Spot when accelerating

  1. Another vacuum line tied into the Map sensor line.
  2. Restricted vacuum line.
  3. Vacuum line too long.
  4. Too small port for Map sensor on intake manifold.
  5. Incorrect fuel setting of maps or accelerator pump.

Engine lack power, idle erratic, or runs lean

  1. The fuel pressure is erratic. This may be due to the pump sucking air on the in feed which causes cavitation and loss of pressure. This happens more frequent when the engine is hot.
  2. Injector positive is wired incorrectly. It does not have its own supply direct from the battery via relay 1.
  3. Incorrect setting of fuel maps.
  4. Fuel pressure or flow rate to low. Dirty fuel filter.
  5. Faulty fuel pump.

ECU cuts and start erratic or randomly during driving - See Electrical Interference

Copyright © 2013. All rights reserved.


Specific Instructions

Help > ECU Engine Managment >

Specific Instructions

This section is to highlight certain firmware that is not standard practice. It will help the user to set up his device to suit difficult applications. Always look in this section to see if there is something you need to take notice of.

Se the sub folders for more details.


Rotary Engines

Help > ECU Engine Managment > Specific Instructions >

Rotary Special instructions.

General Information

The two stroke setting means that the firmware will inject the calculated amount of injector time in every stroke. Putting it off means that the injector time will be divided by 2. This will cause the tuning graphs to be twice as high. The advantage is that the graphs tune more easily and adjustments is 50% finer resolution. A drawback is that 25 milliseconds maximum fueling is easily reached during accelerator pump function and might cause problems at tuning flat spots during blip conditions.

Another feature is the duel injector system. It can be tuned with a ratio adjustment or separate graph system which is discussed in this article. Not that the secondary injectors is compensated, on all the graphs except the lambda control. Also during cranking the secondary's is not pulsed. During acceleration they will be pulsed even if the main graph is set at zero.

Determining if coils are on the correct plugs.

Due to the duel spark plug system it is sometimes confusing to understand why some leads can be faulty. The rotary engine allow the leading plugs to be fired in wasted spark configuration. The reason is that the non-combustion rotor is still covering the leading plug with the previous chamber. The trailing plug however is now situated in the upcoming chamber and will ignite the fuel in the intake should it be fired with the other rotor. Spitronics uses a different setup for the 3 coil wasted spark Leading coil pack. You connect both leading drivers on to the same wasted spark coil. Then it is Important to set the software to wasted spark as the firmware will then reduce charge time at high RPM to ensure that charge time does not overlap and that there is enough discharge time between charges. See the setting below.

NOTE: Always use a colder spark plug on the trailing and one size warmer on the leading for instance NGK B10EG on trailing and NGK B9EG on the leading. This will help with detonation that can be caused by a warmer plug on the trailing do to heat glow on the intake cycle

Note: Should the "Wasted spark coil per cylinder" be selected then the software will change it to Full Sequential.

To make sure that coils are setup in the right position, disconnect the drivers from the trailing coils. It is not good practice to pull off HT leads and let them spark in dry air. Reason is high voltage feedback may damage coil drivers. Now start the engine. There may be a 5% power loss but it should start easy and rev up smoothly. Get the timing light out and make sure timing is according to specs. Now disconnect the leading coils and reconnect the trailing coils. In the software set the maximum trailing degrees to zero as below. This will ensure that the trailing degrees fire the same time as the leading plugs. Now insert the trailing plugs onto their plugs. Again start the engine. If they are correct then the engine should start and rev up smoothly. There should be a power difference but no misfires. If they are incorrect there should be misfires in the intake manifold. Swop them around and try again.

Timing light degrees.

Due to 1 spark per revolution the normal timing light that does not have a 2 stroke setting will have an error in its reading. The degrees on the timing light will be double that of the actual degrees. If the timing light is on 20 it is 10 actual. If you use the wasted spark option there are 2 pulses per revolution and the degrees will be quadrupled on the timing light. If the timing light is on 40 it is 10 actual. Best way in these conditions is to set the timing light to zero degrees and work on the degrees on the engine pulley.

Determine Maximum injector time.

This is important because at high revs there is only a certain amount of time to inject fuel. This time may not be exceeded as the engine will leaned out. You may argue, that at lower RPM's you can go higher duty cycle with the primaries, but the problem is that this is not matrix and the switch over point is hard to determine. This time is calculated as follows.

Injection Time = 85% * 60 / Max RPM

= 51 / 8000

= 0.006375

Or 6.375 milliseconds

85% is recommended max duty cycle of an injector.

Max in this example is 8000 RPM

First set all the RPM graphs to 0.

To tune this unit set the Micro fuel setting on graph. There are 2 graphs available for the dual injectors. Red is for primaries and blue is for secondary's. First adjust the secondaries' to 0 right through the scale. Then at 3000 RPM adjust the primaries' from light load to full load until the max time is reached. In this case 6.3 milliseconds. Make a note of the load where max injector time is reached. About 0.84 bar. Then make the rest of the graph flat at the same value.

Now take a load just smaller than max like 0.75 bar. and look at the air fuel ratio. Lift the secondary's graph in totals till you see that the A/F ratio becomes richer. Decrease just enough till it is back to what it was. This offset will eliminate the dead band of the secondary injectors which will help to make the transition as smooth as possible.

Now you may increase the load and tune the secondary injectors to maintain the correct A/F ratio. Note that the secondaries' may also not increase the max injection time.

Lastly taper the injection time to the left off to eliminate pulse on the secondary injectors. Note the taper off is on the left where the primaries stopped working.


4+2Home 4Cyl Engines

Help > ECU Engine Managment > Specific Instructions >

4 Pulse + 2 Home Programs

Spitronics has a generic program for 3 different variations of these angle sensors. They are mostly distributor hall type sensors. This firmware is called Combo 48 4+2Home due to the number of different cars using this configuration. This firmware is used for different manufacturers like Mitsubishi, Mazda and Hyundai etc. It is up to the tuner to set it up so that coil and injection timing is correct. Or, a map from a previous install will ease this process. Note that distributors can be adjusted, but it is not advisable as it will create incorrect rotor fazing. Always leave the distributor in the manufacture position.

Crank TDC Pulse

This is the yellow pulse in the pictures below. It is used to calculate the engine degrees for spark and injection timing. There is an even 4 window signal in the distributor that gives 2 pulses per RPM which is 180° spaced apart. If the sensor is on the crank it will only have 2 teeth. The different versions may differ in length of the pulses but they are consistent in degree spacing on the rising and falling edge.

Cam Home Pulse

This is the blue pulse in the pictures below. It is used to calculate a Home signal to synchronize engine stroke. TDC will indicate to the ECU when Cylinder 1 is on TDC. This is adequate for Spilt-sequential injection and wasted spark. The Home signal will indicate when Cylinder 1 is on firing stroke. This is important to synchronize injection timing on a specific stroke for full sequential injection. Always crank the engine with no outputs connected. P1 only. Then play with the edges till no errors occur. Press C to clear the errors before cranking. If it accumulates as missing TDC or Home pulses, try another setting and clear errors again. Ignore the Error 6 Emergency shutdown when you release the key. It is normal.

Program 39 on Simulator 2 & 3

This combination below has 2 trigger setup options. The cam signal may be rising or falling. Both will produce no errors during cranking. The problem is that the actual stroke sink between the 2 settings will shift timing 180° degrees. You may have to go further in the startup procedure and look and see where is No 1 Cylinders' spark. If you don't see it then try the other setting.

or

Program 38 on Simulator 2 & 3

Program 42 on Simulator 2 & 3

Setting up Instructions

Make sure the distributor is in the factory position. Otherwise do rotor phasing as discussed in the manual. Disconnect all the output connectors and leave only P1 connected. This is important as wrong settings will fire coil times at random degrees causing starter failure. Make sure the jumper settings are set up for Hall sensors.

Crank the engine and look at the errors on the software. If it shows error 4 [image] then change the Crank(TDC) edge on the software [image] to the other selection.

It shows error 5 [image] then change the TDC edge on the software [image] to the other side.

You can press ''C'' to clear the error. There should be no error during cranking this indicates that the ECU is happy with the setup.

The ECU can now read your trigger pattern correctly but it still needs to know where TDC and Home pulse are.

TDC is important for the coils, so we begin timing from there. Connect P2 now. Disconnect the injectors and fuel pump so that there is no fuel while we work with the timing light and spark degrees.

If you use 1 coil on the engine put the settings as below.

Gear teeth is adjustable 1 or 2, which will shift the timing 180°. This is irrelevant with a distributor. Leave it on 1 then.

Set the Maximum timing to 10 degrees so that it is easy to find the timing mark.

Now put a timing light on cylinder 1 and set the timing on it to be 0°. This will eliminate timing light errors for the setup procedure.

Now crank the engine and look at the timing mark on the pulley. If it is not around 10° BTDC adjust the Timing Sensor block it in 10 degree steps to find it. Now adjust it as close to 10 as possible. You can click the arrow to increase while someone is watching with the timing light.

If you cannot find the mark with multi coil packs then it means timing is 180° out of phase. Set the [image] to 2 and start with the timing sensor at 0 again. Repeat the above process. Once you find it then you can connect the other coils as per drawing.

After this adjustment put the Maximum timing back to the original value.

Timing for fuel can be adjusted in 360 steps. This is to change the phase of injection between the 2 revolutions. Unfortunately, only gear programs can adjust different degrees on one revolution. There is no easy way to tell if you are on the right resolution but a dyno will indicate which one gives the better performance. This is usually found at low rpm loads. The setting to jump between the revolutions is [image]. It may be adjusted between 1 and 2.


Frequently asked questions

Help > TxW Controller >

Frequently Asked Questions

This chapter will shed light on certain areas where common mistakes are made. It will explain certain topics and test procedures to help you solve this problem faster without the help of a dealer. It may also save the dealer time if you do the legwork in testing before hand to the point that you need advice. Some chapters may have numbers which helps to bring the dealer up to speed on where you get stuck with solving the issue. This section is generic in all the manuals so it may cover topics not really featured in this installation manual but rather the software manual.

If your answer is not included in this section, please contact the dealer for help and forward us your query as to include any new questions in future FAQ modules.

See the sub folders for the different topics.

Image result for FAQ Image


Manual Problems with HTML

Help > TCU Transmission Management > FAQ Frequently Asked Questions >

Manual Problems with HTML

The manuals are written in HTML files. This cause anti-virus programs to suspect the data and sometimes block the content. Here are the problems that arise and how to get past them.

When downloading you may encounter this message. Select Keep.

When you open a manual you may find the list but no data.

Go to the manual file and right click on the icon. Select properties. Select Unblock and Apply.

Open the manual file again and now the content will show.


Fuel Suply Problems

Help > ECU Engine Managment > FAQ Frequently Asked Questions >

Fuel Supply

The fuel supply is mostly a basic mechanical system which is not controlled by the ECU except for switching and controlling the power of the fuel pump. some of the Ecu's have the ability to do fuel pressure control. Below is a few schematics on basic fuel flow systems.

The basic fuel rail and pressure regulator system.

External Fuel Pump

In this system the fuel pump is supplied from the tank via a petrol filter through a thick pipe at gravity feed pressures. The pump pressurizes the fuel through the high pressure fuel filter into the fuel rail with injectors. A fuel pressure regulator will bleed fuel back to the tank if the pressure is higher that it calibrated bypass diaphragms. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. The return fuel also cools the fuel pump. The fuel pump is always on full power.

Internal Fuel Pump

In this system the fuel pump is mounted inside the tank with a sift as a pre-filter. The pump pressurizes the fuel via a high pressure fuel filter through the fuel rail with injectors against a fuel pressure regulator. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. This is done by returning the excess pressure and fuel via a return line straight back to the tank. The fuel in the tank cools the fuel pump. The fuel pump is always on full power. Some systems have the pressure regulator built into the tank and then there is only one fuel line to the fuel rail and injectors. No return line.

Pressure controlled Fuel Pump

In this system the fuel pump is mounted inside or outside the tank with a pre-filter. The pump pressurizes the fuel via high pressure fuel filter through to the fuel rail and injectors. In the fuel rail a fuel pressure sensor will relay the pressure to the ECU. The ECU will speed control the fuel pump with PWM to increase or decrease the pressure. There is no return line or mechanical fuel pressure regulator. The fuel DP fuel pressure sensor also senses the manifold pressure.

Related Links

Software


Spark Problems

Help > ECU Engine Managment > FAQ Frequently Asked Questions >

Spark Problems

Work through each point below to find your problem.

1. First ensure that the setup in galaxy is done according to the startup procedure . You came to a point where you want to start and everything is according to the startup procedure but there is no spark or weak spark. The timing bar should read around 10 degrees and there should be no errors.

2. Ensure that the coils are correctly powered from the ECU relay. Do not connect them from the original vehicle power. This may damage the coils during startup of the ECU.

3. Coils require a constant battery supply on their positive or supply terminal. This power is switched via a relay so that it is disconnected during an accident or power off condition. To check that this power is present put you multi-meter on DC volts at a scale of 20 or higher. Measure on battery negative pole and the coil positive terminal. Now switch the ignition on. The power relay will come on for 3 seconds then switch of. During this time you must read 12 volt on these points. If there is no volts or less than battery voltage check the wiring for bad connections. This is no load power testing.

4. If you have dumb coils (coils without drivers) do the same test as above but this time measure on coil negative. You should see 12 volt on this point too. If not it means the coil is dead or open circuit. Replace. Intelligent coils (coils with built in drivers) cannot be tested like this.

5. Sometimes bad connections will indicate that the power is present but during load conditions the power will drop due to high resistance that is formed by bad connections. So for load testing switch the meter to AC volts and measure at the same points as point 3 above. Crank the engine. During cranking there should be close to zero volts. If there are any volts above 2 it means that the power to the coils is fluctuating which could not happen because it is connected to the battery. This will indicate a bad connection in the power supply line during load conditions. Sometimes a bad fuse connection makes this voltage drop. With the same test procedure it could be tested backwards to the problem source. It could also be due to too thin supply wires that cannot hold the current that flows through them.

6. The next problem could be in the earth line of the coil current. Normally the driver supply earth to the coil momentarily to charge the coil and then break the earth connection to fire the coil. For dumb coils the earth is switched in the ECU or external coil driver. To test this put the meter on AC volts like above and measure between the ECU earth wire on the chassis or the external coil diver's earth. Again crank the engine and see if you measure any volts. It should be close to zero volts. Above 2 volts means a bad connection in the negative earth line during load conditions.

7. Now you have established that power and earth is present at the coil or driver but there is still no spark. This means that the trigger pulse is not coming from the ECU or driver. For dumb coils put the meter on the highest AC volts scale and measure on coil negative and battery negative. Crank the engine. You should read a voltage above 100 volts. This means the driver and primary coil works. If you put a sparkplug on the HT lead and let the plug earth against the engine you should be able to see the spark. If not then the coil secondary is dead or open circuit. If you did not see any volts during cranking it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe.

8. For intelligent coils measure the trigger signal to the driver side. Here you should measure 12 volts meaning that the ECU driver is pulsing the coil. If no spark then the coil driver is dead. If you did not see any volts during cranking it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe.

9. If you use an external driver and dumb coil then measure the trigger signal on the ECU side. Again it should be 12 volt during cranking. If not it means the ECU driver is dead or it is not pulsed by the ECU for some reason in the setup maybe. If there is a pulse measure the coil negative side for the hi-voltage pulse around 100 volt. Remember to put the meter on the higher voltage scale. If there is no pulse it means the driver is dead. Replace.

10. There may be 2 faults present. So finding one may only then present the other. Test from the beginning again.


USB Cable History

Help > TCU Transmission Management > FAQ Frequently Asked Questions >

USB Communication Cable History

Communication between devices and the Tuning Software is done via a USB Cable manufactured by Spitronics. The electronic components for communication was put in a separate cable to reduce production cost and board space on the devices. The cable can work on all the current devices and are only required for tuning. The electronics in the cable consist of the USB converter as well as isolation devices. This cable will protect the laptop during high voltage interference. This cable requires drivers to be installed to operate on a laptop. They can be downloaded from the Spitronics website under Downloads - USB Drivers. The baud rate to all products are 19200.

As development progressed over the years these products were upgraded as well. Spitronics started out when USB was only in the beginning stage and very expensive to use on micro design level. They started out using a standard USB to RS232 converter for laptops that did not have serial ports. Nowadays these serial com ports are discontinued so the RS232 were abandoned and changed over to UART directly. This saved the 2 RS232 chips. One in the cable and one on the device. Later we found that during tuning the 9pin D-Sub connectors were coming loose during tuning and were also prone to static discharge doe to the metal housing. So they changed to the clip-in Molex connector which is the current cable and will stay like that for a while. So keep in mind that cables between the products do differ. In some cases, you may require an adapter to use the USB cable on older products. See below for explanation on the different types over the years. The current cable (left) clips into the device and won't fall out during tuning. It will also not be vulnerable to statics as the metal counterpart. This will be the style for the future.

History

1. TCU, EMU and Titan units were the fore runners. They used a RS232 to USB converter with a 9 Pin Male D-Sub connecter. With these units you had the option of a third party converter and breaking out pins. Note that this connecter is the same as the Mercury and Neptune one but the cable electronics is different. The electronics is not compatible with Venus, Mercury, Mercury2, Neptune, Neptune2, Pluto or Pluto2. Mark them properly so that you do not get confused. It may damage the other devices as higher voltage levels were used. Below is a picture of the cable and connecter.

The Prolific RS232 to USB converters were popular in the old days and could be used only for TCU, EMU and Titan units. Note however that you had to break-out pins 1, 4, 6, 7, 8 & 9. This is due to other connections from the ECU to the 9 pin D-sub connector. Use a small screwdriver and bend them outwards and then inwards till they break out. Do not damage the other pins. There are small numbers inside. Below is an illustration of the layout.

If you have the skills and equipment like a hot air de-solder machine, you may modify your TCU or Venus to work with the new style USB/UART cables. You need to install two connection links as well. Then you will require also the converter cable and maybe adapter to make the connection to the 9 pin D-Sub. Do mark the box that it is now using the new cable so that other dealers can see if they work on it. Below are photos that illustrate this modification. Blue is TCU and green is Venus.

2. Venus used a USB to UART converter with a 9 Pin Female D-Sub connecter. This was to stop confusion and the different connectors was easy to identify the product it was used for. But the male pins on the ECU were susceptible for static spikes. During the era of the Venus the cable changed to the isolation cable due to laptops that "hang" with interference wiring. Some of the cables had the electronics in the wire covered with heat shrink and most have it in the D-Sub holder. Below is a picture of the cable and connecter.

3. Mercury, Neptune and Venus2 were using the same electronics as the Venus cable except with the 9 Pin Male D-Sub connecter. We changed this unit back to the standard connector due to static electricity on the male pins that were exposed. Spitronics do solder the 9 Pin D-Sub connecters back to back to make USB converters between Venus, Mercury and Neptune compatible. See further in this section for details. Do not use a gender changer as the pins are mirrored and will not work. Below is a picture of the cable and connecter.

4. Pluto, Pluto2, Mercury2, Neptune2 and Orion use the new generation cable. It will be standard to all the new products released. Here Spitronics have done away with the D-Sub connecter and go for a 6 Pin Molex connecter which is the same type as the harness connectors. The reason is it is plastic which eliminates the static connection with the human body and it clips in place preventing it from falling out during tuning. It is also more durable. With this cable the electronics is also in the wire covered with a plastic enclosure. Again these USB cable's electronics is compatible with Venus, Mercury and Neptune. You only require a converter cable harness to make it work. Below is a picture of the cable and connecter.

Converter Cables

Spitronics made converter cables to interchange cables between similar products.

The cable below could convert your Mercury, Neptune and Venus2 USB cable to fit the new Pluto, Pluto2, Mercury2 Neptune2 and Orion products.

The cable below could convert your Pluto, Pluto2, Mercury2 Neptune2 and Orion USB cable to fit the older Mercury, Neptune and Venus2 products.

These bare connectors could be soldered back to back in male/male or female/female pairs to cater for Venus2 or Venus Racing cable converters. The heat shrink only covers the pins. Solder all the pins in 9 pairs.

Note that only the Spitronics USB cables are compatible with their products. They are not expensive cables.


USB Drawings

Help > TCU Transmission Management > FAQ Frequently Asked Questions > USB Cable History >

USB Cables and Converters

Cables:

USB1B Pluto Wiring Drawing

USB1B Venus Wiring Drawing

Converter Harness:

U1 USB Converter Cable

U2 USB Converter Cable


Dual Drive by Wire Throttles

Help > TxW Controller > Frequently asked questions >

Dual Drive by Wire Throttles

Due to the number of questions I decided to discuss this setup in detail.

Dual throttles was designed to split mostly V engines to run it as two separate engines. The V12 and some V8 engines used this setup. The advantage is in cruise mode one throttle operate independently from the other and can reduce fuel consumption by taking the load of half of the cylinders. It may also help in low power use to control a single throttle more effectively than one large throttle. There may be more reasons unknown to me.

These engines have two intake plenums and they are not shared with vacuum. This means that the two throttles is not balanced and does not produce the exact same manifold pressure. This will then require two MAP or MAS sensors and separate fuel calculations. Which means two ECU's which are difficult to setup and tune.

To run this engine with a dual throttle and one ECU will be impossible. You will have to modify the intake to add a runner between the 2 manifolds. This may influence the air flow dynamics of the manifold. The other option is to add one larger throttle and split it to the two intake pipes. I've seen this plenty of times and were done professionally. It is in my opinion the better modification.

There are however a few engines that share an intake plennum. We may still develop a dual controller later that will contril the 2 throttles on the same system but it will require software development.


TCU Transmission Management

Help >

TCU Transmission Management

This chapter explains all the drawings instructions and tuning around Transmission Management. View the sub folders for different sections.


RPM and Speed Sensors

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

RPM and Speed Sensors

The Orion2 TCU is a universal controller designed for most types of Optic, Hall or Magnetic reluctor sensors. It can read 2 sensors in total. Mostly Crank or RPM signal from ECU, and Speed sensors from transmission.

The drawings are based on the OT01 - P1 and OT02 - P1 harnesses. Take care to keep wires screened as close to the sensor as possible. Do not route sensitive input harnesses with HV leads or switching inductive loads. This will induce spikes in the sensor lines and confuse the TCU on what is the real signals.

The Red parts in the drawing are not always needed but if you do get interference on speed or RPM readings then you may add these components as filters to clean the signals up.

Common mistakes installers make in connecting ECU and TCU signals is that the Earth point is not on the same voltage level. As all the signals are referenced to earth this will make problems.

OT02 - P1 is for standalone applications like diesels where there is no ECU available. Here the TPS and RPM sensor is made with screened wires that brings power and earth to the sensor.

OT01 - P1 harness is made to use with ECU systems. The TPS and RPM lines are single wires and made to connect to the ECU signals. Mercury2 or Orion2 ECU's already have the Green RPM output wire and Yellow TPS output wire for easy installations. These wires can be connected together.

Below are links to the connection diagrams of the different sensors. Note that RPM connections differ between the 2 harnesses.

Speed Sensor Wiring

RPM Sensor Wiring OT01-P1

RPM Sensor Wiring OT02-P1 Stand Alone


TCU RPM Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

RPM Sensors

The RPM sensor for the TCU is important to determine the correct shift points. This will keep the engine in its optimum gear at all times. It will also prevent erratic shifting and over-revving of the engine.

The TCU is mostly used together with an ECU so the RPM signal comes from the ECU via a green wire installed in the Spitronics harness. In some cases, the RPM signal is tapped into an existing sensor and some cases it requires a sensor to be installed like on old carburetor or diesel engines. There are 2 different harnesses for these applications. See below the different connection diagrams.

RPM Sensor Wiring OT01-P1

RPM Sensor Wiring OT02-P1 Stand Alone

Do not connect the RPM signal to coil negative. It requires a signal converter board to filter out the high voltage. If it is the only option, you can use the circuit below. The caps are non-polarized. If you have a MSD device this will not work.

The RPM signal can be any pulse that is equivalent to engine RPM. It can be a bolt on the alternator etc. Some alternators have a 'W' point which can be used in the magnetic input. The pulses can be adjusted up to 60 pulses per engine revolution.

There are three types of sensors. The Inductive sensor, Optic sensor and Hall type sensor. The inductive sensor is a coil wound over a magnet. The teeth of a gear will disturb the magnetic field and that will generate a voltage spike over the 2 wires. Hall and optic sensors both give a square wave output and are treated exactly the same. They have electronic components in the sensor which convert the signals to square wave. The Hall sensor uses magnetic field where optic uses infrared light. In both cases a beam is broken and detected.

Operation of an inductive sensor:
The inductive sensor generates a voltage between the coil wires when the magnetic field strength is changed by a tooth passing the sensors. The sensor must be wired for a Falling waveform, this is best determined using an oscilloscope. The output voltage amplitude increases with increased RPM. The output voltage amplitude also depends on the gap between the sensor and the Tooth. The Minimum acceptable output voltage under cranking conditions is 3v.

Testing an Inductive Sensor:
Inductive sensors has a wired coil with a magnet. The sensor either has two or three wires from which the third wire is not connected to the coil. The sensor coil resistance may vary from 150ohm to 1200ohm. Multi meter polarity will not change the coil resistance reading. A multi meter switched to AC voltage can be used to test the sensor polarity without an oscilloscope. Connect the wires from the coil to the multi meter and move a metal object to the sensor. Look closely at the polarity indicator, if it indicates positive when moving closer and negative when moving away from the sensor then the red wire of your meter is on the positive of the sensor and the black wire of your meter is on the ground of the sensor.

Operation of a Hall Effect Sensor:
Hall sensors use a magnetic field effect to switch between a low voltage (usually 0 V) and a high voltage (5 V or 12 V) to form a 'square wave'. Both the rising and falling edges are valid reference points for the ECU input.

Testing a Hall Effect Sensor:

Hall Effect sensors normally have three wires. A supply wire (5v + or 12v +), an earth wire and a signal out. This sensor is equipped with electronic components that require power to operate. Incorrect connections will cause damage to the sensor. First test for resistance on all the pins and swop the test leads around to make sure it is not an inductive sensor. Put the multi meter on diode test and measure voltage drop over the pins. You should get a voltage drop between 0.5v and 1.9v. This is an indication that it is a Hall Effect sensor.

Now take two 1k ohm resistors and tie one end of each to 12v +. This will ensure that if you connect the supply wrong the sensor will not be damaged. Connect ground to the one sensor pin and the two resistors onto the remaining two pins. Connect the multi meter black wire for the remainder of this test. Connect the multi meter red wire onto any of the other pins. Now move a metal object to the sensor or in the gap and away. If the signal varies between 0v and 12v then this pin might be the sensor signal output. Now put the red wire on the other pin and repeat the metal process. The voltage should not change, but might be less than 12v due to the drop over the resistor. If so then this is the supply pin.

Now change the earth pin to the next and repeat the process. Note that you may get a similar reaction if you have the earth and signal pins swopped, the pin that reacts most to the iron pulse is the signal and the other the earth.

Remember this is a guideline to black box testing and not a failsafe operation.


TCU Speed Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

Speed Sensors

The Speed sensor for the TCU is important to determine the correct shift speed. This will keep the engine in its optimum gear at all times. It will also prevent erratic shifting and over-revving of the engine.

The Speed sensor is normally situated at the tail piece of the transmission. In 4x4 vehicles it is at the back of the transfer case. If there is no sensor available for the TCU, it may be tapped into an existing sensor and some cases a sensor can be installed to sense the prop-shaft bolts. The speed signal can be any pulse that is equivalent to prop-shaft rotation. The pulses can be adjusted up to 60 pulses per engine revolution. See below the different connection diagrams.

Speed Sensor Wiring

There are three types of sensors. The Inductive sensor, Optic sensor and Hall type sensor. The inductive sensor is a coil wound over a magnet. The teeth of a gear will disturb the magnetic field and that will generate a voltage spike over the 2 wires. Hall and optic sensors both give a square wave output and are treated exactly the same. They have electronic components in the sensor which convert the signals to square wave. The Hall sensor uses magnetic field where optic uses infrared light. In both cases a beam is broken and detected.

Operation of an inductive sensor:
The inductive sensor generates a voltage between the coil wires when the magnetic field strength is changed by a tooth passing the sensors. The sensor must be wired for a Falling waveform, this is best determined using an oscilloscope. The output voltage amplitude increases with increased RPM. The output voltage amplitude also depends on the gap between the sensor and the Tooth. The Minimum acceptable output voltage under cranking conditions is 3v.

Testing an Inductive Sensor:
Inductive sensors has a wired coil with a magnet. The sensor either has two or three wires from which the third wire is not connected to the coil. The sensor coil resistance may vary from 150ohm to 1200ohm. Multi meter polarity will not change the coil resistance reading. A multi meter switched to AC voltage can be used to test the sensor polarity without an oscilloscope. Connect the wires from the coil to the multi meter and move a metal object to the sensor. Look closely at the polarity indicator, if it indicates positive when moving closer and negative when moving away from the sensor then the red wire of your meter is on the positive of the sensor and the black wire of your meter is on the ground of the sensor.

Operation of a Hall Effect Sensor:
Hall sensors use a magnetic field effect to switch between a low voltage (usually 0 V) and a high voltage (5 V or 12 V) to form a 'square wave'. Both the rising and falling edges are valid reference points for the ECU input.

Testing a Hall Effect Sensor:

Hall Effect sensors normally have three wires. A supply wire (5v + or 12v +), an earth wire and a signal out. This sensor is equipped with electronic components that require power to operate. Incorrect connections will cause damage to the sensor. First test for resistance on all the pins and swop the test leads around to make sure it is not an inductive sensor. Put the multi meter on diode test and measure voltage drop over the pins. You should get a voltage drop between 0.5v and 1.9v. This is an indication that it is a Hall Effect sensor.

Now take two 1k ohm resistors and tie one end of each to 12v +. This will ensure that if you connect the supply wrong the sensor will not be damaged. Connect ground to the one sensor pin and the two resistors onto the remaining two pins. Connect the multi meter black wire for the remainder of this test. Connect the multi meter red wire onto any of the other pins. Now move a metal object to the sensor or in the gap and away. If the signal varies between 0v and 12v then this pin might be the sensor signal output. Now put the red wire on the other pin and repeat the metal process. The voltage should not change, but might be less than 12v due to the drop over the resistor. If so then this is the supply pin.

Now change the earth pin to the next and repeat the process. Note that you may get a similar reaction if you have the earth and signal pins swopped, the pin that reacts most to the iron pulse is the signal and the other the earth.

Remember this is a guideline to black box testing and not a failsafe operation.


RPM and Speed Signal Tap-In

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

RPM and Speed Sensor Tap-in

The Orion2 controllers can be tied into existing OEM circuits. There are a few rules around this to ensure that both systems operate correctly and is not damaged. It varies for the different products and sensors.

Controllers that share a sensor has to share a common earth connection. Differences in earth will have an effect on the sensors signal. So make sure you connect the Orion2 earth to the OEM earth.

Never connect the reference voltage of the Orion2 controller to any wire of the OEM sensor. Only the signal wire is connected. It may damage either controller. The sensor already has power or reference voltage from its own OEM controller. See the drawings below.

Isolate the Orion2 wires that are not used. They will have power on them and may short circuit damaging the Orion2 or harness.

If the OEM sensor is not screened it is best to tie in close to the sensor and use the Spitronics screened harness. It may reduce some interference from coils. Remember Orion2 inputs need to cater for all kinds of sensors and cannot cater for week signals with interference. If you still have interference, then you may add a 100uF and 100nF cap as filtering on their reference line. See drawings below. NB. Do make sure which line is signal and which is reference. Crank the engine and measure AC volts to ground of each point on the sensor. The one with the highest value will be the signal line. For speed sensor you may need to lift the wheels up to simulate pulses. It must detect speed at speeds from about 3 Km/H.

The blue Reference volts comes from the OEM controller and differs between car manufacturers. Some use earth as a reference, other 2.4 volt, 5 volts and even 12 volts. The isolating capacitor will block the DC volts from flowing and only let AC signal volts through. Orion2 reference its sensor to 5V. Note that Orion2 requires a minimum 1-volt peak to peak signal.

Below are the basic connections. Some cars may have a magnetic crank sensor in combination with a Hall speed sensor. Connect them accordingly. All the Orion2 P1 connectors has the same pattern for crank (Pin 12) and Speed (Pin 11) input signal. Note that harness colours differ and should be verified on drawings or GP Priority charts.

Speed Sensor Wiring

RPM Sensor Wiring OT01-P1

RPM Sensor Wiring OT02-P1 Stand Alone


TCU TPS Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Throttle Position Sensor

The throttle position sensor is used by the TCU to determine what the driver's intent is. The TCU will use the TPS, engine RPM and road speed to calculate a shift pattern to use. This sensor is very important and must be a stable signal. Most of the time the TCU will operate side by side to the ECU. The TCU can tap into the signal from the existing TPS or as with Spitronics ECU's there is a yellow wire that is installed in the harness for this signal. Do not connect any supply or earth to existing TPS connections. Just the signal wire is connected. See the drawings on this.

TPS Sensor Wiring OT01-P1 With ECU

TPS Sensor Wiring OT02-P1 Stand Alone

Operation:
The TPS is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Which Pin is which?
Use a multi-meter set to the 20,000 ohm (20 K) range.

· With throttle closed, find the two pins with the lowest resistance between them. They are C & B. The remaining pin is the 5 V pin A.

· With one probe on the 5 V pin A, find the pin whose resistance changes when the throttle moves. This is the Signal pin B.

· The remaining pin is the earth pin C.

This same route can be used on a four pin throttle position sensor, note that only three of the four pins will be connected or one pin may be a switch to ground or 5 Volt as an idle activation switch. The Spitronics ECU does not require this pin.

Pre-load the Sensor
The sensor has a dead band at either end so it must be rotated slightly to move the wiper into the operating range of the sensor.

Connecting the TCU TPS to an existing ECU TPS sensor.

TPS Sample Pin outs:


TCU Shifter Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Shifter Sensors

The Shifter sensor or Range Switch is important for the TCU to select the correct shift pattern for each shifter position. This is a requirement of the transmission. It will indicate to the TCU which gear may not be exceeded. For example, if the shifter is in position 2, the TCU will not shift above 2nd gear unless it is allowed in that position. It will also tell the TCU to engage engine brake clutches etc. this switch is calibrated in the software.

The Shifter sensor is normally situated on the transmission where the shifter lever enters the transmission. Some transmissions do not have this sensor and it may be situated in the shifter itself. Other transmissions have hydraulic switches inside the transmission. These switches may only operate when the engine is running like GM 4 speed transmissions. If there is no sensor available, you may connect the sensor wire to the reverse light or a reverse ground switch. The TCU must know when it is in reverse to prevent shifting forward gears. This is an option for first generation 4 speed boxes that were not very complicated.

There are two different types of sensors. Analogue and Digital. The TCU requires an analogue signal that can be calibrated. If it is a digital sensor, Spitronics has a converter board that convert the signal to analogue. The digital switches can be serial or parallel switches so we designed 2 different converter boards. The type is also listed with the harness numbers as well as the diode boards on the top label of your drawing. Make sure you have the correct ones before wiring.

Shifter Converter Drawing

Spitronics Shifter
The Spitronics shifter has a serial shifter switch that convert the positions to analog signal by a series of resistors with progressive values. The TCU will measure the resistance and then calculate in which position it is. Note that Orion has a 1 K pull-up resistor built into the harness because the hardware is also ECU capable.

GM Shifter sensors:
The GM transmissions have parallel pressure switches that connects to oil channels inside. The switch pattern indicates position of the shifter lever. Spitronics has a parallel converter board with progressive resistor values to convert this digital pattern to an analog signal. The drawing in the Example below is for the 5L40E.


TCU Map Selection Switch

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Map Selection Switch

The TCU can save up to 4 different tuning maps with a Map selection switch. This switch can be calibrated in the software. It is also a digital switch that is converted to analog signal with resistors. Note that Orion2 has a 1 K pull-up resistor built into the OT01-P1 and OT02-P1 harness. The hardware is also ECU capable and then do not require these resistors. If you use a different harness make sure to add the resistor to the 5 volt output on P1 Pin 9.

See the wiring diagram Below.

4 Map Switch Drawing


TCU Oil Temperature Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Oil Temperature Sensor

The Orion2 TCU can sense the transmission oil temperature and make line pressure adjustments accordingly. This will ensure the shifting is smooth even if the transmission is still cold. The sensor is situated inside the transmission and the pins is connected to the main connector. The sensor is mostly a NTC resistor. There are two inputs for different values of the NTC sensor. One is a 2K input and the other a 10K input. Depending on the type of sensor the wiring diagram will indicate the correct one to use.


TCU Tiptronic Buttons

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Tiptronic Switches

Each TCU has the ability to wire 2 push button switches for Tiptronic functions. When the Map is set to operate in Tiptronic mode, these buttons will give the driver the option to shift the transmission manually to his command. On the Ver 3.3A firmware their function can be changed to overdrive and 2nd gear start.

There are a couple of variations to the buttons but all wire in the same connections on the TCU. Please view the relevant drawings for that. Spitronics also sell a remote wireless version to build into the steering wheel and without the need for connecting wires.

Related Link

Tiptronic Switches Drawing


General Purpose

Help > TCU Transmission Management > TCU Hardware Description > Outputs and Drivers >

General Purpose

The general purpose outputs could be used for numerous control on the transmission. Each option requires different wiring. The outputs of the TCU may be strong enough to drive certain units directly and others may require a relay or amplifier.

Click on the link below for the different wiring diagrams.

Electric Fan Control

Lamp Control


Speedommeter Output

Help > TCU Transmission Management > TCU Hardware Description > Outputs and Drivers >

Speedometer Output

The Speed output can be used to drive cluster speedometers or data logger. This output is a square wave signal and has adjustable pulses to calibrate external speedometers. See the tuning software for more details.

The Orion2 output is a ground square wave signal with a 1K pull-up resistor to 12V. Most digital speedometers can be connected directly but there are 2 main types. A third type is stepper control speedometers that is controlled by the OEM TCU. This one cannot be done and it is best to keep the OEM TCU running by providing it the normal pulses it is used to.

Digital Speedometers

This type can be connected directly on the ECU Speed output. The positive and negative is usually supplied by the dash electric connections.

Magnetic Pickup Speedometers

This type requires a spike circuit that is based around earth. There is no fixed circuit that will work with all of them. Since the 12 volt square wave only goes to earth it does not trigger these speedometers. In this case a 10uF 25V capacitor can be used to isolate the DC which will generate a +/-6 volt spike circuit around earth. If you use a polarized cap put the positive to the TCU side. If their ref wire is 12 Volt you may need to turn the cap around. If you use a non-polarized cap you should be ok for both types.

You may need to add a 1K resistor in option 2 for their electronics. In some cases, they require a reference voltage on their sensor wire.

In some cases, you may require a 1K resistor on both sides as in option 3. This to ensure more energy through the capacitor. You may also need to tweak the capacitance in some cases. There is no fixed circuit that will work with all of them.


TCU Power Relay Wiring

Help > TCU Transmission Management > TCU Hardware Description >

TCU Power Relay Wiring

The TCU controls the power to the solenoids via the power relay circuit. This relay also acts as a safety cutout in case of engine stalls. When there is a RPM or Speed signal, the TCU will switch the relay output on. In case of an accident this relay will be shut down in one second after the engine and speed has died. This will stop power from making sparks during shorts to eliminate a fire. Note: Do not connect solenoid power with ignition coils or injectors as they will feed back power after the ECU is switched off. This may damage the solenoid drivers. They must be connected to the TCU power relay.

Mechanical Relays

Pin 86 of the Relay is tied to battery positive.

See the drawings for more instructions.

Click on the links below to open the relevant drawings.

Orion Power Distribution E33

Related Links

Power Connection

Safety Precautions


TCU Software Desciption

Help > TCU Transmission Management >

TCU Software Description

This software is used to adjust all parameters in the TCU. There is information, setup, graph, gear profile and real time screens. Please read the sub folders for more information on this software.


Top Toolbar

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen >

Top Toolbar

Like any Windows program you will find standard menus and buttons which relate to program settings and preferences. Offline Map files could also be selected and edited with the file button.

Notice the Version and Date in the name. this will help dealers to see if you have the latest software installed. Make sure from time to time that you have the latest version which is free from our website. Especially if you find something in the software that may function incorrectly. We fix these errors immediately and replace the version on our website.

This software is Version 3.3.5 The last 5 is a sub release as fixes etc. are made.

2018-12-13 19:15:56 is the date and time this version was released

See the sub folders for detail explanation on the Tuning, Device, File and Help menus.


Tuning Menu

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

Tuning Menu

Settings is to set up units, software and device communications and auto map save settings.

Exit is to quit the software.

Connect is to connect or dis-connect to the ECU,

Settings

Unit selection

Select Metric or Imperial units.

Language

Select Language if it is available.

Styles

Custom your own tuning pallet to suit the collars and font size that works for you. Remember these settings is saved in the Config file. If you upgrade versions, then rename your Config file to carry your settings over.

Device Settings

Max Poll error count: This is the time it takes to read the real time values from the device via the Blue Tooth serial port. Blue tooth communication is not as smooth and fast as USB communication. It requires a tolerance setting to ignore short intervals of no communication. Increase this value till the flashing LED stops flashing RED. For USB cables keep this value at 0.

Save Settings

The software will do Auto saves at time intervals. The intervals can be adjusted here. It will also have a max display list on the open file menu. Then the software will also make a backup copy of each download to ECU and it is called Device Saves. File location for these maps is in the folder where the Hyperspace is saved on the hard disk.

Hotkeys

These settings let you customise quick keyboard keys to fast track moving between screens and functions. They are completely customisable. In the factory we will set up basic keys for your convenience. You may restore to default when you chose to. Remember these settings is saved in the Config file. If you upgrade versions, then rename your Config file to carry your settings over.

Close will save your selections in the Config file and go back to the tuning pallet.


MAP Lock feature

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > TCUToolbar >

MAP Lock feature

Locking a device means entering a 6-digit password into the device. It will then require that password to unlock it and retrieve the tuning information. There is no master password so ensure you save a copy of that MAP or password for future reference in case of a device fail and you need to clone it with the same data Map. Note that on TCU Ver 3.3B and earlier you have to be in MAP 1 to lock a TCU. This button will not be available in other maps.

If a device is locked and you don't have the password, you may load another map into the device to enable tuning again. Note: The previous maps will then be cleared from flash memory. It is not retrievable.

When you are finished tuning and you want to lock your TCU you can click on the Lock button. Enter your 6-digit password twice and press ok.

Your device is locked. Close the software.

When you connect to a TCU that is locked the software will require this password. It does not matter in which map the TCU is at the time.

If you enter the password, it will unlock the TCU for as long as the software is connected to the device. If you save to device, then the password will be cleared and the TCU will be open for future connections. If you don't save to device the password will be reinstalled. Note that on TCU Ver 3.3B and earlier you have to be in MAP 1 to lock a TCU. This button will not be available in other maps.

If you don't have the lock password, press Cancel. You now have the opportunity to load a new map and cloning the TCU. Note that this will clone the device to that map, meaning that your existing data will be gone. Then all settings will have to be reset. As a precaution, disconnect all the output cables from the device to minimize damage due to incorrect output layout.

You may load an open map into the device to unlock it. Remember to go through all your settings as with a Start-up Procedure.

Click the connect button

Click Download to Device or Clone device to write all settings and calibrations to the TCU.

Click Yes

The device will now be unlocked as well as cloned to the exact map you used. This feature is handy if you want to make a carbon copy of a device. Or a spare unit for backup.


Real Time Display

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen >

Real-Time Display

This block displays all the analogue sensor values as they change in the TCU. You may change the appearance of some of the signals as well as the colors in the settings tab. Double click on certain fields will toggle between 2 types of views. Below is a description of the meaning of each signal.

Speed

This will indicate road speed.

Lockup

This will indicate if lockup is on or off as the TCU selects it.

Current Gear

This indicates what gear is selected by the TCU

Max Gear

This indicates what the maximum gear is allowed for the TCU. This is set by the driver.

RPM

This is engine RPM.

TPS

This will indicate pedal movement to tell the TCU what the driver is demanding from the engine. When it is calibrated it must move from 0% to 100% over the pedal movement.

Low Range

This will indicate if low range is selected by the driver.

Over Drive

This will indicate if overdrive is selected by the driver.

2ND Start

This will indicate if second gear pull-off is selected by the driver.

MAP

This will indicate which one of the 4 tuning maps is active.

Tiptronic

This will indicate if the tiptronic buttons are pressed.

Shifter

This will indicate which position of the shifter lever is selected.

Oil Temperature

This will indicate the transmission oil temperature.

Battery Volts

This will indicate battery charge condition, cranking and alternator volts.


TCU Information

The device information screen displays vital information regarding the Spitronics TCU that has been connected. Note: Firmware is the program that is loaded into the TCU to make the electronics operate in a specific way. This is normally a HEX file or Firm file which is loaded into the product by a USB debug programmer or BootLoader. Software is the tuning interface that runs on the computer and it is used to tune the product's parameters.

Serial Number

There is a unique number assigned to each product. It is saved on maps and recognized by the database on its status etc.

Hardware release

Displays which type of device has been connected to the software. In this case an Orion Engine Control Unit.

Hardware class

Displays the Hardware class of the product that has been connected to the software. The hardware class will determine which firmware can be uploaded onto the product. This feature allows the unit to open certain or all functions of the electronics. The amount of features determines the price of the unit. This feature can be changed over on the internet to allow for remote upgrades of the unit. The hardware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

7. Commercial

8. Racing

Product Release

The product release section displays the function of the device connected. E.g. Engine control unit, Transmission Control unit etc. The Orion hardware can be used with different firmware to control different applications like ECU, ECU, TXW etc. It is used by the software to identify if the correct firmware is connected.

Firmware Class

Displays the class of the firmware that has been downloaded onto the device. Each firmware program supplied will have a certain class according to the features used. You may load any firmware for a specific product into the unit as long as the firmware class does not outrank the hardware class. The firmware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

7. Commercial

8. Racing

Program Number

Displays the current firmware program that has been downloaded onto the device. The program is identified by a program number and description. See the firmware list of programs for the TCU.

Protocol Version

Displays the current protocol version number between the firmware and the PC software. This must be the same for the hardware and software to communicate. The firmware will indicate to the software which version of the program to open.

Firmware Version

Displays the sub version of the current firmware that has been downloaded into the device. It is an alphabetic number and has no effect on the protocol version used. This version is used when corrective firmware is released. Always use the latest version available.

Program Restriction

Displays the Firmware number which the TCU is locked to. If it says No Restriction it means that any TCU program for that TCU can be programmed into the unit, provided it does not outrank the hardware class. If there is a number, it means the TCU is locked to a specific program and only that program may be loaded onto the unit. This is for sponsored or specials which was approved by the manufacturer.

On the top bar you will find the product software version. Note that version 3.3 will be standard with the Firmware version 3.3.

The first 3 is version 3 PC Software.

The second 3 is the protocol version between the PC software and the firmware. When new features are programmed into the unit, this protocol version will change in the PC software and in the Firmware.

The .5 at the end is a sub version and has no effect on the firmware. This version will indicate corrective or improved PC software. Always use the latest version available.


TCU Setup

Help > TCU Transmission Management > TCU Software Desciption >

TCU Setup

General Settings

Engine Settings

Transmission Settings

Sensor Settings

This blocks are where all the setup values for the TCU are grouped so that the tuner can setup his transmission.

See the sub folders for explanations.


General Settings

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup >

General Settings

See the sub folders for explanations.


Map Information

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > General Settings >

Map Information

The Map information screen, Name Model and Transmission, contains info for the TCU application for a specific vehicle. This helps the tuner to recognize previous work and tuning data. It is saved in the TCU and also in PC maps. It does not affect any tuning on the engine.

Map no - The firmware consists of 4 maps for different transmission setups or tuning algorithms. This is only an indication and the map cannot be forced on this page. The map is determined by the Map Selection switch that is selected. Map no on the TCU software is also displayed in the real-time data. Maps can be changed on the fly. Map 1 and 2 as well as 3 and 4 can be changed while driving. From 2 to 3 the vehicle must be stationary. This is a failsafe for high and low range applications.

NB!! Note that the sensor calibrations can only be done in Map number 1.

Related Links

Map Switch Wiring


General Purpose Outputs

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > General Settings >

General Purpose Outputs

There are two or more general purpose GP outputs to configure for several different functions. These outputs can be configured to use the analogue signals and switch a relay on or off when certain limits have been reached.

Example: RPM for a shift light, Oil temperature to control a fan relay or Shifter to switch a reverse alarm on etc.

This is a generic block so you first need to select which output will be used.

Now select a signal to be used as an output.

RPM - RPM/min 100rpm increments

Speed - road speed at 1 Km/h increments

TPS - percentage at 1% increments

Oil Temperature - degrees at 1°C increments

Gear - select a number of gears

Shifter - select a number from the bottom line representing the following shifter positions:

1 2 3 4 D N R P

1 2 3 4 5 6 7 8

Map No - select a Map from 1 to 4

The appropriate limit values are set in the min and max blocks.

For example, for a shift light select RPM and set the minimum value at 5000 RPM when the shift light must come on. If the RPM go higher than 7000 RPM the shift light will switch off. If the min value is smaller than the max value, the relay will switch on between the limits and off outside the limits. If the minimum value is higher than the max value, the relay will switch off between the limits and on outside the limits.

Note also that the relay will switch on or off at the set value +/- 1 increment. For the above example the relay will switch on at 5100 RPM and off at 7100 RPM when the RPM increase, and on at 6900 RPM and off at 4900 RPM when the speed decrease. This means that if an RPM value hovers around a limit, there is a two value increment dead band that ensures that the relay is not switching erratic.

Note! If you don't use these outputs, select Not Used so that valuable processor time can be saved. On certain firmware these outputs will be disabled as their drivers may be used in the application for other features. These outputs are not meant to draw high current so for fans and lights use them to switch on a relay that can handle the current. See the drawings and specifications for each product.

Related Links

General Purpose Wiring


Speedometer Output

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > General Settings >

Speedometer Output

This feature is used for Speedometer Calibration. This is handy for engine conversions.

You can adjust the number of output pulses per prop shaft revolution. You can also do a fine calibration on the speedo. Always start with a calibration value of 100. Then adjust the Pulses till you are as close to the value as possible. Then go to calibration and make a Percentage adjustment to get it to read accurate. Speedos usually read a bit over to compensate for Tyre wear and keep the driver in the limits.

Note that the Speedometer Calibration block is only available in Ver 3.3C onwards.

Related Links

Speedometer Wiring


Auxiliary

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > General Settings >

Auxiliary Output

These registers are custom settings which is used for development mostly and explained in special instructions. When a new transmission is developed it may require new settings that is not placed in the software. Most standard firmware will blank out these settings.


Engine Settings

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup >

Engine Settings

See the sub folders for explanations.


Engine Configuration

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Engine Settings >

Engine Configuration

Cylinders - Number of cylinders on the engine can be selected in this block. It is not used by the current firmware but reserved for future development of different firmware.

Idle RPM - Idle RPM of the engine can be typed in this block. It is used by the firmware to release the lockup clutch if the revs fall below this value plus 200 RPM. Example if you select 800 the lockup will release below 1000 RPM's.

Engine Max RPM - Maximum RPM of the engine can be typed in this block. It is used to scale the gear profile graphs so that the whole graph can be used for tuning. It also calibrates the maximum scale of the analogue RPM gauge.

Pulses / RPM - This setting is the number of RPM pulses per engine revolution that the TCU receives. It is used for correct revolution calculation and display. Example: If you connect to a 36-1 gear then enter 35 pulses per rpm.


Transmission Settings

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup >

Transmission Settings

See the sub folders for explanations.


Transmission Configuration

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Transmission Settings >

Transmission Configuration

Gears - This setting tells the software how many forward gears are allowed for the specific Map. The user may select any number up to the maximum number of gears for that specific transmission. This is handy for low range or towing where you do not want to engage overdrive or too high gear.

Converter Stall Speed - This setting is used in some firmware programs to control the lockup minimum engage RPM's.

Maximum Speed - This setting is mainly used to adjust the maximum speed calibration of the analogue speedometer display.

Speed Sensor Pulses / RPM - This setting is the number of pulses per one prop shaft revolution received from the Speed sensor. It is used for correct speedometer calculation in conjunction with the Speedometer Calibration value. You may see this as a course adjustment but the main advantage is that uneven pulses may be used like a 36-1 gear where you would then use a value of 35 pulses. For finer calibration you need to adjust the speedometer calibrate at the sensor settings page.

Lockup TPS Low - When the TPS value drop below this setting in %, the lockup will be disengaged. This will smooth the down shifting of the Transmission. This features can be set 0% and 100% to deactivate it if you require the lockup to stay on.

Lockup TPS High - When the TPS value rise more than this setting in %, the lockup will be switched disengaged. This will protect the TCC with hi torque engines. This features can be set 0% and 100% to deactivate if you require the lockup to stay off or on.

Shift Solenoids - This setting tells the software how many shift solenoids the transmission has. In most firmware programs this setting is forced and cannot be changed.

Duty Control Solenoids - This setting tells the software how many control solenoids the transmission has. In most firmware programs this setting is forced and cannot be changed.

Transfer Box Ratio - This setting tells the software what the transfer gearbox ratio is so that when low range is selected the speed settings on the gear profiles can be adjusted.

Oil Temp Graph Count - This setting tells the software how many oil temperature graphs is active. In most firmware programs this setting is forced and cannot be changed.


Sensor Settings

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup >

Sensor Settings

See the sub folders for explanations.


Active Sensors

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Sensor Settings >

Active Sensors

This block let the tuner select the different sensors that is used for his application. Not all the sensors are used but each one has different features that makes the transmission perform at its best. If a sensor is not used, leave the block unchecked. This will free up valuable processor time. Also make sure the wiring to that sensor is properly isolated as there is power on the leads that could short circuit, damaging the TCU as a result. Some of the sensors cannot be altered or will be forced on or off by the firmware.

NB! Note that all these calibrations must be made in Map 1 as they will be the same in the other Maps,

Calibration

Some of the inputs can be calibrated by clicking on the calibrate button. This allows for a wider range of sensors to be used in the software.

RPM Sensor

This input is forced on and essential to the operation of the TCU. It can be any pulse configuration even uneven pulses. As long as you enter the number of pulses per one revolution of the engine. In some conversions you may add a sensor that scans a bolt on the crank or camshaft as the engine may be of a carburetor type. It is not possible to control the engine without this signal. This signal is normally connected on the ECU.

Battery

This input is not used in the TCU control parameters at this stage but merely an indication for the tuner. It may be used on the GP outputs to switch on a battery low lamp which indicates that the alternator is not charging.

TPS

This sensor indicates to the TCU what the driver's intent is. It is also used for features such as kick down, lockup control and smooth shifting. It is not possible to control the transmission without this sensor. This signal normally is connected from the ECU. For the TCU to operate correctly this sensor needs to be calibrated. Click on the calibrate [image] button left of the TPS check box and do the following procedure:

Now press [image] button and Press the fuel pedal in completely and release the pedal completely. The Min and Max values will be indicating the range of the TPS.

The TPS value must increase with throttle depression. If it is decreasing, click on Polarity to select rising or falling edge. This feature is normally used where the original TCU is still connected and wiring cannot be altered. In this case you connect only the TCU TPS signal wire to the ECU TPS signal wire. Do not connect the ground or 5 volt signal wires but isolate them to prevent shorts.

Click the Save button. You may now test the TPS signal by pressing the pedal in and releasing it. The TPS real time value should operate from 0 to 100%. Then click on the Save to TCU [image] button to make the changes permanent.

Speed

This sensor indicates road speed to the TCU. It is also used for features such as kick down, gear down and smooth shifting. It is not possible to control the engine without this sensor. This signal is normally connected at the back of the transmission to measure prop shaft rotation. This sensor is set up in 2 parts. Firs input the number of pulses per one prop shaft rotation in the

block. Click on the calibrate [image] button left of the Speed check box.

Change the offset value till the speed value reads the same as the car, speedometer or as a GPS reading. Click the OK button. Then click on the Save to TCU [image] button to make the changes permanent. If you are not sure what the pulses value is then start with a 110 value here and adjust the speed sensor pulses/RPM till the speed is as close to real speed. Then do offset value again. If the offset value is very low or very high, then speed calculation becomes erratic.

Oil Temperature Sensor

This sensor indicates transmission oil temperature to the TCU. It is not used in all TCU firmware but it does help to smooth shifting when the transmission is cold. There are 2 selections for different sensors. Normally 2k or 10k which alter the sensor calibration. Note that this does use a different wire in the harness as well. Select None if it is not used.

This sensor can be calibrated slightly but it is only an offset adjustment to make it accurate at a critical temperature. Most firmware is pre calibrated for that sensor on the TCU. Click on the calibrate [image] button.

Now adjust the offset value to match your accurate thermometer. Click the OK button. Then click on the Save to TCU [image] button to make the changes permanent.

Low Range Switch

This feature indicates to the TCU when low range is selected. This will do an automatic adjustment on the speed values entered in the gear shift profiles. The arrow will select the signal logic for low range. Note that light on the real-time bars must be green when low range is engaged.

Set the ratio for the transfer box in the [image] block. Check the wiring diagrams to connect it properly.

Overdrive Switch

Overdrive function was used on the older vehicles but today tiptronic buttons took this to the next level where you could select any gear as the highest in certain driving conditions. But you may select the overdrive function if you prefer it. Note that this function will disable tiptronic and then the tiptronic upshift button becomes the overdrive button. If you don't wire in a button, you can still use the overdrive function with the map switch to enable or disable overdrive on different map. You may also use the Gears function [image] to select the max gear. The arrow will select how the overdrive is activated on start-up in different maps. If it is on top arrow, then it means that the transmission will go to the high gear. If it is on down arrow, then the transmission will go to high gear one. If the overdrive button is pressed and released the overdrive function is toggled on or off. On some TCU's there is an output that could be wired to a lamp indication for the dashboard. Alternatively, the dash displays may indicate these functions. Note that if you do use an OEM overdrive switch check the wiring recommendation for the specific TCU. They differ between the products.

Second Gear Start

This function is very handy in snow or slippery roads to minimise torque and also used in low range driving. Note that this function will also disable tiptronic and then the tiptronic downshift button becomes the second gear button. If you don't wire in a button, you can still use the second gear function with the map switch to enable or disable second gear pull-off in different maps. The arrow will select how the second gear is activated on start-up in different maps. If it is on top arrow, then it means that the transmission will pull off in second gear. If it is on down arrow, then the transmission will pull off in first gear. If the second gear button is pressed and released the second gear function is toggled on or off. On some TCU's there is an output that could be wired to a lamp indication for the dashboard. Alternatively, the dash displays may indicate these functions. Note that if you do use an OEM overdrive switch check the wiring recommendation for the specific TCU. They differ between the products.

4 Wheel Drive

With Version 3.3C and onwards there is an all-wheel drive selection for certain transmissions like Subaru.

This feature will allow the user to select a manual On/Off switch or an automatic graph with TPS activation. If a switch is wired in, then the user may also select negative or positive signal for activation. This will allow it to be tapped into an existing OEM installation if such a switch exists.

If he switches the selection Off, and firmware is written for the graph, then another graph will become visible on the duty cycle graphs. The solenoid can then be faded in or set on or off by adjusting the graph.

Related Links

Sensor Wiring


Shift Base Algorithm

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Sensor Settings >

Shift Base Algorithm

This block is for future use on specific firmware. Current firmware can only base calculations for profiles on the RPM signal with Speed limits implemented. In future firmware will be developed for speed base calculations.


Tiptronic Options

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Sensor Settings >

Tiptronic Options

This block gives the tuner options on how he would like to set up the tiptronic operation and LED indication for each Map. This is useful for modes like towing, racing and low range. If it is used as automatic only without buttons, select Not used. These modes may be set up differently for each of the 4 maps.

Automatic

This is a standard feature on most cars today. The driver uses the tiptronic buttons to set the desired gear for the TCU. This does not control the shift directly but merely the indication to the TCU which gear should not be exceeded during driving. This is useful in a pass where you go uphill and need a lower gear. If you release the throttle in a corner the TCU will select a higher gear only to gear down again when you press the throttle after the corner. There is no different tuning on the gear profiles for automatic.

This desired gear is indicated as MAX GEAR on the software. When you press the downshift button the TCU will downshift one gear if it is allowed. The max indicator will then indicate the current gear that you are in. Another press will downshift one gear again if it is allowed and the max indicator will follow. If a gearshift is not allowed, then the TCU will do nothing. This may be the case when the speed for the lower gear is too high. If you slow down the TCU will shift down but leave the max indicator where it is, then it will upshift to that indicator value but will not shift higher. Should the driver press upshift button the max indicator will increment one gear per push till highest gear is reached.

So in short explanation you can tell the TCU what is the highest gear that it is allowed to shift to. With the downshift feature when the engine labor or you want to preselect lower gear for an upcoming hill.

Should he however accelerate to maximum revs where the marker passes the blue top dot on its right side, the transmission will select a higher gear to prevent over revving. It will also set the Tiptronic Max to the current gear.

If the driver is stationary and press the down button, the desired gear select will be 1st.

Then he can dictate up gears at higher rpms with the upshift button.

Semi-automatic

This feature is more direct and will shift the transmission directly if a legal shift can be performed. This mode is used for towing where it is difficult to set the transmission up for different loads. Here there are changes on the profile maps to move the up and down shift points further from normal automatic mode. This means the middle dot of the blue line moves more to the right and the middle dot of the brown line move more to the left. This will cause the engine to go higher in revs before upshifting and lower in revs before down shifting. Then the driver can decide when a shift is required and shift the transmission with the buttons. The TCU will shift up and down when low speed or high RPM's is achieved, making the transmission still semi-automatic and drivable.

Manual

This mode is completely manual. It is used for off-road driving or Dyno tuning. The driver can select the gear while standing still and then the transmission will pull off in that gear. This is useful in sand and snow when the driver need to pull off in 2nd gear. The transmission will stay in that gear even if the engine over-rev. This is useful in 4x4 mode where a steep slippery hill must be crossed. The lockup clutch remains in automatic mode and will only engage under low load conditions. Remember that when driving in loose sand or on the Dyno. The transmission may over-heat due to the lockup that is not engaged and creating heat in the circulating oil. You may need to back off the power to engage the lockup and then put the power back on.

LED

The 2 LED's on the dashboard may be selected to indicate in function mode where the green is the lockup clutch and the red is the desired gear selected or in gear mode where the 2 indicate in binary code which gear is selected by the TCU. This function is disabled in Ver 3.3A firmware. This is an old generation feature and new firmware will blank it out.

Related Links

Tiptrinic Button Wiring


Shifter Sensor

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Sensor Settings >

Shifter Sensor

This block will set up the type of shifter position sensor on different transmissions. Some will be blanked out by the firmware and other will leave the installer choices on his method of wiring. Note that the TCU is mostly concern in reverse so that it will prevent shifting gears as the shift solenoids as this action will put some transmissions in neutral or lock mode which can be detrimental.

Pot Input

The software will indicate all the shifter positions if the TCU has a signal representing all the different positions. This selection is for shifters with a potentiometer to indicate the lever position like the Spitronics Shifter or some Ford shifter models. Spitronics also manufacture a resistor encoder board for shifters with complex logic selector switches. The advantage is that the TCU only requires one input for multiple switches. This values for the shifter must be calibrated If this button is not available it is either Pre Ver 3.2 firmware or the TCU is currently on a Map greater than 1. In the last case click on 1 Map do the calibration and then click on 4 Map Switch before you save the data to TCU. The older versions were preprogrammed and could not be changed. Note than most transmissions require the shifter sensor to prevent solenoid operations in certain shifter positions and for the transmission to operate correctly. Also to activate Squad functions to eliminate transmission shock when lever move to R or D positions.

Reverse Low

This setting is used where a switch is mounted on the shifter which gives a ground signal when reverse is selected. Note that the software will only indicate drive or reverse.

Reverse High

This setting is used where the signal is connected to the reverse light between the switch and the bulb. It is a positive signal that switch on the reverse lights. The bulbs need to be working as they act as pull down resistors. Note that the software will only indicate drive or reverse.

Click on this button to enter calibration mode.

If your shifter or transmission has only 3 positions, 3 & 4 will be hidden.

Put the Shifter in Park. As a test you can go through all the positions to position up to 1st in sequence to see if the real time value change significantly. Note that the value must change for each position of the shifter. Some shifters have the same value in park and neutral then only park will be indicated on the software.

Put the Shifter in Park and click on P. It will become green. Go through the other positions R, N, D, 2 & 1. Put the Shifter in Park again and click Save & Close. Then click the save to TCU button to make the calibration permanent.

Related Links

Shifter Sensor Wiring


Map Switch Sensor

Help > TCU Transmission Management > TCU Software Desciption > TCU Setup > Sensor Settings >

Map Selection

The TCU has the feature of setting up to 4 different Maps for the transmission. This can be normal Automatic mode, Towing Mode, Tiptronic Mode, Racing Mode, low range mode etc. Should a TCU start with the wrong selection due to pre setup, you may select 1 Map and first set the TCU up with all calibrations. Then select the 2 Map Buttons or 4 Map Switch selections and load the relevant Maps in them.

1 Map

This is for standard cars where the driver only need automatic mode.

2 Map buttons

This mode has 2 Maps and require the Tiptronic buttons to be installed. Pressing the Down button for 2 seconds will switch to Map number 2. Pressing the Up button for 2 seconds will switch to Map back to number 1. Note that the software will disconnect and then reconnect. It may take a couple of seconds. This is to read the new data from flash memory in the TCU. The TCU will do this in less than a second though. It can be done while driving. Also note that the TCU will default to Map 1 on startup.

4 Map Switch

This mode requires a rotary 4 Map switch to be installed on the TCU. Each position will activate the relevant Map to be used. Note that Map 1 and 2 may be changed while driving also 3 and 4. But 2 to 3 or 3 to 2 must be stationary. Should you switch to them while driving, nothing will happen until the speed is 0 km/h. Note that the TCU will start in the Map where the switch is positioned. This switch must be calibrated to suit different styles and versions of the Map selection switch. Note that this calibration is always in mode one and is saved in the TCU. Loading other maps will not alter the calibration. If this button is not available, it is either Pre Ver 3.2 firmware or the TCU is currently on a Map greater than 1. In the last case click on 1 Map do the calibration and then click on 4 Map Switch before you save the data to TCU. The older versions were preprogrammed and could not be changed.

Click on this button to enter calibration mode.

Put the Map switch in position 1. As a test you can go through all the positions to position 4 to see if the real time value change significantly.

Put the Map switch in position 1 and click on 1. It will become green. Go through the other positions 2, 3 & 4. Put the map switch in position 1 again and click Save & Close. Put the Switch selection to 4 Map Switch again. Then click [image] to make the calibration permanent.

Note that the other Maps may not have data in and then the software will indicate Setup data could not be read. In this case click on Cancel and load a map into that Map memory.

Related Links

Map Selection Wiring


Gear Shift Profile

Help > TCU Transmission Management > TCU Software Desciption >

Gear Shift Profile

These profiles are used to set up each gear to shift on its own pattern and according to certain criteria. This feature will let the installer set up the TCU for custom drive trains to the liking of his customer. The up and down shift algorithms can be manipulated with ease.

Marker

This Red circle is called the Marker. It is a graphical point on the graph that indicates the crossing point of the vertical TPS signal with the horizontal RPM signal. It let the user see where the crossing point is and when it passes the shift lines.

Brown down shift line

When the marker moves over to the left of this line a down shift will occur. This is usually when the RPM's drop too low in a gear or the throttle is pressed and the engine needs a lower gear to accelerate.

This line has 3 dots.

· The bottom dot will always stay on the 0% TPS line. This dot is used to shift down at closed throttle and low RPM's.

· The top dot is usually set at 90% throttle and more or less in the middle of the RPM range. This dot is used as a safety limit for the maximum RPM's where shift down may occur. If the marker is on the right side of this dot, even if it is lower in TPS, the TCU will not shift to a lower gear. When you choose a RPM value for this dot, make sure that after the shift there is still RPM's to gain in the lower gear. Otherwise the TCU will have to shift up immediately causing hunting in the transmission.

· The middle dot is normally set on 40% TPS value and slightly to the right of a straight line between the top and bottom dot. This will let the transmission shift down at lighter throttles during acceleration from higher gears. This will to help get the vehicle move with ease without laboring the engine.

Blue up shift line

When the marker moves over to the right of this line an up shift will occur. This is usually when the RPM's increase too high in a gear or the throttle is release after the required speed is achieved. Then the engine needs a higher gear to coast.

This line has 3 dots.

· The bottom dot will always stay on the 0% TPS line. This dot is used to shift up at light throttle and low RPM's.

· The top dot is usually set at 90% throttle and more or less at maximum RPM range. This dot is used as a safety limit for the maximum RPM's to prevent engine over revving. When you choose a RPM value for this dot, make sure that after the shift the engine did not reach the engine limiter due to the shift time. In 1st gear you may need to drop this value as the engine pick up revs very fast and the transmission take around 2 seconds to do the actual shift. This may cause the engine to over rev.

· The middle dot is normally set on 40% TPS value and slightly to the right of a straight line between the top and bottom dot. This will let the RPM increase more before shifting at low throttle position. This will to help get the vehicle move with ease without laboring the engine.

Gear number and lockup.

This block indicates which gear's profile are being adjusted. If you click the arrows it will select between the profiles. The lockup check box will indicate to the TCU that you want to engage lockup clutch in the torque converter for this gear. Note that lower gears normally have too little time to use this feature. The standard is usually the top 2 or 3 gears. You may in tiptronic off-road select it in each gear as you spend some time in it. Note that not all transmissions have the lockup available in lower gears.

Gear down speed

This block is used to force a down shift to the lower gear when the road speed falls below this value. The reason is that if a lockup clutch did not engage the RPM will fall to idle due to the slippage in the converter. Then the TCU will shift down causing the shift to be harsh. In this case lower the brown bottom dot to an RPM that is lower than idle. This will prevent downshift at low RPM and force down shift only if the rad speed is slow enough. This is also the case with Aisin transmissions where 1st and 2nd gear has free running clutches. If you go fast in the gear and release the throttle the engine will fall to idling.

Note that in first gear this value is used as an upshift limit. The reason is that if you are on a downhill and let the car coast by itself, it must engage second gear. Here a value of around 10km/h is selected. As the road speed increase with closed throttle above this value, then 2nd gear will be selected. This will put the transmission in the correct ratio when the driver start to accelerate.

Gear shift time

This block is used to give the transmission time to complete a shift before the next shift will be made. The reason is that the transmission is mechanical and it takes up to 2 seconds to complete a shift procedure. If the time is too short the TCU will start comparing the marker and speed values for the next shift. The result will be that the transmission will skip gears. Note that the TCU cannot shorten actual shift times, it has to be modified by a transmission specialist.

Kick down speeds.

When the road speed is above this value, no down shift will occur. This acts the same as the top brown dot but just with a speed setting and with the exception that the shift time is ignored. The reason is that road speed is not influenced like RPM's due to torque converter slippages. The advantage of this setting is that it enables the TCU to shift 2 gears simultaneously during hard accelerating from a slow cruise in a higher gear. Like overtaking a car when the transmission was in a high gear coasting. The TCU will shift one gear down then wait for the shift time to time out. But if the road speed is lower than the kick down speed, the TCU will shift immediately to a lower gear. This happen very fast and the transmission will shift 2 gears.

Reset profile

This helps the tuner to put all the dots on the tuning pallet if no map is loaded in the TCU. They are not necessary placed where they should be.


Pressure Graph

Help > TCU Transmission Management > TCU Software Desciption >

Pressure Graph

This graph will determine the line pressure which acts on the clutches. This pressure is a pulse width modulation signal and is calculated according to the throttle position. It is critical that the TPS is calibrated and operates correctly.

Duty solenoid 1 is usually for the line pressure. The higher the Duty Cycle, the less the line pressure will be on the clutches. Never go higher than around 70% Duty Cycle at light throttle as this may damage some control solenoids. Always go for the lowest value without the shift being too harsh. If you feel slippage during shift, back off the throttle immediately and decrease the graph setting at that TPS value. These clutches are not made to endure slippage and will damage permanently.

Duty solenoid 2 & 3 are firmware specific and can be viewed in the special files.

Graph selector

Click on the dropdown menu to select a graphs to tune. You may press the "T" button to toggle between them. The "H" button will hide or show all 3. Note that some firmware will only allow 1 graph to be available.


Temperature Compensation

Help > TCU Transmission Management > TCU Software Desciption >

Temperature Compensation

This graph is used to compensate line pressure with temperature. A cold transmission will shift harder. Depending on specific firmware this graph will compensate either line pressure or shift control pressure. The example above is line pressure. If it is for shift pressure the graph may have a rising slope.

When tuning a transmission from the start disable the temperature sensor. Then afterwards enable it and modify this graph when it is cold so that it could shift softly. Don't go too soft as it may slip in some cases. Note that this graph should cross the zero line at working temperature.


Transmission Drawings

Help > TCU Transmission Management >

Transmission Drawings and Info

Look in the Sub folders for your transmission. If it is not there, please ask your dealer to find out if it is in the process of being developed. The info covers all the drawings and connections around the specific transmission. Please report any errors to info@spitronics.com so we can update immediately.


Aisin A343E 4Speed

Help > TCU Transmission Management > Transmission Drawings >

Aisin A343E 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with OT01-P1 Harness

Orion2 Aisin A343E Drawing

Use as Stand Alone with OT02-P2 Harness

Orion2 Aisin A343E Stand Alone Drawing

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT02 - P Input Harness Stand Alone

OT03 V2 - P2 Output Harness

E36 V2 - P3 Output Harness

OT20 - Comms Buttons Harness

Other Harness Options

E31 V2 - P2 Output Harness

Diode Board.

DB1 Positive Diode Board

A343E Freewheel Diode Schematic

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Aisin A343E 4Speed Connection Layout

Hardware Class Comparison

Aisin A343E

Tyre Calculator

Tyre Calculator Aisin A343E (Excel)

Packing List

Orion2 Aisin A343E Packing List (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


Ford 4R44E

Help > TCU Transmission Management > Transmission Drawings >

Ford 4R44E 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with OT01-P1 Harness

Orion2 Ford 4R44E Drawing.pdf

Use as Stand Alone with OT02-P2 Harness

Orion2 Ford 4R44E Stand Alone Drawing.pdf

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT02 - P Input Harness Stand Alone

OT03 V2 - P2 Output Harness

E36 V2 - P3 Output Harness

OT20 - Comms Buttons Harness

Other Harness Options

E31 V2 - P2 Output Harness

Diode Board.

DB2 Negative Diode Board

Ford 4R44E Freewheel Diode Schematic

Shifter Converter Board

GP Priority Layout

Ford 4R44E 4Speed Connection Layout

Hardware Class Comparison

Ford 4R44E

Tyre Calculator

Tyre Calculator Ford 4R44E (Excel)

Packing List

Orion Ford 4R44E Packing List (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


Ford AODE 4R70W 4Speed

Help > TCU Transmission Management > Transmission Drawings >

Ford AODE 4R70W 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Orion TCU Ford AODE 4R70W Drawing

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT03 V2 - P2 Input Harness

OT20 - Comms Buttons Harness

Other Harness Options

OT02 - P1 Input Harness (Stand Alone System)

E31 V2 - P2 Output Harness

E36 V2 - P3 Output Harness

Diode Board.

DB2 Negative Diode Board

GP Priority Layout

Ford AODE 4R70W 4Speed Connection Layout

Hardware Classes

Ford AODE 4R70W

Tyre Calculator

Tyre Calculator Ford AODE 4R70W (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


GM 4L30E

Help > TCU Transmission Management > Transmission Drawings >

GM 4L30E 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with OT01-P1 Harness

Orion GM 4L30E Drawing

Use as Stand Alone with OT02-P2 Harness

Orion GM 4L30E Stand Alone Drawing

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT02 - P Input Harness Stand Alone

OT03 V2 - P2 Output Harness

OT20 - Comms Buttons Harness

Other Harness Options

E31 V2 - P2 Output Harness

Diode Board.

DB2 Negative Diode Board

GM 4L30E Freewheel Diode Schematic

Shifter Converter Board

CON1 Parallel A/D Converter

GP Priority Layout

GM 4L30E 4Speed Connection Layout

Hardware Class Comparison

GM 4L30E

Tyre Calculator

Tyre Calculator GM 4L30E (Excel)

Packing List

Orion GM 4L30E Packing List (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


GM 4L80E

Help > TCU Transmission Management > Transmission Drawings >

GM 4L80E 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

GM 4L80E TCU Drawing

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT03 V2 - P2 Input Harness

E36 V2 - P3 Output Harness

OT20 - Comms Buttons Harness

Other Harness Options

OT02 - P1 Input Harness (Stand Alone System)

E31 V2 - P2 Output Harness

Diode Board.

DB1 Positive Diode Board

Shifter Converter Board

CON1 Parallel A/D Converter

GP Priority Layout

GM 4L80E 4Speed Connection Layout

Hardware Classes

GM 4L80E

Tyre Calculator

Tyre Calculator GM 4L80E (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


ZF 4HP18

Help > TCU Transmission Management > Transmission Drawings >

ZF 4HP18 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Orion TCU ZF 4HP18_Drawing

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT03 V2 - P2 Input Harness

E36 V2 - P3 Output Harness

OT20 - Comms Buttons Harness

Diode Board.

DB1 Positive Diode Board

Shifter Converter Board

CON1 Parallel A/D Converter

GP Priority Layout

ZF 4HP18 4Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator ZF 4HP18 (Excel)

Packing List

Orion ZF 4HP18 Packing List (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


ZF 4HP24/22

Help > TCU Transmission Management > Transmission Drawings >

ZF 4HP22/24 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with OT01-P1 Harness

Orion TCU ZF 4HP22_24 4 Sol Drawing

Orion TCU ZF 4HP22_24 5 Sol Drawing

Use as Stand Alone with OT02-P2 Harness

Orion ZF 4HP22-24 4Spd 4Sol Stand Alone

Orion ZF 4HP22-24 4Spd 5Sol Stand Alone

Default Harnesses

OT01 - P1 Input Harness (ECU Connections)

OT02 - P Input Harness Stand Alone

OT03 V2 - P2 Output Harness

OT20 - Comms Buttons Harness

Other Harness Options

E31 V2 - P2 Output Harness

Diode Board.

DB2 Negative Diode Board

Orion ZF 4HP24 FreeWheel Diode

Shifter Converter Board

CON1 Parallel A/D Converter

GP Priority Layout

ZF 4HP24 4Sol 4Speed Connection Layout (Pdf)

ZF 4HP24 5Sol 4Speed Connection Layout (Pdf)

Hardware Class Comparison

ZF 4HP24 4 Sol

ZF 4HP24 5 Sol

Tyre Calculator

Tyre Calculator ZF 4HP22_24 (Excel)

Packing List

Orion ZF 4HP22_24 Packing List (Excel)

Old Harness Layout

This is not recommended for Orion but merely for backwards compatibility explanations. Some are discontinued.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness

E28 Input Harness E21 Output Harness P03-P3 Harness

E29 Input Harness E23 Output Harness P05-P3 Harness

E34 Input Harness E23 V2 Output Harness

E35 Input Harness E26 Output Harness

E27 Output Harness

E27 V2 Output Harness

E31 Output Harness

E32 Output Harness

E33 Output Harness


TCU Startup Procedure

Help > TCU Transmission Management >

Startup Procedure

The Startup procedure is a very important procedure, as to prevent damages to the TCU and Transmission. If at any time the clutches slip, back- off on the throttle immediately! Increase the line pressure and/or check if the fluid levels are correct. Do not continue if problem persists as the clutches are very delicate and can damage in seconds.

Transmission and system preparation:

Before you connect the TCU do the following:

1. If it is a conversion, service the Transmission filter and oil. Make sure if the Transmission uses the correct ATF or synthetic oils. Check the oil level when the engine is running in drive.

2. First, ensure that the installation is correct according to the Hardware Installation procedure.

Connecting the TCU for the first time:

You may now proceed with the following steps.

* If any steps do not correlate with the TCU operation, stop and look for the faults. Ensure that the TCU is earthed correctly!!!

1. Remove the solenoid fuses.

2. Connect only the 12 way connector leaving the 10 way connector open. Switch the Ignition on. Do not start the Engine. The yellow LED on the TCU must come on, if the yellow LED does not come on switch off immediately as there may be a short on the 5 Volt output that will damage the TCU!

3. Now switch the Ignition off and connect the Laptop to the TCU. Switch it on again. Start the PC software and connect to the TCU. The Transmission data i.e. the TPS and gear position should be displayed.

4. Start with MAP 1 in automatic. If, however it shows MAP 2 or more, click on 1 MAP or turn the map switch to MAP 1.

5. Go through the setup page and ensure all the settings are correct for your specific Transmission.

6. Calibrate the TPS sensor and save the calibration as described under active sensors. The TPS and speed sensor must be calibrated in MAP 1.

7. Calibrate the shifter so that all positions show correctly. Some transmissions such as GM use pressure switches, therefore the engine need to idle.

8. Start the engine and make sure the rev counter is calibrated.

9. Switch the ignition off and connect the 10 way connector. Replace the fuse and start again.

10. Put the shifter in drive and the software on the gear profiles. Pull off in first and check that the speedometer works.

11. If the gears are slipping, reduce the line pressure on the graph according to the tuning principles.

12. Calibrate the speedometer by asking a passenger to set the calibration value till it reads the same as the cars speedometer or a GPS. Alternatively do this procedure with the wheels off the ground and compare to the vehicles speedometer. Once you are on the road use the GPS for accuracy.

13. Check if the transmission selects all the gears and gear backs.

14. Do fine tuning according to the tuning principles.

15. Save the data for that profile and start tuning the other profiles and functions.


TCU Tuning

Help > TCU Transmission Management >

Tuning

The TCU normally comes with standard gear profiles loaded. These profiles are just startup profiles to test the unit. Transmission setup differs too much to make standard maps for it due to the many variables like engine power specifications, final drive ratios, wheel sizes, fuel type and application requirements. In most cases you wall have to tweak maps or start over with a fresh tune.

This section will guide you to setup different scenarios for your application like Automatic, Racing, Towing, Snow, Sand, Mud Low Range and Manual to name a few.

Each transmission comes with a Tyre Calculator to assist you in setting up the correct speed and RPM values. You will have to enter parameters like:

Engine Max RPM

Engine Idle RPM

Final Drive or Diff Ratio

Torque Converter Stall Speed

Wheel Size like eg. 255 / 55 / 17

These values can then be entered in the software map.

Always start with Profile 1 in automatic mode as this is the profile in which you have to calibrate all the sensors, so that it is the same for the other profiles. Any calibration in other profiles is not available. Calibrations are not changed by loading maps. They have to be adjusted in real time on the TCU. (See Cloning in the manual to preload calibrations.)

Note. The buttons have built in denounce features. If you press them too fast they will not respond. If you press them during the Shift Time cycle they will also be ignored. If you press them too long, then you may activate map change if the 2 buttons are selected. So give the TCU ample time to complete each action before you press them again.

See the sub folders for more info.

Automatic Mode

Semi Automatic Mode

Manual Mode


Automatic Mode

This is the normal mode for your vehicle where you will use it every day like town and open country driving. This mode is used with Tiptronic in Automatic selection. The buttons will merely tell the TCU which is the highest gear to use. It will down shift if it is permitted. If you selected Maximum gear to be 3 for example, then it will ride automatic up to third gear. Up and down shifts will commence as usual.

This mode can also be slightly changed as a Towing mode where you require the engine to shift at higher RPM's and do downshifts quicker to keep the engine in the torque band. This will be called Towing Map and saved in another Map position. Usually map 2 because map 1 and map2 can be changed on the fly. Map 2 to 3 or 3 to 2 must be changed at stand still.

Another variation is Sport map where you also select gears at higher RPM's to make the engine more responsive. Very much like the Towing map.

Procedure of Tuning.

Use this guide if you don't know the final drive ratio or wheel sizes so that you can use the Tyre calculator. (Wheel sizes is written on the sidewalls like 225/55/17)

Standing Still

1. First go through the setup and enter all the relevant settings that you do know.

2. Calibrate the TPS sensor.

3. Start the engine and check the rev counter calibration is correct, then save the data and switch the engine off.

4. Switch the ignition on and do the following settings while you are standing still.

5. Start with the following option settings.

Set the Gear-Down Speed to zero and the Kick-Down Speed to 200 for all the gear profiles as below.

Set the Gear-Up Speed for first gear to 100 as in the block below.

This will disable the speed settings so that you can set the RPM settings first. It will not work for Tiptronic as you do need the required speed settings.

Top Dots

Then set the Up Shift (Blue Line) High Dot to 90% TPS value, and to the maximum RPM value allowed for that gear. Do this for each gear. Set Gear 1 a bit lower to compensate for the shift time of the transmission. If it is too high the engine will over-rev.

Now set the Down Shift (Red Line) High Dot to 90% TPS value and half of the maximum RPM value allowed for that gear. Do this for each gear. An example is, if you want a gear to reach 6000RPM under WOT, adjust the Down Shift High Dot to 3000RPM. This will be a safe value to start with, so that shift down does not over-rev the engine.

Bottom Dots

Set the Up Shift (Blue Line) Low Dot to idle RPM plus 800 RPM. An example is if idle RPM is 800, set this Dot to 1600RPM. Do this for each gear and add 100RPM to the next gear.

Now set the Down Shift (Red Line) Low Dot to idle RPM plus 200 RPM. An example is if idle RPM is 800, set this Dot to 1000RPM. Do this for each gear again adding 100RPM per gear. This will ensure that the gear does shift back when idling RPM is reached.

Middle Dots

Then set the Up Shift (Blue Line) Middle Dot to 40% TPS value, and set the RPM value slightly right form a straight line between the Low and High Dot. Do this for each gear.

Now set the Down Shift (Red Line) Middle Dot to 40% TPS value, and set the RPM value slightly right form a straight line between the Low and High Dot. Do this for each

Preparation is now done and the gearbox should shift and make the vehicle drivable. Save this to the TCU.

Driving and Basic Settings

Start the engine and pull off in drive. Find a quiet level road and calibrate the speedometer.

Should the transmission at any time feel like slipping, immediately back off the throttle and decrease the line pressure graph at that TPS setting. (It is the blue graph 1.) These clutches are small and will burn quickly and also burn the oil. If the transmission has more than one control solenoid, see the specific instructions on how to adjust the different graphs. Note, lowering the blue line pressure graph will increase line pressure that will result in a firmer shift. This may be transmission specific so make sure you have the special instructions document handy.

The first setting to adjust is light throttle pull off. Push the throttle to about 5 to 10 % TPS value and feel each gear when it shifts forward. This is an important setting if you crawl in traffic. If it shifts too quick to your liking, move the Up Shift (Blue Line) Low Dot more to the right and vice versa. Do this for each gear.

The next setting to adjust is low throttle gear down. For this setting we use the Gear-Down Speed setting. It is better to use actual road speed for gear down than RPM's. The reason is that torque converter's slip gives a false sense of drivetrain RPM's at low engine RPM's. This is due to the stall speed of the torque converter. There is also a difference in RPM when the Torque Converter Clutch is engage or not. Another reason is lower gears sometimes have free-wheel clutches which means the engine will idle ate high speeds. First you need to set the Down Shift (Red Line) Low Dot to idle RPM minus 200 RPM. An example is if idle RPM is 800, set this Dot to 600RPM. Do this for each gear. This will prevent the TCU to gear down by engine RPM's.

Enter a value for the Gear Down Speed settings for all the gears except Gear 1. Leave it at 100 Km/h. Use a value which you thing it should gear down. Start with a lower value to prevent lockup of the wheels.

Now accelerate to top gear and release the throttle. Now feel each gear when it shifts back. If it shifts back harsh or too quickly, decrease the value and vice versa. Do this for each gear.

The Gear-Up Speed setting in Gear 1 is used as a forward shift speed to second gear. This is handy when the vehicle starts rolling on a downhill where the driver does not touch the throttle. When the vehicle exceeds this speed, the TCU will automatically shift to second gear. This speed must be higher than the second gear, Gear-Down Speed setting, otherwise the transmission will hunt between the gears. On some transmissions this setting is important as 1st and 2nd gear has a free running clutch and no engine brake, which means that RPM stay at idle regardless of the speed of the vehicle. Start with a value of 10km/h and make gear 2 Gear down speed 8.

Middle Blue Dots

To set the Up Shift (Blue Line) Middle Dot, press the throttle in about 40% TPS value. Again, feel each shift if it takes place at the right RPM's. If it shifts too quickly move the Dot more to the right and vice versa. Do this for each gear.

Top Red Dots

Now to set the Down Shift (Red Line) High Dot RPM value, you need to cruise in the gears higher than gear 1, and at an RPM just lower than this Dot value. Then kick the throttle in quickly to reach a value higher than 90% TPS value. When the TCU shifts the previous gear, feel if the RPM in this gear is too high or too low. Adjust the Dot only left or right. This kick back should occur at a RPM where the lower gear still has range to improve the vehicle speed, without over-revving the engine. It should not be too low so that the engine labors in higher gear and not be able to gear down under high load conditions. Do this for each gear.

Middle Red Dots

To set the Down Shift (Red Line) Middle Dot for gear down when Throttle is pressed is a bit trickier. You'll need to cruise in each gear at low RPM. Then press the throttle in at certain depths and feel as gear down occurs at the correct acceleration. Adjust this Dot left and right till kickback occurs at the correct throttle opening.

Kick Down Speed

The last shift setting to adjust is the Kick-Down Speed setting. This setting lets the TCU gear down regardless of the RPM or if the Gear Shift Time has lapsed. It will also let the TCU shift back 2 gears at once. The TCU will gear down when the speed is below this value and the throttle is pressed to a TPS value greater than the Down Shift (Red Line) High Dot TPS value. This is set at 90% TPS. To start with a reasonable value, use 50% of the maximum speed for the lower gear. Example: If Gear 2 can reach a speed of 100 Km/h, use 50Km/h as a setting for Gear 3. This will leave ample room for the lower gear to accelerate the vehicle. If you found that the engine revs in the lower gear is too low, increase this value. Do this for all the gears except Gear 1.

Gear Shift Time is important to let the transmission complete its hydraulic action before the TCU attempts its next shift. A setting here is normally 2.5 to 3 seconds. If the time is too short the TCU will do calculations for the next gear while the transmission has not yet engaged that gear. This will result in the transmission skipping gears and the engine revs falling too low. It will then kickback and start an erratic shift process. Rather start with a larger value and decrease till you detect inadequate operation. Then increase the time slightly. Also note that during the shift time at full throttle the engine may over-rev. then decrease the blue top dot's RPM value.

Now, drive around with the vehicle under normal city and highway conditions feeling the TCU operation. This will indicate where little adjustment may be required to get the shifting to perfection.

Save the profile in the TCU and also on the PC as Profile 1 Automatic.Spitcu.

Now, select Profile 2 and load the file Profile 1 Automatic. Spitcu from the PC into the TCU. Press Connect and save it to the flash in the TCU and then start editing from there.

Repeat the save process and go to the next profile. For low range you may need to start over as with Profile 1. This is due to the speed settings that will be different. If the tranny has a L/R switch, then wire it in or make yourself a L/R profile. Then use only that profile with low range.

Once you are familiar with tuning you may tune the middle and top dots also in the up and down dimension. This is mostly a feeling by yourself if the transmission does what you want it to do. Try to see what the marker does while driving and try to get the shift lines where the transmission feels smooth. Be careful while driving as you may get distracted and cause an accident.


Semi Automatic Mode

This mode is used for 4x4 or racing where the driver controls the gears of the transmission manually but the TCU will still do safety protection against over revving. You can set it up so that the transmission to assist the driver in routine tasks like gearing back automatic so you pull off in the right gear. Or shift up when the engine limiter is reached. This is handy for drag racing. This mode is also handy to pull off in higher gears or keep it in that gear for Dyno's etc.

This mode is used with Tiptronic in Semi-Automatic selection. The buttons will shift gears up or down if it is in the set limits. Below are a few rules on how to set it up. If the TCU seems non responsive it is one of these settings that will keep it from responding.

Procedure of Tuning.

The next steps should have been done in your profile 1 automatic mode.

1. First go through the setup and enter all the relevant settings that you do know.

2. Calibrate the TPS sensor.

3. Start the engine and check the rev counter calibration is correct, then save the data and switch the engine off.

4. Switch the ignition on and do the following settings while you are standing still.

5. Start with the following option settings.

Set the profiles in a typical setup like below.

Notice how the graphs are drawn. All the dots are on the top or bottom. This means the marker cannot move above or below the horizontal lines and activate up or down shift. It can only move left or right of the vertical lines. You may have any variation you need but this one is popular for most control by the driver. Set each gear profile according to the following rules. Each scenario will be discussed.

Gear Shift Time

This time must be long enough to allow the manual transmission to complete the shift and the next gear to take up the drive train without slip.

Slow Gear Down

This block will force a gear down if the speed falls below this value and the marker is left of the blue bottom left dot. In this example the blue revs are 1700 and the marker is 1900 so it will not gear down even if the speed is lower than 23 Kph. This will prevent gear down if the drive-wheels spin in mud for example. (Speed in this case must be taken from the non-drive wheels).

Preventing Automatic Down Shift

If you do not want the transmission to downshift automatically, move the vertical red line to below the Idle RPM's. In the example this line is on 600 RPM and the engine idles at 800 RPM. Also make the gear down speed 0 so that it will not activate down shift. Only way to down shift from here is with the buttons.

Preventing Automatic Up Shift

If you do not want the transmission to upshift when engine limiter is reached, then move the blue vertical line higher than the engine limiter. In the example this line at 7400 and the engine limiter is 7000 RPM max. So it will not go beyond the blue line and force an up shift.

Preventing Tiptronic Down Shifts

There are 2 limits that will prevent gear down with the tiptronic buttons. Vehicle Speed must be less than Kick down speed and the engine RPM must be less than the top right red dot. If revs are higher than 2500 in the example or speed are more than 55 Kph, then the downshift button is ignored.

Preventing Tiptronic Up Shifts

There are 2 limits that will prevent gear up with the tiptronic buttons. Vehicle Speed must be more than the next gear's Gear Down Speed otherwise that gear will force it back. The engine revs must be higher than the Blue bottom left dot. In this example it is 1700 rpm. If it is less, then the up shift button is ignored.


Manual Mode

This mode is used for complete manual selection of gears. The TCU can only be set up for protecting against accidental down shift at high RPM. This is handy for Dyno's etc.

This mode is used with Tiptronic in Manual selection. The buttons will shift gears up or down if it is in the set limits. Below are a few rules on how to set it up.

Procedure of Tuning.

The next steps should have been done in your profile 1 automatic mode.

1. First go through the setup and enter all the relevant settings that you do know.

2. Calibrate the TPS sensor.

3. Start the engine and check the rev counter calibration is correct, then save the data and switch the engine off.

4. Switch the ignition on and do the following settings while you are standing still.

5. Start with the following option settings.

No need to set up profile lines. Only 3 settings are important.

Gear Shift Time

This time must be long enough to allow the manual transmission to complete the shift and the next gear to take up the drive train without slip.

Kick Down Speed

No downshift will occur if the speed is higher than the Kick Down speed.

No downshift will occur if the RPM is higher than the Top red Dot.

Upshift will occur even at stand still.

Note that the engine must be running for shifts to occur.


TCU Trouble Shooting

Help > TCU Transmission Management >

Orion TCU Trouble Shooting

Faults and Remedies

The Orion yellow power LED does not come on

  1. The ignition wire does not have 12Volt
  2. There is a short on the 5 Volt output from the TCU. - The magnetic crank or speed sensor, or the TPS sensor all use 5 Volt. (Check the wiring.)
  3. Check if the TCU is earthed.

The Software does not connect to the TCU with the USB to UART Converter

  1. Incorrect or faulty USB converter.
  2. No Device Driver for the USB cable is installed on the PC.
  3. Faulty TCU

The TPS does not want to calibrate

1. Check the wiring according to the drawing. See if it has 5 Volt, Ground and if the signal varies between 0 and 5 Volt.

2. Check Calibration procedure again. Make sure that you are in Map 1. When you press calibrate the bar will indicate movement from the TPS. Remember to save after calibration.

The RPM signal does not register in the software

1. Incorrect sensor wiring. (See drawings.)

2. Incorrect harness for the application. There is a standalone harness or a ECU connection harness.

3. Incorrect jumper settings.

4. Sensor gap too large. Make the gap between 0.5 and 1mm between sensor and iron teeth.

5. Incorrect Setup or Calibration.

The Speedometer does not register in the software

1. Incorrect sensor wiring. (See drawings).

2. Incorrect harness for the application. There is a standalone harness or a ECU connection harness.

3. Incorrect jumper settings.

4. Sensor gap too large. Make the gap between 0.5 and 1mm between sensor and iron teeth.

5. Incorrect Setup or Calibration.

The Shifter indicates incorrect positions in the software

1. Incorrect wiring. (See drawings.)

2. Incorrect Setup or Calibration.

3. Shifter is not earthed.

4. Faulty or incorrect converter board.

The TCU does not want to shift from 1st gear to second

1. One of the above sensors is not working correctly. Make sure the software shows that drive is selected.

2. Incorrect profile settings.(See Tuning Principles.)

The Marker moves past the up or down shift line without shifting

1. Faulty Number of Gears setting uploaded.

2. Incorrect gear profile speed settings. (See Tuning Principles.)

3. Faulty Shifter Position switch.

The TCU shift before the Marker moves past the up or down shift line

1. Incorrect Speed settings for Gear down Speed or Kick down Speed.


Specific Instructions

Help > TCU Transmission Management >

Transmission Specific instructions

Each transmission may have specific setup rules that is not standard. This could be an extra pressure solenoid or setting for example. These instructions on how to tune it properly will be saved in the transmission folder on the web along with its firmware, startup map and drawing.


TxW Controller

Help >

TxW Throttle by Wire Controller

This chapter explains all the drawings instructions and tuning around TxW Management. View the sub folders for different sections.

Motors and Drives for Drive-by-Wire Throttle Control - ElectroCraft


Precautions / Disclaimer

Help > TxW Controller >

Precautions / Disclaimer

This product is very critical in a vehicles controls and could cause accidents and death or injury. Spitronics carry no responsibility in this regard as it is a DIY product that is installed by third parties. If you are an installer then read the instructions carefully and communicate the fact that it is used at your/his own risk, to the customer. Strictly abide by the wiring ruses as this may cause accidental opening. It is your responsibility as an installer and make the customer sign a disclaimer should something go wrong.


Introduction

Help > TxW Controller >

Introduction

The Orion2 can be used as throttle by wire controller. It can be used for single acting throttles or dual acting throttles. Double acting throttles require positive and negative drivers to form an H-bridge. This will allow current to change direction to open or close the butterfly. Dual throttles have a rest position that is partially open to act as limp mode power during electronic failure. This product is in prototype status and use the ECU software for now. Dedicated TxW software will follow soon.

These units are standalone units and can operate without the engine running. It may also be used with other management systems. There are protection diodes and resistors wired into the harness. It also has its own relay to power the throttle. These modifications is to ensure lockout of the power to the throttle during malfunction of the sensors, harness or electronics. Do not power the unit via another source by bypassing the relay etc.


Version Changes in Ver 3.5B

Help > TxW Controller >

Version Changes in Ver 3.5B

Each version change will have changes in the software or firmware. This document will explain the changes from Hyperspace Ver 3.5 to Hyperspace Ver 3.5B. Version 3.5A was a test version for Proxima.

Throttle Protection

This is a product under development and in Version 3.5B we improved throttle power protection. This will limit the duty cycle power applied on the throttle motor during calibration and testing. It is a universal program and must be set for each type of throttle. See Step 1 Pedal & Throttle Test.

Tuning settings

After Mercury2 firmware was developed after Proxima and the settings differed. Proxima used the auxiliary registers which is changed to be the same as Mercury2 to simplify manuals.

Clone Feature

The standard Hyperspace clone feature is also added to copy tuning maps and calibrations without the need for a programmer. See the ECU manual for more description on this. If you upgrade it may be locked where you then have to load your map again. So make a copy before upgrading.

Dual Maps

These units can now handle dual maps for different operations. See the ECU manuals for more description on this. Proxima is the same as Pluto2.

Temperature Compensation

Proxima can now also do cold start compensation. You will need Standard Class for this feature.


Wiring

Help > TxW Controller > TxW Hardware Description >

Wiring

See the wiring diagrams in the sub folders for each type of throttle valve. There may also be custom firmware for different models like the Citroen TxW. Make sure to connect the free wheel diodes correctly and let the Mercury2 power its own relay as per drawing. Note that the dual throttle requires 4 diodes to eliminate spikes. After the unit is tuned you may load the lock file which means the firmware does not have the ability to write to memory during interference spikes on the micro. If you need to make adjustment reload the normal firmware.

Standard Universal drawing

Orion2 Universal Wiring Diagram

Specific models drawings

Harness design drawings

OTX01 TxW Standalone.pdf

OTX02 TxW.pdf


TxW Software Description

Help > TxW Controller >

TxW Software Description

This TxW software use the current Hyperspace ECU Ver 3.6 software. It uses certain blocks in the ECU software that may not have the correct terminology. Blocks that is not relevant is blanked out to prevent confusion. Dedicated TxW software will follow soon which will address this problem. The amount of products sold is still too low to justify the development cost. This way we can do the product at a low cost. So please bear with us.

There is information, setup, and graph screens. Please read the sub folders for more information on this software.


Firmware File Name

Help > TxW Controller > TxW Software Description >

Firmware File Name

Orion2 Combo 1 Ver 3.6A 12_08_2020.OTfirm

The dates may differ but Ver 3.6A if discussed here in this manual.


Step 1: Pedal & Throttle Test

Help > TxW Controller > TxW Software Description >

Pedal and Throttle Test

This step is will allow you to test the Pedal and Throttle TPS operation. It also determines the maximum power allowed on the throttle motor. Most throttles have plastic gears and will be damaged if too much power is applied to them. The butterfly may also hit the barrel too hard causing damage that can lead to a sticky throttle body. The throttle TPS calibration are done automatically by the TxW which means you do not have to open it up to see if it is working correctly.

NB! Do not attempt to calibrate the TPS before this procedure is done.

First set the following values before proceeding:

Under the Sensors tab, use the fuel pressure block to set the maximum power allowed to the motor in duty cycle PWM. On the Fuel Pump High, set a safe value of 128 which is 50% power. A value of 254 = 100% Power. This value may be changed later in the program to less or higher values.

Now go to the fuel pages and set the ACC values to Zero. This represents opening and closing PWM or Duty Signals and then Gain or Proportional settings.

Now go to the Sensors page and set the Check the Crank Test signal to On. This will deactivate throttle control and calibration, and will display the actual values of the Pedal TPS and the Throttle TPS on the real-time bars. The Throttle TPS is displayed on the POT bar and the Pedal TPS is displayed on the TPS bar. On simulators it may use different potentiometers as we use different inputs on the TxW.

NB! Disconnect your engine ECU outputs as this setup requires the pedal to be moved plenty of times which will activate the prime function and inject petrol into the intake manifold.

To test the Pedal TPS look at the real time display and press the pedal fully and then release it again. The TPS bar should move a fair distance in the display but should not reach maximum or minimum limit. If it does, then use the other signal on the Pedal TPS, or adjust the sensor inside so that it has free play. See min and max example below.

to

Also note if the action is inverted. This will help setup the pedal logic on rising- or falling edge later during calibration. The standard setup is rising volts with throttle depression. It may be an incorrect connection of the 5 volt and ground wires which may be swopped around. Below is the calibration tab when it is opened to indicate rising edge.

To test the throttle TPS for correct operation you need to manually press the throttle open and close. This must be done by finger or soft plastic so that you don't damage the butterfly or tube. First press it close, then leave it at rest point, then open it fully. The POT bar should move a fair distance in the display but should not reach maximum or minimum limit. If it does, then use the other signal on the throttle TPS or adjust the sensor inside so that it has free play. You should see some results like below:

to [image] to

Also note if the action is inverted. It must be rising in value with increase of throttle. If it is falling volts with opening, then it may be incorrect connection of the 5 volt and ground wires.

Note. If you can't get to the throttle to test the TPS then you can skip to the next step and open it from the TxW side and see if it functions correct. You will only be able to see the rest and open position.

to

Determine Maximum Duty cycle.

Make sure Test is on. Now adjust the Opening Duty with the arrow and increase it gradually till the throttle opens.

Look carefully at the throttle TPS on the POT bar. Adjust it ill it reaches the maximum determined in the previous test which was 71%. If you could not do the previous test, then adjust it till you don't see any more increase in throttle movement on the POT bar. Adjust it lower again till you can see throttle movement so that you don't have too much power on it. Then slightly up so that you can assure maximum openening.

Now put the Test off. If you put Test back on, then the throttle will open again. It may be slow to react as it gets just enough power to its motor. Now increase the Opening Duty more and testing throttle response every time you alternate the Test function. Do this till the throttle responds just fast enough without making the value more than is needed. You should hear it reaching its full open limit but not too hard. If you make the duty more, then you may risk damaging the plastic gears. If it is too slow then it may respond sluggish in blip conditions. If this value increase more than 128 then you may need to increase the Fuel Pump High value.

Now take this Opening Duty value and type it in the High Limit Duty Cycle block. This will prevent the TxW to ever exceed this amount of power to the unit.

Now put the Test function off and proceed with the next Step.


Step 2: Pedal TPS Calibration

Help > TxW Controller > TxW Software Description >

Pedal TPS

The TPS selection is forced on. The electronic pedal signal is wired to the TPS input so that the calibration feature and TPS graph can be utilised. This signal is only conected to the TxW and it must not be used for the ECU etc. It is an indication to the firmware what the driver requires and it could be modified in relation to actual throttle movement. This mean the pedal could be 50% depression but the actual throttle opening could be 35%. This will have the ECU reacting on false information regarding throttle opening.

Calibration of the TPS.

Once wiring and connections are done, and the maximum duty power in previous step is set, then you may proceed to calibration. Click on the calibrate tab next to the TPS signal and then on the Calibrate tab in the calibration window.

Calibration is done by stepping on the pedal and releasing it. The min and max values will be populated in two positions in the calibration window.

Now press the Save button and the Orion2 will do an automatic calibration of the throttle. It will open the throttle completely and take a reading. Then close it completely and take another reading. Then switch power off and take a reading of the rest position. It happens in half second intervals but you should see the action as it happens. The throttle TPS is now also calibrated but the throttle control power still needs to be setup. This is described further in the manual. If you are not sure on TPS calibration, then see the ECU manual for calibration procedure.

Click on the Map save button to save your calibration values at this stage.

or CTRL S

Show graph is used for pedal profile change and is discussed in another sub folder.


Step 3: Throttle TPS Settings

Help > TxW Controller > TxW Software Description >

Throttle TPS

The Throttle TPS input is wired on the MAP sensor input of Orion2. It will relay the actual throttle position to the TxW controller. This signal is also connected to the ECU and TCU as a TPS input. In some cases, the ECU may supply the power to the throttle TPS, and in other cases it may be the TxW that supply the power of 5 volts. Do not connect both supplies together as it may damage some of the devices. The other systems must tap in to the TPS signal only. Note that systems that share sensors requires the same earth connection to ensure signal accuracy.

The Tuning Pot input is forced On and selected on launch. The POT register is used as a Dashpot damper in % throttle opening. When the throttle is blipped it will dampen the return to let the engine return to idle more gradually. This is very useful with automatic transmissions to prevent stalling. If the Pedal TPS value is greater than TPS idle cutoff, and revs is 500 rpm more than target RPM, then the throttle minimum opening is set to this POT Register %. When the pedal is release below TPS idle cutoff, then the throttle will be momentarily stopped at this opening and then returned slowly. Start with a small value and blip the throttle. See the effect of dampening at a slighter higher than idle RPM.


Step 4: Throttle Setup

Help > TxW Controller > TxW Software Description >

Throttle Setup.

After TPS calibration you need to set the throttle control parameters. This is done manually because throttles differ in power requirements. Some use more power to open than others and this is universal firmware to cater for most variations. There may be some throttles that cannot be controlled by this firmware but we will determine that in this process.

The throttle TPS range limits are calculated by the Orion2 automatically during Pedal TPS calibration. This setup procedure will determine opening and closing power required to control the throttle gently. It differs between different throttle manufacturers and must be adjusted for each type. If you load a map from a similar throttle then it should be working.

The Accelerator Pump in the ECU software is used for the throttle adjustments. Click the Fuel Tab. Note that the text in Red is not in the software but only for explanation which blocks to adjust. First zero Duty and Gain settings for both sides.

The throttle will then have no power on it and it should show the resting %.

If you open the throttle by finger completely it should go to 100% and closing completely should indicate 0%. Which means it was calibrated correctly.

Click on the Engine Tab.

This POT or throttle value at resting position of 9% in this case, multiplied by 2.55 should be roughly the same as the Map Teeth value that was calculated by the Orion2. Map Teeth setting is the rest position of the throttle and is a value from 0 to 255 which represent 0 to 100% throttle. Map Teeth = POT * 2.55

This is handy to know later if you want to fine tune erratic movement around the rest position.

To adjust throttle opening and closing duty.

Put the ignition on. Do not start the engine.

Put the TPS graph, Water Temperature and Idle-control off. Also put the Idle Control Low Limit Duty Cycle to 0.

Now press and keep the pedal in completely. Look at the throttle TPS in the real time screen on the POT bar. Now use the arrows of Opening Duty and increase the value till the throttle opens above 95%. Remember this value. Now reduce this value till the throttle close to 5% above the rest position (less than 9 + 5 =14%) Take the average of the two values and set opening duty to that value. In this example 115(to open) + 75(to close) = 190 / 2 = 95. Now release the throttle. If you press the throttle again, it should not open. This means you have determined neutral duty cycle where the throttle will not open or close. It will stay in any position if you press it with your finger while the pedal is pressed. If the difference in open and closing duty cycle are very small, then this neutral zone will not happen. For these throttles you will require different firmware.

Now release the throttle and increase the Closing Duty till the throttle close to 1 or 2 %. Then lower the Closing Duty till the throttle open to 8 %. (About 1% lower than rest position) Take the average of the two values and set closing duty to that value. It should be similar than the opening duty.

To adjust throttle opening and closing gain.

Now press the pedal fully and increase the Opening gain slightly. The throttle should open to about 99%. You may increase the value till you get a fast enough response and the throttle follow the pedal value. If the gain value is too high the throttle will vibrate. It should be around 4.

Now release the pedal and increase the Closing Gain till the throttle is about 1% value. The closing values should be the same value as the opening duty and gain. It should look like the example below.

Now press the pedal slowly so that the throttle read the same as rest point. Take it slowly above the rest point and back. Notice if the throttle shudder excessively on the transition point. If it does vibrate or seem to have a dead band, increase or decrease the Map Teeth and see where the throttle is smooth when it passes the rest point with the least amount of shutter. Save the settings to the device.

Idle setting

This value is the minimum opening for the TxW to control the butterfly. Now you may start the engine and adjust the Low Limit Duty Cycle till the engine idles on its own. Let the engine get up to working temperature and adjust this setting till the engine runs at the desired idle RPM. If you are going to activate Idle control, then let it idle at Idle RPM minus 100. This will allow the TxW to control the idle faster. You may now proceed to idle control setup.

Note that if your throttle requires only one direction of movement then you can skip the closing settings. You may also disconnect TxW Motor Neg2 and TxW Motor Pos2. Look at the difference in wiring diagrams.


Step 5: Throttle Modulation

Help > TxW Controller > TxW Software Description >

Throttle Modulation

The throttle movement can be adjusted to open on a different value than the pedal set point. This is handy when large throttles are used. Then when it is used in town you can select more pedal movement than throttle movement which will make the car more drivable or the pedal less sensitive. Then on last movement to full throttle, the throttle will move more than the pedal and give the extra power required.

Select the Show Graph next the TPS selection.

Click on the TPS Graph TabSee the graph below. The X Axis is pedal TPS movement and the Y axis is throttle movement set point. The range is from 0 to 100. -50 is 0% and +50 is 100% throttle. If Show Graph is off then throttle movement set point will be the same as pedal TPS %.

After setting, make sure the throttle can move over the whole scale range. Note that Low Limit Duty Cycle will cause the throttle to not go to 0% but remain it idle %. You may start the graph at a higher value than -50% so that the throttle moves more instantly when the pedal is pressed. Make sure not to set it too high, as it will then overcome the min duty cycle and the engine will idle faster.


Step 6: Cold Start Compensation

Help > TxW Controller > TxW Software Description >

Cold Start Compensation

The TxW can do cold start compensation. It compensates by increasing the min opening of the throttle. It is more stable than to lift the target RPM's. It will operate even if idle control is not used.

To use cold start control, the unit requires a water temp sensor. Orion2 has a jumper for the pull-up resistor for the water temperature sensor. If you have a standalone sensor, then the jumper must be on. If you want to tap into another sensor, then the jumper must be off. Note that the curve for both sensors is for the 2K NTC resistors.

Put the option On for the Water Temperature. Put the calibration value on 100. The water compensation graph will replace the Low Limit Duty Cycle value as idle setting.

With temperature compensation selected, the water graph for fuel will be used as the minimum closing duty cycle with temperature compensation. Note that the graph on the Y-Axis is used from 0 to 100 which means 0% to 100% opening. For a cold engine you can raise the value which will let in more air to compensate for poor fuel burn. This feature can also be used without idle control. See the graph below.

If the Water Temperature setting is off, then there will be no water temperature compensation for cold start. The Idle Control Low Limit Duty Cycle value will be used as idle setting.

Note that a big part of idle control lies in fuel and timing tuning. See the section in the ECU manual how to compensate for that.


Step 7: Idle Control

Help > TxW Controller > TxW Software Description >

Idle Control

To use idle control, the unit requires an RPM pulse. Any number of pulses per revolution could be used up to 60. This will calibrate the rev counter in the software easily. You may compare it to the ECU Tachometer. Ex. Should you use a 36-2 trigger wheel then select 34 pulses which will represent one engine revolution.

Note that a big part of idle control lies in fuel and timing tuning. See the section in the ECU manual how to compensate for idle control. Otherwise the ECU and TxW may end up amplifying control parameters and then oscillate the idle control.

The Gear Teeth block is used for this value.

The rest of the idle control settings is the same as is used in the ECU. See description below.

Idle Control Type

If idle control is used, then select Idle Valve. Otherwise select Not Used. If idle valve is selected, then the RPM signal will become active. Otherwise it is disabled because it is not required.

RPM

This setting is the target idle RPM's when the engine is on running temperature. Note that the min idle setting or the cold temperature compensation may cause the engine to idle at a higher value.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve to this %. Once the engine reaches 500 RPM it will cancel this setting and go to normal throttle operation. If you press the pedal, then this setting will be override.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the air conditioner on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the TxW so that the valve does not close beyond this value. It is used as min idle when there is no temperature sensor connected. To set the value start with a larger % and decrease until the desired idling RPM is reached in neutral when the engine is on working temperature. Note that the throttle modulation or cold start compensation may override this value.

High Limit duty cycle

This setting is used to limit the maximum throttle opening. It is set at 100 to open the throttle fully. It may be used as power limiter by entering lower values.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a minimal amount of revs with slight throttle.


Limp Mode Testing

Help > TxW Controller > TxW Software Description >

Limp Mode testing

It is good practice to test the TxW for sensor failure. Any one of the 3 wires of the Pedal or Throttle TPS sensors can fail and then the TxW must react and put itself in limp mode. To test this operation lightly connect the 2 TPS sensors. After throttle setup, put the ignition on and press the pedal 50%. The throttle will open some way depending on setting. Now take the 6 wires to the 2 TPS sensors off only one at a time. Each time the throttle must fall out and go in limp mode. Limp mode means the butterfly is in rest position. If it goes fully open or fully close, then there is a wiring problem. Some single action throttle may close completely. After fixing the problem then solder the joints and cover them properly. Remember this throttle control the power of the engine and it could cause the car leaping forward and into an accident or leaving the road. So make sure wiring is done according to recommendations.


Trouble Shooting

Help > TxW Controller > TxW Software Description >

Trouble shooting

There are common problems that installer make that hinder proper operation and reliability. Especially if custom harnesses are made. Below are a few examples:

  • Make sure the TxW earth and ECU earth is mounted on a proper place on the body of the car. Do not make long earth leads to the battery. See the power wiring section in the ECU manual.
  • The power on the relay pin 30 must come from the battery with thick wires. Do cot connect pin 87 to the ECU relays.
  • If the power wires are too thin, then the throttle calibrations change once you start the engine. This may also be due to the alternator wiring that connects with the power harness.
  • The ECU power comes from the key power circuit and not the same power that supply the throttle. This usually make interference in the RPM signal.
  • Make sure the RPM signal is constant and stable. Erratic behavior will result in incorrect idle control.
  • The free-wheel diodes must also have a proper earth and power wire. Earth must go to the ECU earth point and positive to pin 87.
  • Do calibration and setup in the same order as discussed in the manual. Make sure the throttle flap open, close and rest after you calibrated pedal TPS.
  • If you set up the system and it does not perform like the document say investigate or contact your dealer for support. Do not let a half done project go into the street.
  • Make sure you wire the resistors in as the harness drawing suggest. The reason is that it is fail safe resistors in case a wire breaks off. See the Limp Mode Testing section.
  • Throttle is hunting on idle control. Make sure the ECU settings on idle fuel and timing settings is correct. See the idle control tuning section. It could also be incorrect settings of gain and rest position.

Error Codes

Two error codes are implemented to show common cutout issues. This is due to the TPS value that went outside the calibration limits. It could be due to a faulty wire to a TPS Sensor or voltage drops on wires due to incorrect thickness or power sharing. Filter diodes could also be the culprit.

Error Value 29 - Pedal TPS Sensor Failure or Calibration limits breached.

Error Value 37 - Throttle TPS Sensor Failure or Calibration limits breached.


CAM Controller

Help >

Orion2 CAM Controller

The universal CAM controller firmware is written for a Orion2 ECU controller to control other features that the ECU normally lack due to the amount of drivers or signal inputs. It is a standalone product and can be used with any type of ECU. It is sold in Standard hardware class which make it very cost effective.

It has the following features.

1. It can control 4 VVTI camshafts in open loop with separately tunable duty cycle signals with TPS lockout,

2. It can control 2 Nitrous solenoids with separately tunable duty cycle with TPS lockout. This is handy for ratio control.

3. It can control a single or dual Idle valve motor directly

4. It can control Spitronics manufactured stepper drivers for idle control motors.

5. It has 4 GP outputs that can be configured for TPS, RPM or Battery voltage signals.

6. The GP2 output can also be used for V-Tech camshafts.

7. It can scale RPM signals for rev counter calibration

8. It has Dual Map capabilities to enhance duel fuel applications.

See the sub folders for explanations.


CAM Setup

Help > CAM Controller >

Setup

The universal cam controller use the Ver 3.6 Hyperspace ECU software to minimize development cost and bring the unit at a good price to the market. This means that some of the tuning blocks does not have the right meaning. Once you get to memorize them you will find it very easy to setup and tune. This manual is not extensive and only explains the relevant settings for the controller. You may need to read the ECU manual if you are not familiar with it. Only the settings used in this firmware and their differences with the ECU will be discussed.

Just as with the ECU this block can be used to memorize tuning and customer data.

The controller has dual map capability and this will indicate which Map is in use. See the ECU wiring diagrams on how to wire and use the Dual Map Switch.

This selection will save setup when a map is loaded. Note that critical settings marked with [image] must be changed on line or with the clone function.

These settings work the same as in the ECU program with the exception that only RPM, Water Temperature, TPS and Battery Voltage may be selected if the sensors is wired in. That is the only signals wired into the controller. See the ECU manual for further description.

This block will pulse the RPM output at the set number of pulses per revolution. This is handy to calibrate some rev counter signals.

Map Range is forced to 1 to create a scale for the top fuel graph which will represent 100% TPS signal.

RPM Range will Scale the bottom fuel graphs to accommodate the tuning range. Set it to 500 RPM higher than engine maximum RPM.

The CAM controller can read any form or RPM signal. See the Hall and Magnetic setup as well as tapping into other ECU signals. Note that there is a special filter required for connecting to Coil Negative. The amount of pulses per revolution is entered into this block. It does not have to be even pulses. In this example the trigger signal was tapped into the crank sensor of a 60-2 crank wheel. Note that you enter only the pulses which will be 58. It can take pulses from 1 pulse to 120 pulses per revolution.

This block is used to select between 2 cam control options.

Option 1 (Wasted Spark Coil per cylinder)

This option use the first 4 graphs on the Fuel Graph RPM compensation map to adjust 4 cams separately in the RPM domain. The top Graph will do the TPS lockout for all 4 camshafts.

Option 2 (Wasted spark Coil Pack)

This option use the first 2 graphs on the Fuel Graph RPM compensation map to adjust 2 NOS solenoids separately in the RPM domain. The green limit bar on the top graph is used for TPS lockout.

Then it will use the second 2 graphs to control 4 cams in 2 pairs in the RPM domain. The top Graph will do the TPS lockout for all 4 camshafts.

This will indicate how many drivers is used and their position.

This setting is forced and will keep the Fuel graph visible

The TPS and Map sensor is locked in the on position. Although MAP is not wired and ignored, it has to be enabled to make use of the graphs. The TPS signal is converted to the MAP signal as well. The TPS must be calibrated to work properly. See the ECU manual for more information on this procedure.

Water Temperature may be wired in to use with Idle Control. It has a calibrate function but like the ECU it is made for a 2K NTC resistor sensor. The Jumper for its pull-up my be opened and then you can connect it with the ECU sensor.

The Battery signal may be switch off but it's merely for the GP outputs to have a low battery feature for NOS applications.

The trigger signal may be selected to positive or negative transitions.

The Idle Control block works exactly as the ECU descriptions with the exception of the two GP outputs that is exchanged.

This is all the relevant settings.


Real Time Display

Help > CAM Controller >

Real Time Display

Only 4 real time signals are available on the CAM controller. The other are either blanked out or set to zero.

An RPM signal which can also be analogue by double clicking on the digital value.

A TPS signal which are copied onto the MAP signal to make use of the top graph there.

Water temperature

Battery Voltage


Tuning Graphs

Help > CAM Controller >

Tuning Graphs

The Cam controller use the fuel graphs as they contain the information to set the cams to work properly. Mostly cams are adjusted to RPM as they improve the volumetric efficiency due to air mass. This will broaden the torque curve of the engine. In some cases they are also adjusted with throttle position. Newer technology engines requires the cams to be adjusted in a window in the RPM range and only when the throttle is opened at a certain percentage.

This Fuel Load Graph is used as a TPS block out signal. A 10 on the vertical scale represent 100% duty cycle. The bottom of the graph represent the TPS signal at 0%.This graph will adjust the maximum duty cycle allowed at that TPS position. This will not activate the outputs to the cams. That is set at the bottom graph. As you can see that values lower than 30% in this example has no signal, and higher is 100% signal. The bottom graph's value will be compared to this graph and the lowest value between them will be used. This means under 30% TPS value it does not matter what the value is set on the bottom graph. The outcome will be 0% duty cycle on all the cam and solenoid outputs.

The green half vertical line is the TPS lockout point for the NOS solenoids. This is used so that NOS can only be applied at fully opened throttles as a safety measure. In this example it is set to 90% throttle opening. Below this % the solenoids will be off. To adjust this setting use the adjustment block and arrows below.

This Fuel Graph has 5 graphs and are used in the RPM domain. It has a graph representing each of the 4 cam outputs. Red is the 5th one and is not used. The vertical scale go from -50 to +50 which is a total of 100% duty cycle. The horizontal scale is engine RPM. In this example the duty cycle is adjusted from 25% to 75% and back to 25% which is required by this engine.

In this example Option 2 (Wasted spark) was selected. Green and Brown is used for 2 cams each. Blue and orange is used for the NOS solenoids. In this case the blue solenoid will open at lower RPM's then the orange one. For NOS control solenoids the duty cycle may be gradually phased in adjusting a ration between the fuel and oxygen solenoids.


Wiring

Help > CAM Controller >

CAM Control Wiring

Connection Layout

E38 - P1 Harness

E31 - P2 Harness


BootLoader

Help >

BootLoader

The Orion2 controller has a built-in Bootloader that will load Firmware into the device without the need for a programmer or special cables. It utilise the normal USB/UART communications cable that is used for tuning. This will save money and time for remote customers that can now upgrade or customise their systems.

This section displays the different methods on how to program or recover BootLoader that may have been corrupted.

Warning: Never disconnect the unit from power while the BootLoader is running. This will corrupt the code and then you will have to recover it. Also explained in this section.

See the sub folders for different methods:

BootLoader Software

Integrated BootLoader

BootLoader Recovering

Firmware Programmer


BootLoader Software

Help > BootLoader >

BootLoader Software

The Orion Bootloader software will only be necessary when the code in the device was corrupted. The new tuning software can also be used for normal programming. Note in the bottom information bar there is an indication if the BootLoader is present. If it is not present, then you will need the USB debug programmer to reinstall it. Older products do not have this ability.

You will require the Bootloader software that can be obtained from our website. It is a file called BootLoader V1.0.0.exe. Connect your Orion to the Laptop with a USB/UART communication cable. Disconnect all the outputs connectors leaving only P1 and the COMMS connector on the unit. This will prevent the unit from switching coils or injectors randomly when you are finished. Switch the Ignition or Simulator on.

Now open the Bootloader Software.

You will see the Device Information with the Program Number that is loaded currently. All the firmware has program numbers for identification.

Now click on the Load Firmware button.

Now guide the browser to the firmware file that you want to load. Make sure the file starts with Orion and has a .firm extension. Click Open.

Click yes and then the file will be downloaded into the Device.

The Device Information will be refreshed and your device is programmed. You can now close the BootLoader.


Integrated BootLoader

Help > BootLoader >

Integrated BootLoader

Load Device Firmware

Orion2 has a built in bootloader and you may load firmware from the Hyperspace tuning software. Click on Load Device Firmware and a browser will come up. Select your firmware file to load and click open. All Orion2 Firmware ends with a OTfirm extension. This will prevent you from loading the wrong firmware in the different devices.

As you can see from the message do Not put the power off while the BootLoader is running. It will lock the device and then it is another process to open it again. Click Yes and the file will be loaded.

Your Orion is now programmed. You may proceed with tuning.


BootLoader Recovering

Help > BootLoader >

Bootloader Recovery Instructions

The BootLoader may be corrupted should you lose power during downloading or maybe load a corrupted firmware file. In this case there will be no communications so the normal bootloader software or integrated software will not work. The BootLoader firmware is still loaded though. Switch the Orion2 off and get a fine point tweezer in place which will ensure that you will not cause connections or shorts to other components. Below is a step by step instruction how to restart the device.

You will need the following files that can be downloaded from our website under Downloads/Firmware Programmer/BootLoader/Orion2/. Do not attempt to load Orion2 files in as it is 2 different products.

There is also a Bootloader Recovery Instructions and a Zip File of the above folders. This is useful if your downloader or antivirus program complains about downloading the exe file.

Keep them together in a folder. You will also need to know on which comport the USB cable is situated. This can be seen under the Device manager of your PC. If you are not sure, you will have to try them all till you get the @@@ string in die downloader instead of ????? string.

Open the enclosure of the Orion2. Take care not to damage the screws or isolation pads or white silicone heat transfer compound. They are important to keep the drivers cold. Connect it with P1 connector and Comms connector with USB cable only. Leave the other connectors disconnected as it my switch outputs on during startup process. There are 2 files that can be used to recover the Orion2. One is a Orion2 Recover DM4 file that will put the device in a recover status which will require Hyperspace Device Manager 4 to connect to the unit. This file will also pulse all the outputs for the simulator. The other is a Orion2 ECU Firmware file that will recover the Orion2 with Hyperspace ECU Ver 3.6 software. After this you will need to load the correct firmware for your application and make sure everything is still correct before connecting the outputs. Your Map data should

Ensure the Orion2 power is off. Now use a tweezer or small jumper wire and short the White and Blue pin lightly. Do not short any other points as you may damage the Orion2. Then switch the power on to the Orion2.

The Green LED will light up as long as the short is present. Release the short by taking the tweezer away.

Now run the Orion2 Recover DM4.Bat file or the Orion2 ECU Firmware Bat file.

It will now display a list of comports available which may be connected to the USB cable. It helps if you know which one. Otherwise try them one by one till you are successful. Type the comport number only ex 3 or 6 like below.

If you selected the right comport then this message will appear.

The "@" sign says the firmware download was a success. If it shows ???? then it is the wrong port. Close the program and start again with another port. You will have to short the pins again with the tweezer.

The unit will reset itself and the green led will turn on and off. You can use the normal BootLoader or integrated BootLoader to upload firmware. The firmware loaded in the Orion2 is only a start program. See the bootloader section in the manual.


Firmware Programmer

Help > BootLoader >

Orion2 USB Debug Programming

Should it happen that the program really corrupted and the BootLoader was corrupted as well then the only way is to reprogram it with the Sillabs UDB Debug Adapter. New Orion2's is also programmed this way for the first time. As always connect only P1 and the Comms harness form the firmware programmer. Disconnect the output connectors to prevent them from switching coils and injectors randomly.

Note that Orion2 cannot be programmed on the front Comms port like older products. You will require this special cable below. It connects to the normal USB debug adapter.

Open the Orion2 enclosure. You will see the 3 holes marked with wire colours. Insert the 3 pins in them and hold it slightly as below to ensure contact on all three pins.

Now you can connect with the Sillabs software and Debug adapter.

For the recovery process you will require 2 HEX files. One to re install the BootLoader and one to load start-up firmware.

Load the following file first:

EFM8LB1_UART0_Bootloader.HEX

Now load the following file. No need to disconnect with the programmer. You can load them one after the other.

Orion2 ECU Combo 28 60-2 4Cyl Ver 3.5A 01_10_2018.HEX

The last file is not your correct firmware but only a file that will allow the software to connect to the device so that your bootloader works again.

Now follow the Firmware Programmer instructions as laid out in that chapter.


Quick Links

Help >

Quick Links

These links are handy to jump to certain parts of the information quickly. Once you are on a page you can browse the bottom of the page for related links. Each product type firmware has its own links.

See the sub folders for the correct link page.

Quick Links ECU

Quick Links TCU


Quick Links ECU

Help > Quick Links >

Quick Links ECU

Air Temp | Software | Hardware |
Altitude | Software | Hardware |
BootLoader | Software |  |
Cloning | Software |  |
Coils | Software | Hardware |
Compiling an ECU | Manual |  |
Crank & Cam | Software | Hardware |
Flat Shift | Software | Hardware |
Fuel Pump |  | Hardware |
GP Outputs | Software | Hardware | Priority
Idle | Software | Hardware | Tuning
Injectors | Software | Hardware |
Lambda | Software | Hardware | Tuning
Launch | Software | Hardware |
MAP | Software | Hardware |
POT | Software | Hardware |
Hardware Class |  |  | Selection
TPS | Software | Hardware |
Tuning | Software |  |
Water Temp | Software | Hardware |


Quick Links TCU

Help > Quick Links >

Quick Links TCU

BootLoader | Software |
Cloning | Software |
Compiling a TCU | Manual |
Files | Software |
GP Outputs | Software | Hardware
Harness Layout |  | Hardware
Jumper Settings |  | Hardware
MAP Switch | Software | Hardware
Oil Temp | Software | Hardware
Retard Signal |  | Hardware
RPM & Speed | Software | Hardware
Shifter Switch | Software | Hardware
Speedometer Out | Software | Hardware
Tiptronic | Software | Hardware
TPS | Software | Hardware
Tuning | Software |
TCU Drawings |  | Hardware
FAQ | TCU |


BootLoader

The Orion controller has a built-in Bootloader that will load Firmware into the device without the need for a programmer or special cables. It utilise the normal USB/UART communications cable that is used for tuning. This will save money and time for remote customers that can now upgrade or customise their systems.

This section displays the different methods on how to program or recover BootLoader that may have been corrupted.

Warning: Never disconnect the unit from power while the BootLoader is running. This will corrupt the code and then you will have to recover it. Also explained in this section.

See the sub folders for different methods:


ECU Altitude Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Altitude Sensor

The altitude pressure sensor provides instantaneous altitude pressure information to the Mercury2 ECU. It uses an external 1.1 bar map sensor. The data is used to calculate air density, which in turn determines the required fuel compensation for optimum combustion. It influences also the advancement or retardation of ignition timing as the altitude changes.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to the sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The altitude pressure sensor can be mounted inside the cabin and the pipe should be left open to ambient pressure. It could also be connected to the air intake box.

Pressure sensor types
The pressure sensor available from Spitronics is Motorola series sensors that comes in 1.1 Bar calibration.

Sample Sensor Pinouts

Related Links

Software Setup


Cam Control

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Cam Control

The ECU could be used to control 2 VVTI Cams on the engine. The outputs of the ECU may be strong enough to drive most solenoids directly. Some may require an Electronic relay or amplifier. Drivers may be positive or negative. View the GP priority sheet or look in the software which driver is allocated and then use the correct wiring procedure.

Click on the link below for the different wiring diagrams.

Cam Solenoid Control


1 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coil 1 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

Single Coil Single Coil Driver

Single Coil 2 Way Coil driver

Intelligent Coils - Built-in Driver

Single Coil


2 Rotor

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coil 2 Rotor

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

3 Coils Wasted Spark Leading Coil

4 Coils

Intelligent Coils - Built-in Driver

4 Coils


3 Rotor

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coil 3 Rotor

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

6 Coils

Intelligent Coils - Built-in Driver

6 Coils


Coils

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Coils

This folder contains all combinations of wiring options for Coils. The main choices are, no of cylinders, basic or built-in driver coils, wasted spark or COP coils and the type of spark required namely Distributor, Wasted Spark or Full sequential spark. Each folder contains its different variations for your engine. Note that the drawings are generic and you have to dill in your own firing order to see which wire colour goes to which coil. Print the document and write on it before you begin.

Abbreviations in this section.

F/S - Full Sequential

W/S - Wasted Spark

COP - Coil On Plug

See the sub folders more information.

Mercury Coil Drivers

Ignition Coils

Distributed Spark System
With this system, which was popular in the older cars, there is only one ignition coil for all the cylinders. The spark is distributed to the spark plugs with a rotor and distributor cap. Here only one driver is required from the ECU. The disadvantage of this system is that the coil has to charge and discharge a couple of times in one revolution. With high revving and performance motors this means that spark quality will deteriorate with increased RPM's. Another problem is spark deterioration with the gap between rotor and cap. It also has a higher maintenance service. Very important for these systems is the rotor fazing. Advantage is one coil and driver and full sequential spark system. (View it further in the manual.)

Wasted Spark System
With this system there is one coil for the two cylinders that move up and down simultaneously. The cylinders that are 360 degrees apart are paired. These coils have two High Tension towers which spark on the two plugs simultaneously, one on compression stroke and the other on exhaust stroke. Each dual coil is being driven by its own driver in sequence from the ECU. The advantage is less drivers and coils and better spark than distributors. This method only requires a crank gear with TDC slot. Disadvantage is the coils energy is divided between 2 spark plugs. Also the fact that current is reversed through on plug. This deteriorate copper cored sparkplugs unevenly.

Multi Coil Spark system

With this system there is one coil for every spark plug. The coils must be driven by separate drivers from the ECU. This makes the ECU larger and more expensive. The coils are fired in full sequential or wasted spark method. The advantage is more spark energy per cylinder. Disadvantage is the number of coils and drivers required.

Different Types of Coils

Coil Selection

It is important to know which coil on the engine has a faulty setting as this may destroy the ECU driver or coil. Always start the ECU with a disconnected output connecter till you set the trigger level output to the correct setting, or alternatively wire the ECU correctly. Start with a 5A Fuse in the coil positive circuit which will blow quickly if you have an error. If you have coil packs with a common positive, insert 5A fuses in each driver signal to protect the coil against damage.

Oil filled coils

The point-condenser coil has a resistance of +/- 1.5 ohm and a charge-time of 7 m/s. the spark on this coil will be weak. Should you need to use it do not connect the ballast resistor. If the coil has a resistance of 3 to 3.5 ohms it has a built in ballast resistor and will produce poor spark. It is not recommended to use these coils.

Electronic ignition coils were designed for variable dwell systems to improve spark at high Rpm's. They have a resistance of +/- 0.8 ohm. and a charge time of 3 to 3.5 ms. they can be used effectively but are being phased out by manufacturers. Some coils go as low as 0.4 ohm and need charge times of 1.5 to 2ms. For these coils Mercury2 must be used with the Mercury Coil driver.

Epoxy filled Basic coils

These hard resin coils and consist of single, wasted spark, COP or combinations of coils in a single housing. Some have built in driver electronics. If it has no driver there is usually a common pin and one pin for each coil. To measure this coil put the meter on Ohms and measure all the points. You should get a 0.8 Ohm reading for each coil. If you measure over the two coils it should read 1.6 Ohm. For these coils Mercury2 must be used with the Mercury Coil driver. See the Mercury Coil Drivers.

Epoxy filled coils with built in drivers

If you measure high resistances on open circuit, then the coils have an internal driver. These coils normally have a positive, ground and trigger input for each coil. These coils are normally charged with a positive pulse and fired with a negative going pulse. Mercury2 can drive these coils directly. These Coils with internal drivers can be connected two coils per output. You must make sure on the firing order to connect the two cylinders of these coils that move up and down simultaneously.

Spark Plugs and Leads

Use high quality inductive suppression leads such as Bougi Cord. Don't use wire leads: Possible interference.

Be careful when changing spark plug type. Always consult the vehicle's owner's manual first. Some ignition coils are sensitive to the type of spark plug used. If the ignition system uses resistive type plugs from the factory NEVER use non-resistive plugs as it may result in coil failure.

Run high tension leads as far from the ECU wiring as possible (especially sensor signals). Otherwise reconsider the wiring loom and layout. If the loom must cross the ignition wiring it should do so at 90° angles to minimize the interference.

(See the sub folders for explanation on wiring and connections.)

Related Links

Software


2 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 2 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

2 Coils

Intelligent Coils - Built-in Driver

2 Coils


3 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 3 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

3 Coils

Intelligent Coils - Built-in Driver

3 Coils


4 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 4 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

1 Coil with Distributor 2-Way Coil Driver

1 Coil with Distributor Single Coil Driver

2 Coils Wasted Spark

4 Coils COP Wasted Spark

4 Coils COP Full Sequential

Intelligent Coils - Built-in Driver

1 Coil with Distributor

2 Coils Wasted Spark

4 Coils COP Wasted Spark

4 Coils COP Full Sequential

Add-on Harness - Built-in Driver

4 Coils COP Wasted Spark Add_on - IS4X01-2

4 Coils COP Full Sequential Add_on - IS4X01-2


5 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 5 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

5 Coils

Intelligent Coils - Built-in Driver

5 Coils


6 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 6 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

1 Coil with Distributor 2-Way Coil Driver

1 Coil with Distributor Single Coil Driver

3 Coils Wasted Spark

6 Coils COP Wasted Spark

6 Coils COP Full Sequential

Intelligent Coils - Built-in Driver

1 Coil with Distributor

3 Coils Wasted Spark

6 Coils COP Wasted Spark

6 Coils COP Full Sequential

Add-on Harness - Built-in Driver

Straight 6 Coils COP Wasted Spark Add_on - CS6X01-2

Straight 6 Coils COP Full Sequential Add_on - CS6X01-2

V6 Coils COP Wasted Spark Add_on - CV6X01-2

V6 Coils COP Full Sequential Add_on - CV6X01-2


8 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 8 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

1 Coil with Distributor 2-Way Coil Driver

1 Coil with Distributor Single Coil Driver

4 Coils Wasted Spark

8 Coils COP Wasted Spark

8 Coils COP Full Sequential

Intelligent Coils - Built-in Driver

1 Coil with Distributor

4 Coils Wasted Spark

8 Coils COP Wasted Spark

8 Coils COP Full Sequential

Add-on Harness - Built-in Driver

8 Coils COP Wasted Spark Add_on - IV8X01-2

8 Coils COP Full Sequential Add_on - IV8X01-2


10 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 10 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

5 Coils Wasted Spark

10 Coils COP Wasted Spark

Intelligent Coils - Built-in Driver

5 Coils Wasted Spark

10 Coils COP Wasted Spark


12 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Coils >

Coils 12 Cylinder

Below are links for the Mercury2 connections on all the different variations of standard coils without drivers and intelligent coils with built-in drivers. Note on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine. Always disconnect P2 and P3 before switching the ECU on.

Standard Coils - No Drivers

1 Coil with Distributor 2-Way Coil Driver

1 Coil with Distributor Single Coil Driver

6 Coils Wasted Spark

12 Coils COP Wasted Spark

Intelligent Coils - Built-in Driver

1 Coil with Distributor

6 Coils Wasted Spark

12 Coils COP Wasted Spark


Comms Sensor Inputs

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Comms Connector

Comms Input connector contains wiring of the USB to UART communications cable and the Firmware Programmer. Click on the links below to find wiring diagrams for the items.

USB/UART communication cable

Firmware Programmer


ECU Crank and Cam Signal Tap-In

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Crank and Cam Sensor Tap-In

The Mercury2 controllers can be tied into existing OEM sensor circuits. There are a few rules around this to ensure that both systems operate correctly and is not damaged. It varies for the different products and sensors.

Controllers that share a sensor, has to share a common earth connection. Differences in earth will have an effect on the sensors signal. So make sure you connect the Mercury2 earth to the OEM earth.

Never connect the reference voltage of the Mercury2 to any wire of the OEM sensor. Only the signal wire is connected. It may damage either controller. The sensor already has power or reference voltage from the OEM controller. See the drawings below.

Isolate the Mercury2 wires that are not used. They will have power on them and may short circuit damaging the harness.

If the OEM sensor is not screened it is best to tie in close to the sensor and use the Spitronics screened harness. It may reduce some interference from coils. Remember Mercury2 inputs need to cater for all kinds of sensors and cannot cater for week signals with interference. If you still have interference, then you may add a 100uF and 100nF cap as filtering on their reference line and the Mercury2 sensor earth. See drawings below. NB. Do make sure which line is signal and which is reference. Crank the engine and measure AC volts to ground of each point on the sensor. The one with the highest value will be the signal line.

The blue Reference volts comes from the OEM controller and it differs between car manufacturers. Some use earth as a reference, other 2.4 volt, 5 volts and even 12 volts. The Mercury2 has isolating capacitors built in to connect to these signals without having a problem with different voltage levels. Mercury2 use a reference voltage for its sensors as ground. Note that Mercury2 requires a minimum 0.5-volt peak to peak signal to function correctly.

Below are the basic connections. Some cars may have a magnetic Crank or RPM sensor in combination with a Hall Cam sensor. Connect them accordingly. All the Mercury P1 connectors has the same pattern for Crank and Cam signals. Note that harness colours differ and should be verified on drawings or GP Priority charts.

For sensor Tap-In connections look at the following drawings.

Crank and Cam Sensor Tap In MEX02 2 P1.pdf


Crank and Cam Sensors

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Crank and Cam angle sensors

The Mercury2 is a universal controller designed for most types of Optic, Hall or Magnetic reluctor sensors. It can read 4 sensors in total. Mostly Crank and Cam or Speed sensors. Below is a link to a drawing with the different connect options for the Orion triggers.

Crank & Cam sensor options

The crank and cam angle sensors on an engine is used to determine crank and cam angles. (See the sub folders for more information.)

A crank angle sensor can be used alone for non VVTI engines, but this can only give information relative to 360 degrees. This engine will only run with split sequential injection and wasted spark coil firing. If full sequential injection is selected, injection is not in sink per engine stroke. It means you may sometime inject on the bottom deck of exhaust stroke and sometimes on bottom end of compression stroke. The aim is to always go for injection angle at bottom stroke just after the intake valve closes. Here atomization will be at its best and also consistent even if the stroke is not in sink. Full sequential spark is not possible in this scenario.

The cam angle sensor will give the ECU information over 720 degrees. This will indicate the 4 strokes for sequential injection or coil firing. Depending on the trigger wheel designs, some engines may need up to 2 revolutions cranking before the ECU can sink properly. Some programs may start in split sequential injection and fire the injectors in split sequential to enhance starting. Thereafter it will go to full sequential mode and stay there.

VVTI engines may have additional cam angle sensors that indicates the cam angle relative to the crank angle. This will let the ECU calculate and manipulate the cam angle for RPM and load variances. There may be intake cam control, exhaust cam control and also lift control. Then V type engines have all this in dual banks.

There are three types of sensors. The Magnetic reluctor sensor, Optic sensor and Hall type sensor.

The Magnetic reluctor sensor is a coil wound over a magnet. The teeth on the crank gear will disturb the magnetic field and that will generate a voltage spike over the 2 wires. The sensor is normally located on the engine block and picks up from a toothed wheel on the crankshaft. The physical position of the sensor may vary from front pulley, inside block and flywheel.

Hall and optic sensors both give a square wave outputs and are treated exactly the same. They have electronic components in the sensor which convert the signals to square wave. The Hall sensor uses magnetic field where optic sensor uses infrared light. In both cases a beam is broken and detected. The sensor output is usually an open collector transistor which means it will require a pull-up resistor normally situated in the ECU or TCU. This sensor is normally located on the valve cover and picks up protruded teeth from the camshaft. The physical position of the sensor may vary. The VVTI sensor will be positioned on the actual camshaft and not on the cam pulley to measure cam movement.


Error Codes

The ECU software has Error, Warning and Information codes displayed in the Status tool bar at the bottom. These codes will help the tuner to find problems during startup and tuning, also to see if the ECU is functioning correctly. Some of the functions on the ECU will indicate to the tuner what is happening. He can then see if these functions are operating correctly.

The codes are displayed at the right hand bottom corner. The code list [image] will display a list of accumulating codes so that the tuner can see what the codes were and in which order. The bottom indication will only show the last code. Also note that a code is only updated once, until it disappears and when it appears again the code will be logged again. This is to prevent the list from being too long. This does not apply to the angle sensor error codes during cranking. They will increment the counter as each one occurs.

Press the ''C'' key to clear the error codes. This is handy as you will not be able to see is the code is still present or if it was only listed once.

Note: If you crank an engine and it does not start, there will be one error code, error code 6 for Emergency Engine Shutdown. This is normal and not an actually an error. The ECU was expecting more trigger pulses but pulses were stopped. Therefore, the ECU goes into a safe shutdown of coils and injectors etc. A tip, press C then crank the engine. There should be no error and it will read 200 RPM's on the rev counter until the key is released.

The blue codes are for crank and cam related sensor errors. This is normally the angle signals that makes the ECU operate correctly. The red codes are warnings like over temperature etc. The green codes are for information of functions that were activated. The colors are only for explanation in this document.

The following list explain the different error codes

1 - Missing crank pulses - The crank sensor senses too little teeth per revolution

2 - Too many crank pulses or spikes - The crank sensor senses too many teeth per revolution

3 - Incorrect crank TDC slot - The crank sensor did not sense a TDC slot. (Maybe incorrect wiring)

4 - Missing TDC pulse - The TDC pulse is not present

5 - Missing home pulse - The Home pulse is not present

6 - Emergency engine shutdown - Safe shutdown of engine due to lack of or incorrect signals

7 - Fuel pressure safety cut-out - The fuel pressure sensor low limit has been reached

8 - Economy fuel cut-out - The fuel economy cut is implemented

9 - RPM limiter reached - The engine RPM limiter has been exceeded

10 - Max boost limiter reached - The boost pressure limit has been exceeded

11 - Water hot/cold temperature limiter reached - The water temperature limit has been exceeded

12 - Launch limiter reached - The launch limit RPM has been exceeded

13 - Lambda control limits reached - The lambda control limit has been reached

14 - Battery low voltage limit reached - The battery voltage falls below a critical limit

15 - Selection refreshed. Confirm driver placement - The ECU changed driver output configurations

16 - Timing retarded - Ignition timing is retarded during an automatic transmission shift procedure

17 - Flood control injector cut-out - Fuel is cut by injectors during cranking when the throttle is fully opened

18 - Flat-shift activated - Ignition or fuel is cut for a moment to enhance gearshift for racing engines

19 - Ignition power switched off - Ignition key power is switched off

20 - Sponsor counter depleted - The sponsor counter is depleted for sponsored ECU's

21 - Anti-Lag activated - Anti-Lag is activated on the Launch features

22 - 2Hardware Class don't support this feature - Incorrect firmware loaded

23 - 2Speed Limit Reached - Speed Limit was exceeded

24 - 2Bootloader Not Present - This indicate if the BootLoader firmware was not loaded in the newer products

25 - Overcharge Limit Reached - This error will come when the charge time plus graph times exceed the maximum charge times

26 - 2Test Mode is Selected - This is used for calibrating TxW firmware


Firmware Programmer

Help > Product Selection >

Firmware Programmer

The USB Debug Adapter or Firmware Programmer as we call it in the manual, are used to download updated firmware or other firmware into the ECU. This unit requires software to be installed and can be downloaded from www.spitronics.com under the following path. You may click on the bottom link to download the software.

Firmware Programmer Software

http://www.spitronics.com/downloads/Firmware Programmer/mcu_ide.exe

This manual can be found under the sub folders. One rule is NEVER press a button called "Erase All Code Space". This will wipe the unit completely and it will have to be returned to the factory. Read through the precautions part before attempting to program your device.

Related Links

Wiring Diagram


FAQ Frequently Asked Questions

Help > TCU Transmission Management >

Frequently Asked Questions

This chapter will shed light on certain areas where common mistakes are made. It will explain certain topics and test procedures to help you solve this problem faster without the help of a dealer. It may also save the dealer time if you do the legwork in testing before hand to the point that you need advice. Some chapters may have numbers which helps to bring the dealer up to speed on where you get stuck with solving the issue. This section is generic in all the manuals so it may cover topics not really featured in this installation manual but rather the software manual.

If your answer is not included in this section, please contact the dealer for help and forward us your query as to include any new questions in future FAQ modules.

See the sub folders for the different topics.

Image result for FAQ Image


Fuel Pressure Control

Help > ECU Engine Managment > ECU Hardware Description > Fuel Supply >

Fuel Pressure Control

The Mercury2 ECU has the feature to control fuel pressure by controlling the speed of the fuel pump. This is done with Pulse Width Modulation (PWM) from the power that is supplied to the fuel pump. In some cases, the positive driver of the Mercury2 is strong enough to directly control the fuel pump. But most fuel pumps draw more than 6-amp power at full delivery which will current limit the driver. To remedy this an amplifier is used in the form of the Spitronics Electronic Relay. The relay is pulsed in PWM and then does all the hard work and protects the ECU. Note: All inductive loads that are pulsed requires the free wheel diode over the power wires. This diverts generated currents back through the inductive loads eliminating electrical interference. Note: Cathode or the stripe on the diode must always be on the positive side, otherwise it will act as a short circuit and may damage itself and other components. Always put a fuse inline to protect the circuit and as close to the power supply as possible.

(See all the settings required under the Product Software Description.)

Related Links

Software

Error Codes


Fuel Pressure Sensor

Help > ECU Engine Managment > ECU Hardware Description > Fuel Supply >

Fuel Pressure Sensor

The fuel pressure sensor relays the fuel pressure back to the ECU to control the fuel pump with PWM and keep a constant pressure over the injectors. This is important for the ECU to supply an accurate amount of fuel per engine stroke. The ECU can vary the speed of the fuel pump to increase or decrease fuel pressure accordingly. The sensor gives a continual feedback of fuel rail pressure so that the ECU can make pressure adjustments almost instantaneously. This setup allows the engine to run without a manual fuel pressure regulator or return line. The 4 Bar Map sensor, 5.5 Bar DP sensor, or 7 Bar Map sensor can be used as a fuel pressure sensor. The setting differs for each of them and is discussed in the software.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The fuel pressure sensor must be mounted inside the engine bay. The pressure input pipe must be securely connected to the high pressure fuel line with a T piece. The sensor must be mounted higher than the fuel line with the pressure nipple facing downwards. This will produce an air bubble between the sensor and the fuel to prevent damage. The fuel does not actually contact the sensor element and the bubble acts as a damper to the pulsing fuel. The other pipe of the DP sensor must be connected to the intake manifold. It could be joined with the MAP sensor line if the takeoff pipe has a large enough hole to prevent delays in the signal.

Pressure sensor types
The fuel pressure sensor available from Spitronics is the Motorola series sensor

The fuel pressure sensor is rated at 5.5 bar differential pressure (DP) and the aluminum one is 4 or 7 Bar MAP.

Sample Sensor Pinout and layout

Related Links

Software

Error Codes


Fuel Supply

Help > ECU Engine Managment > ECU Hardware Description >

Fuel Supply

The fuel supply is mostly a basic mechanical system which is not controlled by the ECU except for switching and controlling the power of the fuel pump. some of the Ecu's have the ability to do fuel pressure control. Below is a few schematics on basic fuel flow systems.

The basic fuel rail and pressure regulator system.

External Fuel Pump

In this system the fuel pump is supplied from the tank via a petrol filter through a thick pipe at gravity feed pressures. The pump pressurizes the fuel through the high pressure fuel filter into the fuel rail with injectors. A fuel pressure regulator will bleed fuel back to the tank if the pressure is higher that it calibrated bypass diaphragms. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. The return fuel also cools the fuel pump. The fuel pump is always on full power.

Internal Fuel Pump

In this system the fuel pump is mounted inside the tank with a sift as a pre-filter. The pump pressurizes the fuel via a high pressure fuel filter through the fuel rail with injectors against a fuel pressure regulator. The regulator senses the intake manifold pressure and adjusts the fuel pressure to a set level. This is done by returning the excess pressure and fuel via a return line straight back to the tank. The fuel in the tank cools the fuel pump. The fuel pump is always on full power. Some systems have the pressure regulator built into the tank and then there is only one fuel line to the fuel rail and injectors. No return line.

Pressure controlled Fuel Pump

In this system the fuel pump is mounted inside or outside the tank with a pre-filter. The pump pressurizes the fuel via high pressure fuel filter through to the fuel rail and injectors. In the fuel rail a fuel pressure sensor will relay the pressure to the ECU. The ECU will speed control the fuel pump with PWM to increase or decrease the pressure. There is no return line or mechanical fuel pressure regulator. The fuel DP fuel pressure sensor also senses the manifold pressure.

Related Links

Software


Fuel system Trouble Shooting

Help > ECU Engine Managment > ECU Hardware Description > Fuel Supply >

Fuel system Trouble Shooting

Fuel supply line to the pump is too thin. This will cause the fuel pump to draw a very low pressure on the inlet. When the fuel becomes hotter it will percolate due to the low pressure. This gas will then enter the pump making the pressure erratic. The gas is then pressurized at the injector tip and will reduce petrol flow and cause lean mixtures. The gas bubbles can also damage the pump.

Fuel pump heats up. It could be mounted too close to the exhaust or the pump is too large for the fuel rail system. The fuel flowing through it is too little to cool it off. It could be a dirty fuel pressure filter down stream that causes the pump to pump at too high pressures. If the pump is hot it will also cause the fuel to percolate and make gas bubbles. Do not bring the return line to the front of the fuel pump. The fuel must be cooled off in the tank.

Mechanical fuel pressure failure. Inside is diaphragms that could rupture or become soft with heat. Then accuracy may be a factor in cold and hot conditions. The vacuum line to the intake manifold can leak causing pressure differences.

Fuel lines are too thin. If the line to the fuel rail is too thin, the fuel pressure will drop before it reaches the injectors. If the return line is too thin the fuel pressure regulator cannot regulate properly and the pressure will be too high.

Erratic fuel pressure. This is usually caused by batch fueling as all the injectors open and close all at once. This makes for differences in pressure and fuel supply between the cylinders upstream and downstream.

Fuel pump is noisy and makes uneven sounds. These pumps get damaged by dirt, water and air bubbles. It is good practice to put an inline filter in front of the pump to ensure that dirt does not go through the pump. This will also indicate if air is in the system as most filters are see-through. It may pull in air through the connections.

Related Links

Related Links

Software

Error Codes


General Purpose

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

General Purpose

The general purpose outputs could be used for numerous control on the engine. Each option requires different wiring. The outputs of the ECU may be strong enough to drive certain units directly and others may require a relay or amplifier.

Click on the link below for the different wiring diagrams.

Electric Fan Control

V-tech Solenoid Control

Variable Intake Solenoid Control

Lamp Control


GP Priority Layout

Help > ECU Engine Managment > ECU Hardware Description >

GP Output priority

The Mercury2 is a universal controller that can have many variations of wiring. Due to new features that is added to the same hardware it is inevitable to move inputs and outputs to suit certain applications. This means that newer versions in firmware is connected differently. We try and keep wiring as standard as possible for same group of engines like 4 or 6 cylinders etc. There are engines that has to be different in the same group. It may be to keep backwards compatibility or to optimise the hardware. Make sure your application uses the correct firmware and I/O locations.

NB! Make sure to verify the new wiring against your old wiring when you upgrade your system.

This manual is a modular drawing manual where you have to decide on wiring and print different section of drawings. The GP Priority sheet will explain where each Input or output is, and for convenience the wire colour is next to it for the different harnesses available. Make sure on your harness part number at the connector end. For wiring at the other end you need to print your own combination from the different drawings in the manual.

Click on one of the links below and print this section.

Version 3.5E

Standard

Mercury2 ECU Standard Pulses 3.5E+ GP Output Priority Layout.pdf

4 Cylinder

Mercury2 ECU 4Cyl 3.5E+ GP Output Priority Layout.pdf

5Cylinder

Mercury2 ECU 5Cyl 3.5E+ GP Output Priority Layout.pdf

6 Cylinder

Mercury2 ECU 6Cyl 3.5E+ GP Output Priority Layout.pdf

8 Cylinder

Mercury2 ECU 8Cyl 3.5E+ GP Output Priority Layout.pdf

Mercury2 ECU 8Cyl Lexus VVTI 3.5E+ GP Output Priority Layout.pdf

Mercury2 ECU 8Cyl Nissan VVTI 3.5E+ GP Output Priority Layout.pdf

Mercury2 ECU V8 2Coil 3.5E+ GP Output Priority Layout.pdf

10 Cylinder

Mercury2 ECU 10Cyl 3.5E+ GP Output Priority Layout.pdf

12 Cylinder

Mercury2 ECU 12Cyl 3.5E+ GP Output Priority Layout.pdf

2 Rotor

Mercury2 ECU 2 Rotor 3.5E+ GP Output Priority Layout.pdf

Old Version 3.5A

Standard

Mercury2 ECU Standard Pulses 3.5A GP Output Priority Layout.pdf

3 Cylinder

Mercury2 ECU 3Cyl 3.5A GP Output Priority Layout.pdf

4 Cylinder

Mercury2 ECU 4Cyl 3.5A GP Output Priority Layout.pdf

Mercury2 ECU 4&6 Cyl Combo 3.5A GP Output Priority Layout.pdf

Mercury2 ECU 4Cyl VVTI 3.5A GP Output Priority Layout.pdf

5 Cylinder

Mercury2 ECU 5Cyl 3.5A GP Output Priority Layout.pdf

6 Cylinder

Mercury2 ECU 6Cyl 3.5A GP Output Priority Layout.pdf

Mercury2 ECU 6Cyl VVTI 3.5A GP Output Priority Layout.pdf

Mercury2 ECU 6Cyl M3 E46 3.5A GP Output Priority Layout.pdf

8 Cylinder

Mercury2 ECU 8Cyl 3.5A GP Output Priority Layout.pdf

Mercury2 ECU 8Cyl VVTI 3.5A GP Output Priority Layout.pdf

Mercury2 ECU 8Cyl LS2 3.5A GP Output Priority Layout.pdf

Mercury2 ECU V8 2Coil 3.5A GP Output Priority Layout.pdf

10 Cylinder

Mercury2 ECU 10Cyl 3.5A GP Output Priority Layout.pdf

12 Cylinder

Mercury2 ECU 12Cyl 3.5A GP Output Priority Layout.pdf

2 Rotor

Mercury2 ECU 2 Rotor 3.5A GP Output Priority Layout.pdf

Related Links

Software Setup

GP Output Wiring


Handshake ECU with TCU

Help > TCU Transmission Management > TCU Hardware Description >

Handshake with TCU

The Mercury2 ECU can be interfaced with Spitronics TCU's to make wiring less complex. Sensors like TPS could be shared. The TCU also requires an RPM signal and it is connected to the RPM output of the ECU. This is calibrated in the ECU and TCU. The TCU can indicate to the ECU to retard timing during automatic transmission shifts. This will soften the shift making driving more pleasurable. Note how these connections ate interfaced with the TCU.

The TPS input of the ECU is connected to a yellow wire to supply the signal to the TCU input. The ECU will supply the power and ground to the TPS sensor.

The RPM is processed in the ECU and then output to the TCU.

The TCU negative Retard output is taken to the ECU POT input. When the signal goes to negative then the ECU will retard timing to a set level.

Click on the link below for the different wiring diagrams.

Handshaking wit Mercury2 TCU


Harness Layout

Help > TCU Transmission Management > TCU Hardware Description >

Harness Layout

Mercury2 is a universal controller and has many options with firmware like ECU,TCU,TxW,etc. This calls for different harness options. It is based on the old pinout structure started wit Mercury way back. However it has more conectors and features. Although older harnesses can be used with Mercury2, it is not reccomended. Below is a list of harnesses that is reccommended and also ones that are still in production. There is also a list of old harnesses that we added in the manual for backwards compatability should a installer want to upgrade from and older product.

This manual is based on the most complete harness for explanation purposes. Some harness do not contain all the wires so make sure on your harness' part number to view the correct wire colours. ECU and TCU harnesses are featured here due to the overlapping of harness in use. Note that some design drawings have 2 or 3 pages. If a harness has a V2 (Version 2) behind it then it means, there was alterations or improvements done on it. There may be components added to reduce interference so compare your old harness one to the latest version to see if you need to do the modifications. Always select the Reccomended harnesses for new installations.

NB! Mercury2 is not completely backwards compattible to Mercury or other products. Make sure that you are familiar with the changes or rather install the reccommended harnesses.

For more information, click on the links below:

Harnesses in Production

Reccomended

MEX02-2 Harness.pdf (Drawing) - MEX02-2 Harness.pdf (Describtion) - MEX02-2 (Overview) - ECU Easy Install Harness Level 2

MTSX02-2 Harness.pdf (Drawing) - MTSX02-2 (Overview) - TCU Easy Install Harness Level 2 - Stand alone aplication

MTWX02-2 Harness.pdf (Drawing) - MTWX02-2 (Overview) - TCU Easy Install Harness Level 2 - Use with ECU system

S03 Idle Control Harness.pdf (Drawing) - SO3 (Overview) - Idle2 Stepper Control Harness 12 Pin

MC1-P1 Harness.pdf (Drawing) - MC1-P1 (Overview) - Required for any of the Mercury Coil Drivers

MC2-P2 Harness.pdf (Drawing) - MC2-P2 (Overview) - Required for the Mercury 2 Way Coil Driver

MC4-P2 Harness.pdf (Drawing) - MC4-P2 (Overview) - Required for the Mercury 4 Way Coil Driver

MC6-P2 Harness.pdf (Drawing) - MC6-P2 (Overview) - Required for the Mercury 6 Way Coil Driver

Not Reccomended

This is Level 1 harnesses designed for Mercury and handy for backwards compatibility explanations. They are not featured in this manual.

P1 - Input Harness P2 - Output Harness P3 - Input / Coms Harness P4 - Input / Output Harness P5 - Output Harness

M01 - P1 Harness M02 - P2 Harness M03 - P3 Harness M04 - P4 Harness M07 - P5 Harness

M05 - P1 Harness M02 - P2 V2 Harness

M06 - P1 Harness

T01 - P1 V2 Harness T07 - P2 Harness T03 - P3 Harness T04 - P4 Harness

T02 - P1 Harness T06 - P3 Harness T05 - P4 Harness

T08 - P1 Harness T09 - P3 Harness

ECU Injector and Coil Add-on Harnesses

These drawings illustrate the layout and specifications of the optional Add-on harnesses that connects injectors or coils to the MEX01-2 harness. They are there for easy installation but are sold separately due to the number of engine configurations. They are not required for the installation but merely a help in faster wiring. Below are a series of links to make choosing more easy on your part. Note that some engines are not covered here so you will have to make your own connections on the engine. See the individual wiring diagrams of your engine under injector and coil wiring.

Coil Add-on Harness

Straight 4 Cyl CS4X01-2 Coil Add-on Harness Design

Straight 6 Cyl CS6X01-2 Coil Add-on Harness Design

V6 Cyl CV6X01-2 Coil Add-on Harness Design

V8 Cyl CV8X01-2 Coil Add-on Harness Design

Injector Add-on Harness

Straight 4 Cyl IS4X01-2 Injector Add-on Harness Design

Straight 6 Cyl IS6X01-2 Injector Add-on Harness Design

V6 Cyl IV6X01-2 Injector Add-on Harness Design

V8 Cyl IV8X01-2 Injector Add-on Harness Design

Old Harness Layout

Injector Harness

IN02 Injector Lexus Harness

Stepper Idle Control Harness

S02 8 Pin Stepper Harness


Harness Overview

Help > TCU Transmission Management > TCU Hardware Description > Harness Layout >

Harness Overview

Mercury2 (Complete Wire and Play Series)

MEX02-2 Harness

MTSX02-2 Harness (Standalone Option)

MTWX02-2 Harness (Use with ECU Option)

Mercury(Econnomy Series - May be used with Mercury2)

M01-P1 Harness

M05-P1 Harness

M06-P1 Harness

M02-P2 V1 Harness

M03-P3 Harness

M04-P4 Harness

M07-P5 Harness

T01-P1-V2 Harness

T02-P1 Harness

T03-P3 Harness

T04-P4 Harness

T05-P4 Harness

T06-P3 Harness

T07-P2 Harness

T09-P3 Harness


High Impedance Injectors

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

High Impedance Injectors

These drawings explain how the injectors are connected for each injector driver. The amount of connections will vary with engine size. (See specific drawings for your application.)

Batch & Split Batch Wiring

With this method you always combine 2 injectors in Parallel. In this drawing A1 is on cylinder 1 and A2 is on the cylinder that moves with it.

Batch & Split Sequential Wiring with Dual injectors

With this method you still combine 2 drivers in parallel. The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. Note: Make sure that the driver can take the combined current for the 4 injectors. Mercury2 can handle 6 Amp per driver. A diode large enough must be wired-in for each bank from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For 2 high impedance injectors the diode must be 3A or higher. In this drawing A1 & A2 is the primary injector and A3 & A4 is the dual injectors. A1 & A3 is on cylinder 1 and A2 & A4 is on the cylinder that moves with it.

Full Sequential Wiring

With this method only one injector is connected per driver.

Full Sequential Wiring with Dual injectors

The electronic relay will split the power from getting to the dual injectors. The ECU will switch the electronic relay on with a positive signal from one of the positive drivers reserved for this function. Some applications have enough drivers and then the dual drivers are connected (as above) onto its own driver. No electronic relay will be required. A diode large enough must be wired in for each injector from the electronic relay. This will prevent power feedback from the injector drivers when the electronic relay is off. For high impedance injectors the diode must be 3A or higher. In this drawing A1 is the primary injector and A2 is the dual injectors.

Relate Links

Software


Idle Control

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Idle Control

There are different methods to cater for most types of idle control motors found on the different engines. Make sure you select the correct wiring procedure for positive or negative driver outputs. When a certain type is selected the software will indicate on which output it must be connected. You can also view this on the GP Priority spread sheets available for different firmware. Note that on the stepper controllers there are an ID wire to select between positive or negative input from the ECU.

Click on the links below:

Single Idle Valve with Spring Return

Dual Idle Valve

Idle Control2 Type 1 Stepper 4 Pole

Idle Control2 Type 2 Stepper Bipolar

Toyota Black Idle Valve


Injectors

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Injectors

This folder contains all combinations of wiring options for injectors on the Mercury2. These drawings are made for the high end harness and may differ in wire colours to other harnesses. Consult your harness layout further in the manual. The main choices are, no of phases, low or high impedance, single or dual injectors per cylinder and the type of injection namely Batch, Split-sequential or Full sequential injection. Each folder contains its different variations for your engine. Note that the drawings are generic and you have to fill in your own firing order to see which wire colour goes to which injector. Print the document and write on it before you begin. Also note that combinations included in this manual may or may not be available for the hardware class.

See the sub folders for drawings.

Fuel Injector explanations

The fuel injector outputs drive the fuel injectors to allow measured amounts of fuel into the engine. These signals are on/off control signals that are varied by duty cycle. The more fuel is required the higher the duty cycle will be. The injectors are connected to common positive and the drive signals from the ECU is ground signals.

Operation
The injectors are solenoid valves that are opened by current to let fuel pass through the nozzle. The nozzle has a spray pattern that will help in atomizing the fuel with air. This in turn will make a combustible mixture.

Injection types

Batch Injection

With this method, injector drivers are being pulsed at the same time once or twice per revolution. Very rare firmware from Spitronics, although not preferred, can use this method. However, fuel metering and timing is done very accurately and should still give excellent results. Split the injectors in groups to divide the current evenly between the available driver outputs. For bigger engines keep the mean supply current below the current capability of the drivers of that product. (See specifications.) Note: More outputs are available in the intermediate and advance units. (See specific wiring diagram.) The biggest disadvantage with this method is the fuel pressure pulses due to uneven tapping. Advantage is easy wiring.

Split Batch Injection

With this method, two injector drivers are being pulsed 180° out of faze. Although not preferred, fuel metering and timing is done very accurately and should give excellent results. Split the injectors in two groups to divide the current on the 2 driver outputs. Put alternate numbers on the firing order together to ensure a more even fuel distribution. For bigger engines keep the mean supply current below the current capability of the drivers of that product. Note: More outputs are available in the intermediate and advance units. (See specific wiring diagram.)

Split Sequential Injection

This method will inject on the two cylinders that move up and down together simultaneously and then in sequence on the other cylinders at the same position. Injecting once per revolution and will start at BDC or it may be adjusted otherwise. Fuel is injected very accurately and excellent CO adjustments can be achieved. The advantage of this method is that each cylinder receives its fuel under the same conditions, resulting in very smooth idling and revving. It is definitely better on power and consumption than the batch injection method. Injectors are wired in the same sequence as wasted spark. The fuel is distributed more evenly from the fuel pump and pulsing of fuel pressure comes to a minimum. The ECU only requires half the amount of drivers than cylinders on the engine. (See driver selection chart on how to combine these injectors.)

Full Sequential Injection

With this method each injector requires a driver. Fuel is injected once in 2 revolutions and normally starts at Bottom Deck Centre (BDC). Note: This feature is mainly for engines up to 8 cylinders. Disadvantage is that this method does require the Cam or home pulse to sink injection with fazes and low impedance injectors require a ballast resistor. Advantages are better fueling at lower RPM and longer duty cycle makes for more accurate measuring on large injectors. If you don't have a home pulse it can still do full sequential injection but injection is not slinked on stroke. In these cases, start injection degrees can be set at BTDC just after the intake valve closes. (See wiring diagram on how to combine the injection methods.)

Throttle Body Injection

With this method, injectors are situated at the throttle body. The first generation injection systems used this method. It is important to inject in the right sequence especially on the 4 barrel systems. Some injectors are aimed at certain ports and must be pulsed in sequence to get a smooth distribution of the fuel mixture. (See specific wiring diagram to ensure the correct injectors are on the correct drivers.) Advantage of this method is easy to convert carburetor engines to fuel injection.

Micro Fueling or Dual Injectors

The ECU allows for the use of dual injectors per cylinder to be used. This has the advantage for turbo and duel fuel applications. If the power range of an engine is very big, one injector is too small at maximum load or too large to control at minimum load. Then the ECU will use 1 injector for light loads and 2 for high loads. The second injector could also be phased in with a different fuel mix for racing. Wiring is done in two ways depending on how many drivers are available on the ECU. Some may require an electronic relay to power the second set. (See wiring methods in the sub folders.)

Injector Sizing
Sizing example: 5 cc fuel is required for every 1 HP. This means that an 8 cylinder 600 HP requires 600 HP x 5 cc / 8 injectors = 375 cc/min. This is assumed at Lambda 1.00 (14.7 AFR) so if you are running richer, the desired Lambda reading needs to be taken into account. This calculation is based on information from the internet and should be researched with other manufacturers. It is merely as an example.

Resistance & Current
Different injectors have different resistance from 0.5 ohms to 16 ohms. This means that they require different operating currents and wiring circuits to open them. The Spitronics ECU's were designed for high impedance injectors. They draw 1 Amp each and can be connected together on the drivers in parallel. (See specifications on how much current the drivers can handle between the different products.) Low impedance, 3 to 5 ohm injectors, require current limited drivers to peak and hold drivers. With a minor wiring difference, the ECU's can do low impedance injectors connected in series. They draw 4 Amp each but in series they draw 2 Amp. Again, see the specifications on the ratings of the ECU's. If you want to do full sequential you need to add a 3.3 Ohm 10 Watt resistor in series to limit the current. Injectors with lower resistances like direct injection drivers cannot be used with the ECU's.

Dead Time
Dead time is the amount of time the injector takes to open from when the injector pulse starts. This varies with battery voltage and fuel pressure. Also varies between different kinds of injectors but is usually about 1 milliseconds or less at 14 volts. This dead time needs to be accounted for with Battery Voltage Compensation. But it is tuned in when the engine is mapped on the Dyno or street.

Spray Patterns
Some injectors have better spray patterns and atomize the fuel better than others. Injector position can dictate what type of spray pattern is required. Cycle, Duty Cycle and Pulse Width

A fuel injector is continuously powered by battery positive. The ECU output switch to ground to turn the injector 'on'.

Frequency: Number of complete cycles in one second, measured in Hertz. 1 Hz = 1 cycle/second. It is engine RPM / 60.

Cycle: Time from when an injector is turned 'on' until the next time it is turned 'on'.

Pulse Width: The time in seconds the injector is 'on'.

Duty Cycle: Percentage of time the injector is 'on' in one cycle.

Most injector ratings are to be used within 85% duty cycle. You may get more fuel through with higher fuel pressure but stay within the working limits of the injector.

(See sub folders for explanation on wiring and connections.)

Relate Links

Software


1 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 1 Cylinder

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2 Harness

High Impedance

1 Injector Full - Sequential


2 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 2 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

2 Injector Full - Sequential


2 Rotor

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 2 Rotor

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

4 Injector Full - Sequential


3 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 3 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

3 Injector Full- or Slit- Sequential


3 Rotor

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 3 Rotor

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

6 Injector Full - Sequential


4 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 4 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

There are 2 groups of drawings.

· Connection to the MEX01-2 harness directly. With this connection you have to make your own harness on the engine for injectors to group them with power wires.

· Connection of the IS4X01-2 optional Add-on Injector harness. The add-on harness makes wiring easier but it must be bought for a specific engine like straight six or V8 etc. Note that these part numbers differ for each engine combination.

MEX01-2

High Impedance

4 Injector Split - Sequential

4 Injector Full - Sequential

8 Dual Injector Split - Sequential

8 Dual Injector Full - Sequential

Low Impedance

4 Injector Split - Sequential - No Longer Recommended

4 Injector Full - Sequential

8 Dual Injector Split - Sequential - No Longer Recommended

8 Dual Injector Full - Sequential

IS4X01-2

4 Injector Full - Sequential High Impedance


5 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 5 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

5 Injector Full- or Slit- Sequential


6 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 6 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

There are 2 groups of drawings.

· Connection to the MEX01-2 harness directly. With this connection you have to make your own harness on the engine for injectors to group them with power wires.

· Connection of the IV6X01-2 optional Add-on Injector harness. The add-on harness makes wiring easier but it must be bought for a specific engine like straight six or V8 etc. Note that these part numbers differ for each engine combination.

MEX01-2

High Impedance

2 Injector Split - Sequential TBI

6 Injector Split - Sequential

6 Injector Full - Sequential

12 Dual Injector Split - Sequential

12 Dual Injector Full - Sequential

Low Impedance

2 Injector Split - Sequential TBI

6 Injector Split - Sequential - No Longer Recommended

6 Injector Full - Sequential

12 Dual Injector Split - Sequential - No Longer Recommended

12 Dual Injector Full - Sequential

IV6X01-2

Straight 6 Injector Split - Sequential High Impedance - IS6X01-2

Straight 6 Injector Full - Sequential High Impedance - IS6X01-2

V6 6 Injector Split - Sequential High Impedance - IV6X01-2

V6 6 Injector Full - Sequential High Impedance - IV6X01-2


8 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 8 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

There are 2 groups of drawings.

· Connection to the MEX01-2 harness directly. With this connection you have to make your own harness on the engine for injectors to group them with power wires.

· Connection of the IV8X01-2 optional Add-on Injector harness. The add-on harness makes wiring easier but it must be bought for a specific engine like straight six or V8 etc. Note that these part numbers differ for each engine combination.

MEX01-2

High Impedance

4 Injector Split - Sequential TBI

8 Injector Split - Sequential

8 Injector Full - Sequential

16 Dual Injector Split - Sequential

16 Dual Injector Full - Sequential

Low Impedance

4 Injector Full - Sequential TBI

8 Injector Split - Sequential - No Longer Recommended

8 Injector Full - Sequential

16 Dual Injector Split - Sequential - No Longer Recommended

16 Dual Injector Full - Sequential

IV8X01-2

8 Injector Full - Sequential High Impedance


10 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 10 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

10 Injector Split - Sequential

Low Impedance

10 Injector Split - Sequential - No Longer Recommended


12 Cylinder

Help > ECU Engine Managment > ECU Hardware Description > Outputs > Injectors >

Injectors 12 Cylinders

Below are links for Mercury2 on all the different variations of injector driver connections. Note that on each drawing the software settings are displayed. Make sure to follow the start-up procedure to ensure all the settings are correct before attempting to start the engine.

MEX01-2

High Impedance

12 Injector Split - Sequential


Introduction

Help >

Introduction

The Mercury2 Manual is a complete document which have all the information regarding the product, accessories, installation drawings, instructions and software. It will teach you the do's and don'ts, installation tips and tuning guidelines. It has all the different product software and installation like ECU, TCU TxW etc.

Some drawings may refer to software settings to help a customer to select the correct settings. Each product has its range of features and are sold on different price levels for that reason. So do make sure there are firmware available for that type of connection before you install the system. See the Mercury2 Selection Chart for features and hardware class reference.

Mercury2 harnesses are developed for different applications and products. Each harness has a part number label that is placed at the connector side. This is important as drawings are made for specific harness and wire colours. Always make sure your drawing and harness match up. Each drawing will have its harness numbers in the top label. The manual is based on the Level 2 easy install harnesses that includes relays and fuses. Other harness options are displayed in the GP Priority sheet to verify colours. These harnesses are adopted from older products and are displayed to make backwards compatible colour tracing easy.

In the harness drawings you will also find a layout of these harnesses. Other drawings will explain each item as it is connected to the Mercury2 controller.

If there is any confusion or lack of information, please let us know and it will be updated regularly. Always make sure you have the latest update. The date is part of the manual name.


Jumper Settings

Help > TCU Transmission Management > TCU Hardware Description >

Jumper Settings

The Mercury2 are universal products that cater for all kinds of sensors and features. Therefore, it has Jumpers that will expand the universality of these products. The jumper settings are around the crank and cam angle sensors to select between hall or magnetic sensors.

Click on the link below for an explanation of jumper positions.

Mercury2 ECU Jumper Settings

Mercury2 TCU Jumper Settings


ECU Lambda

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Lambda Sensor

The Lambda Sensor or Oxygen Sensor is used by the ECU to display Air Fuel Ratios AFR and optimize the fuel economy after the vehicle has been tuned. Note: In the ECU software it shows a voltage signal and not the actual AFR value. The reason is that the ECU is not a tuning tool with calibration software. It is merely using the sensor for control purposes which is tuned to the correct mixture.

Different Lambda sensors
1 to 4 wire sensors are normally narrow band sensors. Their signal could be used directly in the ECU as it is a 0.1 volt to 0.9-volt signal. The 5 and 6 wire sensors require driving electronics and give a 0 to 5-volt signal out for the ECU. This wideband signal could be used by the ECU.

Testing a Lambda sensor for the correct Pin-outs
Test the resistance with an Ohm Meter between two pins at a time. The heater element normally has the same colors and has a resistance of 6 to 12 ohm. Connect the element wires to earth and 12 volts as above. The element does not have a specific polarity. The sensor output can only be measured while the engine is running. Connect the two remaining wires to the ECU signal input wires as indicated on the drawing. The sensor will only give an output when the engine has achieved some temperature. If the sensor is not working, swop the signal and earth wires and test again. The sensor will not be damaged if the earth and signal output has been swopped.

Life expectancy.
The life expectancy of a lambda sensor varies due to fuel type and application. On unleaded fuel around 500 hours. Very rich mixtures will shorten sensor life. Lambda sensors can be damaged by gasket sealants, anti-seize and some fuel additives.

Position
The ideal position for mounting the lambda sensor is at least half a meter from the engine and after the exhaust collector or turbo down pipe. The lambda should be orientated on the top or side of the pipe. Never at the bottom!

Sample Sensor Pin outs

Related Links

Software Setup

Error Codes


Low Impedance Injectors

Help > ECU Engine Managment > ECU Hardware Description > Outputs >

Low Impedance Injectors

Explanation

First you need to understand what is a low or high impedance injector. Most injectors nowadays are high impedance. They have a resistance of around 15 Ohm or even higher. This means they draw a current of about 1 amp which makes it very suitable for todays ECU's. No need to use complicated drivers or high current components. Typical injector drivers is around 40 volt which is found in Mercury2.

High performance injectors or large volume injectors are still manufactured with a low impedance. They are around 2 to 5 Ohm in resistance. These injectors use more energy which means they open faster and can handle higher fuel pressure. The correct driver for these injectors is what they call a Peak and Hold driver. It means the driver will start with a high voltage and send a lot of current through the driver to open quickly and strongly. Then after about 1 milliseconds the voltage is reduced by as far as 3 volt to have just enough retaining current to keep it open. Then when the driver switch the injector off, the current will subside quickly and the injector close fast without delay or high voltage spikes. Due to the complexity of these Peak and Hold drivers we did no include them in the Mercury2.

How to use Low Impedance Injectors with Mercury2 Ver 3.5E

Mercury2 do not have High voltage or high current drivers. The only method to use Low Impedance correctly is the single injector per driver with a ballast resistor. Select Full Sequential or Split Seq 1x Inj Per Driver.

This means that only 1 injector is connected per driver which will reduce the amount of current drawn from the injector driver. Mercury2 drivers can only deliver 6 amp then they switch off to protect themselves. This usually happens at full load conditions where the engine will then cutout without an error code. Full Sequential is also better when large injectors are used because the time the injector is opened is longer and can be more accurately adjusted. There is only one dead band in two revolutions.

If the resistance is 4 ohm and above you can try a direct connection like with high impedance.

If the resistance is lower you may add a series resistor the get the combined resistance to 4 ohm and above. Use a 10 Watt resistor and mount them on a heatsink so that they can cool down. They will generate quite an amount of heat. The injector is cooled by the fuel so they don't heat up too much. Below is a wiring example.


TCU Map Selection Switch

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Map Selection Switch

The TCU can save up to 4 different tuning maps with a Map selection switch. This switch can be calibrated in the software. It is also a digital switch that is converted to analog signal with resistors. The hardware is also ECU capable and then do not require these resistors. If you use a different harness make sure to add the resistor to the 5 volt output on P1 Pin 9.

See the wiring diagram Below.

4 Map Switch Drawing


ECU MAP Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

MAP Sensor

The Mean Absolute Pressure (MAP) sensor provides instantaneous manifold pressure information to the ECU. The data is used to calculate air density and determine the amount fuel required for optimum combustion. This sensor influences also the advancement or retardation of ignition timing. This sensor is a reliable replacement for the Mass meter type sensors.

This Aluminum model comes in 1.1 Bar, 2.5 Bar, 3 Bar and 4 Bar versions.

Operation
The Pressure Sensor requires 5 volts DC which is supplied to the sensor by the ECU. It then generates a signal from 0 to 5 volt equivalent to the pressure range of the sensor.

Sensor Location
The manifold take off point should be at a position that best represents the average manifold pressure with minimum pulsations. A filter can be fitted inline to reduce manifold pressure pulsations. Do not T-off idle or brake booster fittings etc. The take-off pipe must be direct to the manifold. When mounting the MAP sensor, face the intake port down and mount it above the take-off point. This will prevent moisture to build up so it can drain out. Ensure that the hose runs downhill all the way to the manifold if possible.

MAP sensor types
The MAP sensors available from Spitronics is the Motorola series sensors that come in two packaged styles; Sealed plastic enclosure or Aluminum machined enclosure. The MAP sensors are rated at 1.1 bar, 2.5 bar, 3 bar and 4 bar respectively. Be sure to order the correct map sensor for your application. In some cases, the vehicle's existing MAP sensor can be used, ensure that you have the sensor wired and calibrated correctly.

Map Sensor Calibration
The MAP sensor is pre calibrated to the specifications of the 4 models. If you use another map sensor you may select custom and calibrate it yourself. Make sure you use the correct altitude pressure value from your altitude level in order for this to function correctly. Calibration needs to be done with the ECU switched on, but the engine must not be running.

Sample Sensor Pinouts

Related Links

Software Setup

ACC Pump Tuning

Error Codes


Memory Handling

Help > TCU Transmission Management > TCU Software Desciption >

Orion Memory Handling in Ver 3.5

The Memory handling in Ver 3.5 is changed to provide more GP outputs from the unused Coil and Injector drivers. The danger before was that when different Map files is downloaded into the Device, it may override critical setup values which could damage the device or components on the engine. Now the critical values cannot be changed by loading a map. It is saved in a separate space in the flash memory. These values can only be changes by adjusting them on a connected device or by Cloning the device.

Below is a block diagram of the map memory and how map data is handled.

The memory is divided into 3 categories. Map setup data, Map Graph and Matrix data and Critical setup data. Below follows a description of the different memory spaces.:

Map Setup Data

In this block all the normal settings are saved. If you load a map file, this setup data can be overwritten or it can be retained by selecting or de-selecting the Save Setup Data.

Note. This setting must be selected before opening the map. Once you open a map file then this setting is ignored as it is now part of the setup. There are values like TPS calibration that must be recalibrated if you load a new map.

Map Graph and matrix data

This memory house all the graphs and matrix data. This influences the actual tuning of individual engines.

Critical I/O setup data

The memory holds settings that will alter the inputs and outputs connections of the device. They are part of the normal setup data but are critical not to change during a map load function. This memory can never be overwritten by loading a map. One way to change these settings is online with the device connected, and then save it to the device. The other is by cloning function.

The Critical settings are:

Tuning Mode

This setting does not change connections to the device but selects different tuning parameters which may not be adjusted by the tuner.

Save Setup Data

This setting determines if the setup block will be overwritten or not. Checked on means it will be overwritten.

Dual Map Selection

This setting will effect which map data is loaded at startup. It effects also which wiring is used on some devices. This setting was already saved permanently in previous versions.

RPM Output pulses

This setting is used by other devices like a tachometer or TCU and should not change by loading a new map.

Coil Combination

This setting is critical because it could free up drivers that may be used for GP outputs. It will effect wiring connections.

Coil Driver Trigger Combination

This setting is only used in Pluto2 and Saturn and is critical setting because it will damage coil or driver if it is set incorrectly.

Injection Type

This setting is critical because it could free up drivers that may be used for GP outputs. It will effect wiring connections

Idle Control

This setting effect wiring connections and is combined with GP outputs,

Fuel Pressure Control

This setting effect wiring connections and is combined with GP outputs,

Duel Injector Control

This setting effect wiring connections and is combined with GP outputs,

Map Lock Password is also saved in this block. Note that if you upgrade a unit with new firmware it will be locked because this memory space was not cleared. Save both your maps before upgrade and load it in afterwards. See the Clone function.

Cloning

Cloning means copying a device map exactly onto another device. This process will save all the settings including the critical setup data exactly as the device map that was saved. This is handy for builders that use the same engines and drivetrains in different builds. It is also handy to load a startup map of a similar engine in the device to assist new customers. Simply lock a device by entering a map lock password. Then load the map into the device without unlocking it. This will initiate an exact data replacement into the locked device. It will also load the map in all the relevant maps for systems with Dual or quad maps. See locking a device below.

Related Links

Locking a Device


Mercury2 Installation Precautions

Help > Safety Precautions >

Mercury2 Safety Precautions

Connecting

· Never connect a Mercury2 on other harnesses that have the same connectors.

· Connect the ECU earth strap and the harness Earth wires to a proper earth on the body.

· Leave the output connectors P2, P3 and P5 disconnected when you switch the ECU on the first time.

· Test the installation before connecting the ECU. This will prevent damage due to faulty wiring.

· Make sure that relay pin numbers of the relay correspond with the drawing. Some relays differ on the contact pattern and may damage the ECU.

· Make sure that the coils and injectors get their power from the Saturn power relays. This relay will only switch on after the ECU has selected the logic level for the driver. Powering them from the vehicles power will damage the drivers and coils.

· Check that coil connections are secure. Loose connections will damage the coil driver Mossfets.

· The TPS must be connected correctly as it may damage the ECU or TPS permanently.

· Do not put cutout switches from coil negative to earth as this will damage the coil permanently. Rather break the supply line through a switch so that the module does not have power.

· Do not connect the ECU outputs directly to solenoids or fuel pumps unless it is shown on a drawing. Check the current rating or the outputs in the Specifications.

· Test the coil resistance to see which type coil you are using and if it is still functional. This is important to program the correct parameters. See Coil Selection. If you are not sure take it to your agent for a test, or start with the lowest Coil charge time values namely 1 or 2 milliseconds.

· Make sure of the type of injectors and connect them according to the recommendations. There is a wiring difference between low and high impedance injectors.

· Never connect direct injection injectors to the ECU. Their resistance is very low and will damage the ECU and the Injector.

· The trigger input may not be connected to coil negative. The high voltage spikes on coil negative will damage the unit permanently.

· Make sure about the correct Jumper Settings before you switch the ignition on.

· Do not disconnect high tension leads and let them hang loose. It creates feedback voltage that may destroy the ECU.

· Never run HT leads with ECU harnesses. A crack in the HT lead will cause a spark to jump to the ECU harness and damage it.

Power

· Ensure that fuses are the minimum value required to hold the current. Too large fuses will not blow resulting in driver or coil destruction.

· Connect the relay supply power directly to battery positive via a fuse as shown in the drawings, otherwise voltage drops will cause lean mixtures.

· Connect the injectors to its own relay if mechanical relays are used as other items will cause a voltage drop and result in leaner mixtures.

· Do not connect screen wires on the engine. The starter will draw current through them melting the harness. It will also bring all the engine interference in the ECU.

· Ensure a proper earth between battery negative and chassis and also between battery negative and the engine. Do not earth the engine on the body or the body on the engine.

· Do not disconnect the battery while engine is running. The alternator will create high voltage spikes which will damage the ECU permanently.

· Ensure that all connections from the battery and alternator are secure.

· Connect the alternator charge wire directly to battery positive and not to the harness somewhere. This causes voltage spikes on the common wire.

· Never switch the power on, if the ECU earth strap is not earthed properly - this may damage sensors or the ECU.

Programmer

If you have a firmware programmer, ensure you only load firmware with the starting name Mercury2. Never press the ''Erase All Code space'' button. This will wipe the device information and it will have to be reset at the manufacturer. Always disconnect the output cables P2, P3 and P5 when using the programmer. Outputs may switch on damaging drivers, coils or fill the cylinder with fuel. See the programmer manual for correct operation.

Interference

· Install free-wheel Diodes on other relays to prevent spikes from interfering with the ECU. Always put the stripe side of the diode to the positive side of the signal. See the drawings for correct connections.

· Connect screen input wires as close to the sensor wires to minimise exposure of open wires to electro-magnetic noise.

· The spark plug leads can cause interference with the ECU wiring. Keep the ECU wires away from the ignition leads wherever possible. If it is necessary to cross the ignition leads, cross it at right angles.

Wiring Reliability
The wiring is critical for reliable operation of the ECU. The following points will help to ensure that the wiring is reliable:

Earth Wiring
One of the most common wiring problems is poor earth wiring. The earth wire must be earthed properly to the chassis and there must be no paint or anodizing between the earth wire and mounting point. Temporary wiring is likely to cause problems, use the proper terminal that is securely crimped to the earth wires. These comments apply to both the ECU earth wire and the ignition system earth wires.

Power wiring
The power required for the fuse box must be wired by the shortest possible path to the battery via relays activated by the ECU. This power must not be fed directly from the ignition switch because it won't be able to handle the required current. The relay must be in good condition and the wires must be crimped securely to the appropriate terminals.

Terminal crimping
Use the correct crimping tool for each type of terminal. Do a pull test on a sample wire and terminal to verify that the crimp is done properly. In theory the wire should break before the wire pulls out the crimp. Most crimp tools are only designed for a certain range of wire sizes so be sure to test the crimp with the particular wire size being used. Soldering the terminal is the last resort if the correct crimping tool is not available.

Terminal Damage
Connector terminals are easily damaged if probes are inserted into them. If checking a circuit for continuity gently touch the side of the terminal only.

Wire splicing
Use a crimp splice to join wires. If you solder a wire in a splice, ensure that wire movement near the splice is avoided because a fracture might occur at the stress point created by the solder. Use heat shrink to insulate and provide support to the wires. Never simply connect wire splices without solder or a crimp splice. These types of joins will corrode rendering it without connection. Never use 'Vampire Taps' & 'Plastic Butt Splices'. The first is an absolute NO. Vampire taps only work under ideal conditions and wire thickness. Too big and they make a poor connection, too small and they chop the wire in half. Both of these failures are acceptable for stereo systems, but not when you're hooking up things like injectors or ignition coils.

Wire strain

Avoid pulling wires tight at the connectors. Ensure that wires are kept away from hot or sharp parts in the engine. Also ensure that engine movement does not put strain on the wires, as metal fatigue will break the wires in time, resulting in ECU failure.


Mercury2 Simmulater Test Program

Help > Product Selection >

Mercury2 Test Program In an Out Ver 4.0

This firmware will allow dealers to test Mercury2 and see if all inputs and outputs are functional. It is for use on a Spitronics Simulater2 or 3. It is required before you accept Test 2 on the Portal. Note that this test is not 100% fool proof as the simulator does not have the proper loads like coils etc. connected to them. But it will show the obvious faults that come during manufacturing. This firmware will not alter map data unless you load a new map in. This program is used for all firmware types like ECU, TCU, etc. After the test procedure make sure you load the same firmware in for the customer. This program has firmware lockout if it is loaded in the wrong device.

This process will require the following:

· Mercury2 Device

· USB/UART Spitronics cable to connect to Mercury2 with Device Manager 4.0

· Computer or laptop with internet connection.

· Device Manager Ver 4.01 Software

· Simulator2 with power

· USB Debug Adapter with installed software

The firmware for a device is called:

Mercury2 Simmilater2 30 Test Program In and Out Ver 4.0 (Date).HEX

· Mercury2 - device that is tested

· Simulater2 - the model of simulator that the firmware is developed for

· 30 - Program number to be selected on Simulater2

· Serializer - Description of firmware

· Ver 4.0 - firmware version

· 01_10_2018 - the date of the firmware

· HEX - a file type extension used for programmers

Steps:

· Ensure that all the jumpers are in the prescribed positions. This may affect the outcome of your test 1 results. See further in the manual the Jumper settings.

· Connect the simulator to the Mercury2 and use the correct simulator harness

· Connect the USB Debug Adapter to the laptop

· Connect the Mercury2 to the USB Debug Adapter on the Comms Port

· Connect the simulator to power and switch on

· Open the Silicon Laboratories IDE software

· Load the Serializer Program in the device.

· Switch power off and disconnect the USB Debug Adapter. Connect the USB/UART Spitronics cable and switch on

· Open the Device Manager Ver 4.0 software and connect to the Mercury2

Device Manager

No need for login.

.

The information on the device and firmware is displayed.

· Device Serial Number is a unique code in the microprocessor and cannot be altered.

· Flash Serial Number. If you use the device with Ver 3.5 firmware and it has an old activation, then the flash serial number is the serial number of the device. Later activations and after the upgrade process, the device serial number will match the flash serial number by the last 3 digits.

· Hardware Type confirms the device and its photo is displayed.

· Hardware Class of your device.

· Firmware Type Locked of your device. This may be some number but it is not used in Ver 3.5 older firmware.

· Firmware number Locked of your device.

· Brand Code

· Firmware Type (the next information is irrelevant in the test firmware).

· Firmware Number

· Firmware Class

· Firmware Version

Click on Tester to go to the Test screen.

With this screen you can test each input to the device. On the simulator is LED's for each output. Further below is a description of each I/O to be tested.

The flash memory value is always [image] is used to test if the flash is working by saving different maps with different saved. It is the Start prime pulse in the ECU map.

Testing the inputs of the Mercury2 Device

All the analogue bars must be tested for low and high scale. The POT or potentiometer must represent low and high limits. With other words when the POT is close or open the bar must be zero or full scale. Then movement from the POT must indicate movement from the bar. No dead band before the bar moves. That will be a fail.

or

Note that the bar may not reach 255 exactly as it may be variance in simulator voltage. But each similar device will sow the same values.

MAP Potentiometer

TPS Potentiometer

LAMBDA Potentiometer

WAT Potentiometer

AIR Potentiometer

ALT Altitude

POT Potentiometer

Batter Voltage - must be confirmed at ECU input and GND with multi meter.

RPM indicator - it has 2 scales selectable by the PROG button. Low is 2100 max and high is 15600 max. Note that program 30 must be selected on the simulator.

Memory chip operation test. 255 means failure after map is loaded.

Now focus on the Simulator2 and on the ECU for LED flashes. Below is a pattern and each LED must light up in this sequence. If there is a short between outputs, then other LED's out of sequence will flash. The LED's on right hand side in the column will flash in random sequence to make running lights on the 4 LED's on the Mercury2. You may need to put the simulator on low speed and slowest rpm's.

If you are a dealer and this is a new device, you can confirm that these tests were successful with TEST 2 on the portal. Should the results be different later then I will be traced back to you. So make sure it is correct.

You may now load back the customer firmware program and load another map. This will confirm that the flash memory is also working.


TCU Oil Temperature Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Oil Temperature Sensor

The Mercury2 TCU can sense the transmission oil temperature and make line pressure adjustments accordingly. This will ensure the shifting is smooth even if the transmission is still cold. The sensor is situated inside the transmission and the pins is connected to the main connector. The sensor is mostly a NTC resistor. There are two inputs for different values of the NTC sensor. One is a 2K input and the other a 10K input. Depending on the type of sensor the wiring diagram will indicate the correct one to use.


P1 Sensor Inputs

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Inputs and Sensors

P1 Input connector contains wiring of the following Sensors.

Map Sensor

TPS Sensor

Water Temperature Sensor (Sensor included)

Air Temperature Sensor (Sensor included)

Lambda Sensor

P1 Sensor Input Drawing


P4 Sensor Inputs

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Inputs and Sensors

P4 Input connector contains wiring of the following sensors and output.

Tuning Potentiometer (POT)

Altitude Sensor

Fuel Pressure Sensor

GP Output 2

P4 Sensor Input Drawing


Power Connection

Help > TCU Transmission Management > TCU Hardware Description >

Power Connection

When an ECU does not have proper connections to Power or Earth it will generate spikes and erratic behavior. The starter and alternator needs to be wired correctly.

Earth straps can cause interference and is usually a problem during cranking. The starter draw around 60 amp during cranking. Its current flow is a thick strap from battery negative directly to the engine. Then form battery positive to the starter solenoid to the starter motor. You do not want to share these wires with sensitive electronics. The chassis also needs to be earthed. The best way is another earth strap from battery negative to the chassis. Do not earth the chassis and engine to each other to simplify wiring. This cause a common wire that will share the starter spikes and will cause interference. The Alternator is also a source of interference. It is best to connect the charge wire which is the thick one directly to the battery positive. Remember the battery acts as a damping source for interference. So it is best to connect all different supplies to the poles.

Testing for earth problems.

1. Make sure all earth points are properly earthed. Sometimes paint of the chassis will prevent a good electrical connection.

2. Ensure that the thick black earth wire from the ECU is earthed properly. Also make sure that the thin black wires coming from the harnesses is also tied to this point. We call this junction Test point A

3. First ensure that the setup in galaxy is done according to the startup procedure. This means you will only have P1 connecter and on Mercury2 also P4. The other connecters must be open except the comms cable.

4. Now use a multi meter and put it on AC volts. Now measure on test point a to battery negative pole. Now crank the engine. The reading should be less than 0.2 volt. If it is higher it means a bad earth. See the advice above.

5. Now do the same test for the ECU positive. Measure between the ECU power pin 10 that comes from the key to battery positive terminal. Here you may find a slight more voltage due to other electronics that draw current from the ignition. Again if the volts is more that 1volt then you may need to put a relay in to bypass ignition key voltage drops. Remember the key does not supply much current and is only low amperage power to activate relays. Below is a circuit of a bypass relay.

Related Links

ECU Power Relay Wiring

TCU Power Relay Wiring

Safety Precautions


ECU Power Relay Wiring

Help > ECU Engine Managment > ECU Hardware Description >

Power Relay Wiring

The ECU controls the power to all the hardware via the power relay circuit. These relays also act as a safety cutout for the fuel pump in case of engine stalls. When you switch the ignition on, the ECU will switch the relay output on for 3 seconds. If the engine is not cranked in that time it will be shut off again. This is to prime the fuel rails. In case of an accident these relays will be shut down in one second after the engine has died. This will stop the fuel pump from pumping fuel in ruptured lines. Note: Do not connect control hardware like coils and pumps to other power sources as they will feed back power after the ECU is switched off. They must be connected to the control relays.

Mechanical Relays

Always use 3 mechanical relays. For 2 or less coils you may reduce to 2 relays. On large systems like 8 coils or more, you may add a fourth relay to share the load. Use Relay 1 for clean power for the ECU and lambda sensor. Use Relay 2 for injectors and fuel pump. This will prevent uneven voltage drops on the line that will cause the injectors to open unevenly resulting in fuel mixtures variation. Use Relay 3 for coils which create high voltage inductive spikes. Always make sure there is a 6-amp diode on each relay specially if there are inductive loads on them like coils, injectors and fuel pump. The stripe must be on 87 and the other side on earth.

Pin 86 of the Relay 1 is tied to batter positive. Note that some of the older Mercury2 units had a built in freewheel diode which prevented the ECU from switching off when the key is switched off. In these cases, connect Pin 86 to ignition power that feed the ECU power on the P1. See the drawings for more instructions.

Note: There is a diode on Relay 1 pin 86 and 85 that will prevent spikes and relay buzz. Do not use this relay for other inductive loads.

Click on the links below to open the relevant drawings.

Power Distribution MEX01

Power Distribution with Fuse box

Electronic Relay

The electronic relay was designed by Spitronics to eliminate contact wear and to be waterproof. It is a solid state product with no moving parts. It can handle current up to 45 Amp and is short circuit protected. You only need one relay as the power handling should be enough. Note: One large fuse placed in front of the unit is recommended and the normal fuses for the different circuits.

Click on the links below to open the relevant drawings.

Electronic Relay Option

Related Links

Power Connection

Safety Precautions


RPM and Speed Signal Tap-In

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

RPM and Speed Sensor Tap-In

The Mercury2 controllers can be tied into existing OEM sensor circuits. There are a few rules around this to ensure that both systems operate correctly and is not damaged. It varies for the different products and sensors.

Controllers that share a sensor, has to share a common earth connection. Differences in earth will have an effect on the sensors signal. So make sure you connect the Mercury2 earth to the OEM earth.

Never connect the reference voltage of the Mercury2 to any wire of the OEM sensor. Only the signal wire is connected. It may damage either controller. The sensor already has power or reference voltage from the OEM controller. See the drawings below.

Isolate the Mercury2 wires that are not used. They will have power on them and may short circuit damaging the harness.

If the OEM sensor is not screened it is best to tie in close to the sensor and use the Spitronics screened harness. It may reduce some interference from coils. Remember Mercury2 inputs need to cater for all kinds of sensors and cannot cater for week signals with interference. If you still have interference, then you may add a 100uF and 100nF cap as filtering on their reference line and the Mercury2 sensor earth. See drawings below. NB. Do make sure which line is signal and which is reference. Crank the engine and measure AC volts to ground of each point on the sensor. The one with the highest value will be the signal line. For speed sensor you may need to lift the wheels up to simulate pulses. It must detect speed at speeds from about 3 Km/H.

The blue Reference volts comes from the OEM controller and it differs between car manufacturers. Some use earth as a reference, other 2.4 volt, 5 volts and even 12 volts. The Mercury2 has isolating capacitors built in to connect to these signals without having a problem with different voltage levels. Mercury2 use a reference voltage for its sensors as ground. Note that Mercury2 requires a minimum 0.5-volt peak to peak signal to function correctly.

Below are the basic connections. Some cars may have a magnetic RPM sensor in combination with a Hall Speed sensor. Connect them accordingly. All the Mercury P1 connectors has the same pattern for RPM and Speed signals. Note that harness colours differ and should be verified on drawings or GP Priority charts.

For sensor Tap-In connections look at the following drawings.

Speed Sensor Wiring

RPM Sensor Wiring MTWX02-2

RPM Sensor Wiring MTSX02-2


RPM and Speed Sensors

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

RPM and Speed Sensors

The Mercury2 TCU is a universal controller designed for most types of Optic, Hall or Magnetic reluctor sensors. It can read 4 sensors in total. Mostly Crank or RPM signal from ECU, and Speed sensors from transmission.

The drawings are based on the MTSX02-2 and MTWX02-2 harnesses. Take care to keep wires screened as close to the sensor as possible. Do not route sensitive input harnesses with HV leads or switching inductive loads. This will induce spikes in the sensor lines and confuse the TCU on what is the real signals.

The Red parts in the drawing are not always needed but if you do get interference on speed or RPM readings then you may add these components as filters to clean the signals up.

Common mistakes installers make in connecting ECU and TCU signals is that the Earth point is not on the same voltage level. As all the signals are referenced to earth this will make problems.

MTSX02-2 is for standalone applications like diesels where there is no ECU available. Here the TPS and RPM sensor is made with screened wires that brings power and earth to the sensor.

MTWX02-2 harness is made to use with ECU systems. The TPS and RPM lines are single wires and made to connect to the ECU signals. Mercury2 or Orion ECU's already have the Green RPM output wire and Yellow TPS output wire for easy installations. These wires can be connected together.

Below are links to the connection diagrams of the different sensors. Note that RPM connections differ between the 2 harnesses.

Speed Sensor Wiring

RPM Sensor Wiring MTWX02-2

RPM Sensor Wiring MTSX02-2


TCU RPM Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

RPM Sensors

The RPM sensor for the TCU is important to determine the correct shift points. This will keep the engine in its optimum gear at all times. It will also prevent erratic shifting and over-revving of the engine.

The TCU is mostly used together with an ECU so the RPM signal comes from the ECU via a green wire installed in the Spitronics harness. In some cases, the RPM signal is tapped into an existing sensor and some cases it requires a sensor to be installed like on old carburetor or diesel engines. There are 2 different harnesses for these applications. See below the different connection diagrams.

RPM Sensor Wiring MTWX02-2 With ECU

RPM Sensor Wiring MTSX02-2 Stand-Alone

Do not connect the RPM signal to coil negative. It requires a signal converter board to filter out the high voltage. If it is the only option, you can use the circuit below. The caps are non-polarized. If you have a MSD device this will not work.

The RPM signal can be any pulse that is equivalent to engine RPM. It can be a bolt on the alternator etc. Some alternators have a 'W' point which can be used in the magnetic input. The pulses can be adjusted up to 60 pulses per engine revolution.

There are three types of sensors. The Inductive sensor, Optic sensor and Hall type sensor. The inductive sensor is a coil wound over a magnet. The teeth of a gear will disturb the magnetic field and that will generate a voltage spike over the 2 wires. Hall and optic sensors both give a square wave output and are treated exactly the same. They have electronic components in the sensor which convert the signals to square wave. The Hall sensor uses magnetic field where optic uses infrared light. In both cases a beam is broken and detected.

Operation of an inductive sensor:
The inductive sensor generates a voltage between the coil wires when the magnetic field strength is changed by a tooth passing the sensors. The sensor must be wired for a Falling waveform, this is best determined using an oscilloscope. The output voltage amplitude increases with increased RPM. The output voltage amplitude also depends on the gap between the sensor and the Tooth. The Minimum acceptable output voltage under cranking conditions is 3v.

Testing an Inductive Sensor:
Inductive sensors has a wired coil with a magnet. The sensor either has two or three wires from which the third wire is not connected to the coil. The sensor coil resistance may vary from 150ohm to 1200ohm. Multi meter polarity will not change the coil resistance reading. A multi meter switched to AC voltage can be used to test the sensor polarity without an oscilloscope. Connect the wires from the coil to the multi meter and move a metal object to the sensor. Look closely at the polarity indicator, if it indicates positive when moving closer and negative when moving away from the sensor then the red wire of your meter is on the positive of the sensor and the black wire of your meter is on the ground of the sensor.

Operation of a Hall Effect Sensor:
Hall sensors use a magnetic field effect to switch between a low voltage (usually 0 V) and a high voltage (5 V or 12 V) to form a 'square wave'. Both the rising and falling edges are valid reference points for the ECU input.

Testing a Hall Effect Sensor:

Hall Effect sensors normally have three wires. A supply wire (5v + or 12v +), an earth wire and a signal out. This sensor is equipped with electronic components that require power to operate. Incorrect connections will cause damage to the sensor. First test for resistance on all the pins and swop the test leads around to make sure it is not an inductive sensor. Put the multi meter on diode test and measure voltage drop over the pins. You should get a voltage drop between 0.5v and 1.9v. This is an indication that it is a Hall Effect sensor.

Now take two 1k ohm resistors and tie one end of each to 12v +. This will ensure that if you connect the supply wrong the sensor will not be damaged. Connect ground to the one sensor pin and the two resistors onto the remaining two pins. Connect the multi meter black wire for the remainder of this test. Connect the multi meter red wire onto any of the other pins. Now move a metal object to the sensor or in the gap and away. If the signal varies between 0v and 12v then this pin might be the sensor signal output. Now put the red wire on the other pin and repeat the metal process. The voltage should not change, but might be less than 12v due to the drop over the resistor. If so then this is the supply pin.

Now change the earth pin to the next and repeat the process. Note that you may get a similar reaction if you have the earth and signal pins swopped, the pin that reacts most to the iron pulse is the signal and the other the earth.

Remember this is a guideline to black box testing and not a failsafe operation.


TCU Shifter Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Shifter Sensors

The Shifter sensor or Range Switch is important for the TCU to select the correct shift pattern for each shifter position. This is a requirement of the transmission. It will indicate to the TCU which gear may not be exceeded. For example, if the shifter is in position 2, the TCU will not shift above 2nd gear unless it is allowed in that position. It will also tell the TCU to engage engine brake clutches etc. this switch is calibrated in the software.

The Shifter sensor is normally situated on the transmission where the shifter lever enters the transmission. Some transmissions do not have this sensor and it may be situated in the shifter itself. Other transmissions have hydraulic switches inside the transmission. These switches may only operate when the engine is running like GM 4 speed transmissions. If there is no sensor available, you may connect the sensor wire to the reverse light or a reverse ground switch. The TCU must know when it is in reverse to prevent shifting forward gears. This is an option for first generation 4 speed boxes that were not very complicated.

There are two different types of sensors. Analogue and Digital. The TCU requires an analogue signal that can be calibrated. If it is a digital sensor, Spitronics has a converter board that convert the signal to analogue. The digital switches can be serial or parallel switches so we designed 2 different converter boards. The type is also listed with the harness numbers as well as the diode boards on the top label of your drawing. Make sure you have the correct ones before wiring.

Shifter Converter Drawing

Spitronics Shifter
The Spitronics shifter has a serial shifter switch that convert the positions to analog signal by a series of resistors with progressive values. The TCU will measure the resistance and then calculate in which position it is. Note that Mercury2 has a 1 K pull-up resistor built into the harness because the hardware is also ECU capable.

GM Shifter sensors:
The GM transmissions have parallel pressure switches that connects to oil channels inside. The switch pattern indicates position of the shifter lever. Spitronics has a parallel converter board with progressive resistor values to convert this digital pattern to an analog signal. The drawing in the Example below is for the 5L40E.


Testing Hall or Optic Sensors

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

Testing Hall or Optic Sensors

Work through each point below to find your problem.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 and P4connector on the Mercury2. The other connectors must be open, except for the Comms cable. Open the software and connect to the Mercury2.

2. Ensure that the correct firmware is loaded into the ECU or TCU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

3. Make sure the Jumper settings are set for Hall sensors. On Mercury2 the 2-pin jumper must be closed. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of Mercury2. Note: If it falls below 10 see chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

6. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the Mercury2 sees them as trigger pulses.

7. If it shows no error and no RPM it means that the Mercury2 does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

8. Make sure you use the correct sensor size with your crank trigger wheel size. If the magnet of the sensor is larger than the gap in the teeth, then your signal will be very week. Rather use a gear with less teeth for the diameter or a sensor with a smaller sensing diameter. If you can't see the magnet protruding from the sensor, put a bit of iron filings on the tip. The magnetic field will show the diameter of the internal magnet immediately. In this case you may enlarge the sensing distance it the signal is strong enough. See the illustration below.

Testing the sensor.

1. The hall or optic sensor requires power to operate. So it cannot be dry tested like a magnetic sensor.

2. First measure continuity from the ECU ground to the sensor ground. There should be 0 ohms as the earth comes from the thin black wire coming from the harness to the thick black earth of the Mercury2.

3. Measure continuity from the sensor power to the Mercury2 ignition power that comes from the key. There should be 0 ohms.

4. Now measure continuity from the sensor signal to the ECU input for that sensor, see the drawing. You can disconnect P1 and measure on the pin.

5. The fastest way to test it is while it is powered in the circuit. While P1 is connected switch the ignition on.

6. Measure at the power at the sensor between negative and positive. You should measure around 12V DC.

7. Now unbolt the sensor from the engine. Measure DC volts between sensor negative and signal. It should be 12 volts and if you bring a metal object to the sensor it should go to 0 volt. The logic may be reversed for some sensors. As long as you see the step change. On optic or some hall sensors you may need to move a plate between the sensor and transmitter part. If the voltage doesn't go to less than 1 volt, then it means the ECU will not detect the change.

8. If you don't measure the 12 volt on any condition on the sensor signal, it may be the pull-up jumper is not in closed position. If it is then disconnecting the sensor signal wire and measure at the ECU side for the 12 volt. If you measure 12 volts, it means the sensor output is damaged and short the signal wire to ground. If you don't measure 12 volts then the ECU does not provide power through the pull-up resistor.

9. Now bolt the sensor in place and measure on the signal negative and positive with AC volts. Crank the engine and you should see 12 volts AC.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the Mercury2 harness screen.

2. The coils may spike the Mercury2 and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU. A restart error will come up.

3. Errors that comes at higher RPM's may be due to a trigger wheel that is not balanced or is buckled. Sensing distance may be too large. It could also be due to a small gear teeth pitch, or a sensor with a large sensing magnet. The sensor may require an extra pull-up resistor.

4. Ensure that the test signal next to the crank sensor is off.

5. The RPM on the sensor signal could fade, this could be due to the gap between it and the trigger wheel been too close or too far apart.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked lead also generates interference. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Mercury2 pull-up

The Mercury2 use an isolated digital input to allow for magnetic sensor tap-in. For hall sensors an external jumper will connect a 1K pull-up resistor internally to the 12-volt power from the key. If this power is erratic due to other switching elements, then it may cause secondary triggering or interference of the input. To remedy this, you may add a 1K pull-down resistor to minimize the rippling effect on the power. If this does not help you may open the jumper and add a 1K pull-up resistor to 5-volt power from the ECU P1 pin 9. Alternatively use a relay to power the Mercury2 directly from the battery. Then the ignition power is only used to activate the relay. See the drawings below.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Testing Magnetic Sensors

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors > RPM and Speed Sensors >

Testing Magnetic Sensors

Work through each point below to find your problem.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 and P4 connector on the Mercury2. The other connectors must be open, except for the Comms cable. Open the software and connect to the Mercury2.

2. Ensure that the correct firmware is loaded into the ECU or TCU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

3. Make sure the Jumper settings are set for magnetic sensors. On Mercury2 the 2-pin jumper must be open. You may now crank the engine without the other connectors.

4. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of Mercury2. Note: If it falls below 10 see chapter about 'Power Connection'.

5. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

6. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

7. If it shows no error and no RPM it means that the ECU does not pick up the signal from the sensor. Proceed to testing the sensor itself.

8. Make sure you use the correct sensor size with your crank trigger wheel size. If the magnet of the sensor is larger than the gap in the teeth, then your signal will be very week. Rather use a gear with less teeth for the diameter or a sensor with a smaller sensing diameter. If you can't see the magnet protruding from the sensor, put a bit of iron filings on the tip. The magnetic field will show the diameter of the internal magnet immediately. In this case you may enlarge the sensing distance it the signal is strong enough. See the illustration below.

Testing the sensor.

1. Ensure that the thick black earth wire from the Mercury2 is earthed properly. Also make sure that the thin black wires coming from the harnesses are also tied to this point. We call this junction Test Point A

2. Disconnect P1 from the Mercury2. Now use a multi meter and set it on 2000-ohm scale.

3. Measure from Test Point A to pin 12 on the P1 harness connecter. You should get a resistance of 300 to 2000 ohm depending on the sensor. If you swop the meter wires you must read the same ohm measurement. If you don't get a reading it means your sensor is not connected correctly. Check your wiring connections. NB! Do not press too hard on the female pins as you may damage them resulting in poor contact later.

Harness Pin view

4. If you do get a reading put the meter on AC volts and measure on the same points. Use the lowest scale or 20 volts. Now crank the engine. The sensor will generate AC volts. Mercury2 requires a voltage above 0.5-volt peak to peak and above. If this voltage is lower, it means the signal is too weak and the ECU will not sense it properly. This could be due to a dirty sensor or the gap is too wide between the sensor and the gear. The gap is normally below 1 mm. It could also be that the sensor magnet inside the sensor is wider than the width in the teeth if it's a custom installation.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the Mercury2 and it may want to restart. This may be due to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the Mercury2. A restart error will come up.

3. Errors that comes at higher RPM's may be due to a trigger wheel that is not balanced or is buckled. Sensing distance may be too large. It could also be due to a small gear teeth pitch, or a sensor with a large sensing magnet. The 2-pin jumper is on and it should be off.

4. Ensure that the test signal next to the crank sensor in the ECU software is off.

5. The RPM on the sensor signal could fade, this could be due to the gap between it and the trigger wheel been too close or too far apart.

6. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked lead also play havoc. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


TPS Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Throttle Position Sensor

The throttle position sensor is used by the TCU to determine what the driver's intent is. The TCU will use the TPS, engine RPM and road speed to calculate a shift pattern to use. This sensor is very important and must be a stable signal. Most of the time the TCU will operate side by side to the ECU. The TCU can tap into the signal from the existing TPS or as with Spitronics ECU's there is a yellow wire that is installed in the harness for this signal. Do not connect any supply or earth to existing TPS connections. Just the signal wire is connected. See the drawings on this.

Operation:
The TPS is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Which Pin is which?
Use a multi-meter set to the 20,000 ohm (20 K) range.

· With throttle closed, find the two pins with the lowest resistance between them. They are C & B. The remaining pin is the 5 V pin A.

· With one probe on the 5 V pin A, find the pin whose resistance changes when the throttle moves. This is the Signal pin B.

· The remaining pin is the earth pin C.

This same route can be used on a four pin throttle position sensor, note that only three of the four pins will be connected or one pin may be a switch to ground or 5 Volt as an idle activation switch. The Spitronics ECU does not require this pin.

Pre-load the Sensor
The sensor has a dead band at either end so it must be rotated slightly to move the wiper into the operating range of the sensor.

Connecting the TCU TPS to an existing ECU TPS sensor.

TPS Sample Pin outs:

Related Links

Software Setup

ACC Pump Tuning

Error Codes


TCU Tiptronic Buttons

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Tiptronic Switches

Each TCU has the ability to wire 2 push button switches for Tiptronic functions. When the Map is set to operate in Tiptronic mode, these buttons will give the driver the option to shift the transmission manually to his command. On the Ver 3.3A firmware their function can be changed to overdrive and 2nd gear start.

There are a couple of variations to the buttons but all wire in the same connections on the TCU. Please view the relevant drawings for that. Spitronics also sell a remote wireless version to build into the steering wheel and without the need for connecting wires.

Tiptronic Switches Drawing


ECU Tuning POT

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Tuning POT

The multi-function variable resistance potentiometer can be configured in the software to perform numerous features. These features include making changes to the fueling, ignition angle or adjusting the launch RPM without having to connect a laptop computer.

Operation
The POT is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Sample sensor Pin out

Related Links

Software Setup

Error Codes


M01-P1 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains most ECU connections from the 12 Way Connector for most engine combinations. It does not have the CAM1 and CAM2 wires required for VVTI sensors.

· It has Crank TDC and CAM Home signals which is required for Full Sequential features.

Design Points to take Notice of.

· Crank and Cam sensor wires are enclosed in one shield. They share common power and earth wires. This is suitable for complex Distributor type pickups where the sensors are close together. If you use this harness where the sensors is apart you may need to splice in a separate shielded wire for the other sensor. Connect the shields together for interference protection on the spliced section. Alternatively use the M06-P1 harness instead where the 2 signals have separate shielded wires.

· TPS, Air and Water sensors also share a shielded wire. Take the shielded part as close to the sensors as possible. They share common earth wires. Solder these connections and insolate them properly.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

Wire Names and connections on this harness:

Crank (Shielded) contains:

· Crank Sensor (Green)

· Cam Sensor (Yellow)

· +12V Ignition (Red)

· Earth (Blue)

Map (Shielded)

· Map Sensor (Blue)

· +5V (Red)

· Earth (Black)

Engine (Shielded)

· Water Temperature Sensor (Green)

· Air Temperature Sensor (Yellow)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

· Earth (White)

Lambda (Shielded)

· Lambda Sensor (Red)

· Earth (Blue)

Ignition Power (Orange)

TPS Output signal for TCU or other systems (Yellow)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


M02-P2 V2 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all ECU/TCU connections from the 10 Way Connector for most engine or transmission combinations.

Design Points to take Notice of.

· This harness has 6 positive drivers used for Smart Coils with built in drivers or solenoids or other features.

· It has the Mechanical and Electronic Relay Outputs. Never mix these connections as the mechanical relay can damage the sensitive Electronic relay output rendering both disabled.

· It has 2 Clean Power inputs from Relay 1 required for the positive drivers. Do not bring this power from the ignition directly or do not use the same power supplied to injectors and coils or any inductive loads. Clean power is for electronics and resistive circuits like Lambda element. On transmissions they are used with solenoids because the solenoids have freewheel diodes to eliminate spikes.

· The power wires to and from the relays are not included and relays and fuse boxes should be added for circuit protection. There should also be Diodes for protection wired into the harness for protecting against Inductive spikes. Ensure relay numbers are correct according to the drawing. See the power relay connections in the manual for correct wiring of these components.

Wire Names and connections on this harness:

6x Positive outputs (Striped Red)

Mechanical Relay Output (Blue/Red)

Electronic Relay Output (Blue/Black)

2x Clean 12V Power Supply Inputs via Relay 1 (Red)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


M03-P3 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all ECU connections from the 8 Way Connector for most engine combinations.

Design Points to take Notice of.

· This harness has 6 negative drivers used for injectors or other features.

· It has the RPM Output for tachometers.

· It has GP1 output for general purpose features.

Wire Names and connections on this harness:

6x Negative outputs (Striped Black)

RPM Output (Green)

GP1 Output (Blue/Orange)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


M04-P4 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all ECU connections from the 6 Way Connector for most engine combinations.

· This optional harness is used only if Altitude Sensor, Fuel Pressure Sensor or Tuning POT are required. It also has the GP2 output on it.

Design Points to take Notice of.

· The Altitude Sensor and Fuel Pressure Sensor share a shielded wire. Take the shielded part as close to the sensors as possible. They share common earth wires. Solder these connections and insolate them properly. If you use this harness where the sensors is apart you may need to splice in a separate shielded wire for the other sensor. Connect the shields together for interference protection on the spliced section.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

Wire Names and connections on this harness:

POT (Shielded) contains:

· Potentiometer Signal or Wiper (Blue)

· +5V (Red)

· Earth (Black)

Alt/Fuel (Shielded)

· Altitude Sensor (Green)

· Fuel Pressure Sensor (Yellow)

· +5V (Red)

· Earth (Blue)

GP2 Output (Blue/White)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


M05-P1 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all ECU connections from the 12 Way Connector for most engine combinations.

· It has Crank TDC and CAM Home signals which is required for Full Sequential features.

· It also has the 2x Cam sensor inputs for 2 VVTI cams in loop control.

Design Points to take Notice of.

· Crank and the 3 Cam sensor wires are enclosed in one shield. They share common power and earth wires. If you use this harness where the sensors is apart you may need to splice in a separate shielded wire for the other sensors. Connect the shields together for interference protection on the spliced section.

· TPS, Air and Water sensors also share a shielded wire. Take the shielded part as close to the sensors as possible. They share common earth wires. Solder these connections and insolate them properly.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

Wire Names and connections on this harness:

Crank (Shielded) contains:

· Crank Sensor (Green)

· Cam Home Sensor (Yellow)

· Cam1 Sensor (Red)

· Cam2 Sensor (Blue)

· +12V Ignition (White)

· Earth (Black)

Map (Shielded)

· Map Sensor (Blue)

· +5V (Red)

· Earth (Black)

Engine (Shielded)

· Water Temperature Sensor (Green)

· Air Temperature Sensor (Yellow)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

· Earth (White)

Lambda (Shielded)

· Lambda Sensor (Red)

· Earth (Blue)

Ignition Power (Orange)

TPS Output signal for TCU or other systems (Yellow)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


M06-P1 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains most ECU connections from the 12 Way Connector for most engine combinations. It does not have the CAM1 and CAM2 wires required for VVTI sensors.

· It has Crank TDC and CAM Home signals which is required for Full Sequential features.

Design Points to take Notice of.

· Crank and Cam sensor wires are in separate shields. Each have their own power and earth wires. This is suitable for systems where the sensors are far apart.

· TPS, Air and Water sensors also share a shielded wire. Take the shielded part as close to the sensors as possible. They share common earth wires. Solder these connections and insolate them properly.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

Wire Names and connections on this harness:

Crank (Shielded) contains:

· Crank Sensor (Blue)

· +12V Ignition (Red)

· Earth (Black)

TDC (Shielded) contains:

· Cam Sensor (Blue)

· +12V Ignition (Red)

· Earth (Black)

Map (Shielded)

· Map Sensor (Blue)

· +5V (Red)

· Earth (Black)

Engine (Shielded)

· Water Temperature Sensor (Green)

· Air Temperature Sensor (Yellow)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

· Earth (White)

Lambda (Shielded)

· Lambda Sensor (Red)

· Earth (Blue)

Ignition Power (Orange)

TPS Output signal for TCU or other systems (Yellow)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


M07-P5 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all ECU/TCU connections from the 4 Way Connector for most engine combinations.

Design Points to take Notice of.

· This harness has 2 positive drivers used for Smart Coils with built in drivers or solenoids or other features.

· This harness has 2 negative drivers used for injectors or solenoids or other features.

Wire Names and connections on this harness:

2x Positive outputs (Striped Red)

2x Negative outputs (Striped Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


MC1-P1 Harness

Products that can use this harness

· Mercury Coil Drivers

History

· This Level 1 harness was made for all of the Mercury Coil drivers. It contains the power wires as well as the inputs from the ECU. You will need this harness regardless of which type of Mercury Coil Driver you select.

Design Points to take Notice of.

· This harness has 2 Positive Power inputs that must come from Relay 1 of the ECU that provides clean power. Do not connect them with the coils or any inductive load as they supply the sensitive electronic circuits inside the Coil Driver.

· The Inputs does not have wires but comes with the pins so that the installer can add them to the Mercury2 Output wires. This will eliminate the need for a wire to wire connection and leave the harness more neat. If you have an issue soldering and inserting the pins ask the dealer to do it for you before shipping.

Wire Names and connections on this harness:

2x Power Inputs (Red)

6x Coil Inputs from Mercury2 (Striped Red)(Not installed)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


MC4-P2 Harness

Products that can use this harness

· Mercury Coil Drivers

History

· This Level 1 harness was made for the 4 Way Mercury Coil driver. It will connect 4 basic coils to the high voltage drivers.

Design Points to take Notice of.

· This harness has 4 High Voltage Negative drivers used for basic Coils without built in drivers.

· Output Wire Colours are the same as the Input wire colours from the MEX harness. This may be confusing to the standard Striped Black wires from other systems. But we tried to keep the input and output the same to minimise confusion.

Wire Names and connections on this harness:

4x Negative outputs (Striped Red)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


MC6-P2 Harness

Products that can use this harness

· Mercury Coil Drivers

History

· This Level 1 harness was made for the 6 Way Mercury Coil driver. It will connect 6 basic coils to the high voltage drivers.

Design Points to take Notice of.

· This harness has 6 High Voltage Negative drivers used for basic Coils without built in drivers.

· Output Wire Colours are the same as the Input wire colours from the MEX harness. This may be confusing to the standard Striped Black wires from other systems. But we tried to keep the input and output the same to minimise confusion.

Wire Names and connections on this harness:

6x Negative outputs (Striped Red)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


MEX02-2 Harness

Products that can use this harness

· Mercury2

History

· This new style Level 2 harness was developed for Mercury2 to save install time and minimise fault-finding afterwards. The harness contains all ECU connections from all of the Connectors and will serve most engine combinations.

· It is the recommended Wire and Play loom that has all the relays and fuses pre-wired in the loom. No need for extra power wires etc. It is designed to contain all the ECU connection wires so that all connection options on any engine are possible. The manual is also based on this harness structure for wire colours and placement.

Design Points to take Notice of.

· It comes with PVC sleeving, heat shrink and a roll of cloth tape to dress up upon final installation. You will still need the connectors of the engine as this is an universal harness. It is not Plug and Play. Note that other items like Sensors, Stepper Idle Controller, Coil Igniter Modules etc. are still add-on's and has to be connected or wired in according to the manual drawings and recommendations.

· It does come with a Water and Air sensor option built into the harness. The water sensor is a Lug that is bolt onto the thermostat housing and the Air sensor is a button sensor without housing that could be mounted inside the air cleaner box. In most cases they are cut off and the harness connected to the actual engine's water and air sensor.

· This harness comes with 3 Mechanical relays that are wired according to ECU requirements. Relay 1 is the clean power relay and must not be used for coils, Injectors or inductive loads. Each Relay has a Inline Fuse for protection of that segment. For large applications you may still add external fuse boxes for more individual circuit protection.

· Injector and Coil looms are also available to ease installation. They are sold separately because of different connection options between straight and V engines.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

· Crank and Cam sensor wires are enclosed in one shield. They share common power and earth wires. If you use this harness where the sensors are apart you may need to splice in a separate shielded wire for the other sensors. Connect the shields together for interference protection on the spliced section.

Wire Names and connections on this harness:

Crank (Shielded) contains:

· Crank Sensor (Green)

· Cam Home Sensor (Yellow)

· Cam1 Sensor (Red)

· Cam2 Sensor (Blue)

· +12V Ignition (White)

· Earth (Black)

Map (Shielded)

· Map Sensor (Blue)

· +5V (Red)

· Earth (Black)

TPS (Shielded)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

WAT (Shielded)

· Water Temperature Sensor (Red)

· Earth (Blue)

AIR (Shielded)

· Air Temperature Sensor (Red)

· Earth (Blue)

Lambda (Shielded)

· Lambda Sensor (Red) (Shield)

· Lambda Sensor Earth (Blue) (Shield)

· Lambda Element Earth (Black)

· Lambda Element Power (Red)

Alt/Fuel (Shielded)

· Altitude Sensor (Green)

· Fuel Pressure Sensor (Yellow)

· +5V (Red)

· Earth (Blue)

POT (Shielded) contains:

· Potentiometer Signal or Wiper (Blue)

· +5V (Red)

· Earth (Black)

POS (Sleeved) contains:

· 8x Positive outputs (Various Colours)

· +12V Relay Power (Red)

· Earth (Black)

NEG (Sleeved) contains:

· 8x Negative outputs (Various Colours)

· +12V Relay Power (Red)

GPO (Sleeved) contains:

· 2x Negative outputs (Various Colours)

Fuel Pump (Red)

Ignition Power (Orange)

RPM Output signal for TCU or other systems (Green)

TPS Output signal for TCU or other systems (Yellow)

BAT+ 3xRed

Earth Wire for Screens and sensors (Black)

3x Relay Sets of wires (12)

See the design drawing for thickness and lengths or wires.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


MTSX02-2 Harness

Products that can use this harness

· Mercury2

History

· This new style Level 2 harness was developed for Mercury2 to save install time and minimise fault-finding afterwards. The harness contains all TCU connections from all of the Connectors and will serve most engine combinations.

· This harness is designed to use as a Standalone option where there is no ECU present like Carburettor or Diesel engines. It has the RPM and TPS sensor in shielded sleeve to connect directly to the sensor on the engine. It has power and earth wires included in the shield. In some cases you may need to build a sensor onto the engine.

· It is the recommended Wire and Play loom that has the relay and fuse pre-wired in the loom. No need for extra power wires etc. It is designed to contain all the TCU connection wires so that all connection options on any transmission are possible. The manual is also based on this harness structure for wire colours and placement.

· Due to the different nature of transmission wiring each harness requires different diode boards and shifter converter boards. This is not wired into the loom and has to be added afterwards.

Design Points to take Notice of.

· It comes with PVC sleeving, heat shrink and a roll of cloth tape to dress up upon final installation. You will still need the connectors of the transmission as this is an universal harness. It is not Plug and Play. Note that other items like diode boards and shifter converter boards are still add-on's and has to be connected or wired in according to the manual drawings and recommendations.

· This harness comes with a Mechanical relay that are wired according to TCU requirements. The Relay has a Inline Fuse for protection.

· All the input wires are shielded and is earthed on the TCU side with the small black lead that must be connected to the TCU earth. Never connect a shield on the transmission or chassis of the car.

· Speed and Oil sensor wires are enclosed in one shield. They share common power and earth wires. If you use this harness where the sensors are apart you may need to splice in a separate shielded wire for the other sensors. Connect the shields together for interference protection on the spliced section.

Wire Names and connections on this harness:

Speed/Oil (Shielded) contains:

· Speed Sensor (Blue)

· Oil Sensor 2K (Green)

· Oil Sensor 2K (Yellow)

· +12V Ignition (Red)

· Earth (White)

· Earth (Black)

Profile SW (Shielded)

· Switch Signal (Blue)

· +5V (Red)

· Earth (Black)

TPS (Shielded)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

Shift (Shielded)

· Shifter Sensor (Blue)

· +12V Ignition (Red) (Shifter Lights)

· Earth (Black)

Buttons (Shielded)

· Up Shift (Red)

· Down Shift (Blue)

· Earth (Black)

Gearbox (Sleeved) contains:

· 8x Positive outputs (Various Colours)

· 8x Negative outputs (Various Colours)

· +12V Relay Power (Red)

· Earth (Black)

Ignition Power (Orange)

Speed Output signal for Speedometer (Green)

BAT+ 1xRed

Earth Wire for Screens and sensors (Black)

1x Relay Set of wires (4)

See the design drawing for thickness and lengths or wires.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


MTWX02-2 Harness

Products that can use this harness

· Mercury2

History

· This new style Level 2 harness was developed for Mercury2 to save install time and minimise fault-finding afterwards. The harness contains all TCU connections from all of the Connectors and will serve most engine combinations.

· This harness is designed to use with ECU systems. It has the RPM and TPS wires un-shielded to connect directly to the ECU signals. Om Spitronics ECU's there is already wires included in the loom with the same colours where it must be connected. On OEM ECU's you may need to splice into the signal wires.

· It is the recommended Wire and Play loom that has the relay and fuse pre-wired in the loom. No need for extra power wires etc. It is designed to contain all the TCU connection wires so that all connection options on any transmission are possible. The manual is also based on this harness structure for wire colours and placement.

· Due to the different nature of transmission wiring each harness requires different diode boards and shifter converter boards. This is not wired into the loom and has to be added afterwards.

Design Points to take Notice of.

· It comes with PVC sleeving, heat shrink and a roll of cloth tape to dress up upon final installation. You will still need the connectors of the transmission as this is an universal harness. It is not Plug and Play. Note that other items like diode boards and shifter converter boards are still add-on's and has to be connected or wired in according to the manual drawings and recommendations.

· This harness comes with a Mechanical relay that are wired according to TCU requirements. The Relay has a Inline Fuse for protection.

· All the input wires are shielded and is earthed on the TCU side with the small black lead that must be connected to the TCU earth. Never connect a shield on the transmission or chassis of the car.

· Speed and Oil sensor wires are enclosed in one shield. They share common power and earth wires. If you use this harness where the sensors are apart you may need to splice in a separate shielded wire for the other sensors. Connect the shields together for interference protection on the spliced section.

Wire Names and connections on this harness:

Speed/Oil (Shielded) contains:

· Speed Sensor (Blue)

· Oil Sensor 2K (Green)

· Oil Sensor 2K (Yellow)

· +12V Ignition (Red)

· Earth (White)

· Earth (Black)

Profile SW (Shielded)

· Switch Signal (Blue)

· +5V (Red)

· Earth (Black)

Shift (Shielded)

· Shifter Sensor (Blue)

· +12V Ignition (Red) (Shifter Lights)

· Earth (Black)

Buttons (Shielded)

· Up Shift (Red)

· Down Shift (Blue)

· Earth (Black)

Gearbox (Sleeved) contains:

· 8x Positive outputs (Various Colours)

· 8x Negative outputs (Various Colours)

· +12V Relay Power (Red)

· Earth (Black)

Ignition Power (Orange)

TPS input signal (Yellow)

RPM input signal (Green)

Speed Output signal for Speedometer (Green)

BAT+ 1xRed

Earth Wire for Screens and sensors (Black)

1x Relay Set of wires (4)

See the design drawing for thickness and lengths or wires.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T01-P1 V2 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains most TCU connections from the 12 Way Connector for most transmission combinations.

Design Points to take Notice of.

· This harness is used with ECU applications where the RPM and TPS wires is spliced into the ECU inputs. They are not shielded and must be connected close to the ECU.

· 2 Oil temperature sensor wires are enclosed in one shield. They share a common earth wire. Some firmware will use one wire and some firmware will use the other. This is determined by the sensor value for each firmware to read as accurate as possible. On each transmission connection drawing is specified which harness and sensor connection is required. Consult the manual for more information.

· All the input wires are shielded and is earthed on the TCU side with the small black lead that must be connected to the TCU earth. Never connect a shield on the transmission or chassis of the car.

Wire Names and connections on this harness:

Speed (Shielded) contains:

· Speed Sensor (Blue)

· +12V Ignition (Red)

· Earth (Black)

Oil (Shielded)

· Oil Temperature Sensor 2K (Blue)

· Oil Temperature Sensor 10K (Red)

· Earth (Black)

RPM Input (Green)

TPS Input (Yellow)

Shifter Sensor (White)

Optional Input (Blue)

Ignition Power (Orange)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T02-P1 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains most TCU connections from the 12 Way Connector for most transmission combinations.

Design Points to take Notice of.

· This harness is used as a standalone application where the RPM and TPS wires is shielded to connect to sensors on the engine. They come with Power and earth included for the sensor. This is handy for Diesel engines with mechanical fuel pump.

· The 2K Oil temperature sensor wires are enclosed in a shield. The 10K input option is available in an un insulated Blue wire. You may need to convert it to a shielded wire. On each transmission connection drawing is specified which harness and sensor connection is required. Consult the manual for more information.

· All the input wires are shielded and is earthed on the TCU side with the small black lead that must be connected to the TCU earth. Never connect a shield on the transmission or chassis of the car.

Wire Names and connections on this harness:

Speed (Shielded) contains:

· Speed Sensor (Blue)

· +12V Ignition (Red)

· Earth (Black)

Oil (Shielded)

· Oil Temperature Sensor 2K (Blue)

· Oil Temperature Sensor 10K (Red)

· Earth (Black)

TPS (Shielded)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

RPM (Shielded)

· RPM Sensor (Blue)

· +12V Ignition (Red)

· Earth (Black)

Shifter Sensor (White)

Oil 10K Input (Blue)

Ignition Power (Orange)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T03-P3 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all TCU connections from the 8 Way Connector for most transmission combinations.

· This harness was for a specific transmission like the A650E Aisin box. It has the negative driver diode board installed in the harness.

Design Points to take Notice of.

· This harness has 6 negative drivers used for 3x PWM Solenoids, 2x LED's and 1 for other features.

· It has the Speed Output for speedometers.

· It has GP1 output for general purpose features.

· It contains the Lockup and Mode LED's for user interfacing.

Wire Names and connections on this harness:

6x Negative outputs (Various Colours)

Speed Output (Green)

GP1 Output (Blue/Orange)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T04-P4 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains some TCU connections from the 6 Way Connector for some transmission combinations.

Design Points to take Notice of.

· This harness is used to connect 2x Tiptronic buttons for up and down shifting.

· It also has the GP2 output.

Wire Names and connections on this harness:

Buttons (Shielded) contains:

· Up Shift Input (Red)

· Down Shift Input (Blue)

· Earth (Black)

GP2 Output (Blue/White)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T05-P4 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all TCU connections from the 6 Way Connector for some transmission combinations.

Design Points to take Notice of.

· This harness is used to connect 2x Tiptronic buttons for up and down shifting.

· It has the 4x Rotary Map switch

· It also has the GP2 output.

Wire Names and connections on this harness:

Buttons (Shielded) contains:

· Up Shift Input (Red)

· Down Shift Input (Blue)

· Earth (Black)

Profile (Shielded) contains:

· Switch Input (Blue)

· +5V (Red)

· Earth (Black)

GP2 Output (Blue/White)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T06-P3 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all TCU connections from the 8 Way Connector for most transmission combinations.

· This harness was made for a specific transmission. It has 2 negative driver diode boards installed in the harness.

Design Points to take Notice of.

· This harness has 6 negative drivers used for 5x PWM Solenoids and 1 for other features.

· It has the Speed Output for speedometers.

· It has GP1 output for general purpose features.

Wire Names and connections on this harness:

6x Negative outputs (Various Colours)

Speed Output (Green)

GP1 Output (Blue/Orange)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T07-P2 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains some ECU connections from the 10 Way Connector for most transmission combinations.

Design Points to take Notice of.

· The harness contains the 2 LED's for Lockup and Mode indication. It does not contain any other wires apart from the power required for the positive outputs.

· It has 2 Clean Power inputs from the Relay required for the positive drivers. Do not bring this power from the ignition directly or do not use the same power supplied to injectors and coils or any inductive loads. Clean power is for electronics and resistive circuits like Lambda element.

· This harness does not have the wires for a TCU relay which the latest firmware requires. The power wires to and from the relays are not included and relays and fuse boxes should be added for circuit protection. There should also be Diodes for protection wired into the harness for protecting against Inductive spikes. Ensure relay numbers are correct according to the drawing. See the power relay connections in the manual for correct wiring of these components.

Wire Names and connections on this harness:

2x Positive outputs (Striped Red)

2x Clean 12V Power Supply Inputs via Relay 1 (Red)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


T09-P3 Harness

Products that can use this harness

· Mercury and Mercury2

History

· This old style Level 1 harness was part of the economy series for Mercury and some people still prefer them today to save on expenses. The harness contains all TCU connections from the 8 Way Connector for most transmission combinations.

· This harness was made for a specific transmission. It has 2 negative driver diode boards installed in the harness.

Design Points to take Notice of.

· This harness has 6 negative drivers used for 6x PWM Solenoids.

· It has the Speed Output for speedometers.

· It has GP1 output for general purpose features.

Wire Names and connections on this harness:

6x Negative outputs (Striped Black)

Speed Output (Green)

GP1 Output (Blue/Orange)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


Aisin A650E 5 Speed Special instructions Ver 3.3B

This firmware and software can be set up with a little bit of knowledge and understanding in mechanical and electrical functions. Different ratios in the drive train do make a big difference in line pressure settings and also the gear profile settings. Also to achieve off-road settings, engine braking in lower gears needs to be fine-tuned.

Note that the TPS sensor used is the one on the throttle body servo motor and not the one on the cable side of the throttle body. The throttle also needs to be modified to become a normal Drive by Cable Throttle. Alternatively you can use the drive by wire module from Spitronics which is still currently under development.

The A650E Transmission has a direct clutch for 2nd gear and accumulators for the other gears. This means that the main line pressure Graph 1 is applied directly via a control solenoid on the second gear clutch. The control solenoid will apply a certain amount of the line pressure which is adjusted on Graph 2.

Graph 1 will adjust the main line pressure of the transmission. Because this action is inverted for safety in limp mode, it means that the higher the graph the lower the line pressure will be. The reason for this is that in case of solenoid failure the line pressure will be high to prevent the clutches from slipping and be damaged in limp mode.

Graph 2 will adjust the shift pressure from 1st to 2nd gear. If there is a momentarily slip between shifts or no second gear, it means the pressure is too low. You need to raise the graph at that TPS setting. If the shift is harsh it means the pressure is too high. You need to lower the graph at that TPS setting. If you can't get enough firmness in the shift you may need to raise the main line pressure by lowering the line of graph 1 at that TPS setting.

Graph 3 will adjust the pressure when shifting from 2nd gear to 3rd gear to achieve a smooth shift. If there is a momentarily slip between shifts it means the pressure is too low. You need to raise the graph at that TPS setting. If the shift is harsh or it means the pressure is too high. You need to lower the graph at that TPS setting. If you can't get enough firmness in the shift you may need to raise the main line pressure by lowering the line of graph 1 at that TPS setting. Note that line 3 will always be slightly higher than line 2 but not too high otherwise 2nd and 3rd will try to engage at the same time resulting in engine brake action.

Note that the TPS settings for the lockup clutch must be set 0% and 100%.

Tuning Tips

Begin with the A650E start up map supplied by Spitronics and make sure that all the sensor calibrations are done and are operating correctly. This will be important especially for TPS, RPM Speed and Oil temperature. These sensors will influence how the pressures and shift times are applied.

To calibrate the speed setting you may need to lift the vehicle from the ground and compare the TCU speed to the speedometer. Then later do a fine calibration on the road. If the speedometer is dependent on the TCU then you will have to calibrate it on a quiet road with a GPS. See speed calibration in the software under active sensors.

NB. If at any time a gear slips immediately back off the throttle and increase the pressures according to the manual. These clutches are very small and could damage easily.

Do not be afraid to play with the settings to see what the effect is. This way you will understand the operation of the TCU. Always start with the light load settings and if it feels like the clutches is slipping release the throttle and adjust the pressures.

Graphs

Start with graph 1 and feel the shift firmness between 3rd & 4th and also 4th & 5th gears. The reason is that you need to determine a line pressure first which will then be applied to the lower gears. Make sure that the transmission is now on operating temperature. It should be from 50°C to 70°C

Now start with 1st to 2nd gear at a very light throttle like 5%. If it is a hard shift lower the graph 2 line at that TPS value. If it sounds as it slips or does not get 2nd gear and the software indicates 2nd raise the graph till it shifts to 2nd gear. If it shifts acceptable go to 3rd gear. The graph 3 line should be around 10% to 15% higher than the graph 2 line. Notice if there is a slip between the shifting process raise the line till it connects firmly. If the shift is too harsh lower the line slightly and test again. If this pressure is too high it will try to engage 2nd and 3rd gear simultaneously causing the engine to loose RPM as the transmissions will try to lock up. If you cannot get a firm shift it means the main line pressure is too low at that TPS value. Decrease graph 1 line slightly and test again. Now increase the throttle by 10% or more and adjust it the same as above. Repeat the process till you are at 100% TPS value. The graph should have a profile like below.

Gear Profiles

Again see the tuning part in the manual for setting up the profiles. The A650E transmission has free-wheel clutches in 1st, 2nd, and 3rd gear when the shifter is in the Drive position. This is a safety feature should a sensor or TCU fails during driving and the TCU does an accidental shift to a lower gear. For off-road braking you need to put the shifter in 2nd or 1st position to achieve engine braking. Note that 2nd the engine braking is achieved by the applied line pressure to the clutch. Note on the picture below how the line pressure is dropped at 0% TPS. This will release the clutch and freewheel 2nd gear. The moment the throttle increase in TPS value, the pressure will be up and 2nd will engage in positive drive. Drop it just far enough so that total free wheel is achieved. If you de accelerate from 3rd gear and 2nd is engaged, it must not have engine braking at close throttle. If you can feel 2nd engage or see a slight RPM increase, reduce both the 2nd and 3rd graph values.

Another thing to keep in mind here is to reduce the speed and RPM for shifting to 2nd when you reduce speed with the vehicle. Do the following adjustments.

3rd Gear

This engine idles at 700 RPM. As you can see the brown bottom dot is at 500 RPM which means the TCU will not shift down on RPM. This is set like that because the free wheel clutch will let the engine idle even if you are going at 50 Km/h. so to get it to shift to second set the gear down speed low. Also note the middle brown dot is set at 15% TPS and 1400 RPM. Should you accelerate fast it will engage the 2nd quickly while power is still low. Then the harsh kickback will be reduced. You can also set the speed limit so that any downshift above this speed will not be permitted.

Note that this system does have a feature with Ver 3.5A ECU software to retard the timing of to soften the shift process. It does not control the fly by wire throttle so if you press the accelerator the TCU cannot reduce the power too much for a smooth shift. The shift from 3rd to 2nd and from 2nd to 1st may be very harsh because the engine is powerful. However the shift will come quick and without delay from the TCU. Set the profiles so that it does not kick back to 1st. Also from 3rd to 2nd must be set at low speed and low rpm.

2nd Gear

Again notice that the low brown dot is below RPM idle setting. This means that this profile will not downshift on RPM value but on speed. Set the gear down speed very low as this engine can use second gear for pull-off if you did not come to a complete stand-still. Note also that the brown line goes up steep so a kickback to first will only occur when the throttle is blipped. You can also prevent kick back with the kick down speed setting. Remember to drop the line pressures as discussed at closed throttle.

1st Gear

1st gear is straight forward, set it up to select second gear quickly as the engine has enough power in second to accelerate. Then the amount of energy put on these clutches are reduced and the wear and tear will be minimum. Important to note is than the gear down speed in 1st is actually a gear up speed and it must be higher in value than the 2nd gears gear down speed. This will prevent hunting between 1st & 2nd.

Oil Temperature Compensation

For the A650E transmission oil temperature is critical due to the direct clutch system. We use the settings in oil temperature graph to lower the oil pressure applied to the 2nd gear when it is cold. It will also raise the pressure when it is hotter than normal. This will prevent harsh or slipping clutches. First tune the transmission at normal operating temperature till you are satisfied with the shift times and load settings. Start with the graph on the zero line. When the transmission is cold and second gear is harsh, decrease the graph line till the shift feels acceptable. When the transmission temperature goes above operating temperature, then the pressure must be raised to achieve a smoother shift. Never make it too soft. The graph should look like below.


Aisin A750E Special Instructions Ver 3.3B

This Transmission operate with a lever that has mechanical positions for 12DNRP. What Toyota did was making 2 slide slots in the shifter that make switches to tell the TCU what you want. Position 1 has a slot for 1 - 2 and Position D has a slot for 4 - 5.

To understand this, look at the following positions of the shifter.

Position D - Here the TCU can select between 1st to 5th gear and only 4th and 5th gear has engine brake.

Position 2 - Here the TCU can select between 1st and 2nd and 3rd gear and only 3rd gear has engine brake

Position 1 - Here the TCU can select between 1st and 2nd gear. 2nd Gear will have engine brake and 1st not. If you want engine brake is 1st then you must select the tiptronic Max Gear to 1st. So this means if your shifter is in position 1 and you select 2nd then 1st will not have engine brake. If you force 1st then you will have engine brake. Tiptronic setting must be on one of the 3 modes.

There is a Retard output that signals the ECU to retard timing during shift conditions. For performance applications shift harshness must be tuned in the ECU.

The transmission is momentarily put in second when the lever moves from N to D to soften Squad engagement.

In Drive mode lockup can be used in 3rd, 4th and 5th gears. In S4 it is used in 4th gear only.

The oil temperature sensor is a 3.5K sensor and the graph is calibrated for it. Put it on the 2K setting and the calibration value must be 100

Shifter positions on the display or real time block will be 1,2,D,N,R,P.

The SL1 Orange graph is used for 5th gear shift pressure. High line is high pressure. Low line is soft pressure. It should be tuned between approximately 40% to 70%. Start with 70% and lower if the shift is harsh.

The SL2 Green graph is used for 1st to 4th gear shift pressure. High line is high pressure. Low line is soft pressure. It should be tuned between approximately 40% to 70%. Start with 70% and lower if the shift is harsh.

The SLT Blue line is line pressure. High line is soft pressure. Low line is high pressure.

Courtesy Toyota manual


ZF 5HP19 Special Instructions

This transmission use 3 pressure control PWM outputs.

1. Blue line - is the line pressure EDS1. It works inverted which means a high setting will result in low line pressure in the transmission. When throttle opening is small in light throttle conditions, the line is high and the transmission will do soft shifting between gears. As the throttle increase the line drops gradually to increase the pressure and prevent the clutches from slipping.

2. Orange line EDS2 - is the shift pressure used during shifting. It will apply a percentage from the line pressure onto the clutches and brakes during shifting. It is active in 2nd 3rd and 5th. The higher the line the more the pressure will be. We don't have a profile yet so a suggested line to start with should look like above.

3. Green line EDS3 - is the shift pressure used during shifting. It will apply a percentage from the line pressure onto the clutches and brakes during shifting. It is active in Reverse, Neutral, 1st and 2nd. The higher the line the more the pressure will be. We don't have a profile yet so a suggested line to start with should look like above.


Air Temperature

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Air Temperature Sensor

The air temperature sensor is used by the ECU to correct air density changes due to air temperature variation. This input can also be used for general purpose output controls like Intercooler fans or water spray pumps.

Operation
The resistance of the temperature sensor changes in relation to the temperature it senses. It has a negative temperature resistance co-efficiency, ( NTC). Each sensor has a preprogrammed curve to indicate its resistance to temperature. Note that the Spitronics ECU uses a 10K resistance NTC and this value is measured at 25°c .(See below for a sample of such a curve.)

Electronics sensors

Spitronics build and supply small sensors for customers to build into their own units. There are 2 sizes, both do the same work. Note: These sensors requires a pull-up resistor to enable a constant current through them. (See below a picture of what these sensors look like in their raw form.)

How to measure a sensor
Use a multi-meter set to the 20,000 ohm (20 K) range. With the sender unit at approximately 25°c, measure the resistance. It should be between 8000ohm and 12000ohm at 25°c.

Multiple Devices on One Sender Unit.
Do not share temperature sender units between two devices. Only one device may be coupled onto a sender unit at any one time. Both devices will excite the sensor with current which in turn will change the signal value and then both will display the wrong temperature. In such a case you may need to add an extra sensor for the Spitronics ECU. The only exception for this rule is when a data logging device is used that has no internal pull up resistor. Example: Race Technology DL1.

Sensor Location
The ideal sensor location is before the butterfly and after the intercooler if turbo charged. Mount away from fuel "stand-off" to avoid the sensor being cooled by the fuel vapor. Use a High Speed Air Temp sensor on turbo applications where the intercooler comes out as temperature varies quickly.

Related Links

Software Setup

Tuning

Error Codes


Water Temperature

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Water Temperature Sensors

The water temperature sensor is mostly used by the ECU for cold-start and run enrichment, engine over temperature limit and thermostatic radiator fan control. They come in different shapes and resistance values.

Operation
The resistance of the temperature sensor changes in relation to the temperature it senses. It has a negative temperature resistance co-efficiency (NTC). Each sensor has a preprogrammed curve to indicate its resistance to temperature. Note: The Spitronics ECU uses a 2K resistance NTC and this value is measured at 25°c. (See below a sample of such a curve.)

Image result for NTC sensor graph

Electronics sensors

Spitronics build and supply small sensors for customers to build into their own units. There are 2 sizes but it does the same work. Note: These sensors require a pull-up resistor to let a constant current through them. (See below a picture of what these sensors look like in their raw form.)

How to measure a sensor
Use a multi-meter set to the 10,000 ohm (10 K) range. With the sender unit at approximately 25°c, measure the resistance. It should be between 1800ohm and 2200ohm at 25°c. Those two pins will be used for the ECU. The remaining two pins are normally used for the dash cluster and measure in the region of 3500ohm at 25°c. This same test can be done on engines with multiple sender units to determine which sender unit will be used for the ECU. Example: Toyota 1uz-fe, where there is three water temperature sender units.

Multiple Devices on One Sender Unit.
Do not share temperature sender units between two devices. Only one device may be coupled onto a sender unit at any one time. Both devices will excite the sensor with current which in turn will change the signal value and then both will display the wrong temperature. In such a case you may need to add an extra sensor for the Spitronics ECU. The only exception for this rule is when a data logging device is used that has no internal pull up resistor. Example: Race Technology DL1.

Sensor Location.
The ideal location for the temperature sender unit is on the engine side of the thermostat as this side will show the exact temperature at all times. The radiator side of the thermostat will show lower temperatures and take longer to react.

Air Cooled Engines
For air cooled engines it is better to measure cylinder head temperature for cold start compensation as the oil takes too long to pick up temperature. A simple cylinder head temperature sender unit can be made by clamping an NTC 2k ohm thermistor on a lug terminal and bolting it onto the cylinder head.

Related Links

Software Setup

Tuning

Error Codes


About the Manual

Help > Introduction >

About this Manual

The Mercury2 Manual is a comprehensive informative manual which includes all the relevant information and drawings. Due to the type of product and functionality there is a lot of information, so please read the instructions below on how to promptly navigate to the section you require.

Always start with the Terms & Conditions of this product displayed in this folder. You need to know how this product is presented to the public should you have any queries later. It is also by Law that these T&C's must be visible and read by you and your valued customer. Failure to comply with this legislation may lead to legal action and/or undesirable complications.

Work through the Product Selection and understand the differences between the products and how to select the best one for your application. (See the Selection charts .) If you still have difficulty, please feel free to email us under Support found on www.spitronics.com and we'll be glad to assist you.

Note: It is detrimental that you start with the Safety Precautions for Mercury2 before you begin installation. This will prevent unnecessary costs, mistakes and negligence and prevent time from being wasted. The FAQ came about from common mistakes that customers have made in the past. Remember these are electronic products and they can be damaged if not installed correctly and/or used in the prescribed manner.

How to use the manual.

Contents

This is the main contents list. All the information is categorized and speaks for itself. Browse through each section so you get a feel for where the information is stored.

Search

To find a subject, click on the Search tab and type the word, click on List Topics. Then click on the Items displayed and it will guide you to the specific document.

The Back key (or Alt+Left Arrow) will take you back to the previous view.

You may print parts of this document with the Print button.

These buttons will take you in and out of sub folders in the menu.

Quick Links

The last topic in the manual is Quick links . This may be the handiest page to find items quickly. each product firmware has its own links. The list is in alphabetical order. It has relevant Software or Hardware topics. When you click on a link it will open the manual on the relevant page. If you click on the [image] button then it will show you where it is in the list and you can view data from there.

Below some of the pages you will find related links to guide you to information that may also relevant at that stage or for that specific application. Use the Back key to go to the previous page. (See above links as example of the related links as explained.)


Compiling a TCU Product

Help > Product Selection > Mercury2 Aplication Selection > TCU Application >

Compiling a TCU Product

This document guides you to put a working product together from scratch. It will link you to the sections in the manual that your application requires, and how to set the product up correctly and print the relevant drawings for that installation. This legwork will save you or your customer time and eliminate lots of support calls. As this is a DIY product, the dealer must do this for his customer. If you carry stock, then you will do it when the customer requests a specific system.

Selecting a Product

There are 2 Spitronics TCU products currently in production namely Orion and Mercury2. Each one has Pro's and Con's and it is wise to take time out to know the differences. Selecting the wrong one may affect the price or the features that is required. Each TCU has its own manual and the Product Selection of its manual is the section to read for this information. You may also look at the TCU Comparison Chart and TCU How to Choose section. Note that these documents are the same for both manuals.

Choosing Firmware

After you have decided on the product type then read this section in that products manual. If you are choosing Mercury2, then you are in the right place.

Now you will need Transmission Information from the customer to decide which firmware must be used. Firmware are developed according to the transmission model number. TCU does not have modular drawings and are specific for each application. However, the customer does have the possibility to combine other shifters and components with this product. In these cases, he may look into the description for general drawings as guidelines. This will be connections like TPS, RPM, Shifter, Tiptronic Buttons , Map Selection Switch and Speed sensor .

Now you can view the Program Number Chart and see if firmware exists for that product. Mercury2 does not have the amount of inputs and outputs that Mercury2 has so it may be that it is impossible to run certain transmissions.

In the Program Number Chart, you will find the Firmware Features according to its hardware class and the GP Priority Layout for that specific firmware. Mercury2 TCU Selection section will explain this chart and how to get the relevant information from it. With this information you know if firmware exists and what hardware class is required as well as how the TCU connections are laid out for that firmware. Remember different firmware versions will have different connections to the TCU.

Example of Firmware Features 7

Example of GP Priority Layout Adv / Int

To program the Mercury2 ECU see the Firmware Programmer section.

Printing documents

If you have a Model number for the transmission then you go to Transmission drawings and look in the sub folders for that transmission. Here you will find all the relevant information that you require.

Installers prefer drawings on paper as they can make notes on customising and different wire colours etc. Also mark what is not used and what is already done. Note that this document only guides you to connections on the transmission that we have found. There may be other versions of the same transmission on other vehicles. For that you will have to consult the Service manuals and please forward variations to us for updating the current documentation.

For Explanation we use the Aisin A343E transmission. If you look at the information on the sheet you will find the following.

Main Drawing

This will open the full wiring diagram of the transmission with its standard connections. Note that ECU application and Stand Alone application use a different harness hence the two drawings. You will see the drawing has 2 pages so you need to scroll down inside for the other half.

Use with ECU withMTWX02/2 Harness

Aisin A343E Drawing

Use as Stand Alone with MTSX02/2 Harness

Aisin A343E Stand Alone Drawing

Default Harnesses

These links will take you to the design drawings of each harness. If you do manufacture your own harnesses do make sure that you comply to wire thickness and screened wires.

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

The TCU applications require external diodes to prevent spikes or interference from the pulsing inductive loads. These boards com in positive or negative configuration. They are built into the harness and sealed properly with silicon and heart shrink to prevent water damage. If you don't have these boards there is a schematic on how to connect normal diodes onto the solenoids. They are not always built in due to the number of connection options for different transmissions.

DB1 Positive Diode Board

A343E Freewheel Diode Schematic

Shifter Converter Board

This board is required for digital switches in the shifter so that only one input on the TCU is required. They come in 2 varieties' namely Serial and Parallel Digital to Analog converters.

CON2 Serial A/D Converter

GP Priority Layout

This link will take you to a connection sheet that indicates where each wire must be connected for that firmware as well as the wire color.

Aisin A343E 4Speed Connection Layout (Pdf)

Hardware Class Comparison

This will compare the features of the different classes as well as Mercury2.

Aisin A343E

Tyre Calculator

This helps to set up a starting map for the customer.

Tyre Calculator Aisin A343E (Excel)

Packing List

This guides dealers and customers to see which items is required for this application.

Mercury2 Aisin A343E Packing List (Excel)

Old Harness Layout

This is not recommended for Mercury2 but merely for backwards compatibility explanations. Some are discontinued.

RPM and Speed Sensors comes in different types and connections. Do note that these connections differ for different harnesses for. Use the correct harness link to view the data and print it for the customer. There are 2 main groups for transmission connections. A harness to use with an ECU product or a harness to use as a standalone product like for a diesel or carburetted engine. The main difference is that RPM and TPS sensor connections have long screened wires that go to the engine bay end connects on custom sensors. Also note if you are tapping into a system you may need a filter to eliminate interference.

Other drawings you may need are TPS, RPM, Shifter, Tiptronic Buttons , Speed sensor, Map Selection, Oil Temperature , General Purpose Outputs and Speedometer.

Precautions and Installing

Before attempting to start an install it will be wise to read the Precautions for Mercury2. This section outlines general wiring mistakes customers make that will cause operation problems like interference later.

Start-up

When you start an transmission for the first time do follow the Start-Up Procedure for Mercury2. This will take you step by step through the process of checking everything. In some cases, you may damage a unit if your setup in the software does not match your wiring on the transmission.


Compiling an ECU Product

Help > Product Selection > Mercury2 Aplication Selection > ECU Application >

Compiling an ECU Product

This document guides you to put a working product together from scratch. It will link you to the sections in the manual that your application requires, and how to set the product up correctly and print the relevant drawings for that installation. This legwork will save you or your customer time and eliminate lots of support calls. As this is a DIY product, the dealer must do this for his customer. If you carry stock, then you will do it when the customer requests a specific system.

Selecting a Product

There are 2 Spitronics ECU products currently in production namely Orion and Mercury2. Each one has Pro's and Con's and it is wise to take time out to know the differences. Selecting the wrong one may affect the price or the features that is required. Each ECU has its own manual and the Product Selection of its manual is the section to read for this information. You may also look at the ECU Comparison Chart and ECU How to Choose section. Note that these documents are the same for both manuals.

Choosing Firmware

After you have decided on the product type then read this section in that products manual. If you are choosing Mercury2, then you are in the right place.

Now you will need Engine Information from the customer to decide which firmware must be used. Firmware are developed according to the crank and Cam sensor patterns. So you will need to know what senor pattern on the engine is like 60-2, 24+TDC etc. Second parameter required is number of cylinders. Firmware are also grouped in cylinder categories.

Now you can view the Program Number Chart and see if firmware exists for that product. Orion does not have the amount of inputs that Mercury2 has so it may be that it is impossible to run such engines with it like the V12 and other complex engines.

In the Program Number Chart, you will find the Firmware Features according to its hardware class and the GP Priority Layout for that specific firmware. Mercury2 Selection section will explain this chart and how to get the relevant information from it. With this information you know if firmware exists and what hardware class is required as well as how the ECU connections are laid out for that firmware. Remember different firmware will have different connections to the ECU.

Example of Firmware Features 28

Example of GP Priority Layout Ult / Adv / Int

You can also view the Mercury2 GP Priority Layouts on a combined section for easy comparison on wiring.

To program the Mercury2 ECU see the Firmware Programmer section.

Printing documents

Installers prefer drawings on paper as they can make notes on customising and different wire colours etc. Also mark what is not used and what is already done. Note that this document only guides you on connections and does not have OEM specific drawings of sensors etc. For that you will have to consult the Service manuals.

Crank and Cam Sensors comes in different types and connections. See Crank and Cam Sensor Options. All the options are on one page so mark the correct one for the customer.

The other Sensors on an engine have a connection diagram and description for each one. This is like water and air temperature sensors, TPS, MAP etc. Do go through them and print and mark what is relevant to your install. There are plenty of wiring options to activate different firmware features. On some of the drawings are also software settings that instruct the firmware on the type of wiring you have selected. See the right hand bottom corner of this Drawing example.

Coils are sorted by number of cylinders for easy grouping. Then they are grouped in 2 main groups like Standard or Dumb Coils that have no built in drivers, and then Intelligent Coils that has built in drivers. Then They are grouped according to coil types namely Single, Wasted Spark or COP coils. Take care to understand the differences and then select the correct drawing to print. There are settings of what the software must be selected for the specific drawing.

Injectors are sorted by number of cylinders for easy grouping. Then they are grouped according to low or high impedance. The connection for low impedance differs as their resistance is too low to be connected directly. They may also be connected in Split or full sequential configuration.

Other drawings you may need are Idle Control, Cam Control, General Purpose Outputs , Fuel Pump Control and Tachometer.

Precautions and Installing

Before attempting to start an install it will be wise to read the Precautions For Mercury2 . This section outlines general wiring mistakes customers make that will cause operation problems like interference later.

Start-up

When you start an engine for the first time do follow the Start-Up Procedure. This will take you step by step through the process of checking everything. In some cases, you may damage a unit if your setup in the software does not match your wiring on the engine. Drivers from the ECU may have different tasks. Then it may not be controlled in the right manner. You may over fuel a cylinder resulting in a bent con-rod etc.


Converter Programs

Help > Product Selection > Mercury2 Aplication Selection > Other Applications >

Converter Selection

This firmware will take a normal RPM pulse and convert it into different triggers like 60-2, 36-1, 24 plus TDC etc. for OEM managements. This will keep them active so that they can run other functions still required like Dash board tacho's etc. Note that the classes that are not used by the converter is not displayed to simplify the chart. If firmware is developed they will be added.

Mercury2 Hardware | Bas
Hardware Inputs |
External Map Sensor |
Built In Map Sensor (optional) |
TPS Sensor |
Water 2K NTC or Tap-In |
Air 10K NTC or Tap-In |
Lambda Narrow or Wide Band |
Battery Volts | 1
Power Management | 1
Crank Trigger Pulse | 1
TDC/Home Pulse |
UART Comms Port | 1
Hardware Outputs |
Low Volt Negative Drivers | 2
Low Volt Positive Drivers |
General Purpose Input / Output |
Features |
Graph Tuning MAP | 1
Matrix Tuning MAP or TPS | 1
Altitude Compensation |
Idle Control |
Dual Maps |
Dual Injectors |
Split Sequential Injection |
Full Sequential Injection |
Fuel Pressure Control |
V-Tech /Vanos Cam Control |
Launch control |
Anti-Lag control |
Flat-Shift control |
RPM Calibration |
Epoxy filed | 1


ECU Class Comparrison

Help > Product Selection > Mercury2 Aplication Selection > ECU Application >

ECU Selection

Note that the classes that are not used by the ECU firmware is not displayed to simplify the chart. If firmware is developed they will be added.

Merury2 Hardware | STD | INT | ADV | ULT | COM |
Hardware Inputs |  |  |  |  |  |
External Map Sensor | 1 | 1 | 1 | 1 | 1 |
Altitude Sensor | 1 | 1 | 1 | 1 | 1 |
TPS Sensor | 1 | 1 | 1 | 1 | 1 |
Water 2K NTC 1K Pull-up | 1 | 1 | 1 | 1 | 1 |
Air 10K NTC 7.5K Pull-up | 1 | 1 | 1 | 1 | 1 |
Lambda Narrow or Wide Band | 1 | 1 | 1 | 1 | 1 | Note 1
Battery Volts | 1 | 1 | 1 | 1 | 1 |
Tuningh Pot | 1 | 1 | 1 | 1 | 1 |
Fuel Pressure Sensor |  |  | 1 | 1 | 1 |
Power Management | 1 | 1 | 1 | 1 | 1 |
Crank Trigger Pulse | 1 | 1 | 1 | 1 | 1 |
TDC/Home Pulse |  | 1 | 1 | 1 | 1 |
VVTI Cam 1 Pulse |  |  |  | 1 | 1 |
VVTI Cam 2 Pulse |  |  |  | 1 | 1 |
UART Comms Port | 1 | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |  |
Low Volt Negative Drivers | 2 | 8 | 8 | 8 | 8 | Note 2
Low Volt Positive Drivers | 1 | 1 | 8 | 8 | 8 | Note 2
General Purpose Negative Drivers | 2 | 2 | 2 | 2 |  |
Features |  |  |  |  |  |
Graph Tuning MAP | 1 | 1 | 1 | 1 | 1 |
Matrix Tuning MAP or TPS | 1 | 1 | 1 | 1 | 1 |
Altitude Compensation | 1 | 1 | 1 | 1 | 1 |
Idle Control | 1 | 1 | 1 | 1 | 1 | Note 3
Dual Maps | 1 | 1 | 1 | 1 | 1 |
Dual Injectors |  |  |  |  | 1 |
Split Sequential Injection | 1 | 1 | 1 | 1 | 1 |
Full Sequential Injection |  |  | 1 | 1 | 1 |
Fuel Pressure Control |  |  | 1 | 1 | 1 | Note 4
VVTI Cam Control Open Loop |  |  | 2 | 2 | 2 |
VVTI Cam Control Closed Loop |  |  |  |  | 2 |
V-Tech /Vanos Cam Control | 1 | 1 | 1 | 1 | 1 |
Launch control |  |  | 1 | 1 | 1 |
Launch control Dealed |  |  |  | 1 | 1 |
Anti-Lag control |  |  | 1 | 1 | 1 |
Flat-Shift control |  |  | 1 | 1 | 1 |
RPM Calibration | 1 | 1 | 1 | 1 | 1 |
Epoxy filed | 1 | 1 | 1 | 1 | 1 |
Notes |  |  |  |  |  |
Note 1 - Wideband requires external electronics to provide 0-5V signal
Note 2 - All drivers that is not used by the firmware become GP outputs
Note 3 - Stepper motors require the external Idle2 Controller
Note 4 - This feature requires the Electronic Relay
NB! Some of the firmware may still be under development. This is merely indicating the capabilities of the different classes. Make sure if such firmware are available before buying or quoting your customers


Getting Started

Help > Introduction >

Getting Started with Mercury2 and Hyperspace Tuning Software

About the product.

Spitronics products are developed for the DIY market and are mostly sold through dealers and to handy customers in and outside the RSA boundaries. This makes it a more cost effective product as the company overheads are held to a minimum. Spitronics rather makes use of the extensive infrastructure of dealers that specialize in this type of business. The Spitronics devices are not plug & play devices but must be customized by the dealer for specific applications. These products are very versatile and can be adapted to most engines, transmissions etc. The dealer is responsible for after-sale service which is a third party company that Spitronics don't have control over. So make sure about the dealer service and capabilities before you buy from him. Spitronics is not responsible for poor service from him. Please read our terms and conditions found on our website. All the information, software and manuals are freeware on our website www.spitronics.com

How does Spitronics Products Work

Each Spitronics product is Micro based which requires specific firmware programs to initialize the hardware for each type of engine or transmission. It then has tuning Maps that adjust parameters and graphs for that engine or transmission. To alter the Maps, require tuning software, so that the tuner can adjust fuel and timing etc. for that application. The product needs to be activated before it will operate.

1. The firmware will initialize the hardware to work on a specific engine or transmission. This firmware is fixed code and is pre-loaded into the product with the Firmware Programmer or BootLoader. Only the manufacturer requires a programmer and from there on it use the Bootloader and normal USB tuning cable as illustrated in Step 1. The firmware files is freeware on our website and has the extension of .HEX for products that require a programmer and it has the extension of .FIRM for products with a bootloader. This process is illustrated in step 1 of Fig 1.

2. Spitronics developed an internet activation system to allow dealers abroad to carry stock at a reduced price. Then when the dealer sells to a customer, he will activate the unit in a specific hardware class according to the required firmware for that application. He will then do a payment for the rest of the amount. He will load the correct firmware and startup Map for the customer and guide him to the correct drawings and settings. He will test the unit on a simulator and verify that everything is in order as to assist the customer. This feature makes the product counter ready without the delay of ordering the product on demand. This procedure is illustrated in the steps of Fig 1.

3. The Hyperspace tuning software will allow the tuner to adjust his engine or transmission to his requirement. This could be performance, economy, automatic or tiptronic etc. This tuning data is saved in the product and also in a file called a data Map or a Tune with the extension .SPIECU or .SPITCU etc.

Block Diagram of Product interfacing

Step 1 - Programming

How does Spitronics Products Work

Each Spitronics product is Micro based which requires a firmware program to initialize the hardware, and tuning Maps that adjust parameters and graphs for the engine or transmission. The Maps require tuning software so that the tuner can adjust fuel and timing for that application. The product also needs to be activated before it will operate.

1. The firmware will initialize the hardware to work on a specific engine or transmission. This firmware is fixed code and is pre-loaded into the product with the USB Debug Adapter. It is optional for an end user because they will use it only once. The dealer has the option to customize standard hardware for all different applications with this programmer. The firmware files are freeware on our website and has the extension of .HEX. This process is illustrated in step 1 in the diagram above.

2. Spitronics developed an internet activation system to allow dealers abroad to carry stock at a reduced price. Then when the dealer sells to a customer he will activate the unit in a specific hardware class according to the firmware and application of the customer. He will then do a payment for the rest of the amount. He will load the correct firmware and startup Map for the customer and guide him to the correct drawings and settings. He will test the unit on a simulator and verify that everything is in order as to assist the customer. This feature makes the product 'counter ready' without the delay of ordering the product on demand. This process is illustrated in step 2 in the diagram above.

3. The tuning software will allow the tuner to adjust his engine or transmission to his requirement. This could be performance, economy, automatic or tiptronic etc. This tuning data is saved in the product and also in a file called a data Map with the extension .SPIECU or .SPITCU etc. This process is illustrated in step 3 in the diagram above.

What you need to get started.

1. The product hardware and accessories for the specific application. This will be the ECU / TCU, control modules such as idle control and Coil Igniters, harnesses, MAP sensors etc. for that specific application. The product is sold in different classes and priced according to the features and outputs used. There is a selection chart in the manual under Products indicating the different classes for different features. Or you may ask a dealer in your area or send a mail to sales@spitronics.com

2. The USB / UART communication cable to connect the device on to a laptop for tuning purposes. This cable is sold separate as you only need one for tuning all our products. The communication electronics is put in the cable which means the product becomes cheaper as each device does not require those components. This USB Cable has Windows drivers that needs to be installed before it will operate. See further in the manual for instructions.

3. The Hyperspace Tuning Software to interface with the products. The software is only Windows based and works on all versions. You need a Laptop of Tablet for this. The software is separate for each product to simplify operation.

4. A Startup map which helps with the setup of the specific engine. Each engine differs in minor changes so these MAP's still requires some refining. A MAP or Tune is a data file that is saved on the hard disk and differs for each type of engine. If you don't get a specific map for your engine, you may adapt any map to suit your engine.

5. The Mercury2 Manual for explaining wiring and tuning. These manuals became bulky with all the information but once you browse through them you will get to your info quickly. They are available on the web and is updated from time to time.

Optional requirements.

1. The Bluetooth and Wi-Fi module. This is handy products to connect the device to dashboard products from third parties.

2. The firmware programmer. This USB Debug Adapter lets you customize the product yourself for any engine or transmission or custom task, if that firmware was developed for it. Firmware is free and placed on the website. You can browse to check if your application is covered. The programmer is also used to download the latest updates available for your application. New features may be added for your convenience. We always recommend buying a programmer to distant customers. Test firmware is also available to help in fault finding.

3. The simulator helps dealers to find faults on customer's units. It is recommended for the dealer that likes to carry stock and help customers over the counter. The latest Simulator2 works on all our products with the exception of different connecting harnesses.

Useful links and direction of info on the website.

The USB / UART communication cable.

·

·

·

· http://www.spitronics.co.za/downloads/USB%20Drivers/Spitronics_USB_Drivers.rar

The Ver 3 Hyperspace Tuning software.

·

·

·

·

· Due to regular updating of software we will not include a link here. Select the software you require. ECU, TCU, TxW etc. The Read Me file has more information regarding the software. The link below will take you to the folder.

· http://www.spitronics.com/downloads/index.php?L2hvbWUtaG9zdGluZy9zcGl0cm9uaWNzLmNvLnphL3B1YmxpYy9kb3dubG9hZHMvVHVuaW5nIFNvZnR3YXJlL0h5cGVyc3BhY2UgU29mdHdhcmU=

The Mercury2 Manual

·

·

· Due to regular updating of manuals we will not include a link here. Select the manual you require. The Read Me file has more information regarding the manuals. The link below will take you to the folder.

· http://www.spitronics.com/downloads/index.php?L2hvbWUtaG9zdGluZy9zcGl0cm9uaWNzLmNvLnphL3B1YmxpYy9kb3dubG9hZHMvTWFudWFscw==

The Firmware Programmer (USB Debug Adapter)

·

·

·

· http://www.spitronics.co.za/downloads/Firmware%20Programmer/mcu_ide.exe

Installation of Software, Drivers and Manual

Manuals

Mercury2 Manual

Select the manual. The browser should download the Manual in the downloads folder on your PC. Sometimes the antivirus programs will block the content of HTML files or ask you if you want to keep the content. Say yes to keep content. The file is compressed with WinRAR which is freeware software. Un-compress the file. If you open the file and the data is not complete, close it and right click on the manual icon, and give it permissions to open the data. Again this is a windows virus protection feature. Then open the file and it should look like this:

USB Drivers

Click with the mouse on the blue The USB / UART communication cable link under the Useful Links topic. The browser should download the drivers in the downloads folder. The drivers file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a folder created as below.

Go into the folder and you should see the following.

If you have a 64bit computer then run the file called

For 32bit computer run the file called

After you installed the driver plug the USB /UART cable into the computer and the cable will be activated. In the device manager you should see the block below in com ports. This means the drivers are installed correctly.

Tuning Software

Select the manual you require. The browser should download the file in the downloads folder on your PC. The file is compressed with WinRAR which is freeware software. Un-compress the file. After uncompressing there should be a file created as the example below.

Run the file and Hyperspace will be opened.

After it is opened and indemnity was done as well as manuals opened in the software you should end up with a file set like below:

That is why it is a good idea to make sub folders Like ECU, TCU etc. to keep files together.

Firmware Programmer

In the manual is a complete description of how to install and operate the Firmware Programmer. Again very important is the Precautions. Read them carefully. Never press the Erase All Code Space button. It will render the product useless and it will have to be returned to the factory. Below is a screen shot of where you can find it in the Hyperspace ECU Manual.

Connecting a Product to Hyperspace for the first time.

By now you should be familiar with the product and information around it. The chapters you should read before attempting to install is the Safety Precautions . This will help to prevented making the obvious faults that could damage the unit or components of the engine. Below is a screenshot where you can find it in the Mercury2 Installation manual.

Always follow the Startup Procedure step by step as it is explained in the manual. Do not attempt to take shortcuts and try to start. If you missed some points in the setup, the ECU or engine components could be damaged. Each Product differs and has its own unique way in the Startup Procedure. Each point is numbered and you can reference this number to the dealer to ask him for advice. If the number does not function correctly do not go further until it is solved. Failing to do so may damage the unit and inflict repair costs for your account. Below is a screenshot where you can find it in the Hyperspace manual.


Mercury2 Aplication Selection

Help > Product Selection >

Mercury2 Application Selection

The Mercury2 can be used in many applications like ECU, TCU, TxW etc. It is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the Internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. Harnesses for different applications will vary so the selection section will guide you on what and how to combine.

See the sub folders for more information.

ECU Application

TCU Application

Other Applications


ECU Selection

Help > ECU Engine Managment >

Mercury2 ECU Selection

The Mercury2 is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance, Ultimate, Commercial and Racing. Not all the products have firmware for all the hardware classes but if a product has n higher hardware class, then all the lower firmware classes will operate on it.

In the sub folders are charts for each product with guidance to what each class can do. To be more secure look at the firmware available for the Mercury2 and which class is required. Or speak to one of our dealers. Blow is a link that take you to the list on the firmware.

ECU Program Numbers

Note that the Program Number list compare Mercury2 vs Orion features. Below is a sample entry in the list.

You can click on the program number (28) if it is blue. This means that firmware is developed for Mercury2 or Orion or both. This will open a feature comparison chart between Mercury2 and Orion and then also a hardware class comparison for each product. The Red and Green X indicates for which product the firmware is available. If the block is gray, then it means that product will not have that firmware. If it is open, then firmware may be developed in the future. See below.

If you click on the red or green hardware class (Ult / Adv / Int) in the list it will open the GP Priority Layout for that program. This will indicate where each input and output is connected to the device because it differs for each firmware program. It will also show harness colors for the standard harnesses supplied. See example below:

See the sub folders for more information.


Mercury2 Features

Help > Product Selection >

Mercury2 Features

Note that some features are in the process to be developed in the future. The hardware has the capability for it. Also note that not all of the features may be included on the same ECU as there is limited amount of drivers available. Some of the hardware classes may not include certain features due to the price range. See the selection chart for the ability of the different classes.

ECU Features

Fuel Delivery

· Accurate fueling such as batch, Split Batch, Split Sequential, and Full Sequential gives better performance and fuel consumption due to constant atomization on each cylinder.

· Fueling is done in graph or matrix method for the tuners preference.

· All graphs or matrix data are interpolated to smooth fuel calculation accuracy for best performance though the operating ranges.

· Fuel is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing and from economy to performance.

· Other sensors that are used to alter the fuel mixture are Water, Air, Altitude, Lambda, Battery Volts, Fuel Pressure and throttle response.

· Fuel injection timing is adjustable on gear type crank angle sensors as low as 12 pulses per revolution.

· Adjustable MAP sensor, reading angle for multiple throttle body systems.

· Two types of dual injector methods can be used. Staged injectors namely Ratio adjust or Graph Fazed method.

· Fuel pressure control with pressure compensation maps.

· Injector trimming up to 8 injectors.

Ignition Spark & Timing

· The Mercury can do distributor, wasted spark coil pack, wasted spark COP or full sequential spark systems

· Use standard coil packs on the engine.

· Can be connected to most intelligent coils with internal drivers directly.

· Plain coils can be connected with the Mercury coil.

· The Mercury high performance firing module ensure a high performance spark adequate to ignite most mixtures of different fuels.

· Very accurate ignition timing especially with the gear type triggers.

· Timing is calculated with MAP or TPS sensor signals versus RPM or a combination of the two. This will accommodate most engines ranging from street to racing.

· Other sensors that is used to alter the Ignition Timing is Water, Air and Altitude,

· Battery Volts is used to compensate for coil charge time.

Sensors

· The ECU use most standard sensors on the engine - No need to do modifications on distributors or converter boards.

· Custom Bolt-On Timing Gears may be used for older engines that run carburetors or engines with incorrect setups. Gear type triggers do make timing more accurate and responsive during blip conditions. This is the preferred method for racing applications.

· Sensors can be calibrated to accommodate the different types found on the engines.

Idle Control & Cold Start - This functions will ease with starting a cold engine and keep the RPM's constant when air conditioners or automatic transmissions draw power from the engine. Idle control is included on board for one and two wire idle valves. The Spitronics stepper control units can be connected to control quad and bipolar stepper motors.

Launch Control - This feature will increase boost pressure during pull-off to eliminate Turbo Lag. Various methods are available to activate launch like buttons clutch switches TPS position etc. it can also do delayed launch recovery to improve traction.

Anti-Lag Control - This feature will increase boost pressure during racing to eliminate Turbo Lag on corners.

Flat-shift Control - This feature will momentarily cut engine power to assist in manual gear shifting.

General Purpose Outputs - Up to 10 drivers if available can be used for injectors, fan control, shift light, Aircon Cut-Out on Pull-Off or Up-Hill etc.

Standard Harness - No need to keep several harnesses in stock for different engines. Level 2 harnesses will include relays and fuses that will ease installation and save time. All the input wiring harnesses use screened cables for neatness of installation and to prevent electromagnetic interference which may cause erratic behavior of the ECU.

Compact Electronics - This will make the ECU easy to install under the dashboard as it takes very little space.

Complete Firmware for Most Engines.

Cost Effective - No need to buy expensive systems as all the necessary features are included with the ECU.

Rotary Systems - The 2 & 3 rotor engines are covered by this ECU. 4 to 6 can be done as well.

External Map Sensor - Easy to change between 1Bar, 2.5Bar, 3Bar 4Bar & custom configurations. External sensors are used to reduce the delay in the vacuum signal It makes the ECU more versatile to adapt to standard MAP sensors found on engines.

Altitude Compensation - This feature is important as the ECU will automatically compensate for differences in pressure.

Fuel Pressure control - This will control the speed of the fuel pump which eliminate the need for the mechanical fuel pressure regulator and return fuel line. It also compensates injector time versus fuel pressure to ensure accurate mixtures during blip conditions.

Standard Tuning Software - The features that is not used or allowed in the firmware will be blanked out.

Easy DIY Instructions - Save a lot of money on installation if you are a person who is up to the challenge.

Start-Up Maps included - This will make for easy start-up & tuning with the help of a Lambda sensor

User Friendly Tuning Software which is extensively explained in the manual.

Tuning map can be locked to prevent tampering. Useful for engine builders to gives guarantees.

No Dyno Required - Tune your own vehicle with the help of the data logger in the software and save money. Just following the instructions in the manual carefully.

(Note that the last four points are for the person who is handy with tools and understand wiring and operation of an engine. If you are not sure, download the software, Map, manual and drawing and experiment with it first. It's free of charge!)

TCU Features

The following are all the current features covered by the Mercury 2. There are some on the charts that are in the process of being developed for the future, however, hardware capability already exists. Not all of the features may be included on the same TCU, as there are limited amount of drivers available. Some of the hardware classes may not include certain features due to price range. (See the selection chart for the ability of the different classes. Note that this hardware could be used as ECU.)

Tiptronic

· Automatic Mode - the driver sets the maximum target gear allowed.

· Semi-Automatic Mode - the driver has more manipulation of the gears with the added automatic features.

· Manual Mode - the driver has complete control over the transmission with the added protection against over revving.

Map Selection Switch - lets the driver set up his transmission in 4 different profiles; Automatic, Tiptronic, Towing, Off-road, Racing etc.

Shifter Position input

· The TCU can sense all kinds of shifter sensors to operate correctly in all lever positions.

· If no shifter sensor is available then the reverse light signal can be used to lockout shifting in reverse.

Gear Profile Adjustments - Each gear can be manipulated to shift up or down when the tuner requires it. These settings work on RPM, Speed and TPS values.

Line Pressure Adjustments - These pressures can be adjusted on a graph with the TPS representing engine load. There may be a number of graphs according to the transmission requirement.

Indication LED's - The TCU has up to 6 dashboard LED's to indicate different functions that is selected. This will help the driver to manage his transmission.

Sensors

· TPS sensor will indicate to the TCU what the driver's intention is. Then it will shift accordingly.

· RPM signal will be used to shift the transmission to harness the engine power correctly and be economical.

· Speed sensor will be used as protection against down gear over revving and also other shift algorithms.

· Transmission Oil Temperature sensor will change line pressures during cold conditions to soften gear shifts.

· Low range sensor will adjust speed settings in the transmission automatically.

· Sensors can be calibrated to suit most engines and transmissions.

Solenoids

· Shift solenoids will manipulate the required gear to be selected

· Duty control solenoids will control line, lockup and shift control solenoids to make the transmission as comfortable to the driver as possible.

General Purpose outputs - These outputs can be used for custom features like speed warning sirens etc.

Speedo output - this signal drives speedometers and can be calibrated in the software.

Selectable Lockup - can switch on in all gears if transmission permits

Standard Harness - No need to keep several harnesses in stock for different engines. Level 2 harnesses will include relays and fuses that will ease installation and save time. All the input wiring harnesses use screened cables for neatness of installation and to prevent electromagnetic interference which may cause erratic behavior of the TCU.

Compact Electronics - This will make the TCU easy to hide under the dashboard as it takes very little space.

Complete firmware for Most transmissions.

Cost Effective - No need to buy expensive systems as all the necessary features are included with the TCU.

Standard Tuning Software - the features that is not used or allowed in the tuning software will be blanked out.

Easy DIY Instructions - Save money on installation if you are a person who is up to the challenge.

Start-Up Maps included - This will make for easy start-up & tuning with the help of a Lambda sensor

User Friendly -Tuning Software which is extensively explained in the manual.

Tuning map -can be locked to prevent tampering. Useful for transmissions builders to give guarantees.

No Dyno Required - Tune your own transmissions and save some money. Just follow the instructions in the manual carefully.

(Note that the last four points are for the person who is handy with tools and understand wiring and operation of transmissions. If you are not sure, download the software, Map, manual and drawing and experiment with it first. It's free of charge!)


Mercury2 Layout

Help > TCU Transmission Management > TCU Hardware Description >

Mercury2 Layout

1. Yellow LED - 5 Volt Power on

2. Green1 LED - RPM Output

3. Green2 LED - N8 output

4. Red1 LED - P8 output

5. Red2 LED - P7 output

6. Coms - Communication Connecter 6 Way - USB Cable & Programmer

7. Jumpers Hall Sensors - Crank Pull-up Left - TDC Pull-up Right

8. P1 - Input Connector 12 Way

9. P4 - Input and Output Connector 6 Way

10. P2 - Positive Output Connector 10 Way

11. P5 - Positive & Ground Output Connector 4 Way

12. P3 - Ground Output Connector 8 Way

13. Mounting Holes 5mm


Other Applications

Help > Product Selection > Mercury2 Aplication Selection >

Mercury2 Other Applications

The Mercury2 is often used for other applications like Converters or Throttle by Wire systems etc. It is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance, Ultimate, Commercial and Racing. Not all the products have firmware for all the hardware classes but if a product has n higher hardware class, then all the lower firmware classes will operate on it.

In the sub folders are information for each application with guidance and instructions. To be more secure look at the firmware available for the Mercury2 and which class is required. Or speak to one of our dealers.

See the sub folders for more information.


Mercury2 Overview

Help > Product Selection >

Mercury2 Overview

This versatile Automotive Controller is designed to be a cost effective durable replacement for high tech Vehicle Electronic Units. It can be used on most engines, transmissions and other products in the motor vehicle industry. It uses unique and easy features which are easy to install and tune. It is designed with the novice and professional installer in mind.

This universal South African made product can easily be customized for various engines, transmissions etc. It can be used for many applications such as racing engines, vehicle conversions, custom built vehicles, replacement parts for production vehicles etc. It is a compact reliable system which can be epoxy filled to make it rugged and water tight for harsh environments and is easy to mount in the driver's compartment.

The Mercury2 can be reprogrammed remotely by a firmware programmer. This will allow a dealer to have less inventory on his floor and customize this product on demand. This product is also sold in different classes which makes it more viable to use for smaller applications. It may also be bought at reduced prices in un-activated status. This will allow the dealer to have better control over his cash flow management in his business. Activations of features can be done over the internet making the unit viable to keep in stock at dealers. Activation will then require the rest of the unpaid amount.

The Mercury2 unit is designed to connect directly to most sensors and drive units that is found on engines, transmissions and other products. No need to modify them. It consists of the latest in high speed micro controllers with surface mount technology. These units are machine soldered to minimize human error.

The Mercury2 cover features like Lambda control, idle control, launch control, cam control, stepper motor control, throttle by wire control, boost control, line pressure control, fuel pressure control tiptronic and lots more. It can drive intelligent coils, injectors, solenoids, throttle by wire motors etc. directly. Due to the versatility some devices may require external resistors or diodes which is supplied with the Mercury2. It can read signals from sensors like water & air temperature, throttle position, manifold pressure, crank angles, cam angles, lambda, fuel pressure etc. directly.

The Hyperspace tuning software is user-friendly and makes all the above features customizable by the tuner. This makes the Mercury2 adaptable for most applications on site.

To learn more about this amazing package browse through the features and specifications in the sub folders.


Mercury2 Specifications

Help > Product Selection >

Mercury2 Specifications

Power Supply

12V Ignition power 200mA, filtered by reverse polarity Diode, 700mA Poly switch and 25V Tranzorb

12V Relay power 14A Max, filtered by reverse polarity Diode

12V Driver Power up to 14 amps depending on power used by items driven.

Fixed Inputs

4x Digital inputs - Magnetic Isolated (2 Inputs require a 1K pull-up resistor for Hall or Optic inputs)

5x Analogue input 0 - 5V

1x Water Temperature Input 2K NTC Resistance Sensor with 1K pull-up resistor

1x Air Temperature Input 10K NTC Resistance Sensor with 7K5 pull-up resistor

1x Lambda Input 0 - 1 V or Processed 0 - 5V signal.

Fixed Outputs

8x 6A P Channel Mossfets 12V Output Floating, Over-current protected

8x 6A N Channel Mossfets Ground Output Floating, Over-current protected

1x Mechanical Relay 3.5A Ground Output Floating, Over-current protected

1x RPM 3.5A Ground Output Floating with 1K pull-up resistor to 12V, Over-current protected

2x General Purpose 3.5A Ground Output Floating, Over-current protected

5V 600mA Power Output for TPS & Map Sensor

Electronic Relay 5V 5mA output for Spitronics custom 45A solid state relay

Communication

Software UART Connection via USB2 converter cable

Firmware Programmer Connection

Dimensions

Size 145mm x 68mm x 21mm

Weight 240g

6 x Connector Type Plastic Molex 12, 10, 8, 6, 6, 4


TCU Selection

Help > TCU Transmission Management >

Mercury2 TCU Selection

The Mercury2 is sold in eight hardware classes categorized by the features required for each application. The advantage is that basic applications is sold cheaper than more complex applications. These features can be activated or changed over the internet which eliminates time lost and courier costs. This makes it viable to have these units in stock at low entry cost and activate the features later when the project is started. The PC Tuning software is standard for all units. Certain features will be blanked out if it is not available. The firmware categories are Micro, Basic, Standard, Intermediate, Advance, Ultimate, Commercial and Racing. Not all the products have firmware for all the hardware classes but if a product has n higher hardware class, then all the lower firmware classes will operate on it.

In the sub folders are charts for each product with guidance to what each class can do. To be more secure look at the firmware available for the Mercury2 and which class is required. Or speak to one of our dealers. Below is a link that take you to the list on the firmware.

TCU Program Numbers

Note that the Program Number list compare Mercury2 vs Orion features. Below is a sample entry in the list.

You can click on the program number (7) if it is blue. This means that firmware is developed for Mercury2 or Orion or both. This will open a feature comparison chart between Mercury2 and Orion and then also a hardware class comparison for each product. The Red and Green X indicates for which product the firmware is available. If the block is gray, then it means that product will not have that firmware. If it is open, then firmware may be developed in the future. See below.

If you click on the red or green hardware class (Ult / Adv) in the list it will open the GP Priority Layout for that firmware. This will indicate where each input and output is connected to the device because it differs for each firmware program. It will also show harness colors for the standard harnesses supplied. See example below:

See the other folders for more information.


Electronic Relay

Help > Product Selection >

Mercury Relay Overview

The Mercury Electronic Relay is designed to eliminate mechanical parts and contacts found in relays. It is more durable and has current limit protection of 45 Amp. This relay will be switched on or off by the Mercury2 on the ELR output. It will power the coils, injectors, fuel pump etc. Note that when you use this relay as a power relay then put the Engine Shutdown in Fuel First mode.

The Mercury Electronic Relay is also used as a fuel pump driver when fuel pressure control is activated. It is the PWM controlled to change the power to the fuel pump. It is driven by a positive signal from the ECU.

The Mercury Electronic Relay is also used as a injector driver for dual injector systems where there is not enough drivars available for all the injectors. in these cases the injectors will share the Mercury2 driver and the secondary bank will have their power controlled via the relay by the mercury2. It is driven by a positive signal from the ECU.

Note that a fuse before this relay is required to protect the circuits from over current. 45 Amp can melt thinner wires causing a fire hazard.

Specifications

Relay Maximum current - 45 Amp protected

LED Indication

Yellow Power on indication

Power required

12V 45 Amp

Inputs

1x Relay Trigger input - 5 to 18 volt for On condition, 0-1 volt for Off condition.

Outputs

1x 12 Volt output 45 Amp

Dimensions

Size 49 x 45mm x 21mm

Weight 50g Epoxy Filled

4 x Fly Leads


Product Selection

Help >

Mercury2 is a cost effective Engine Control Unit (ECU) or Transmission Control Unit (TCU) which is the flagship of our range products. It has negative and positive drivers to cover most applications and reduce costs. It can connect to most sensors found on engines and transmissions. The Mercury2 can easily be customized on site with the use of the low cost firmware programmer. This feature makes it a very versatile product to keep in stock.

See the sub folders for more details.

Mercury2 Overview

Mercury2 Features

Mercury2 Specifications


Purchasing a Mercury2 ECU

Help > Product Selection > Mercury2 Aplication Selection > ECU Application >

Purchasing a Mercury2 ECU

Mercury2 is a universal controller which has multiple options with the accessories like harnesses, sensors and firmware. It is not easy to make a price for advertising as each engine may require different items. The installer also have choices on economy harnesses to save money or easy install harnesses to save on install time. Below is an example on how to select your product and explanations on each item if you are not sure. Just click on the links for more information. This manual does not have prices included but a similar form with prices can be found on our website. From there you can send the it as an order to one of our wholesalers or as a quotation to a customer. Note that the Red text is required or recommended to an application while Green is optional and not necessary needed on all applications.

Item | Selection | Price | QTY | Check | Description
Mercury2 ECU (Hardware Class) |  |  |  |  |
 | Ultimate |  |  |  | Racing Features - Multi Coil
 | Advance |  |  |  | Advance Features - Multi Coil
 | Intermediate |  |  |  | Complex Trigger - Distributor
 | Standard |  |  |  | Simple Trigger - Distributor
USB Tuning Cable |  |  |  |  |
 | USB/UART Comms |  |  |  | Required to connect with the Tuning Software
Map Sensor |  |  |  |  |
 | 2.5 Bar Plastic |  |  |  | Required to Measures Manifold Pressure up to 1.5 Bar Boost pressure
 | 3 Bar Aluminium |  |  |  | Required to Measures Manifold Pressure up to 2 Bar Boost pressure
 | 4 Bar Aluminium |  |  |  | Required to Measures Manifold Pressure up to 3 Bar Boost pressure
Altitude Sensor |  |  |  |  |
 | 2.5 Bar Plastic |  |  |  | Optional to Measure Altitude Pressure for Baro Compensation
Harness Export Complete |  |  |  |  |
 | MEX02/2 |  |  |  | Contains all the wiring relays and fuses. Engine connectors are not included.
Harness Economy |  |  |  |  |
 | M01-P1 |  |  |  | Contains wiring on P1 connector only. Power wires fuses and relays are not included.
 | M05-P1 |  |  |  | Contains wiring on P1 connector only. Power wires fuses and relays are not included.
 | M06-P1 |  |  |  | Contains wiring on P1 connector only. Power wires fuses and relays are not included.
 | M02-P2-V2 |  |  |  | Contains wiring on P2 connector only. Power wires fuses and relays are not included.
 | M03-P3 |  |  |  | Contains wiring on P3 connector only. Power wires fuses and relays are not included.
 | M04-P4 |  |  |  | Contains wiring on P4 connector only. Power wires fuses and relays are not included.
 | M07-P5 |  |  |  | Contains wiring on P5 connector only. Power wires fuses and relays are not included.
 | Relays |  |  |  |
 | Fuse Box |  |  |  |
Stepper Idle Control |  |  |  |  |
 | Type1 |  |  |  | Required if the engine has a 4 Pole Common Stepper Idle Control
 | Type2 |  |  |  | Required if the engine has a 4 Pole Bi-Polar Stepper Idle Control
 | Harness SO3 12Pin |  |  |  | Required for connecting a Stepper Idle Control
Coil Driver |  |  |  |  |
 | MC1-P1 |  |  |  | Required for any of the following Mercury Coil Drivers
 | 2 Way Coil Driver |  |  |  | Required for 2 Basic Coils with no built in Igniters
 | MC2-P2 |  |  |  | Required for connecting the 2 Way Coil Driver
 | 4 Way Coil Driver |  |  |  | Required for 4 Basic Coils with no built in Igniters
 | MC4-P2 |  |  |  | Required for connecting the 4 Way Coil Driver
 | 6 Way Coil Driver |  |  |  | Required for 6 Basic Coils with no built in Igniters
 | MC6-P2 |  |  |  | Required for connecting the 6 Way Coil Driver
Electronic Relay 45Amp |  |  |  |  | Optional Solid State Relay to replace Mechanical Relays
Firmware Programmer |  |  |  |  | Optional for changing or updating Firmware
Simmulater3 |  |  |  |  |
 | Controller |  |  |  | Optional for dealers to test Spitronics Devices
 | Harnesses |  |  |  | Required for each product that must be tested on the Simulator
Connectors and Pins |  |  |  |  |
 | 4 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 6 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 8 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 10 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 12 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses


Purchasing a Mercury2 TCU

Help > Product Selection > Mercury2 Aplication Selection > TCU Application >

Purchasing a Mercury2 TCU

Mercury2 is a universal controller which has multiple options with the accessories like harnesses, sensors and firmware. It is not easy to make a price for advertising as each engine may require different items. The installer also have choices on economy harnesses to save money or easy install harnesses to save on install time. Below is an example on how to select your product and explanations on each item if you are not sure. Just click on the links for more information. This manual does not have prices included but a similar form with prices can be found on our website. From there you can send the it as an order to one of our wholesalers or as a quotation to a customer. Note that the Red text is required or recommended to an application while Green is optional and not necessary needed on all applications.

Item | Selection | Price | QTY | Check | Description
Mercury2 ECU (Hardware Class) |  |  |  |  |
 | Advance |  |  |  | Advance Features - Speedometer Calibration, 2nd Pull off, Drive-Overdrive select, 4x4 etc.
 | Intermediate |  |  |  | Basic Functions + Speedometer Calibration
 | Standard |  |  |  | Basic Functions
USB Tuning Cable |  |  |  |  |
 | USB/UART Comms |  |  |  | Required to connect with the Tuning Software
Harness Export Complete |  |  |  |  |
 | MTSX02-2 |  |  |  | Stand Alone Application. Contains all the wiring relays and fuses. Engine connectors are not included.
 | MTWX02-2 |  |  |  | Use with ECU Application. Contains all the wiring relays and fuses. Engine connectors are not included.
Harnesses Economy |  |  |  |  |
 | T01-P1-V2 |  |  |  | Contains wiring on P1 connector only. Power wires fuses and relays are not included.
 | T02-P1 |  |  |  | Contains wiring on P1 connector only. Power wires fuses and relays are not included.
 | T07-P2 |  |  |  | Contains wiring on P2 connector only. Power wires fuses and relays are not included.
 | T03-P3 |  |  |  | Contains wiring on P3 connector only. Power wires fuses and relays are not included.
 | T06-P3 |  |  |  | Contains wiring on P3 connector only. Power wires fuses and relays are not included.
 | T09-P3 |  |  |  | Contains wiring on P3 connector only. Power wires fuses and relays are not included.
 | T04-P4 |  |  |  | Contains wiring on P4 connector only. Power wires fuses and relays are not included.
 | T05-P4 |  |  |  | Contains wiring on P4 connector only. Power wires fuses and relays are not included.
 | M07-P5 |  |  |  | Contains wiring on P5 connector only. Power wires fuses and relays are not included.
 | Relays |  |  |  |
 | Fuse Box |  |  |  |
Diode Boards |  |  |  |  |
 | DB1 Positive |  |  |  | Required for PWM Solenoids which is driven by a Positive Signal with Common Earth
 | DB2 Negative |  |  |  | Required for PWM Solenoids which is driven by a Negative Signal with Common Positive
Shifter Converter A/D Board |  |  |  |  |
 | CON1 Parallel |  |  |  | Required to convert Parallel Digital Switches from the Shifter Range switch to an Analogue signal
 | CON2 Serial |  |  |  | Required to convert Serial Digital Switches from the Shifter Range switch to an Analogue signal
Electronic Relay 45Amp |  |  |  |  | Optional Solid State Relay to replace Mechanical Relays
Firmware Programmer |  |  |  |  | Optional for changing or updating Firmware
Simmulater3 |  |  |  |  |
 | Controller |  |  |  | Optional for dealers to test Spitronics Devices
 | Harnesses |  |  |  | Required for each product that must be tested on the Simulator
Connectors and Pins |  |  |  |  |
 | 4 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 6 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 8 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 10 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses
 | 12 Way + Pins |  |  |  | Optional for dealers that wants to build their own harnesses


TCU Class Comparrison

Help > Product Selection > Mercury2 Aplication Selection > TCU Application >

TCU Selection

Note that the classes that are not used by the TCU firmware is not displayed to simplify the chart. If firmware is developed they will be added.

Mercury2 Hardware | STD | INT | ADV | ULT | Notes
Hardware Inputs |  |  |  |  |
TPS Sensor | 1 | 1 | 1 | 1 |
RPM Sensor | 1 | 1 | 1 | 1 |
Speed Sensor | 1 | 1 | 1 | 1 |
Oil Temp Sensor |  |  | 1 | 1 |
Low Range Sensor |  |  | 1 | 1 |
Shifter Selection Switch | 1 | 1 | 1 | 1 |
Tuning Maps Selection Switch | 1 | 1 | 1 | 1 |
Tiptronic Up Switch | 1 | 1 | 1 | 1 |
Tiptronic Down Switch | 1 | 1 | 1 | 1 |
Battery Volts | 1 | 1 | 1 | 1 |
Power Management | 1 | 1 | 1 | 1 |
UART Comms Port | 1 | 1 | 1 | 1 |
Hardware Outputs |  |  |  |  |
Low Volt Negative Drivers | 8 | 8 | 8 | 8 |
Low Volt Positive Drivers | 8 | 8 | 8 | 8 |
GP Outputs | 2 | 2 | 2 | * | Note 1
Speedo Output |  | 1 | 1 | 1 |
Electronic Relay Output | 1 | 1 | 1 | 1 |
Relay Output | 1 | 1 | 1 | 1 |
Reverse lights Relay Output | 1 | 1 | 1 | 1 |
Starter Relay Output | 1 | 1 | 1 | 1 |
LED Output | 5 | 5 | 5 | 5 |
Power Management | 1 | 1 | 1 | 1 |
Features |  |  |  |  |
Tiptronic Function | 1 | 1 | 1 | 1 | Note 2
Overdrive Function |  |  | 1 | 1 | Note 2
2nd Start Function |  |  | 1 | 1 |
4 Tuning Maps | 1 | 1 | 1 | 1 |
Individual Gear Shift Profiles | 1 | 1 | 1 | 1 |
Duty Cycle Control | 1 | 1 | 1 | 1 |
Speedo Calibration |  | 1 | 1 | 1 |
Lockup Control | 1 | 1 | 1 | 1 |
Lockup Selectable per Gear | 1 | 1 | 1 | 1 |
Transfer Box Ratio Adjustments |  |  | 1 | 1 |
Number of Gears Capable | 10 | 10 | 10 | 10 |
Epoxy filed | 1 | 1 | 1 | 1 |
Notes |  |  |  |  |
Note 1 - * All drivers that is not used by the firmware become GP outputs
Note 2 - These drivers share the same input as Tiptronic buttons.
NB! Some of the firmware may still be under development. This is merely indicating the capabilities of the different classes. Make sure if such firmware are available before buying or quoting your customers


TxW Throttle by Wire

Help > Product Selection > Mercury2 Aplication Selection > Other Applications >

TxW Selection

This firmware will take a normal RPM pulse, TPS and pedal signal and water temperature and control the electric throttle by wire. Note that the classes that are not used by the converter is not displayed to simplify the chart. If firmware is developed they will be added.

Mercury2 Hardware | BAS | STD
Hardware Inputs |  |
External Map Sensor |  |
Built In Map Sensor (optional) |  |
TPS Sensor | 1 | 1
Water 2K NTC or Tap-In |  | 1
Air 10K NTC or Tap-In |  |
Lambda Narrow or Wide Band |  |
Battery Volts | 1 | 1
Power Management | 1 | 1
Crank Trigger Pulse | 1 | 1
TDC/Home Pulse |  |
UART Comms Port | 1 | 1
Hardware Outputs |  |
Low Volt Negative Drivers | 2 | 2
Low Volt Positive Drivers | 2 | 2
General Purpose Input / Output |  | 2
Features |  |
Graph Tuning MAP | 1 | 1
Matrix Tuning MAP or TPS |  |
Altitude Compensation |  |
Idle Control |  | 1
Dual Maps | 1 | 1
Dual Injectors |  |
Split Sequential Injection |  |
Full Sequential Injection |  |
Fuel Pressure Control |  |
V-Tech /Vanos Cam Control | 1 | 1
Launch control |  |
Anti-Lag control |  |
Flat-Shift control |  |
RPM Calibration |  | 1
Epoxy filed | 1 | 1


Active Sensors

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Active Sensors

This block lets the tuner select the different sensors that he requires for his application. Not all the sensors are used but each one has different features that makes the engine perform at its best. If a sensor is not used, leave the block unchecked. This will free up valuable processor time. Also make sure the wiring to that sensor is properly isolated as there is power on the leads that could short circuit and damage the ECU as a result. Some of the sensors cannot be altered or will be forced on by the firmware.

Calibration

Some of the inputs can be calibrated by clicking on this calibrate button next to it. This allows for a wider range of sensors to be used and calibrated in the software.

See the sub folders for explanations.


Altitude

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

Altitude Compensation

The ECU can compensate for altitude differences in pressure. It will adjust the fuel mixture and the timing in relation to altitude. The Mercury2 can do Altitude compensation by wiring an external 1.1 Bar Map sensor onto it.

Select Altitude and click on Compensate. The Altitude sensor is pre-calibrated. You do however need a 1.1 Bar MAP sensor for external sensors unless the 3 bar sensor on board is used. The real time bar below will indicate the actual altitude pressure of your surroundings.

Fuel Compensation

This feature works differently for the different tuning methods. Below are descriptions of operation in each method.

Graph Map tuning - Normal Aspirated

This scaling feature is only for normal aspirated engines where the map range is set at 1.1 Bar. The ECU will calculate altitude in the background and rescale the MAP sensor value so that the map bar always reaches full scale at all altitudes. This is important because the normal MAP sensor will not reach the maximum scale on the tuning graph at high altitude. Put another way, full scale on the graph will always be compared to available altitude pressure outside.

In a typical Fuel Load graph for example, an engine that was tuned at sea level where the MAP sensor reached 1 Bar, will only reach 0.83 Bar at around 2000 meters above sea level. The full load fuel compensation that was set to be richer above 0.9 bar will not be reached. The ECU will then not have the advantage of the full curve that was mapped out during tuning.

Engine tuned at sea level up to 1 bar only reach 0.83 bar at 2000 meter. Note: The bar will not pass the red bar and take advantage of the WOT rom compensation graph or the extra hump in the full load graph above 0.9 bar.

In the above example the injector time was 11.9 milliseconds.

When compensation is checked by the ECU will it compare the available air pressure in the air cleaner with the actual pressure in the intake manifold. It will then scale the MAP sensor to read 1 bar when the value reaches the same value as the altitude sensor. (See the example below.)

The dark blue bar is the altitude value and the olive bar is the map value. Note how the MAP sensor is now reading 1 bar at 2000 meter.

Notice the difference in fuel due to the hump on the right hand side. Now the ECU still has the advantage of the graph profile even at high altitude.

Matrix Map - Normal Aspirated

The same system applies for the Matrix Map tuning as Matrix Graph tuning. They both operate the same way except that it is a matrix. Read the above section for explaining purposes.

Graph Map tuning - Boosted Engines

In this tuning method altitude compensation is disabled. The reason is that you are already using a MAP sensor and measuring the manifold pressure. Fuel and time is set accordingly and does not require additional altitude compensation.

TPS Matrix tuning

This is for normal aspirated racing engines where TPS versus RPM fueling is used. The altitude sensor becomes very important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel in ratio with altitude pressure differences to ensure a more accurate fuel mixture. For example, 10% less altitude pressure will result in 10% less fuel. The TPS versus RPM tuning is normally for engines with throttles or poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the reduced fuel so that when you descent to sea level, the fuel will be added.

Graph MAP with TPS Matrix tuning

This is for boosted racing engines where TPS versus RPM fueling is used with a boost pressure graph. The altitude sensor becomes very important as RPM versus TPS cannot compensate for altitude pressure differences. The ECU will adjust calculated fuel in ratio with altitude pressure differences to ensure a more accurate fuel mixture. For example, 10% less altitude pressure will result in 10% less fuel. This altitude compensation is done on the TPS matrix and then is compensated with the boost graph. The TPS matrix and boost graph tuning is normally for turbo engines with poor vacuum signal due to overlap camshafts. You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the reduced fuel so that when you descent to sea level, the fuel will be added. For detailed explanation see the Graph MAP and Matrix TPS Tuning section.

Timing Compensation

This feature is available and operates the same in all the tuning modes. If you don't want it to affect your timing, make the value 0.

Under Timing Settings set the Altitude Comp to 3 degrees per 1000 meter.

With timing compensation, the ECU will gradually add timing with increased altitude. The tuner can select the number of degrees' advance per 1000-meter increase in altitude. In this example we used 3 degrees which results in 1 degree for every 333 meters. Note: This will advance the calculated timing in total. There are no extra graphs to tune.

You need to activate the compensation values before tuning an engine. Even if you are inland at high altitude. The ECU will tune with the added degrees so that when you descent to sea level, the timing will be retarded.

Related Links

Altitude Sensor Wiring

Error Codes


Anti-Lag

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Anti Lag

The Anti-lag function will help to keep the boost pressure up when decelerating in corners on the race track. This function will use the launch control settings which will add fuel and retard the timing. The correct installation requires an EGR valve to bypass boost pressured air from the turbo before the throttle body, into the exhaust between the engine and turbo. The extra fuel with this air will ignite and the pressure will cause the turbo to spin creating boost. If the valve is not installed, then the min throttle setting must be opened slightly as to let air pass through the engine to burn the excess fuel. You may need to retard the timing further after TDC to prevent the engine from making power.

Note that some of the settings is only possible in Mercury2 Ver 3.5E firmware and onwards.

Settings

Enable the feature and set the minimum RPM setting. This RPM setting is the limit which will disable the function. If the engine revs fall below this value normal fuel economy cut will resume. During racing the driver will gear down keeping the engine revs high.

These two setting will activate the Anti-lag. When the boost pressure inside the intake manifold falls below the Vacuum fuel cut off value and the throttle position is below the TPS idle cut off value. When the boost pressure goes above the Vacuum fuel cut off the feature will be deactivated and normal functions will resume.

To disable the normal Econo Fuel Cut off function make this value higher than max RPM.

The launch settings Timing and Fuel Enrichment are also used for the Anti-lag feature. If it is activated, the timing will be retarded to the launch timing and the fuel will be enriched to improve burn pressure in the exhaust to spin the turbo.

For valve wiring and output connection on the ECU consult the specific firmware instructions and drawings.

Related Links

Error Codes


Coil Combination

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Combination

This block indicates the type of coil combinations that can be used with this firmware. Some firmware programs will allow the user to select between the different coil combinations on his engine. Note: If you have an intermediate or lower hardware class ECU, you may only use single coil with distributor. Most COP coil per cylinder engines are fired in wasted spark configuration and each coil will have its own driver. (See the wiring diagrams for connections.)

The combo files can be loaded into intermediate, advance or ultimate ECU's. In an intermediate ECU only the single Distributer option will be available. In an advance ECU the tuner my select between single and wasted spark. Ultimate also has Full Sequential spark on some firmware.

Note! On the Rotary programs the tuner may select between coil per cylinder or wasted spark. If the engine has the three coil setup where the leading spark plugs are on a wasted spark coil and the trailing are on coil per cylinder, this value is set on wasted spark. The two leading coil trigger wires must be tied together on the wasted spark coil negative. (See the connection diagrams). The charge time for the leadings will combine without overlapping and destroying the coil. Note that on high RPM's the leading spark will become weaker due to less time available to charge the coil. It has to charge twice per revolution.

Dual distributor
Two ignition coil outputs will be activated and phased to run a dual distributor system as found on the Lexus 1uz-fe and BMW V12,

Single distributor
Only one ignition coil output will be activated and phased to run a single distributor. Old school engines use these types.

Wasted spark coil pack
Coil outputs equal to half the number of cylinders will be activated to run a wasted spark ignition coil. This is a very popular choice on smaller engines.

Wasted spark coil per cylinder
Coil outputs equal to the amount of cylinders, will be activated to COP coil per cylinder. They are fired in wasted spark sequence.

Full Sequential coil per cylinder
Coil outputs equal to the amount of cylinders will be activated to coil per cylinder. They are fired in full sequential mode. This requires a home pulse from a cam signal. This is the preferred method for NOZ systems that has fuel in the intake manifold.

Full Sequential Spark
This feature can do full sequential spark on the gear type triggers. Note that there is a driver for each coil. Should you select wasted spark COP, then the coils are still wired one coil per driver and not externally paired like the Ver 3.5A firmware. With this selection, two pairs of drivers will be pulsed together. To sink the spark over the two revolutions, requires a setting of the Gear Teeth. This setting can now adjust twice as many teeth as the crank gear has. This will cover the 2 revolutions. So a 36-1 gear can be adjusted for 72 teeth. This will determine if it fires on compression or exhaust stroke. This is universal firmware and for some engines it may be on rev one, and other ones it may be on rev two after the cam pulse was read. It depends on where and how the cam teeth are situated.

Example:

If you use the 36-1 gear and your timing mark is on 14 then it could also be on 14+36=50. A simple way to test will be to select COP wasted spark.

Now crank and start the engine. You may need to advance the timing if it wants to backfire through the intake. Use gear teeth settings from 1 to 36. If it starts and idle, then calibrate timing with a timing light then save the map. Now select full sequential mode and save again.

Now start the engine. If it starts, then you have the sink pulse right. If not, add 36 to your current gear teeth value and save. Crank again and it should start now.

Note that this program needs to find the home signal first before it will start the engine. This will prevent backfire through the intake.

Note that full sequential and wasted spark systems has no performance difference as both types will have a full load on the coil so spark is the same energy. It is merely required for overlap cams and NOS systems Also make sure that firmware is available for your application.

Related Links

Ignition Coil Wiring


Coil Driver Selection

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Timing Settings >

Coil Driver Selection

This block selects the type of coil driver used by the ECU. It is note used in Orion as it has Pos and Negative drivers on the board. It will be blanked out.

Note that the coils must get their power from the ECU power relay. At startup this relay is kept off till the ECU can read the map to see what type is selected. Having this wrong will destroy the drivers or the coils.

Related Links

Ignition Coil Wiring


Connecting the ECU for the first time

Now you can proceed with the following steps. If any steps do not correlate with the ECU operation, stop and look for the faults. Ensure that the ECU is earthed!!! Notice that there may be steps not applicable to certain ECU's. Then you may skip them.

1. Remove all the fuses. If it is an easy install harness with a common fuse on the main lead then disconnect the coils, injectors, fuel pump etc. from the power relay.

2. Ensure that the Jumper Settings are correct for that ECU.

3. Connect only the input connector P1 and P4 connector leaving the output connectors open. Switch the Ignition on. Do not start the engine. The yellow LED on the ECU must come on. Also the blue LED on the idle stepper control unit must come on, if it is installed. If the yellow LED does not come on switch the ECU off immediately as there may be a short on the 5 Volt output that will damage the ECU in time. Note: On Mercury2 the other 4 LED's are connected to drivers and do not come on with trigger signals.

4. Now switch the Ignition off and connect the Laptop with the USB cable to the unit. Switch the ignition on. Start the PC software and connect to the ECU. The engine data like the water and air temperature sensors should be displayed. It should read more or less correctly for the cold engine.

5. Go through the setup pages one by one and ensure that all the settings are correct for this engine.

6. Ensure that the crank and cam angle sensors from the distributor or crank are set up correctly. Also their angle level selection must be rising or falling edge.

7. Check the Rotor Fazing if you have a distributor system. This will make electrical interference on the ECU and Laptop if it is set incorrectly.

8. Calibrate the TPS and Map sensors and save the calibration as described under active sensors.

9. Set the maximum RPM range and Map sensor type and range.

10. The Map sensor value should be reading the atmospheric pressure of your region. Check the Altitude chart for the correct pressure in your area.

11. Make sure the Test function next to the crank sensor is on.

12 You may now crank the engine without the other connectors. Look at the RPM signal on the timing map. It should show 200 to 300 RPM constantly. If it shows erratic and runs wild, do not proceed. First find the fault. It must be constant with no errors. The vacuum bar should move slightly to the left of the graph while cranking at closed throttle.

13. Look if any error code is displayed at the bottom. If there are errors remedy the fault condition.

14. Save the data to the ECU if it has been changed.

15. Switch the ignition off and connect the other connectors.

16. Remove all the fuses. If it is an easy install harness disconnect the power on the injectors, coils fuel pump etc. Switch the ignition on. The relays will come on for three seconds then switch off again. If not, check the relay wire according to the drawing. If you have electronic relays, check that the LED on them must come on. Note on Mercury2 there are 3 relays with a free-wheel diode on pin 85 and 86.

17. Switch the ignition off and insert the fuel pump fuse. Start with 5A. If it blows check the wiring and try 7.5A as some pumps draw more power than others. Do not go to larger amp fuses as there may be a short somewhere.

18. Switch the ignition on, the fuel pump must start for three seconds and switch off.

19. Switch the ignition off and insert the coil fuses of 5A. If it blows check the wiring.

20. Now crank the engine with a timing light and check if the spark timing is in the 10°BTDC region. If not see the Calibrate Timing chapter for the correct setup. Do not attempt to start if the timing is not right or erratic. You may need to loosen the plug wire and make a small gap so that the timing light picks up the pulse of the spark plug. For coils that are bolted onto the plug, try using the trigger wire from the ECU. If this does not work, take a separate wire and wound it three times around the inductive pickup of the timing light and then insert this wire between the trigger wire and the coil input. This will amplify the signal three times so that it will trigger the timing light. Set the timing light to zero timing as wasted spark systems read double the degrees. This means if the timing light is adjusted to 20 degrees it is actually 10 degrees timing on the engine.

21. Switch the ignition off and insert the injector fuses of 5A. If it blows check the wiring.

22. Crank the engine. It should start. If the engine backfires or misses stop and do some checks. See the Trouble Shooting chapter to guide as to what the symptoms may be.

23. If your setup is correct the engine should start and idle smoothly.

24. Make sure the RPM is constant before revving the engine. If it jumps more than 300 rpm intervals, recheck the angle sensor's polarity. It must be steady. If it was error free during cranking without coils, it means the interference is now generated by the coils. See the precautions section on wiring tips.

25. Look at the exhaust. If there is black smoke, it is very rich. Try leaning it out on the water temp graph by lowering the dot closest to the yellow bar. The bar is interpolated.

26. Once the engine idles, calibrate the timing so that the Timing value on the software and the timing light on the engine is on the same degrees.

27. During the heating up faze, blip the accelerator from time to time. If the engine has a flat spot it may be lean and need some more fuel. Adjust the Fuel Graph till the flat spot reduces.

28. The blue LED in the idle control should go off once the target RPM is reached. If it keeps on flashing, then the ECU is trying to control the idling but nothing happens. It means the fault is on the idle side or motor. It may be a wiring fault or sticky stepper motor. It may also be a blocked airway or the throttle opening is too large. Remember for every 15% of enrichment on the water correction graph, the ECU will raise the set RPM's by 100.

29. As the engine heats up, the water sensor value must increase. Adjust the mixture on the water graph or by lowering the Fuel Graph till the engine is at normal temperature.

30. The water graph should now be around 85°C with no fuel enrichment. If it is not, you can calibrate the water sensor slightly on the setup page. The engine should rev up smoothly. If it has a flat spot it requires more fuel. Increase the Fuel Graph slightly till the flat spot is nearly gone. Also check that the timing is not the result of the flat spot. Check with the timing light that the timing increases as the software indicates.

31. Let the engine idle and adjust the Fuel Graph till it idles smoothly. Always try to make the mixture as lean as possible because it is difficult to see when it is too rich.

32. Save the data to the ECU. Also save a copy to the Laptop at this stage. The car may stutter and die. Restart again and proceed with tuning.


Crank and Cam angle sensors

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

Crank and Cam angle Sensors

These inputs are required by the ECU to determine exact crank and cams angles so that spark and injection timing can be calculated. VVTI cams can be positioned by the ECU. Their cam signals will be compared to the crank signal to determine the right position for loop control. Version 3.5 can only do open loop cam control. The firmware may blank out or force the signals in a state depending on the specific engine.

Crank (TDC)

The crank angle sensor is used by the ECU to determine exact crank degrees as it rotates. This sensor could be situated on the crank or in a distributor or encoder called a CAS. If it is situated on the cam gear like a distributor, then it will have enough pulses for 2 revolutions to represent the crank signal. For example, Toyota uses what we called a 24+TDC pattern. If the sensor is on the crank there will be 12 teeth. If it is on the cam there will be 24 teeth. If a pulse is generated on a 36-1 gear on a crank for example, then the missing tooth is used as a TDC pulse. A TDC pulse represent a signal that comes once every revolution. It is not necessary at TDC of the engine. In a distributor it may have a TDC pulse or Home pulse. If a pulse come once in two revolutions it is called a a home pulse.

With Firmware Ver 3.5E onwards, the test function is used during crank and cam sensor tests. When this bit is set there will be no fuel injected. With the new Cam Home teeth sink this helps to set up cams with different teeth for different engines. If the sensors are read incorrectly, or the ECU has the wrong firmware, the software will show errors in the bottom status bar. These Errors have numbers indicating a fault code and description. This is a very useful feature for first time startup after the installation is done. See Setting Crank Sensor Timing below. See the next section.

On older firmware, the engine will start after the second revolution if there are no errors. Note. After setup put the test faction off. It may bother at high RPM's due to the calculations to determine correct patterns.

Cam (Home)

The cam angle sensor will always be situated on a cam shaft. It could be a lone sensor in the valve cover or in a distributor. This signal only came with later models when full sequential injection was introduced. Some distributors like Nissan and Toyota had both sensors in the distributor. The cam signal will give a unique pattern over two revolutions, allowing the ECU to detect which revolution is the firing stroke. This signal could be one pulse or a number of pulses. The ECU can compare it with the crank signal pattern and determine firing stroke.

This feature is incorporated in the new version 3.5E firmware to determine a home pulse position from different cam signals. Each manufacture uses a different cam pattern. One of the cam sensors must be connected to the ECU and selected. During setup, start with teeth 1 and crank the engine. It should show missing home pulses on the error codes. Increase the value and press C for clear after each adjustment. If the error stops appearing, at for example 4, then continue increasing till you see the error again. If the value is 10, for example, then set the teeth setting in the average of 7 teeth. Now the ECU knows the difference in stroke 1 and stroke 3 of the engine. One will have a pulse within 7 teeth after the slot and 3 will have no pulses. Note that Full Sequential Injection or Full Sequential Spark must be on to produce errors. Also not that Full Sequential Injection is still possible without a Cam (Home) pulse but not Spark. You need to have the Cam sensor setup correctly for spark.

Cam Control Selection

This feature will reduce the number of firmware files required for different engines. Previous version was split in a normal engine or specific VVTI engines. VVTI consists of 2 cam control settings for inlet or exhaust cams. Control is still open loop so for V engines the 2 Cam solenoids are connected on the same driver. It requires only 1 x 3Amp diode to be installed. No input Cam sensors are required in open loop control. Also note that cam control will be 25% duty cycle when Off and 75% duty cycle when On. If your engine requires different control parameters, then you need to load the engine specific firmware.

First you need to select 1 or 2 cam outputs. Note that the software will refresh the setup data as these drivers are shared with GP output drivers. If you don't use cam outputs, then un select them to free up the GP drivers.

Then the cam control block will become visible also indicating which drivers are used for which coil. If no drivers are visible, then the cam selections are not selected.

Take note that Cam1 is used Cyl1 in V engines or Intake Cam. Cam2 is used for the opposite cam than Cam1 or the Exhaust Cam.

Should the engine have an intake Flap then use the V-Tech feature on GP2 for it as it has a TPS limit as well.

Dedicated firmware like the Lexus VVTI will use the Intake block in the VVTI settings block.

Setting Crank Sensor Timing

This block is used to indicate to the ECU where the exact TDC point is on the crank. It works differently for the different style of crank angle sensors. These settings will allow the ECU to synchronize software timing with the actual spark timing on the engine.

On gear type trigger wheels, the Gear Teeth will indicate to the ECU the amount of teeth between the slot and TDC. The Timing Sensor will do finer adjustments to precisely set the timing in-between the teeth.

The example below explains, if you put the engine of a 36-1 trigger wheel on TDC, count the number of teeth from the slot anti clockwise to the pickup sensor plus the one just past the sensor. Put this value in [image] . Then you may adjust the Timing Sensor [image] from 0 to 9 degrees to precisely align the timing light to the tuning software. The example below should work out as Gear teeth 7 Timing Sensor 6 as the last edge of the teeth is in the center of the sensor.

With the engine running match the timing as close as possible by using the Gear teeth setting. For example; the ECU software indicates 10° advance on the real-time bar, but you see 12° advance on the engine. The Timing sensor °BTDC will now be adjusted to accommodate the difference which is 2. With the Timing sensor adjusted the Timing light and the ECU should now be matched.

Important!
When using an Advance / Retard timing light on a wasted spark system the timing light will read double the timing of the engine. So if the timing light reads 20° advance, the actual ignition timing is 10° advance. If you are not sure rather put the timing light on zero degrees and use the pulley marks. Remember that the COP systems are still fired in wasted spark sequence.

On single event triggers you will find that gear teeth are not adjustable only the degrees between the triggers. On a 4Cyl Nissan for example the timing sensor may be adjusted to 180 degrees.

Related Links

Crank and Cam angle Sensors

Error Codes


Device

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

Device

Assign Device

For your convenience Assign Device is built into the Hyperspace Tuning Software. If a system is upgraded or activated on the Portal, the customer only need to have internet connection to activate his system. When you click Assig and there is an active allocation on the Portal, this message will appear:

Click Yes and the device will be activated.

If there is no allocation change on the Portal, then the following message will appear:


Dual Map Switch

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Dual MAP Switch

The Dual MAP selection switch is a normal on/off switch that is connected to the ECU. When it is on it will connect the input to earth, this indicates to the ECU which map is required. Note: The ECU only tests this switch at startup and not on the fly. The reason is that all the maps have to be uploaded from flash memory and then new settings must be implemented. So the ECU must be switched off and on again to change to the alternate map. The other reason is that the Map switch is used as a flat shift input during riding.

Wiring

The Mercury2 ECU does not have a dedicated input for the Dual MAP selection switch. It can be selected on one of three inputs if any of them have not been used by the tuner. The inputs are Cam 2, fuel pressure sensor input and altitude sensor input. Cam2 does not always function correctly due to the capacitor isolator. Try and keep the wire to the switch as short as possible. The dashboard on/off switch selects which map will be used. If not connected it will default to Map 1 at startup. If the switch is on, it will be Map 2.

Altitude Sensor

The 6-way connector pin 2 which is the altitude input. Open is map 1 and close is map 2. This is the preferred sensor to use.

Fuel Pressure Sensor

The 6-way connector pin 4 which is the fuel pressure input. Note that here a 1 K pull-up resistor is required to 5 volts. Do not connect it to 12 volts. It will damage the ECU. Open is map 1 and close is map 2.

Cam 2 input

The 12-way connector pin 5 which is the cam 2 sensor input. Open is map 1 and close. It may require a 2K pull-up to the ignition power of the ECU.

Related Links

Software Setup

Error Codes


ECU Information

The device information screen displays vital information regarding the Spitronics ECU that has been connected. Note: Firmware is the program that is loaded into the ECU to make the electronics operate in a specific way. This is normally a HEX file which is loaded into the product by a USB debug programmer. Software is the tuning interface that runs on the computer and it is used to tune the product's parameters.

Serial Number

There is a unique number assigned to each product. It is saved on maps and recognized by the database on its status etc.

Hardware release

Displays which type of device has been connected to the software. In this case and a Mercury2 Engine Control Unit.

Hardware class

Displays the Hardware class of the product that has been connected to the software. The hardware class will determine which firmware can be uploaded onto the product. This feature allows the unit to open certain or all functions of the electronics. The amount of features determines the price of the unit. This feature can be changed over on the internet to allow for remote upgrades of the unit. The hardware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

7. Commercial

8. Racing

Product Release

The product release section displays the function of the device connected. E.g. Engine control unit, Transmission Control unit etc. The Mercury2 hardware can be used with different firmware to control different applications like ECU, ECU, TXW etc. It is used by the software to identify if the correct firmware is connected.

Firmware Class

Displays the class of the firmware that has been downloaded onto the device. Each firmware program supplied will have a certain class according to the features used. You may load any firmware for a specific product into the unit as long as the firmware class does not outrank the hardware class. The firmware classes are as follows:

1. Micro

2. Basic

3. Standard

4. Intermediate

5. Advance

6. Ultimate

7. Commercial

8. Racing

Program Number

Displays the current firmware program that has been downloaded onto the device. The program is identified by a program number and description. See the firmware list of programs for the ECU.

Protocol Version

Displays the current protocol version number between the firmware and the PC software. This must be the same for the hardware and software to communicate. The firmware will indicate to the software which version of the program to open.

Firmware Version

Displays the sub version of the current firmware that has been downloaded into the device. It is an alphabetic number and has no effect on the protocol version used. This version is used when corrective firmware is released. Always use the latest version available.

Program Restriction

Displays the Firmware number which the ECU is locked to. If it says No Restriction it means that any ECU program for that ECU can be programmed into the unit, provided it does not outrank the hardware class. If there is a number, it means the ECU is locked to a specific program and only that program may be loaded onto the unit. This is for sponsored or specials which was approved by the manufacturer.

On the top bar you will find the product software version. Note that version 3.5 will be standard with the Firmware version 3.5.

The first 3 is version 3 PC Software.

The second 5 is the protocol version between the PC software and the firmware. When new features are programmed into the unit, this protocol version will change in the PC software and in the Firmware.

The .5 at the end is a sub version and has no effect on the firmware. This version will indicate corrective or improved PC software. Always use the latest version available.


Error Codes

The software has Error, Warning and Information codes displayed in the Status tool bar at the bottom. These codes will help the tuner to find problems during startup and tuning, also to see if the device is functioning correctly. Some of the functions on the device will indicate to the tuner what is happening. He can then see if these functions are operating correctly. Error codes for ECU, TCU, TxW etc. are sharing the same number system to prevent confusion when support is given.

The codes are displayed at the right hand bottom corner. The code list [image] will display a list of accumulating codes so that the tuner can see what the codes were and in which order. The bottom indication will only show the last code. Also note that a code is only updated once, until it disappears and when it appears again the code will be logged again. This is to prevent the list from growing too long with useless information. This does not apply to the angle sensor error codes during cranking. They will increment the counter as each one occurs.

Press the ''C'' key to clear the error codes. This is handy as you will not be able to see is the code is still present or if it was only listed once.

Note: If you crank an engine and it does not start, there will be one error code, Error code 6 for Emergency Engine Shutdown. This is normal and not an actually an error. The ECU was expecting more trigger pulses but pulses were stopped. Therefore, the ECU goes into a safe shutdown of coils and injectors etc. A tip, press C then crank the engine. There should be no error and it will read 200 RPM's on the rev counter until the key is released.

The blue codes are for crank and cam related sensor errors. This is normally the crank and cam angle signals that makes the ECU operate correctly. The red codes are warnings like over temperature etc. The green codes are for information of functions that were activated. The colors are only for explanation in this document.

The following list explain the different error codes

1 - Missing crank pulses - The crank sensor senses too little teeth per revolution

2 - Too many crank pulses or spikes - The crank sensor senses too many teeth per revolution

3 - Incorrect crank TDC slot - The crank sensor did not sense a TDC slot. (Maybe incorrect wiring)

4 - Missing TDC pulse - The TDC pulse is not present

5 - Missing home pulse - The Home pulse is not present

6 - Emergency engine shutdown - Safe shutdown of engine due to lack of or incorrect signals

7 - Fuel pressure safety cut-out - The fuel pressure sensor low limit has been reached

8 - Economy fuel cut-out - The fuel economy cut is implemented

9 - RPM limiter reached - The engine RPM limiter has been exceeded

10 - Max boost limiter reached - The boost pressure limit has been exceeded

11 - Water hot/cold temperature limiter reached - The water temperature limit has been exceeded

12 - Launch limiter reached - The launch limit RPM has been exceeded

13 - Lambda control limits reached - The lambda control limit has been reached

14 - Battery low voltage limit reached - The battery voltage falls below a critical limit

15 - Selection refreshed. Confirm driver placement - The ECU changed driver output configurations

16 - Timing retarded - Ignition timing is retarded during an automatic transmission shift procedure

17 - Flood control injector cut-out - Fuel is cut by injectors during cranking when the throttle is fully opened

18 - Flat-shift activated - Ignition or fuel is cut for a moment to enhance gearshift for racing engines

19 - Ignition power switched off - Ignition key power is switched off

20 - Sponsor counter depleted - The sponsor counter is depleted for sponsored ECU's

21 - Anti-Lag activated - Anti-Lag is activated on the Launch features

22 - 2Hardware Class don't support this feature - Incorrect firmware loaded

23 - 2Speed Limit Reached - Speed Limit was exceeded

24 - 2Bootloader Not Present - This indicate if the BootLoader firmware was not loaded in the newer products

25 - Overcharge Limit Reached - This error will come when the charge time plus graph times exceed the maximum charge times

26 - 2Test Mode is Selected - This is used for calibrating TxW firmware


File Menu

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

File Menu

This menu is to open the different saved maps or to save a map from a device onto the pc. The software will save periodic files in Auto Saves folder and also when you do a Device save it will make a copy in the Device Save folder.

Open is to open Map files offline

Open Recent is to open the last previous map files

Auto Saves is to open the last auto saved files

Device Saves is to open the last device saved files

Save is to save Map files on the PC

Save As is rename Map files on the PC

Related Links

Data Maps


Flat Shift

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

Flat Shift

This feature will momentarily cut the fuel or spark or both for a pre-set time during shifting. This will slow the engine RPM momentarily to ease shifting process in the gearbox. It is initiated by a negative going transition pulse of a switch, or electronics or load cell that will give an earth contact. The switch is combined with movement of the gear lever. Note: This feature is only available on specific firmware. Ask your dealer on it before you buy.

Settings

The following settings is done to activate this feature. On Mercury2 the input is shared with the dual map input. This means dual map will not be able to operate on the fly. It will load a Map only at start up. Then the input will be used for a flat shift input. After that it is used as the flat shift input during run conditions. Normally an open switch will mean Map 1 is loaded when the ECU starts. Then if this contact is earthed the flat shift delay will be activated. If you want to start in Map 2 hold the switch in and put the ignition on. Then Map 2 is implemented, from there on the flat shift work as normal.

A delay can be adjusted from 0 to 350 milliseconds. Zero will deactivate the feature. Zero will disable the flat shift feature. This feature is disabled at RPM below 2000.

You may select the type of engine cut which is the same as the normal rev limiter settings. Soft will cut only fuel, Hard will cut fuel and spark and Spark only speaks for itself.

Related Links

Dual Map Switch Wiring

Error Codes


Fuel Sensor

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Fuel Pressure

The Orion ECU has the ability to control fuel pressure by speed controlling the fuel pump with Pulse Width Modulation (PWM). This is achieved by pulsing the driver at 300 Hz with a required duty cycle and then measuring the actual fuel pressure with an electronic pressure sensor. The duty cycle is then adjusted to reach the required fuel pressure in loop control. At startup for the first time, disconnect the P2 and P3 connecters till you have set the control up properly. Reason is that the ECU may start the pump at full pressure and damage the fuel lines. Note: this will only be selected firmware as some of the other features will be sacrificed to make drivers available. Ask your dealer on this feature before you buy.

The advantage of this feature is that the ECU can compensate for pressure fluctuations as this will vary the fuel amount going through the injector. It also eliminates the need for a fuel pressure regulator and return line to the tank. It can also compensate for turbo engines to increase fuel pressure above manifold pressures.

There are a few requirements to ensure stability of the fuel pressure. The fuel pressure sensor must be mounted higher than the fuel line where it is connected. The pipe must go downwards from the sensor to the fuel line. This will ensure a pocket of air between the sensor and fuel which will have a damper effect and isolate the sensor from the fuel to enhance reliability. Use high quality fuel hoses and clamp them properly to the sensor and fuel line. Note: The ECU has a built-in shutdown protection should the pipe come off and pressure signal falls below a certain level. There will however be petrol spillage as the pump has momentum and the one-way valve will prevent the fuel in the rail to return to the tank. This fuel is under pressure so it will spill at the severed line. Do not mount the fuel pump close to the exhaust as it will heat up and the fuel in the pump will percolate. The air pockets will cause the cavitation in the pump resulting in erratic pressure. The air bubbles can only be pushed through the injectors which also result in incorrect mixtures.

To use this feature, proceed with the following steps. Start by switching the sensor on. Click on show graph.

Click the calibrate [image] button and type in 100. Click OK.

If you have an accurate fuel pressure gauge or a different fuel pressure sensor you may calibrate it with this value. It is a percentage correction which allows for range calibration only. That means calibration is accurate at the working pressure. The sensors supplied are calibrated according to the manufacturer signal specs.

Now set up the following parameters.

Fuel sensor value

Type in the Fuel sensor value that you are using. They come in 4 Bar MAP, 5.5 Bar Differential pressure, and 7 Bar MAP. The most popular sensor is the 5.5Bar DP. Note: The low pressure side of the DP sensor must be tied to the intake manifold pressure just as a normal fuel pressure regulator. This sensor will automatically compensate for the intake manifold pressure.

The fuel pressure real-time gage will also be scaled to this Fuel Sensor value setting.

Fuel Control sensitivity

This setting will adjust how the ECU will react to pressure changes. Fast or slow reaction will control the pressure range. '1' is for the fastest reaction. If it is set too fast the fuel pressure will become erratic. Select the fastest value which will stabilize the pressure against hunting.

Fuel Safety Pressure

This setting is the protection feature that will cut the fuel pump in case of fuel line breakage. Especially to the sensor as this is a thin line. Use a 1 Bar setting.

Fuel Pump Low

This setting is to control the minimum duty cycle of the pump. If it is too low the pump will stop start and make the fuel erratic. Some fuel pumps need to do a minimum RPM or their veins will not deploy to pump fuel. If this is the case the pump will start to make funny noises and the fuel pressure becomes erratic. Sometimes it helps to turn the pump position so that the veins protrude downwards. Set the minimum duty cycle so that the pump runs smooth at lowest pressure. If it is too high the pump will not be able to control at the lowest pressure. A value out of 254 will make up 100% of duty cycle, it means that 127 will be 50% duty cycle.

Fuel Pump High

This setting is to control the maximum duty cycle of the pump. The high setting will limit the pump at a certain pressure. This is handy to prevent the pump from over pressure on the thinner fuel lines to the sensor. Make sure that the pump can supply the right pressure at full load high RPM. Always go for the lowest setting and keep a note on the fuel pressure at high load.

Driver Output

This setting will indicate to the installer which output is dedicated to the pump. This output must be positive and is used with the Spitronics Electronic relay. Make sure on the wiring connections.

Settings the graphs

Click the page button [image] tab.

Fuel Setpoint Graph - Manifold Pressure (Bar)

There are different ways to set-up this control system. With the 4 & 7 Bar MAP, (Mean Absolute Pressure) sensors, you need to compensate on the graph for manifold pressure fluctuations. The reason is that the Map sensor does not compensate for manifold pressure like a fuel pressure regulator. The fuel pressure needs to be adjusted with manifold pressure to keep a constant fuel pressure over the injectors. These settings in the graph below will keep a constant pressure of 2.5 Bar over the injector through the manifold pressure range.

For the 5.5 Differential pressure sensor the compensation is automatic as the open line is connected to the intake manifold. These settings in the graph below will keep a constant pressure of 2.5 Bar over the injector through the manifold pressure range. If you leave the line open to atmospheric pressure it will result in fuel pressure variations with altitude and will influence tuning of the engine.

For Turbo engines with the 7 bar Map sensor the graph below will keep a constant pressure of 2.5 Bar over the injector through the manifold pressure range. Note: The graph below how the pressure increases to 5.5 Bar at 2 Bar boost pressure.

For the 5.5 DP sensor the compensation graph will be flat as the DP graph above. Even if the total pressure is above 5.5 bar the DP sensor will only see 2.5 bar over it. (Fuel pressure minus boost pressure).

Fuel Pressure Graph - Fuel Compensation %

The Fuel pressure graph will allow the ECU to compensate for fuel pressure variations during blip conditions when the injectors suddenly require more fuel. The fuel pressure signal will react faster than the pump can be sped up or slow down at due to mechanical delays. Here the injector opening times will be manipulated in order to add or reduce fuel for pressure variation. To set this graph, start with a flat line.

Load the engine at light cruise settings like 2000 RPM and say 20% throttle. This may be varied as the type of engine may be smother at different RPM's. Now adjust the fuel mix to be in stoic area. Now increase the fuel pressure by half a bar increment. Do not go too high as the fuel lines may burst. Every time adjust the graph lower to maintain the same AFR mixtures. Now reduce the pressure and increase the graph again to stay in the right mixtures. Put the pressure settings back to normal.

Now if fuel pressures vary, the injector times will be compensated for and the AFR will remain constant. These graphs are interpolated.

Related Links

Fuel Supply

Error Codes


Help Menu

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen > Top Toolbar >

Help Menu

This menu holds information. About will indicate all the release fixes and changes between versions released. It also unlocks the embedded manual and will save a copy of it in the Hyperspace folder where the software was saved initially.

Here all the keyboard keys for manipulating features and tuning values are explained. You may change the way they work and also set up alternate keys that would make tuning better.

About

Information on version changes of the software.

Manual

A copy of the software manual is imbedded in the software.


Idle Control

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Idle Control

The ECU has the feature to control different types of idle motors found on an engine. Before adjusting the idle control settings, you need to select which type of valve or stepper is on the engine. Note: The stepper types idle motor (4 to 6 wire), require the external electronic driver. Also note that the electronic unit differs between the 4 Wire bipolar type motor and the 6 Wire common supply type motor.

Type Selection

The Type Selection can select between the two-wire spring-loaded Idle Valve, the three-wire spring or non-spring loaded Dual idle valve, the Bipolar Stepper motor or common supply Stepper motor. Stepper motors do not use the Low Limit and High Limit settings as they keep their position when there is no signal present. If there is no idle control select 'Not' used to free up valuable processor time and general purpose outputs.

Idle Valve

Two wire spring loaded idle valve only use one output from the ECU.

Dual Idle Valve

Three spring or non-spring loaded idle valve two outputs from the ECU.

Stepper Motor

Four or Six wire idle valves operate with a Spitronics Type 1 or Type 2 stepper motor controller, use one output from the ECU.

Settings

Drivers

This indication will show the installer which wires to connect on which outputs of the ECU. Driver 2 is only used for the dual valve to close. Note that positive and negative drivers may be used for idle control. If a valve is used, then make sure the Diode across it is wired correctly. (See the wiring diagrams and general purpose priority spreadsheet for correct installation.)

RPM

This setting is the target RPM's when the engine is on running temperature. When it is cold the ECU will automatically increase engine RPM's with up to 300 RPM's. This is calculated according to fuel enrichment on the water compensation map. Every 15% will increase 100 RPM on the Idle control.

Start %

This setting is used to increase the air intake when the engine is started hot or cold. The ECU will open the idle valve with this %. Note that on stepper controls it will activate 25% every time the key is switched on. If you don't start it, it may idle high at first then come back to idle target.

Response Time Up

This setting will determine the rate at which the valve opens when the actual RPM's fall below the set point in Idle RPM. The further the RPM fall below the set point, the faster the ECU will open the valve to let in more air. Low values will create a faster response time and high values will create a slower response time. This setting must prevent the engine from stalling when you switch the air conditioner on, or put it in drive.

Response Time Down

This setting will determine the rate at which the valve closes when the actual RPM's go above the set point in Idle RPM. The further the RPM goes above the set point, the faster the ECU will close the valve to decrease airflow into the engine. This value is set higher than the Response Up value, to eliminate hunting. Low values will create a faster response time and high values will create a slower response time. This setting must bring fast idling down as fast as possible without hunting the engine.

Low Limit duty cycle

This setting will preload the solenoid against the spring in the idle valve so that the valve starts to open immediately when the ECU starts increasing the value. It can also be used to set minimum idling RPM for throttle valves that closes completely. To set the value start with a larger % and decrease until the desired idling RPM is reached.

High Limit duty cycle

This setting is used to limit the maximum idle RPM's. No need to open the valve more than necessary. It also allows for the use of large valves in smaller engines. Make sure that when the engine is cold, it can still lift the RPM up to approx. 1500 RPM. This can be tested by entering a large Idle RPM value and limit the ECU from increasing it too high.

TPS Idle Cutoff %

This value is used to disable the idle control when the driver touches the throttle. The reason is that the ECU must know when not to control idle as the driver may need just a minimal amount of revs with slight throttle.

Related Links

Idle Control Wiring

Idle Control Tuning

Error Codes


Injection Type

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Injection Type

This setting will allow different methods of fuel injection. The firmware in the ECU will blank out the methods that are not adjustable. In some firmware a refresh will be forced to reshuffle GP outputs or cancel an illegal setting.

Batch Injection

This method all the injectors are pulse at the same time. It is not good practice as the cylinders does not get the fuel under the same conditions or injection angle, and is poor on power and economy. Spitronics programs does not use the feature unless for specific tasks.

Split Batch Injection

This method will pulse two sets of injectors 180° apart from each other. It is used where the trigger has even pulses and no cam signal is present. It is used on the standard systems where budget is of importance. For a 4 cylinder, the injectors are paired so that each cylinder gets fuel under the same condition or injection angle.

Split Sequential Injection

This method will pulse two injectors per driver together for the two cylinders that move at the same crank degrees. It will follow the sequence of the firing order. There may be 2 to 6 drivers in the sequence. The injector will pulse once per revolution and the injection time on the software will be divided in two. With other words for each revolution only half the calculated fuel is injected. This method does not require a home pulse and is the popular choice. There is very little difference in power and economy to a full sequential system.

Full Sequential Injection

This method will pulse one injector per driver in the same sequence as the firing order. The injector will pulse once every two revolutions and it will inject all the fuel in one squirt. Here a cam pulse or home signal is required to sink the injectors with a certain stroke one the engine. If there is no home pulse it will still do full sequential injection, but stroke phasing may vary from start to start. Note that an engine is normally started in split sequential mode and then goes over to full sequential after 500 rpm is reached. This helps for faster starting. This feature is mostly for ECU's with enough drivers for injectors. make sure if firmware is available for your aplication before you buy.

Related Links

Injector Wiring


Injector Trim

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Injector Trim

This feature allows the tuner to trim each injector individually for the ultimate performance. This is done by individual Lambda or EGT sensor on the exhaust runner to measure individual air fuel ratios. It is only selected Mercury2 firmware that has this feature.

Trim Count

This is the number of drivers selected by the tuner. The Mercury2 has 8 injector drivers and can work full sequential for 8 cylinders. At can also run duel injectors full sequential for 4 cylinder engines. A setting of zero will disable this feature.

These tuning blocks allow the tuner to adjust the register from 90.0 to 110.0 % for each cylinder. Adjustments can be made in 0.5 % resolutions.

This block is to clear all the registers to 100.0 % to start with. First tune the engine is as good as possible, then do minor changes here to calibrate the injectors. A tip is to use the middle average of the injectors ant tune to that. Example if the injectors differ by 10 % between high and low. Then use the middle vale and some will be 5% high and some 5% low.

Related Links

Tuning

Injector Wiring


Launch Control

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

Launch

The Launch control feature can be used for Launch control and Anti-lag. It could also be used to retard the timing during transmission shifts. But not for both. The driver will have to set it up for one of them. These features came later than the hardware so plans were made to accommodate them in this hardware. Note: This feature is only available on specific firmware. ask your dealer on it before you buy.

See the sub folders for explanations.


Launch

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings > Launch Control >

Launch Control

· The Launch Control feature will spin a turbo to higher RPM's while the vehicle is stationary. This is done by adjusting the RPM limiter, enrich the fuel mixture and retard the ignition timing. This will create boost pressure so that when the driver launches, there will be no turbo lag.

· Launch Recover Delay will bring the launch limiter slowly back to normal revs. This will improve traction during pull off.

· It will also activate RapidFire for audible limiters of choice. This feature will keep the engine on power while spinning and make exhaust sounds like a machine gun.

Note that the last 2 items are only available in Mercury2 Ver 3.5E firmware and onwards.

Launch

The Launch parameters are implemented in different ways to suit the driver. These Launch settings will only be implemented the moment engine revs reaches Launch revs minus 500RPM. Example: If the limiter is set as 5000RPM then the timing and fuel compensation will only start above 4500RPM. This will help the engine to rev up to launch effortlessly. Should the engine revs go above 5000RPM the fuel or spark will be cut to limit the engine from over revving. If the engine limiter is set to Soft or Hard Cut, then fuel will be cut. If it is set to Spark Only, then the RapidFire feature will come in place and only spark will be cut.

See the Product Hardware description for different wiring options for the different activation methods like Clutch or TPS 90% options. Note: Older Version of firmware the Timing can be retarded to TDC only.

There are 2 methods to implement the Launch feature. One is with hardwire switches and the other, semi-automatic. For both methods set the Tuning POT selection on Launch.

Method 1 (Switch or Clutch and switch)

Select Clutch and set the desired RPM limit. This is variable depending on the grip at the racing track. Timing is set from -30 to 10 degrees depending of the turbo characteristics. Fuel enrichment is set from 10 to 20% to create more burning fuel in the exhaust which will spin the turbo.

Now to activate this feature. If you have only wired the dashboard switch you only need to press the switch and press the accelerator pedal. The moment you need to launch just release the switch with the clutch.

If you have wired the dashboard switch and the clutch pedal switch with resistor combination, then press the clutch in to make the clutch pedal switch, press the dashboard switch once and launch is activated. No need to keep the dashboard switch pressed. Press the accelerator. The launch parameters will be activated. The moment the clutch is released the launch switch will break and launch is deactivated. To activate this feature again you need to repeat the procedure. This feature lets the driver concentrate on his pull-off and free his hands for other tasks.

Method 2 (TPS 90% - Semi-Automatic)

With this method there is no need for a clutch pedal switch. You do however need to install the dashboard On/Off switch or the Tuning POT. This method requires the driver not to press the pedal over 90% during launch activation. Pressing it deeper will deactivate launch to normal settings. The driver may need to practice this. He may also use a GP output to switch a light on at 80% TPS to ensure that he does not press it too deep. Both methods require the engine to rev lower than 3000RPM before activating the launch feature for the next launch. This will prevent the feature from activating during gear shift.

With the Dash Board switch do the following settings:

Select TPS 90% under Launch Deactivation. Set the desired RPM limit Timing and Fuel Enrichment.

Now to activate this feature, put the switch to 'On' position. Now press the accelerator no more than 90%. The launch parameters will spin the turbo. When the driver releases the clutch he also presses the accelerator 100%. This will deactivate the launch feature. To activate this feature again, the revs must be lower than 3000RPM. Note: To deactivate this feature put switch off

With the tuning POT do the following settings:

Set the desired RPM limit to 0. This will indicate to the ECU that it must use the POT value to calculate a RPM limit value. Set the desired Timing and Fuel Enrichment.

Now set the POT register to the maximum allowable launch RPM. Example: 55 means 5500RPM. This will set the POT maximum clockwise value as 5500 RPM.

This feature is useful as different race tracks give better traction and allows for higher launch PRM's. To activate this feature, the driver simply presses the clutch and applies the accelerator till just below 90%. Now he adjusts the tuning POT till he sees the desired RPM on his rev-counter. When he releases the clutch he presses the accelerator 100%. Launch will then deactivate. This feature will activate automatically once the revs falls below 3000RPM because it does not have the Dash Board switch. If you want to cancel this feature set the launch revs 500RPM above the normal engine limiter. Then turn the POT fully clockwise. You can make increments on his tuning POT to calibrate it to the engines' revs.

Launch Recover Delay

This feature allows for a slow increase in Launch limiter RPM when the clutch is released. It will help with traction because then engine power is slowly returned to normal. This value set can be adjusted in 100 milliseconds resolution. A value of 30 will result in 3 seconds delay to rise 2000 rpm. Ex. If launch rpm is 4000 and you release the clutch, then the limiter will increase over 3 seconds to 6000 rpm. Another example if the value is 23 then it will take 2.3 seconds to raise the limiter from 4000 to 6000 RPM. It can be used during shifts to higher gears by touching the launch button. The rise time will be the same for all the gears.

For this feature to operate Tuning POT must be set to Launch and Launch Activation must be set to Clutch so that a launch button can be used.

RapidFire

This feature will randomly spark coils when you go above the Launch Limiter for up to 500 RPM above it. Example if the launch limiter is set at 5000RPM, then it will be active from 5100 to 5500 RPM. The advantage is that the occasional adjusted spark will ignite the fuel in the exhaust making a sound like a machinegun. To get this feature to work you need to put the engine limiter on Spark Only. This is ideal for the spinning guys when you want to keep power at a maximum. Note that your exhaust and silencers must be modified to accommodate the explosions in them. Normal systems will be damaged.

A value of 1 in the RapidFire block will then spark once in 2 rpms. A value of 2 will spark once in 4 rpms and so on till a maximum value of 10. The spark will be alternated so that each cylinder gets a spark in turn to clear the plugs from getting wet. Always go for the lowest count that makes the desirable effect. If the engine revs go to 5500 in this example, then increase the RapidFire setting to minimize engine power.

Related Links

Launch Options Wiring

Error Codes


Launch Control

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors >

Launch Control

The launch control input is an analogue input that combines a digital switch with a resistor to make a dual function input. It is used for Launch, Anti-Lag and Retard functions. There are different ways to activate launch but most methods use the switch on the dashboard. Same cases a push button is used and other an on/off switch. This function is mainly used on racing applications to keep the engine RPM at the desired RPM before taking off. It also helps to spin the turbo before taking off or during cornering. This increases boost pressure at startup.

The clutch switch is a whisker switch that will deactivate launch the moment the clutch pedal is released.

Wiring

The input for the launch button is situated with the 6 Pin Molex connecter pin 5.

Option 1

Dashboard Launch will only be activated as long as the button is pressed.

Option 2

Dashboard pushbutton with resistor and clutch pedal switch. This method will latch the launch action and deactivate it the moment the clutch pedal is released. This method is more automatic and lets the driver focus on other things.

Option 3

Dashboard on/off switch is used for the TPS 90% method. When switched on, this method will activate Launch up to 90% TPS value, and cancel it above 90% TPS value. Revs must fall below 3000 RPM to re-activate the launch feature.

Option 4

Use the tuning POT with TPS 90% to make an adjustable Launch RPM for different traction. To disable this function turn it clockwise so that launch RPM is very high.

Related Links

Software Setup

Error Codes


Map Information

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > General Settings >

MAP Information

The Map information screen, Name Model and Engine, contains info for the ECU application for a specific vehicle. This helps the tuner to recognize previous work and tuning data. It is saved in the ECU and also in PC maps. It does not affect any tuning on the engine.

Map Number

The firmware can save up to 2 maps for different fuel setups or tuning algorithms. This is only an indication and the map cannot be forced on this page. This block is updated when the ECU is switched on. If no selection switch is connected, the ECU will default to Map 1. Note: The maps cannot be changed whilst the engine is running. The power of the ECU has to be cycled for the new Map to be loaded. The reason is the time it takes to load and populate a map in software will let the engine cut out. If you populate in real time settings of one map will be implemented momentarily on another map and then time and fuel values may be out of limits and damage an engine under load.

Save Setup Data

This feature is handy if you want to load a map to change the tuning graphs without altering the setup data. If it is on it will load the setup settings and the graph and matrix data. If it is off it will only load the graph and matrix data. Note: The critical settings and calibrations are not altered in map load. A useful tip is to leave this setting off. Any changes on the setup while the ECU is connected is saved as normal. This feature is permanently saved in the ECU and can only be changed on the screen when the ECU is connected. Note. Never load a map while an engine is running.

Dual Map Selection

The map loaded in the ECU is determined by the Dual Map Selection switch. Note that this block varies depending on the product used. For Mercury2 there are no specific input dedicated to the Map switch. An input that is not used in the ECU control can be selected for this feature. If all the inputs are utilized, then dual maps cannot be used. On Mercury2 you may select between Cam 2, Fuel Pressure input and Altitude input to be used for the Map selection switch. Pluto2 and Saturn has a dedicated input and this whole block will be blanked out. This switch is read at startup and the map cannot be changed during running. The ECU power has to be switched off first to implement the selection and then the switch will determine on which map the ECU will start. If the driver wants to change maps he simply through the switch and switch the ECU off and on again. Then if it started on map 2, the Map No will indicate 2 when the software is restarted. Press the upload button [image] to read the new map information. (See the wiring diagrams for info on the different wiring connections.)

NB!! The fuel sensor input requires a 1K pull-up resistor to 5V and not 12 Volt. This may damage the processor. The cam sensor may need a pull-up resistor due to the isolating nature of the input. Leave it as a last resort.

The Dual map switch only operate at startup. Om Mercury2 the switch then is used as Flat-Shift. This will momentarily cut the spark or fuel to enhance mechanical gear shifting. See the Flat Shift description in the Turbo Settings section.

Tuning Mode

This feature allows the tuner to select variations of tuning according to his skills. The firmware will enable more features as the level of progress is made and hide features on lower levels so that confusion for beginners is kept to a minimum.

Novice

This level is set up as the first generation of Spitronics ECU's. There are however new features which is explained further in the manual. This mode is used for graph tuning and were developed by Spitronics. It is also easier for road tune where a Dyno is not present.

Moderate

This level is more for tuners with Dyno facilities. Here the matrix tuning is present as well as the graph method for fuel and timing. There is also a selection for MAP or TPS tuning versus RPM. Included in this level is a mixture, possibly for racing engines with poor vacuum but with turbo chargers where MAP pressure needs to be compensated for. The tuner can select his preferred option. Note: The graph and matrix data uses its own memory space and both types could be tuned without losing the data on selection changes. This allows the tuner to tune both options and chose the best for his application.

Expert

This level is to assist the tuner to tune racing engines and different fuels where more refined parameters are required. Here parameters like Start Prime Pulse, Start enrichment, and the two Accelerator pump Enrichment values are tuned on a graph versus temperature. This is very useful for methanol cars also in extreme cold conditions when fuel does not ignite easy.

Related Links

Dual Map Switch Wiring

Data Maps


MAP

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

MAP Sensor

This sensor measures the MAP (Mean Absolute Pressure) in the intake plenum. This is the main sensor for the ECU to calculate the fuel amount which is injected into the engine at different conditions and load requirements. This sensor, however, does have its shortcomings when it comes to engines with overlap cams where the intake vacuum falls away at low RPM's. Then the ECU need to rely on other type sensors like TPS or Mass volume in conjunction to air temperature, altitude and RPM's. For multiple throttles this sensor also is inadequate but there is a feature that the ECU can use to remedy this. (See multiple throttle bodies.)

This 'calibrate' button will only appear when the custom sensor is selected.

Only custom sensors can be calibrated. Click on it to adjust calibration.

If you click calibration this block will appear. The offset value will change the MAP reading. Adjust it to read the same as the barometric pressure of your altitude above sea level. Note: Remember to take temperature into account.

The Filtered checkbox can be used to smooth an erratic map sensor signal. It will average the current sample with the previous sample. The down fall is that it may create a minor flat spot under blip conditions. This needs to be corrected with the accelerator pump feature.

The sensor must to be set up correctly by selecting the Type and range under Engine Configurations.

Calibration is done in the firmware.

If the sensor is not used, uncheck it to free up valuable processor time.

Related Links

Map Sensor Wiring

ACC Pump Tuning

Error Codes


MAP_Alt Swop

This function is for Orion to swop the external MAP sensor with the onboard Altitude sensor. This will enable the tuner use the On-board 3 bar sensor for a MAP sensor instead of an altitude sensor. It will also allow the altitude sensor to move to the external input.

Note: The external altitude sensor must be a 1.1 bar sensor.


Micro Fueling Injector

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

Micro Fueling

The Orion ECU has the ability to use two injectors per cylinder. The way these injectors are implemented vary for different applications. If you use one fuel and the primary and secondary injectors does not differ too much in size, then the Ratio method is preferred. If you want to use different fuels together and the secondary injectors is a lot bigger than the primary injector, then the Graph method is preferred. On the hardware side, there is also different wiring configurations for different firmware. If there are enough drivers for all the injectors, then they can be used. If there are not enough drivers, then an extra electronic relay and isolating diodes are used to power the secondary injector's separately. So please see on the wiring diagram. The hardware connections do not affect the software settings if it is the same method. Note: This feature is only available on specific firmware. ask your dealer on it before you buy.

If you are not using micro fueling, set it to 'OFF' to free up some microprocessor time.

Ratio Micro Fueling

This feature uses the primary injector at low manifold vacuum and when the manifold pressure goes high, it will add a secondary injector to increase the fuel amount to the engine. This will allow the engine to be tuned more optimally on low and high loads. This is necessary for high boost applications where the range of the injector's usage become limited. There are two limit values and the ratio value. If any of the two limits are reached, then micro fueling will be activated.

The ECU will calculate the difference in injector time between one and both injectors, so that the same amount of fuel enters the engine under the same conditions. This method should make the transition as smooth as possible. This is done by decreasing the total injector time by a fixed % which is calculated in the explanation below.

The Injector ratio adjust % field is calculated by the primary injector cc divided by the total injector cc multiply by 100.

Example: Primary = 100cc, Secondary = 200cc.

Compensation = Primary Injector x 100 = 100cc x 100 = 33%

Primary + Secondary Injectors 100cc + 200cc

If you are not sure on the injector sizes set the 2 limit values high so that the secondary injectors stay off. Tune the engine at 3000RPM's with the primary injectors up to a load where the injector duty % is around 70% [image] . Set the A/F Ratio with the Fuel Ratio setting [image] to be at stoic or 45%. Now start with 50% Injector ratio adjust value. Decrease the two limit values so that the secondary injectors start to operate. Reduce or increase the Injector ratio adjust % so that the same air fuel ratio at the same load is reached. You may need to reduce the throttle to disable the secondary injectors, while changing the Injector ratio adjust %. Now adjust the % setting till the Fuel Ratio setting [image] to 45% like with single injectors.

The Injection duty limit is one of the limit values where the secondary injectors will be implemented. If you set it at 70% then the moment the primary injector reaches this value, the secondary injectors are implemented. This will result in a combined lower injector duty cycle.

The Injection duty time is the other limit value where the secondary injectors will be implemented. If you set it at 12 milliseconds then the moment the primary injector reaches this value, the secondary injectors are implemented. This will result in a combined lower injector time.

Note: There is a dead band implemented on both limits so that the injectors do not become erratic when you cruise at this changeover load.

Graph micro fueling

This feature is ideal for Methanol Injectors. It will not influence the primary injector time like the ratio method. It will just bring a secondary set of injectors in at a certain boost pressure and progressively adjust the injector time for the secondary injectors on a graph in milliseconds. If you select Graph, a second graph on the Fuel graph will become visible. Click on the fuel graph menu [image] button and set the graph as follows.

The brown graph will be for the primary injectors and the blue graph for the secondary injectors. There is no real time display for the secondary injector value but the milliseconds are exactly as on the graph where the orange boost bar cross. Note that when these injectors do come in working zone, you need to keep the primaries constant or reduce them under the same pressure. The reason is that they may be close to the maximum duty cycle of 100%. This graph is interpolated.

Check the relevant drawings of which drivers will be used for this micro fueling.

Related Links

Injector Wiring

Error Codes


Optic CAS Cam Anfle Sensor

Help > ECU Engine Managment > ECU Hardware Description > Inputs and Sensors > Crank and Cam Sensors >

Optic CAS Cam Angle Sensor

This chapter discuss the connection and settings for the Optical CAS. For fault finding and testing see the Testing Magnetic Crank sensor chapter in this manual.

1. First ensure that the setup in Hyperspace is done according to the startup procedure. This means you will only have a P1 and P4 connector on the Mercury2. The other connectors must be open, except for the Comms cable. Open the software and connect to the ECU.

2. On the CAS there is a 360 slot output and a home or TDC slot output. The Spitronics ECU's only use the Home slots. Connect it to the crank sensor input. These sensors the Crank is forced to rising edge and the Cam is disabled. In older software use the same settings. Gear Teeth is locked on 1 and Timing Sensor is usually between 60 and 65 degrees BTDC. Make sure the CAS is in its original mounting position where the bolt slides in the slotted groove. See the illustrations below:

3.

4. Ensure that the correct firmware is loaded into the ECU for the specific trigger pattern of your engine. You can click on information button [image] to verify.

5. Make sure the Jumper settings are set for Hall sensors. On Mercury2 the crank sensor jumper must be closed. The cam sensor input is not used. Leave the jumper open. You may now crank the engine without the other connectors.

6. Ensure that battery volts on the Real-time Volt Bar [image] does not fall too low. A healthy battery will crank at 11 volts and higher. Under 9 volts, the sensor signal becomes weak and falls below the voltage threshold of the specific ECU. Note: If it falls below 10 see chapter about 'Power Connection'.

7. Look if any error codes are displayed at the bottom. If there are errors remedy the fault. See Error codes.

8. Look at the RPM signal in the Real-time Display while cranking. It should show 200 to 300 rpm consistently. If it shows erratic readings and runs wild do not proceed to start! It must be constant. It means the edge setting is wrong or incorrect firmware or there is interference on the trigger signal and the ECU sees them as trigger pulses.

9. If it shows no error and no RPM it means that the ECU does not pick up the signal from the crank sensor. Proceed to testing the crank sensor itself.

Testing the sensor.

1. The optic sensor requires power to operate. So it cannot be dry tested like a magnetic sensor.

2. First measure continuity from the ECU ground to the sensor ground. There should be 0 ohms as the earth comes from the thin black wire coming from the harness to the thick black earth of the ECU.

3. Measure continuity from the sensor power to the ECU ignition power that comes from the key. There should be 0 ohms.

4. Now measure continuity from the sensor signal to the ECU input for that sensor, see the drawing. You can disconnect P1 and measure on the pin.

5. The fastest way to test it is while it is powered in the circuit. While P1 is connected switch the ignition on.

6. Measure at the power at the sensor between negative and positive. You should measure around 12V DC.

7. Now unbolt the CAS from the engine. Make a proper mark so you can install it in the exact position. Measure DC volts between sensor negative and signal. It should be 12 volts and if you turn the shaft slowly it should go to 0 volt. If the voltage doesn't go to less than 1 volt, then it means the ECU will not detect the change.

8. If you don't measure the 12 volt on any condition on the sensor signal, it may be the pull-up jumper is not in closed position. If the jumpers are correct, then disconnect the sensor signal wire and measure at the ECU side for the 12 volt. If you measure 12 volts, it means the sensor output is damaged and short the signal wire to ground. If you don't measure 12 volts then the ECU does not provide power through the pull-up resistor.

10. Now bolt the sensor in place and measure on the signal negative and positive with AC volts. Crank the engine and you should see 12 volts AC.

Errors and misfire during running or starting.

If the startup procedure tested correctly but you get errors during starting the engine, read through the following points.

1. The ignitions' coils may generate interference spikes on the crank sensor wires. Ensure that the sensor wire is screened as close to the sensor as possible. If you connect to a distant connector there is usually a screen pin that has to be connected to the ECU harness screen.

2. The coils may spike the ECU and it may want to restart. This may be to incorrect supply currents or relay wiring. An indication of this error is that the software will lose connection momentarily to the ECU. A restart error will come up.

3. Errors that comes at higher RPM's may be due to a weak pull-up signal. The sensor may require an extra pull-up resistor between the sensor signal and the sensor positive. Use a 1K resistor.

4. Ensure that the test signal next to the crank sensor is off.

5. Incorrect sparkplugs may generate feedback which leave spikes in the trigger signal. Normally resistor plugs are used for COP engines and non-resistor plugs for HT leads. Note: Ensure that you use carbon HT leads and not copper leads. Cracked leads also make interference. A trick is to look at them in the dark while it idles. It will show flashes in the dark.

Mercury2 pull-up

The Mercury2 use an isolated digital input to allow for magnetic sensor tap-in. For hall sensors an external jumper will connect a 1K pull-up resistor internally to the 12-volt power from the key. If this power is erratic due to other switching elements, then it may cause secondary triggering or interference of the input. To remedy this, you may add a 1K pull-down resistor to minimize the rippling effect on the power. If this does not help you may open the jumper and add a 1K pull-up resistor to 5-volt power from the ECU P1 pin 9. See the drawings below.

Related Links

Software Setup

Jumper Settings

Power Connection

Error Codes


Quick Links ECU

Help > Quick Links >

Quick Links ECU

Air Temp | Software | Hardware |
Altitude | Software | Hardware |
Anti-Lag | Software | Hardware |
Cloning | Software |  |
Coils | Software | Hardware |
Compiling an ECU | Manual |  |
Crank & Cam | Software | Hardware |
Flat Shift | Software | Hardware |
Fuel Pump | Software | Hardware |
GP Outputs | Software | Hardware | Priority
Idle | Software | Hardware | Tuning
Injectors | Software | Hardware |
Jumpers |  | Hardware |
Lambda | Software | Hardware | Tuning
Launch | Software | Hardware |
MAP | Software | Hardware |
POT | Software | Hardware |
Hardware Class |  |  | Selection
TPS | Software | Hardware |
Tuning | Software |  |
Water Temp | Software | Hardware |


Real Time Display

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen >

Real-Time Display

This block displays all the analogue sensor values as they change in the ECU. You may change the appearance of some of the signals as well as the colors in the settings tab. Double click on certain fields will toggle between 2 types of views. Below is a description of the meaning of each signal.

Lambda Sensor

This is the Lambda sensor value displayed in %. Notice on the graph that the rich and lean is inverted between wideband and narrowband.

MAP Sensor

This value displays the manifold pressure and is scaled according to the MAP range setting.

Injection Time

This value displays the total injection time that is applied after all calculations are done. It is in 0.1 milliseconds resolution.

Injection Duty

This value displays the ratio of injection time to revolution time in %.

TPS Sensor

This value displays the throttle position opening in %.

POT Sensor

This input can be connected to a potentiometer or other connections to achieve functions like launch control etc.

RPM

This value indicates engine revolutions per minute.

Ignition Timing

This value displays the total ignition timing that is applied after all calculations are done. It is in 1 degree's resolution.

Water Temperature Sensor

This value displays the current engine water temperature.

Altitude Sensor

This value displays the altitude pressure of your location.

Fuel Pressure Sensor

This value displays the fuel rail pressure and is scaled according to the Fuel range setting.

Air Temperature Sensor

This value displays the current air temperature at the air intake.

Battery Voltage

This value displays battery voltage that is connected to the ECU.

Copyright © 2013. All rights reserved.


RPM Output

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > General Settings >

RPM Output

Pulses/RPM

This feature is used for Rev counter calibration. You can adjust the number of pulses per revolution for the RPM output. This is handy for engine conversions. A value of 1 to 60 pulses can be achieved with this function. On some firmware you may enter 61 which will then divert the crank angle signal onto the RPM output. This is also handy if the standard ECU is still live and doing other functions in the car. Note different electrical connections in the drawings to connect the different RPM gauges onto the Spitronics ECU.

This Auxiliary Values is used on certain firmware to achieve certain functions. It is only used in new development where the features were not yet developed in the Tuning Software. See the specific instructions for that engine type.

Related Links

Tachometer Wiring


Status Bar

Help > TCU Transmission Management > TCU Software Desciption > Startup Screen >

Status Bar Display

This block at the bottom of the software displays all kinds of status, information and fault codes. Below is a description on types of messages.

When no device is connected, the connection button may be open and an indication that no device is recognized. If you use a different USB cable, you may need to click on the connect button to tell the software to search other Comms ports as well. Once a port is found with a recognized device the software will lock onto that port to minimise start up times. It will then display the device type and COM port as below.

On the right bottom corner the software will indicate which ports it is scanning to search for a device. If you use a different USB cable, you may need to click on the connect button to search other ports as well.

]

Some devices may have a BootLoader to load firmware and some are programmed with the USB Debug Adapter. This indication will show if it is installed on that device.

Flash ID or Device ID is an indication of which allocation are installed. Old programs were Flash ID and the newer ones will be changed to Device ID. It is more stable and cannot be spiked easily. The firmware must be written for the type of ID that the device is set up to. If they don't match, then allocation details will not show and won't allow the firmware to run.

This message indicates if the unit is mobile software capable or not. Some mobile applications will run only if this is set. Contact your supplier for activation.

The software will also give occasional indications on tasks like if the map was saved successful or not.

This message will indicate Errors, Warnings and Information. This is helpful to the user to find errors in the setting up of the device. If you click on the button left of the error, a list of the errors will appear with the last one on top. If you go out of the error list it will be cleared. See the list of errors in the sub folders.

See the sub folders for the different error messages displayed on the Status bar:

Copyright © 2013. All rights reserved.


Throttle Selection

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Injector Settings >

Throttle Selection

This setting is developed to use a MAP signal on multiple throttle body engines. The problem with them is there is no intake plenum where the vacuum could be measured. The vacuum signal only makes a spike when the valve opens. This spike is also there only once in two RPM's on a four stroke engine. This makes it important to read the signal on crank degrees when the vacuum signal is present. This setting is only available for gear type triggers as low as 12 teeth.

Single

Most engines have one throttle and an intake plenum where a map sensor is used. The map signal is read 2 or 3 times per revolution. It makes for a fast vacuum signal response. The map teeth can still be adjusted here as there is a small amount of pulsation in the intake plenum.

Multiple

To use this method a crank gear of min 12 teeth is required. The MAP sensor is only connected to cylinder 1 or the cylinder that shares the crank degrees on movement. With this feature the MAP sensor is read once per two RPM's when the vacuum signal is present. This makes for a slow response that may cause flat spots during blip. This however can be cured with the accelerator settings. One requirement is that the throttles are properly balanced as only one's vacuum is measured. The map teeth setting here is very important. When the engine idles it is adjusted to read the best vacuum. The more teeth on the crank gear the finer adjustment could be made to find the sweet spot. This sweet spot on the vacuum signal is around 90° after TDC. For a 36-1 gear 90° would be 9 teeth.

Related Links

Tuning


Coil Charge times

Help > ECU Engine Managment > FAQ Frequently Asked Questions >

Timing Configuration

Maximum trailing

This is for rotary engines and prevents the trailing degrees from being adjusted to far from the leading plugs. In piston engines this block is hidden.

Maximum Timing

This is the maximum combined timing allowed in degrees by all the timing maps combined. If the graphs are tuned for more degrees, it will be limited by this value. On the Timing Matrix this will also prevent the tuner from selecting higher values there.

Minimum coil time

This is the minimum coil charge time which the tuner can select. The ECU will vary the charge time automatically according to engine load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is about 60% from the maximum value. Example if Max value is 3ms then make min 1.8ms. see the Maximum Coil Time to determine the right setting.

Maximum coil time

This is the maximum coil charge time which the tuner can select. The ECU will vary the charge time automatically according to engine load from the minimum to the maximum value. It can be adjusted in 0.1 millisecond intervals from 1ms to 5ms. Standard coil setting is 2.5 to 3.5 milliseconds for coils of around 0.9 ohms but some new coils are lower resistance and may need shorter times. Normally the driver will heat up and may damage if it runs too hot. Always start with a min value if you are not sure. Start with 2.0 to 2.5ms. Coils with a lower resistance in the 0.4 to 0.5-ohm region, use a value of 1.5 to 2ms. Always a good idea to put a 5-Amp fuse in the power line of each coil. If you go too high the fuse will blow. If you use the Mercury Coil driver, then you can look at the overload LED. It comes on at 4-amp current. Most coils are rated at 5.5A. adjust maximum so that the OVL LED may come on at full load but not on at less than 70% load. During cold starting, this maximum value is used till the engine reaches 60°C. Thereafter spark control will commence.

Vacuum Timing Split

This value sets the RPM split between the Low & High Vacuum Timing maps. This value is selected about 500 to 1000 RPM's above idling.

Altitude comp.

This value sets the timing advance ratio for every 1000 meter above sea level. A value of 3 means that the timing will be advanced by 6 degrees at 2000 meter above sea level. If you tune the vehicle at a higher altitude, make sure this value is set. Then when the driver descends to lower altitude the ECU will retard the timing automatically.

Related Links


Top Toolbar

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen >

Top Toolbar

Like any Windows program you will find standard menus and buttons which relate to program settings and preferences. Offline Map files could also be selected and edited with the file button.

Notice the Version and Date in the name. this will help dealers to see if you have the latest software installed. Make sure from time to time that you have the latest version which is free from our website. Especially if you find something in the software that may function incorrectly. We fix these errors immediately and replace the version on our website.

This software is Version 3.5.5 The last 5 is a sub release as fixes etc. are made.

2018-11-20 19:06:30 is the date and time this version was released

See the sub folders for detail explanation on the Tuning, Device, File and Help menus.


TPS

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > Active Sensors >

TPS Sensor

This sensor indicates to the ECU what the driver wants to do. It is also used for many features in the ECU, such as fueling, accelerator pump, idling control, fuel cutoff, cam control, automatic transmission control, etc. It is possible to control the engine without this sensor but with limited drivability. If there is a TPS sensor on the engine, rather connect it. If not, un-select the check box and isolate the wiring.

For the ECU to operate correctly this sensor needs to be calibrated. Note: When pressing the throttle while calibrating, the Fuel Prime function may squirt some petrol on the cylinders. You may disconnect the P2 and P3 connectors so that these functions will have no effect.

Click on the Calibrate [image] button left of the TPS check box and do the following procedure:

The TPS value must increase with throttle depression. If it is decreasing, click on Polarity to select Negative. This feature is normally used where the original ECU is still connected and wiring cannot be altered. In this case you connect only the ECU TPS signal wire to the OEM signal wire. Do not connect the ground or 5-volt signal wires but isolate them to prevent shorts. Now click the Calibrate button. The current TPS value will be written into the two blocks Min and Max.

Press the fuel pedal in completely and release the pedal completely. The Min and Max values will be indicating the range of the TPS. Click the Save button. You may now test the TPS signal by pressing the pedal in and releasing it. The TPS real time value should operate from 0 to 100%. Then click on the 'Save to ECU' [image] button to make the changes permanent.

Show Graph

This checkbox will enable the TPS compensation graph [image] . With this graph it is possible to add fuel % with the TPS position. It is handy to enrich the fuel mixture at full throttle conditions. There is no timing compensation for this graph.

Related Links

TPS Sensor Wiring

ACC Pump Tuning

Error Codes


Tuning Menu

Help > ECU Engine Managment > ECU Software Desciption > Startup Screen > Top Toolbar >

Tuning Menu

Settings is to set up units, software and device communications and auto map save settings.

Exit is to quit the software.

Connect is to connect or dis-connect to the ECU,

Settings

Unit selection

Select Metric or Imperial units.

Language

Select Language if it is available.

Styles

Custom your own tuning pallet to suit the collars and font size that works for you. Remember these settings is saved in the Config file. If you upgrade versions, then rename your Config file to carry your settings over.

Device Settings

Max Poll error count: This is the time it takes to read the real time values from the device via the Blue Tooth serial port. Blue tooth communication is not as smooth and fast as USB communication. It requires a tolerance setting to ignore short intervals of no communication. Increase this value till the flashing LED stops flashing RED. For USB cables keep this value at 0.

Save Settings

The software will do Auto saves at time intervals. The intervals can be adjusted here. It will also have a max display list on the open file menu. Then the software will also make a backup copy of each download to ECU and it is called Device Saves. File location for these maps is in the folder where the Hyperspace is saved on the hard disk.

Hotkeys

These settings let you customise quick keyboard keys to fast track moving between screens and functions. They are completely customisable. In the factory we will set up basic keys for your convenience. You may restore to default when you chose to. Remember these settings is saved in the Config file. If you upgrade versions, then rename your Config file to carry your settings over.

Close will save your selections in the Config file and go back to the tuning pallet.


POT Input

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings >

Tuning POT

This POT is a Potentiometer or variable resistor that lets the tuner or driver change settings in real time while the ECU is operating. It is a device that connects to the communication port plug for on one of the universal I/O. Note that other features will be sacrificed when you use this input. The following functions can be activated for it.

See the sub folders for explanations.

Related Links

Tuning POT Wiring

Error Codes


Injector

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > POT Input >

Tuning POT Injector

Injector setting will change the injector time with 10% richer or leaner in this example. The POT needs to be in the middle to have no effect on current fueling. This is handy in a race car if the driver has an A/F Ratio gauge installed. Then he can manipulate fueling and remember under which conditions he has to lean or richen the mix. Then he can make adjustments on the graph at a later stage.


Timing

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Sensor Settings > POT Input >

Tuning POT Timing

Timing will advance or retard the ignition timing by 5 degrees in this example. The POT needs to be in the middle to have no effect on current timing. It is useful in racing for tuning time while driving. Ensure that the driver has a knock sensor and light fitted to the engine.


VVTI Selection

Help > ECU Engine Managment > ECU Software Desciption > ECU Setup > Turbo Settings >

VVTI Settings

This block is used to set up open loop cam control with TPS limits. It is also used to open variable intake runners found on some engines like the Lexus 1UZ VVTI. In some cases, part of this block may be hidden or disabled. Note: This feature is only available on specific firmware. ask your dealer on it before you buy.

Cam1

In this block the output will be on between 2100 and 3900 RPM if the TPS value is above 30%, This is how most V-Tec cams are applied. The driver output will indicate where the solenoid must be connected on the ECU. Cam 1 is always used for the Intake cam or Cyl1 bank cam.

Cam2

In this block the output will be on between 2500 and 4000 RPM if the TPS value is above 30% as above. It operates the same as Cam1 but for the exhaust cam or bank 2 of a V type engine.

If this block is made visible like above, then it is only to indicate which driver is used. This may be in the V type engine where both cams settings are the same.

The intake flap

This block is firmware dependent on control according to requirements. For Toyota V8 the flap will be powered or activated whenever the RPM's are between 2500 and 4900 in this sample regardless of throttle position. It will also be powered if the throttle is less than 60% depressed regardless of RPM. Said in another way, the flap will not be powered at over 60% throttle and at lower than 2500 RPM or higher than 4900 RPM.

Related Links

Cam Solenoid Wiring

Error Codes


Rotary Engines

Help > ECU Engine Managment > Specific Instructions >

Rotary Special instructions.

General Information

The two stroke setting means that the firmware will inject the calculated amount of injector time in every stroke. Putting it off means that the injector time will be divided by 2. This will cause the tuning graphs to be twice as high. The advantage is that the graphs tune more easily and adjustments is 50% finer resolution. Especially for large injectors. A drawback is that 25 milliseconds maximum fueling is easily reached during accelerator pump function and might cause problems at tuning flat spots during blip conditions.

Another feature is the duel injector system. It can be tuned with a ratio adjustment or separate graph system which is discussed in this article. Note that the secondary injectors are compensated, on all the graphs except the lambda control. Also during cranking the secondary's is not pulsed. During acceleration they will be pulsed even if the main graph for them is at zero.

Determining if coils are on the correct plugs.

Due to the duel spark plug system it is sometimes confusing to understand why some leads can be faulty. The rotary engine allows the leading plugs to be fired in wasted spark configuration. The reason is that the non-combustion rotor is still covering the leading plug with burned gas from the previous stroke. The trailing plug however is situated in the upcoming chamber when the other plug is fired, so it will ignite the fuel in the intake. Spitronics uses a different setup for the 3 coil wasted spark Leading coil pack. You connect both leading drivers on to the same wasted spark coil. Then it is Important to set the software to wasted spark as the firmware will then reduce charge time at high RPM to ensure that charge time does not overlap and that there is enough discharge time between charges. See the setting below.

Note: Should the "Wasted Spark Coil Per cylinder" be selected then the software will change it to Wasted Spark Coil Pack.

NOTE: Always use a colder spark plug on the trailing and one size warmer on the leading for instance NGK B10EG on trailing and NGK B9EG on the leading. This will help with detonation that can be caused by a warmer plug on the trailing do to heat glow on the intake cycle

To make sure that coils are setup in the right position, disconnect the drivers from the trailing coils. It is not good practice to pull off HT leads and let them spark in dry air. Reason is high voltage feedback may damage coil drivers. Now start the engine. There may be a 5% power loss but it should start easy and rev up smoothly. Get the timing light out and make sure timing is according to specs. Now disconnect the leading coils and reconnect the trailing coils. In the software set the maximum trailing degrees to zero as below. This will ensure that the trailing degrees fire the same time as the leading plugs. Now insert the trailing plugs onto their plugs. Again start the engine. If they are correct then the engine should start and rev up smoothly. There should be a power difference but no misfires. If they are incorrect there should be misfires in the intake manifold. Swop them around and try again.

Timing light degrees.

Due to 1 spark per revolution the normal timing light that does not have a 2 stroke setting will have an error in its reading. The degrees on the timing light will be double that of the actual degrees. If the timing light is on 20, it is 10 actual. If you use the wasted spark option, there are 2 pulses per revolution and the degrees will be quadrupled on the timing light. If the timing light is on 40, it is 10 actual. Best way in these conditions is to set the timing light to zero degrees and work on the degrees on the engine pulley.

Determine Maximum injector time.

This is important because at high revs there is only a certain amount of time to inject fuel. This time may not be exceeded as the engine will leaned out. You may argue, that at lower RPM's you can go higher duty cycle with the primaries, but the problem is that this is not matrix and the switch over point is hard to determine. This time is calculated as follows.

Injection Time = 85% * 60 / Max RPM

= 51 / 8000

= 0.006375

Or 6.375 milliseconds

85% is recommended max duty cycle of an injector.

Max in this example is 8000 RPM

First set all the RPM graphs to 0.

To tune this unit set the Micro fuel setting on graph. There are 2 graphs available for the dual injectors. Red is for primaries and blue is for secondary's. First adjust the secondary's to 0 right through the scale. Then at 3000 RPM adjust the primaries from light load to full load until the max time is reached. In this case 6.3 milliseconds. Make a note of the load where max injector time is reached. About 0.84 bar. Then make the rest of the graph flat at the same value.

Now take a load just smaller than max like 0.75 bar. and look at the air fuel ratio. Lift the secondary's graph in totals till you see that the A/F ratio becomes richer. Decrease just enough till it is back to what it was. This offset will eliminate the dead band of the secondary injectors which will help to make the transition as smooth as possible.

Now you may increase the load and tune the secondary injectors to maintain the correct A/F ratio. Note that the secondary's may also not increase the max injection time.

Lastly taper the injection time to the left off to eliminate pulse on the secondary injectors. Note the taper off is on the left where the primaries stopped working.

Multiple Throttles

A rotary engine normally has poor vacuum signal due to the small window that their air is sucked into the rotor. The vacuum signal is at its lowest pressure about 90° ATDC. Spitronics has developed a way to read the vacuum signal during this suction period. The time that the signal is read is adjustable in the same degree intervals as there are pulses from the crank sensor.

If you use the 36-1 gear it means you can adjust it in 10° resolutions. Start with 9 teeth which is 90° after TDC. This is entered in the Map Teeth block.

If you have the 24+TDC dizzy then it has only 30° resolutions. Here you need to first adjust TDC to be on one of the tooth so that you can get to 90° which is 3 teeth.

See the section on calibrating timing on the 24+TDC Dizzy.

Now connect the map sensor only on the throttle of Rotor 1 as in the sketch below.

Put the Throttle Selection on Dual for Multiple throttles.

You may now start the engine and get it to idle. Once it idles look at the Fuel Graph Top Map. The map bar should show a fairly good vacuum.

Now you can adjust the map teeth higher and lower while looking at the bar. Adjust it on a value where you get the best vacuum to the left side. Throttles do tend to create a flat spot due to the fact that it is only read when 1 rotor has vacuum. So you may need to adjust the accelerator pumps slightly. Refer to the ACC Pump adjusting in the manual.

Calibrating timing on the 24+TDC Dizzy.

Put the crank teeth on 1 and Timing Sensor on 0.

Now put the max timings on 0 as a Rotary can start and idle on zero degrees.

Put your timing light on zero degrees and use the TDC mark on the engine. Remember timing lights show double the degrees on a rotary with 4 coils because it is 2 stroke. If you have the wasted spark coil setup, then the timing light shows 4 times more degrees than actual engine degrees. If you make the light zero and use the engine marks, then you are 1 to 1 and more accurate. Now turn the dizzy till the light shows the mark is on TDC. Lock the dizzy.

As a test to make sure your trailing and leading coils is in the correct place do the following. Put the trailing degrees on 10°.

Put the trailing graph on 10°.

Now look with the timing light on 0 degrees. Leading coils (bottom plugs) will be on TDC and the trailing coils (top plugs) will be on 10° after TDC.


Aisin A343E 4Speed

Help > TCU Transmission Management > Transmission Drawings >

Aisin A343E 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU withMTWX02/2 Harness

Aisin A343E Drawing

Use as Stand Alone with MTSX02/2 Harness

Aisin A343E Stand Alone Drawing

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB1 Positive Diode Board

A343E Freewheel Diode Schematic

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Aisin A343E 4Speed Connection Layout (Pdf)

Hardware Class Comparison

Aisin A343E

Tyre Calculator

Tyre Calculator Aisin A343E (Excel)

Packing List

Mercury2 Aisin A343E Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Aisin A650E 5Speed

Help > TCU Transmission Management > Transmission Drawings >

Aisin A650E 5Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with MTWX02/2 Harness

Aisin A650E Drawing

Use as Stand Alone with MTSX02/2 Harness

Aisin A650E Drawing Stand Alone

Special Instructions

Aisin A650E 5 Speed Special instructions Ver 3.3B

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB2 Negative Diode Board

A650E Freewheel Diode Schematic

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Aisin A650E 5Speed Connection Layout (Excel)

Aisin A650E 5Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator Aisin A650E (Excel)

Packing List

Mercury2 Aisin A650E Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Aisin A750E 5Speed

Help > TCU Transmission Management > Transmission Drawings >

Aisin A750E 5Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with MTWX02/2 Harness

Mercury2 TCU Aisin A750E Drawing

Use as Stand Alone with MTSX02/2 Harness

Mercury2 TCU Aisin A750E Drawing Stand Alone

Special Instructions

Aisin A750E Special Instructions Ver 3.3D

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

2 x DB2 Negative Diode Board

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Aisin A750E 5Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator Aisin A750E (Excel)

Packing List

Mercury2 Aisin A750E Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Aisin A761E 6Speed

Help > TCU Transmission Management > Transmission Drawings >

Aisin A761E 6Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Note that there is an older Ver 3.3B at the bottom of the page for old installations.

Main Drawing Ver 3.3D

Use with ECU withMTWX02/2 Harness

Aisin A761E Drawing Type 1 Ver C Connections

Aisin A761E Drawing Type 2 Ver C Connections

Use as Stand Alone with MTSX02/2 Harness

Aisin A761E Drawing Stand Alone Type 1 Ver C Connections

Aisin A761E Drawing Stand Alone Type 2 Ver C Connections

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB2 Negative Diode Board

A761E Freewheel Diode Schematic

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Aisin A761E 6Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator Aisin A761E (Excel)

Packing List

Mercury2 Aisin A761E Packing List (Excel)

Old Drawing Ver 3.3B

Mercury2 TCU Lexus A761E Drawing Option 1 Connections

Mercury2 TCU Lexus A761E Drawing Option 2 Connections

Aisin A761E 6Speed Connection Layout (Pdf)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


GM 4L60E

Help > TCU Transmission Management > Transmission Drawings >

GM 4L60E 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Mercury2 TCU GM 4L60E Drawing

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB1 Positive Diode Board

Shifter Converter Board

CON1 Parallel A/D Converter

GP Priority Layout

GM 4L60E 4Speed Connection Layout (Excel)

GM 4L60E 4Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator GM 4L60E (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Jatco RE4

Help > TCU Transmission Management > Transmission Drawings >

Jatco RE4 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU withMTWX02/2 Harness

Jatco RE4R01A 4Speed Drawing

Use as Stand Alone with MTSX02/2 Harness

Jatco RE4R01A 4Speed Stand Alone Drawing

OEM Tap-In Connections

Mercury2 TCU Jatco RE4 OEM 4Speed Drawing

ULN1A Wiring.pdf (Level Shifter board for Shifter switch)

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB1 Positive Diode Board

RE4 Freewheel Diode Schematic

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Aisin Jatco RE4R01A 4Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator Jatco RE4R01A (Excel)

Packing List

Mercury2 Jatco RE4 Packing List

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Mercedes 722.6

Help > TCU Transmission Management > Transmission Drawings >

Mercedes 722.6 5Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Mercury2 TCU Mercedes 722.6 Drawing

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

2 x DB2 Negative Diode Board

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Mercedes 722.6 5Speed Connection Layout (Excel)

Mercedes 722.6 5Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator Mercedes 722.6 (Excel)

Packing List

Mercury2 Mercedes 722.6 Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Subaru 4EAT

Help > TCU Transmission Management > Transmission Drawings >

Subaru 4EAT 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Mercury2 TCU Subaru 4EAT Gearbox Drawing

Special Instructions

Subaru 4EAT Special instructions.pdf

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB1 Positive Diode Board

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

Subaru 4EAT GP Output Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator Subaru 4EAT (Excel)

Packing List

Mercury2 Subaru 4EAT Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


ZF 4HP22/24

Help > TCU Transmission Management > Transmission Drawings >

ZF 4HP22/24 4Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Mercury2 TCU ZF 4HP22_24 4 Sol Drawing

Mercury2 TCU ZF 4HP22_24 5 Sol Drawing

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB2 Negative Diode Board

Shifter Converter Board

CON1 Parallel A/D Converter

GP Priority Layout

ZF 4HP22_24 4Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator ZF 4HP22_24 (Excel)

Packing List

Mercury2 ZF 4HP22_24 Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


ZF 5HP19

Help > TCU Transmission Management > Transmission Drawings >

ZF 5HP19 5Speed

The Tyre Calculator and Packing List files are Excel spreadsheets. They will ask if you want to save them or just open them. You will need Microsoft Excel spreadsheet to open them. Some drawings have more pages. Click Page Down to view them.

Main Drawing

Use with ECU with MTWX02/2 Harness

ZF 5HP19 Drawing

Use as Stand Alone with MTSX02/2 Harness

ZF 5HP19 Drawing Stand Alone

Special Instructions

ZF 5HP19 5 Speed Special instructions

Default Harnesses

MTWX02-2 Harness (ECU Connections)

MTSX02-2 Harness (Stand Alone System)

Diode Board.

DB2 Negative Diode Board

ZF 5HP19 Freewheel Diode Schematic

Shifter Converter Board

CON2 Serial A/D Converter

GP Priority Layout

ZF 5HP19 5Speed Connection Layout (Pdf)

Tyre Calculator

Tyre Calculator ZF 5HP19 (Excel)

Packing List

Mercury2 ZF 5HP19 Packing List (Excel)

Old Harness Layout

This is not sold anymore but for backwards compatibility explanations.

T01-P1 V2 Harness T02-P1 Harness T08-P1 Harness

M02-P2 Harness T07-P2 Harness T03-P3 Harness

T06-P3 Harness T09-P3 Harness T04-P4 Harness

T05-P4 Harness M07 - P5 Harness


Speedommeter Output

Help > TCU Transmission Management > TCU Hardware Description > Outputs and Drivers >

Speedometer Output

The Speed output can be used to drive cluster speedometers or data logger. This output is a square wave signal and has adjustable pulses to calibrate external speedometers. See the tuning software for more details.

The Mercury2 output is a ground square wave signal with a 1K pull-up resistor to 12V. Most digital speedometers can be connected directly but there are 2 main types. A third type is stepper control speedometers that is controlled by the OEM TCU. This one cannot be done and it is best to keep the OEM TCU running by providing it the normal pulses it is used to.

Digital Speedometers

This type can be connected directly on the ECU Speed output. The positive and negative is usually supplied by the dash electric connections.

Magnetic Pickup Speedometers

This type requires a spike circuit that is based around earth. There is no fixed circuit that will work with all of them. Since the 12 volt square wave only goes to earth it does not trigger these speedometers. In this case a 10uF 25V capacitor can be used to isolate the DC which will generate a +/-6 volt spike circuit around earth. If you use a polarized cap put the positive to the TCU side. If their ref wire is 12 Volt you may need to turn the cap around. If you use a non-polarized cap you should be ok for both types.

You may need to add a 1K resistor in option 2 for their electronics. In some cases, they require a reference voltage on their sensor wire.

In some cases, you may require a 1K resistor on both sides as in option 3. This to ensure more energy through the capacitor. You may also need to tweak the capacitance in some cases. There is no fixed circuit that will work with all of them.


TCU TPS Sensor

Help > TCU Transmission Management > TCU Hardware Description > Inputs and Sensors >

Throttle Position Sensor

The throttle position sensor is used by the TCU to determine what the driver's intent is. The TCU will use the TPS, engine RPM and road speed to calculate a shift pattern to use. This sensor is very important and must be a stable signal. Most of the time the TCU will operate side by side to the ECU. The TCU can tap into the signal from the existing TPS or as with Spitronics ECU's there is a yellow wire that is installed in the harness for this signal. Do not connect any supply or earth to existing TPS connections. Just the signal wire is connected. See the drawings on this.

TPS Sensor Wiring MTSX02-2 Stand Alone

TPS Sensor Wiring MTWX02-2 With ECU

Operation:
The TPS is a variable resistor normally around 5K ohms. The signal voltage varies as the wiper moves. It is connected to 5 volts from the ECU and then the wiper signal will produce a voltage between 0 and 5 volts, proportional to the angle of the throttle plate.

Which Pin is which?
Use a multi-meter set to the 20,000 ohm (20 K) range.

· With throttle closed, find the two pins with the lowest resistance between them. They are C & B. The remaining pin is the 5 V pin A.

· With one probe on the 5 V pin A, find the pin whose resistance changes when the throttle moves. This is the Signal pin B.

· The remaining pin is the earth pin C.

This same route can be used on a four pin throttle position sensor, note that only three of the four pins will be connected or one pin may be a switch to ground or 5 Volt as an idle activation switch. The Spitronics ECU does not require this pin.

Pre-load the Sensor
The sensor has a dead band at either end so it must be rotated slightly to move the wiper into the operating range of the sensor.

Connecting the TCU TPS to an existing ECU TPS sensor.

TPS Sample Pin outs:


Specific Instructions

Help > TCU Transmission Management >

Transmission Specific instructions

Each transmission may have specific setup rules that is not standard. This could be an extra pressure solenoid or setting for example. These instructions on how to tune it properly will be saved in the transmission folder on the web along with its firmware, startup map and drawing.

Aisin A650E 5 Speed Special instructions Ver 3.3B

Aisin A750E 5 Speed Special Instructions Ver 3.3B


Accelerator pump tuning

Help > ECU Engine Managment > ECU Tuning >

Accelerator pump tuning

Accelerator pump selection

The accelerator pump setting is used to richen the fuel mixture when accelerating to avoid flat spots or bog. Here you can select not to use it, use either the TPS or MAP or both signals. Below is the selections to setup each pump for TPS and MAP.

Enrichment %

This is the amount of fuel that will be added momentarily when the accelerator pump is activated. This value is divided by the number of strokes and each stroke the value is reduced by the division value. It will start with 10 and reduce to zero so that fuel is gradually reduced. This value is also compensated with the water temperature graph value. In Expert mode this value for MAP and TPS will be blanked out and the graph value for that temperature interval will be used. See the graph sample below.

Sensitivity

The activation sensitivity can be adjusted from 1 to 10. The lower the value, the more sensitive the accelerator pump will be. If the accelerator pump is set too sensitive it will activate randomly and cause the vehicle to over fuel. Rather keep the activation sensitivity as high as possible to avoid this from happening. For the TPS signal this value can be lower as it is more stable than MAP value and it reacts faster.

Max RPM

This is the maximum RPM that the pump settings will be active. At high RPM you do not need an accelerator pump. A standard is 1500 to 3000 RPM for TPS and 1500 to 2200 RPM for MAP. If a value was initiated before this limit was reached it will finish the decay cycle.

Strokes

This is the number of engine strokes that the fuel must be applied to and then decayed over the amount of cycles. If it is a 4 cylinder engine, a value 0f 8 will inject 4 full revolutions of fuel. There are two firing strokes per revolution. If it was a 6 cylinder engine, a value 0f 12 will inject 4 full revolutions of fuel. Always tune for the lowest value to eliminate flat spots. If a value of example 10 is selected it means that the enrichment amount will be decayed by a tenth every cycle till the tenth stroke.


Fuel economy cut-off tuning

Help > ECU Engine Managment > ECU Tuning >

Fuel economy cut-off tuning

This feature will cut fuel to the engine under low load conditions. This will save fuel in town and downhill driving. The engine will run against compression as you are decelerating. It will also prevent flaming in the exhaust during accelerator blip.

The injectors will be cut when the MAP sensor value is below the Vacuum fuel cut off setting and the engine RPM is above the RPM fuel cut off setting.

The Vacuum fuel cut off setting is chosen as a value lower than idle vacuum. A good value is usually 0.08 bar for a standard street car. The RPM fuel cut off setting is about 500 RPM higher than idle RPM. Rotary and racing engines may need some extra RPM's.

There is a dead band feature built into these settings to prevent jerking when you are cruising close to the settings. When tuning these parameters use third gear at around 2000 rpm and release the throttle. Look at the real-time injection bar and you will see that it goes to zero value which means the injectors are switched off.

You will also notice in information code at the right-hand bottom of the screen indication that this feature is activated.

Now, let the car reduce speed by itself till injection is restored and the engine is running by itself again. This change over point must occur when the engine reaches idle RPM's. If it jerks in the car, reduce or increase one of the settings till it comes-in unnoticed.

Related Links

Software

Error Codes


Graph MAP and Matrix TPS Tuning

Help > ECU Engine Managment > ECU Tuning >

Graph MAP and Matrix TPS Tuning

This method is for Dyno tuning and used for racing engines with poor vacuum signal. Before reading this section please read Matrix MAP Tuning to understand how to tune from scratch. This section will only discuss the differences and types of Tuning options.

For this method you tune the normal aspirated part on the TPS matrix and then the turbo boost part on a graph. This feature is best to use with Altitude compensation sensor wired in. The Altitude sensor will modify the TPS matrix value before it is compensated by the Graph setting. This will give a more accurate calculation of the fuel per air. The trick is to tune normal aspirated fuel on the TPS matrix then add the boost compensation fuel on the graphs. TPS has no reference against pressure of the Turbo. Timing will also activate the two Cruise Timing Graphs for boost timing tuning.

There are two methods of tuning.

Method 1 is to disconnect the turbo and do the TPS matrix as previously discussed. Then connect the turbo and do the Fuel Boost Compensation graph. This method is good for low boost engines.

Method 2 is to add a predicted boost graph line and then tune the TPS Matrix with low boost to get a pattern on the Matrix. Then put the boost up and tune the Fuel Boost Compensation graph part complete.

Method 2 Fuel with Altitude sensor wired in.

Make sure the altitude sensor is switched on Compensate. Especially if you are not at sea level. Tuning will include the pressure difference and change the maps when you go to sea level. This graph will start at 0 pressure which is the current atmospheric pressure where you are. If you change altitude this zero point will move with the altitude pressure. This means that the moment boost pressure goes above altitude pressure the graph will indicate the difference. That will eliminate the need for the ECU from being retuned all different altitude levels.

Fuel Boost Graph with Altitude sensor.

Set a base graph as above. Note that at 1 bar boost it will be around 100% enrichment. With this method you can boost up to 2.5 bar above sea level. If you need higher boost you may have to add fuel on the matrix or add the dual injectors with Ratio or Graph method. The reason is this graph can only go to 250% enrichment. This graph is linear and it should curve up to make mixtures progressively richer at higher boost. So go for the lowest boost setting that you can. Maybe 0.5 bar boost. Now turn your attention to the Fuel matrix.

TPS Fuel Matrix

Note: Due to the turbo engine, the injectors will be bigger and the injection times will be shorter. The maximum set here is 8.7 and with 1 bar boost it will become 17.4 milliseconds. Which should be maximum at high RPM's. After you tuned at low boost then proceed to the graph again.

Now lock the dyno on a high RPM load site at full throttle. As you increase the boost adjust the graph to run at the right AFR mixtures. Once this line is set to maximum boost then change the RPM and check other load sites as well. They should be the same AFR. If you see a lean mixture you may correct it on the matrix map. Notice the graph below now has a slight curve to the top. This one runs out of tuning space because the injectors are too small.

Fuel Boost Graph with Altitude sensor.

Method 2 Timing with Altitude sensor wired in.

TPS Timing Matrix

Timing matrix is set like a normal aspired engine. See sample above. As for the boost part you need to tune the Cruise Timing Graphs.

Fuel Boost Graph with Altitude sensor.

Here only the red graph is of importance as normal liming comes from the TPS matrix. Set the blue one on 0% compensation so that it does not affect low RPM timing.

Fuel Boost Graph with Altitude sensor and Dual injectors.

If you need more fuel for a high boost engine, then you may activate a second set of injectors. There is the standard Ratio method, or the graph method. The graph method is only available if there are enough drivers for that application.

Ratio Method works standard as it is discussed under Micro Fuelling Injector section. A certain duty cycle or injector time will trigger the second injectors to come in and share the load. Fuel will be divided between them.

The Graph Method is also discussed there and below is an example on the set-up of a graph. Note that when the system passes 1 bar boost a second set of injectors are phased in. In some cases the top ones may be flatten out if their duty cycle becomes too large.

Fuel Boost Graph with Altitude sensor and Dual injectors.

Method 2 Fuel with no Altitude sensor.

This method can be used if you don't use the vehicle on different altitudes. Remember air temperature has an effect on atmospheric pressure so there may be slight changes in your AFR from day to day. If possible, use it with the Lambda control. The main difference is the Lambda sensor don't effect the timing and you may get detonation at sea level.

Fuel Boost Graph with no Altitude sensor.

Notice that this method uses the actual MAP signal on the real scale. This example as tuned at sea level on 1.03 bar altitude pressure. At higher altitudes the graph will start to increase from that altitude.

Cruise Timing Graph with no Altitude sensor.

Same as above this starts to change from 1 bar.


Idle Control Tuning

Help > ECU Engine Managment > ECU Tuning >

Idle control Tuning

Idle control is done with different methods. It could be external idle valve or stepper motor or it could be done with partial throttle motor or full drive by wire throttle. Due to the delay in mechanical control to stabilise idle, you need to tune the ECU and idle valve together. The reason is that the ECU can react faster than a mechanical air restrictor valve. And most of the times hunting is a result of incorrect engine tuning. If idle drops then the valve opens to correct. That adds more air resulting in a worst effect and it comes with a delay. Then the ECU will add fuel due to more air resulting in high rpm which in turn close the idle valve and this repeats out of control. Also after blip the idle valve must capture the engine rpm before it stalls. Again here the ECU can react faster by adding timing and fuel to assist in this process. This section describe what needs to be done on the ECU side to help smooth idle control. See the different types of idle control and how to adjust their settings in the idle control setup section.

Setting the Idle Jet for Time & Fuel

When an engine idles in neutral and is at working temperature, the idle timing should be around 15 to 18 degrees depending on altitude. This may vary from engines but this is a basic guideline. Increasing idling degrees usually result in higher RPM's. Do not confuse this thinking it is what the engine needs. All you will do is lowering the air volume to bring idle down. This will result in very poor power and engine will easily die off when you put a bit of load on it. The lower the engine timing the slower the engine idles and the more idle air it requires. It will also require a slightly richer mixture. Now if you put a little load on the engine you immediately add timing which will make more power due to the rich mixture with more air. Adjusting timing is immediate and there is no mechanical delay. Now when an engine wants to hunt you can effectively control power to it without the idle control valve or throttle movement. Below is some basic ECU settings.

First adjust the timing so that at idle there is 15 degree dynamic timing and no vacuum timing.

Adjust the Idle fuel so that the engine has just enough fuel to idle constant. Do not make it too rich. It should be close to avalanche point where if you go leaner the engine will lose power. The best way to see this point is where the vacuum signal will be at its lowest point for normal engines. Any more or less fuel will results in higher vacuum. Racing cams and matrix tuning will be saver to look at A/F ratio. Idling RPM's should be on your Target RPM value. In this example 800 RPM. Notice that the green and brown graph below on RPM compensation is at zero compensation. Only the main graph determine idle fuel. Also make sure water and air compensation is zer0.

Now when the engine hunts we will use timing to control it before the idle valve needs to act. First you must understand what happens in hunting. The engine will lose power resulting in an increase in manifold vacuum. The vacuum bar will move to the right and the RPM bar will move to the left. Due to our slower timing we can increase timing to add power which will increase RPM. Adjust the Low rpm timing graph as below.

Lower rpm also brings more air in the manifold which requires a bit more fuel to make the mixture a power mix. Adjust the green and brown graph on the RPM graph ay the lower rpm range to add a certain % fuel. Note on the fuel load graph we already should have a slight increase in fuel.

Now the above adjustments will capture falling RPM's and it may now cause the idle control valve to react as well adding air. This will increase RPM above target. There is an up and down response on the idle valve control settings. As a rule we make up response faster to ensure that the engine does not stall. Then we make down response slower to prevent hunting. Will result in more vacuum which makes the vacuum bar move left and the RPM bar moving right. First we use timing again to make it slower reducing engine power.

Then less air also needs less fuel. This time we adjust the fuel load graph as the engine don't use this part for normal riding. Note however, that deceleration will cause the vacuum to move in this region. If the mixture is too lean then the engine to being jerking due to too lean mixture.

Automatic Transmissions

For automatic transmissions tuning principles are the same as above. But there are two load steps that differs for neutral and drive. After you do the neutral tuning, then put the engine in drive. The load on the engine from the transmission will cause the vacuum bar to move to the right quite a bit. RPM is controlled and will stay the same. So you need to make sure that the idle fuel will increase for the added load.

Related Links

Idle Control Wiring

Idle Control Setup

Error Codes


Settings before Tuning

When you get to this point your engine should start and idle easily and the basic settings in the startup procedure should be set. Start with a warm engine at working temperature. Remembering you have a start-up map loaded from a running vehicle.

All the sensors such as TPS, MAP sensor, water temperature etc. should be calibrated.

If you are on dyno tuning, then certain graphs must be set to zero.

Disable or set the following features so that it does not influence your basic tuning.

General Settings

Make sure you are in the right tune mode.

Your outputs should be set to ensure that cooling fans etc. operate correctly.

Engine Settings

Set this value 500 RPM higher than your max tuning RPM.

Timing Settings

Set the Maximum timing and trailing degrees to a safe level. It will protect against too much timing on the graphs while tuning.

Set these values to a min. if you are not sure use 2 and 2.5 rather. Later when the engine miss you can increase them to see if it improves the miss. Too higher values may heat the Coil drivers to a critical level.

If you installed an altitude sensor these values must be set before tuning.

Select the right tuning method. Usually the same as fuel.

Fuel Settings

This setting will prevent over fueling while tuning the graphs.

These settings will prevent the engine from cutting unexpectedly. For a rotary use 2000 RPM.

The accelerator pump sometimes influences your fueling. Especially the MAP sensor compensation if the vacuum is erratic. Always start with minimum values. If you see erratic injecting time put it on TPS only.

Select the right tuning method. Usually the same as timing.

Sensor Settings

If you plan to use the Lambda sensor and one is installed, then these settings must be on and the sensor must show your altitude pressure.

If you are doing fuel pressure control you should have set this up already. See the fuel pressure control adjustment section. If not, put the Show Graph or the sensor off if it is not connected.

Disable the battery, Lambda and POT till the tuning is done. The sensor will indicate though. If the lambda is not connected, then put the sensor off as well.

If you can tune without idle control on it will be good. Then select Not Used. You will need to ensure enough idle air to maintain engine RPM. Or you could do this tuning beforehand. But if you adjust Fuel Offset and timing, you may need to adjust the idle control again. See the idle control adjustment section.

Turbo Settings

Set a maximum value 0.1 bar above your planned maximum boost to protect the engine during tuning.

If you plan micro fuel injection with duel injectors, you will need to do some basic adjustments. See the section on dual injectors.

Related Links

ECU Setup

Error Codes


Lambda Correction

Startup Procedure

This procedure is very important as this is a universal ECU that can cater for many combinations of engines. Setting incorrect values here may damage the ECU or some of the engine components permanently. The Maps supplied by the agents are a guideline and not guaranteed to be set up correctly for your application. It is your responsibility to make sure it is setup correctly. Common failures are short circuited wires in the installation. Coil drivers are set incorrectly for internal or external coils, resulting in damaged coils or ECU drivers. Injectors stuck in open condition causing fuel to flood a cylinder and resulting in bent connecting rods. Too larger fuses resulting in damaged electrical components.

See the sub folders for explanations.


Transmission Drawings and Info

Look in the Sub folders for your transmission. If it is not there, please ask your dealer to find out if it is in the process of being developed. The info covers all the drawings and connections around the specific transmission. Please report any errors to info@spitronics.com so we can update immediately.


E22-P1 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This is one of the preferred harnesses because it contains wires for all the options on Orion2. The manual drawings for explanation is based on its wire colours. If you select another P1 harness look at the GP Priority layout for the correct wire colours.

· This old style Level 1 harness was part of the economy series and some people still prefer them today to save on expenses. The harness contains all ECU connections from the 12 Way Connector for most engine combinations.

· It has Crank TDC and CAM Home signals which is required for Full Sequential features.

Design Points to take Notice of.

· Crank and Cam sensor wires are enclosed in one shield. They share common power and earth wires. This is suitable for complex Distributor type pickups where the sensors are close together. If you use this harness where the sensors is apart you may need to splice in a separate shielded wire for the other sensor. Connect the shields together for interference protection on the spliced section. Alternatively use the E29-P1 harness instead where the 2 signals have separate shielded wires.

· TPS, Air and Water sensors also share a shielded wire. Take the shielded part as close to the sensors as possible. They share common earth wires. Solder these connections and insolate them properly.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

Wire Names and connections on this harness:

Crank (Shielded) contains:

· Crank Sensor (Green)

· Crank Sensor Reference Power (Red)

· Cam Sensor (Yellow)

· Cam Sensor Reference Power (Blue)

· Earth (Black)

Map (Shielded)

· Map Sensor (Blue)

· +5V (Red)

· Earth (Black)

Engine (Shielded)

· Water Temperature Sensor (Green)

· Air Temperature Sensor (Yellow)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

· Earth (White)

Lambda (Shielded)

· Lambda Sensor (Red)

· Earth (Blue)

Ignition Power (Red)

TPS Output signal for TCU or other systems (Yellow)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


E24-P1 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This old style Level 1 harness was part of the economy series and some people still prefer them today to save on expenses. The harness contains most ECU connections from the 12 Way Connector for most engine combinations. It does not have the Cam Home signal wires. The manual is not based on this colours. Look at the GP Priority layout for the correct wire colours.

Design Points to take Notice of.

· It has only the Crank TDC signal and not the CAM Home which is required for Full Sequential features or certain types of sensors like 24+TDC firmware. Make sure on the engine setup and firmware before you buy this harness.

· TPS, Air and Water sensors also share a shielded wire. Take the shielded part as close to the sensors as possible. They share common earth wires. Solder these connections and insolate them properly.

· All the input wires are shielded and is earthed on the ECU side with the small black lead that must be connected to the ECU earth. Never connect a shield on the engine or chassis of the car.

Wire Names and connections on this harness:

Crank (Shielded) contains:

· Crank Sensor (Blue)

· Crank Sensor Reference Power (Red)

· Earth (Black)

Map (Shielded)

· Map Sensor (Blue)

· +5V (Red)

· Earth (Black)

Engine (Shielded)

· Water Temperature Sensor (Green)

· Air Temperature Sensor (Yellow)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

· Earth (White)

Lambda (Shielded)

· Lambda Sensor (Red)

· Earth (Blue)

Ignition Power (Red)

TPS Output signal for TCU or other systems (Yellow)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


E31-P2-V2 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This old style Level 1 harness was part of the economy series Output harnesses. See the GP Priority layout for the correct wire colours.

· The harness contains all ECU/TCU connections from the 10 Way Connector for most engine or transmission combinations.

Design Points to take Notice of.

· This harness has 4 High Voltage negative drivers used for basic coils or other features.

· This harness has 4 Negative drivers used for injector drivers or other features.

· It has the Mechanical Relay Output for 2 Relays.

· It has the RPM Output for tachometers.

· The power wires to and from the relays are not included and relays and fuse boxes should be added for circuit protection. There should also be Diodes for protection wired into the harness for protecting against Inductive spikes. Ensure relay numbers are correct according to the drawing. See the power relay connections in the manual for correct wiring of these components.

Wire Names and connections on this harness:

4x HV Negative outputs (Striped Black)

4x Negative outputs (Striped Black, Striped Blue)

Mechanical Relay Output (Blue/Black)

RPM Output (Green)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


E32-P2-V2 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This old style Level 1 harness is part of the easy install series for Orion2. It contains only basic wires for the standard class firmware on Orion2. See the GP Priority layout for the correct wire colours.

· The harness contains some ECU connections from the 10 Way Connector for distributor type engine combinations.

Design Points to take Notice of.

· This harness has 1 High Voltage negative drivers used for basic coils or other features.

· This harness has 4 Negative drivers used for injector drivers or other features.

· It has the Mechanical Relay Output for 1 Relay.

· It has the RPM Output for tachometers.

· The power wires to and from the relay are included as well as one relay and inline fuse for circuit protection. There is a Diode wired into the harness for protecting against Inductive spikes. You may add separate fuse boxes for individual circuit protection.

Wire Names and connections on this harness:

1x HV Negative outputs (Black/Red)

4x Negative outputs (Striped Black, Striped Blue)

Mechanical Relay Output (Blue)

RPM Output (Green)

+12V Ignition Supply for Relay (Red)

Bat+ (Red with Ring Lug)

Earth (Black with Ring Lug)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


E33-P2-V2 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This is one of the preferred Output harnesses because it contains wires for all the options on Orion2. The manual drawings for explanation is based on its wire colours. If you select another P2 harness look at the GP Priority layout for the correct wire colours.

· This new style Level 1 harness is part of the easy install series for Orion2. The harness contains all ECU connections from the 10 Way Connector for most engine combinations.

Design Points to take Notice of.

· This harness has 4 High Voltage negative drivers used for basic coils or other features.

· This harness has 4 Negative drivers used for injector drivers or other features.

· It has the Mechanical Relay Output for 2 Relays.

· It has the RPM Output for tachometers.

· The power wires to and from the relays are included as well as relays and inline fuses for circuit protection. There is Diodes for protection wired into the harness for protecting against Inductive spikes. You may add separate fuse boxes for individual circuit protection.

Wire Names and connections on this harness:

4x HV Negative outputs (Striped Black)

4x Negative outputs (Striped Black, Striped Blue)

Mechanical Relay Output (Blue)

RPM Output (Green)

+12V Ignition Supply for Relays (Red)

Bat+ (Red with Ring Lug)

Earth (Black with Ring Lug)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


E36-P3-V2 Harness

Products that can use this harness

· Orion2, Orion, Saturn

History

· This is one of the preferred Output harnesses because it contains wires for all the options on Orion2. The manual drawings for explanation is based on its wire colours. If you select another P3 harness look at the GP Priority layout for the correct wire colours.

· This new style Level 1 harness is part of the economy series for Orion2. The harness contains all ECU/TCU connections from the 8 Way Connector for most engine or transmission combinations.

Design Points to take Notice of.

· This harness has 4 positive drivers used for Smart Coils with built in drivers or solenoids or other features.

· This harness has 2 High Voltage negative drivers used for basic coils or solenoids or other features.

· It has 2 Clean Power inputs from Relay 1 required for the positive drivers. Do not bring this power from the ignition directly or do not use the same power supplied to injectors and coils or any inductive loads. Clean power is for electronics and resistive circuits like Lambda element. On transmissions they are used with solenoids because the solenoids have freewheel diodes to eliminate spikes.

Wire Names and connections on this harness:

4x Positive outputs (Striped Red)

2x HV Negative outputs (Blue, White)

2x Clean 12V Power Supply Inputs via Relay 1 (Red)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


OT01-P1 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This new style Level 1 harness is part of the easy install series for Orion2. The harness contains most TCU connections from the 12 Way Connector for most transmission combinations.

Design Points to take Notice of.

· This harness is used with ECU applications where the RPM and TPS wires is spliced into the ECU inputs. They are not shielded and must be connected close to the ECU.

· 2 Oil temperature sensor wires are enclosed in one shield. They share a common earth wire. Some firmware will use one wire and some firmware will use the other. This is determined by the sensor value for each firmware to read as accurate as possible. On each transmission connection drawing is specified which harness and sensor connection is required. Consult the drawings in the manual for more information.

· The Map Switch and Shifter Sensor has 1K resistors built into this harness. If you use a different harness be sure to add these resistors like this harness drawing indicates.

· All the input wires are shielded and is earthed on the TCU side with the small black lead that must be connected to the TCU earth. Never connect a shield on the transmission or chassis of the car.

Wire Names and connections on this harness:

Speed/Oil (Shielded) contains:

· Speed Sensor (Blue)

· Speed Sensor Reference (Red)

· Speed Sensor Earth (White)

· Oil Temperature Sensor 2K (Green)

· Oil Temperature Sensor 10K (Yellow)

· Earth (Black)

Map (Shielded) contains:

· 4 Way Map Switch Sensor (Red)

· Earth (Blue)

Shift (Shielded) contains:

· Shifter Sensor (Blue)

· +12V Ignition (Red)(For shifter lights)

· Earth (Black)

RPM Input (Green)

TPS Input (Yellow)

Ignition Power (Orange)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


OT02-P1 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This new style Level 1 harness is part of the easy install series for Orion2. The harness contains most TCU connections from the 12 Way Connector for most transmission combinations.

Design Points to take Notice of.

· This harness is used as a standalone application where the RPM and TPS wires is shielded to connect to sensors on the engine. They come with Power and earth included for the sensor. This is handy for Carburetted engines or Diesel engines with mechanical fuel pump.

· 2 Oil temperature sensor wires are enclosed in one shield. They share a common earth wire. Some firmware will use one wire and some firmware will use the other. This is determined by the sensor value for each firmware to read as accurate as possible. On each transmission connection drawing is specified which harness and sensor connection is required. Consult the drawings in the manual for more information.

· The Map Switch and Shifter Sensor has 1K resistors built into this harness. If you use a different harness be sure to add these resistors like this harness drawing indicates.

· All the input wires are shielded and is earthed on the TCU side with the small black lead that must be connected to the TCU earth. Never connect a shield on the transmission or chassis of the car.

Wire Names and connections on this harness:

Speed/Oil (Shielded) contains:

· Speed Sensor (Blue)

· Speed Sensor Reference (Red)

· Speed Sensor Earth (White)

· Oil Temperature Sensor 2K (Green)

· Oil Temperature Sensor 10K (Yellow)

· Earth (Black)

Map (Shielded) contains:

· 4 Way Map Switch Sensor (Red)

· Earth (Blue)

Shift (Shielded) contains:

· Shifter Sensor (Blue)

· +12V Ignition (Red)(For shifter lights)

· Earth (Black)

TPS (Shielded)

· TPS Sensor (Blue)

· +5V (Red)

· Earth (Black)

RPM (Shielded)

· RPM Sensor (Blue)

· +12V Ignition (Red)

· Earth (Black)

Ignition Power (Orange)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


OT03-P2-V2 Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto, Venus, Titan

History

· This old style Level 1 harness is part of the easy install series Output harnesses. See the GP Priority layout for the correct wire colours.

· The harness contains all ECU/TCU connections from the 10 Way Connector for most engine or transmission combinations.

Design Points to take Notice of.

· This harness has 4 High Voltage negative drivers used for solenoids or other features.

· This harness has 4 Negative drivers used for solenoids or other features.

· It has the Mechanical Relay Output for 1 Relays.

· It has the RPM Output for speedometers.

· The power wires to and from the relay are included as well as one relay and inline fuse for circuit protection. There is Diodes wired into the harness for protecting against Inductive spikes.

Wire Names and connections on this harness:

4x HV Negative outputs (Striped Black)

4x Negative outputs (Striped Black, Striped Blue)

Mechanical Relay Output (Blue/Black)

RPM Output (Green)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


OT20-Comms Harness

Products that can use this harness

· Orion2, Orion, Saturn, Pluto

History

· This old style Level 1 harness is part of the easy install series Output harnesses. See the GP Priority layout for the correct wire colours.

· The harness contains TCU connections from the Comms Connector for Tiptronic feature for most transmission combinations.

Design Points to take Notice of.

· This harness is a piggyback system where the coms connector is extended so that the tiptronic buttons could be connected and the tuning software can still connect to the TCU.

· The buttons wire is shielded and share a common earth wire. You may connect any style Normally Open push buttons.

Wire Names and connections on this harness:

Buttons (Shielded)

· Up Shift Button (Blue)

· Down Shift Button (Red)

· Earth (Black)

Earth Wire for Screens and sensors (Black)

See the design drawing for thickness and lengths or wires. See the connection drawings in the specific product manual on how to connect the harness to each item it was designed for.

NB! Wires that are not connected must be isolated to prevent shorts or interference.


DB1 Positive Drivers

Due to the versatility of our products that can be used as ECU or TCU, the freewheel diodes cannot be installed like dedicated TCU systems. They are built into the harness. If you take level 1 harness or manufacture your own, then you must install these boards for the inductive loads. Especially if it is a PWM solenoid or a low resistance inductive load. Spitronics made it easy by supplying a little Diode board which is compact and can be included in the harness. If it is situated outside the car, care must be taken to seal the unit against water and dirt. You can put silicone on the board before shrinking the sleeve. Silicone will be forced between the components sealing them properly.

Below is an indication of how this board looks and the orientation of the diode stripes.

Warning: Make sure you use the correct board otherwise it will short the drivers damaging the TCU.

Above is a good practical way to solder the wires to the board. Split the sleeve of the wire without cutting it off. Then bend it sharply onto itself and solder on the I tabs. See Option 2. Make sure there are no shorts between the wires. You may also cut the wire and solder the other wire on the opposite pin from the diode. I1 to Q1 etc. See Option 1. Make this connection on the inside of the car if possible. Note that the positive board gets a negative wire on R2+ point. We use the same boards for positive and negative drivers. Only the diodes are connected the other way round and the R2+ point is different.


DB2 Negative Drivers

Due to the versatility of our products that can be used as ECU or TCU, the freewheel diodes cannot be installed like dedicated TCU systems. They are built into the harness. If you take level 1 harness or manufacture your own, then you must install these boards for the inductive loads. Especially if it is a PWM solenoid or a low resistance inductive load. Spitronics made it easy by supplying a little Diode board which is compact and can be included in the harness. If it is situated outside the car, care must be taken to seal the unit against water and dirt. You can put silicone on the board before shrinking the sleeve. Silicone will be forced between the components sealing them properly.

Below is an indication of how this board looks and the orientation of the diode stripes.

Warning: Make sure you use the correct board otherwise it will short the drivers damaging the TCU.

Above is a good practical way to solder the wires to the board. Split the sleeve of the wire without cutting it off. Then bend it sharply onto itself and solder on the I tabs. Make sure there are no shorts between the wires. See Option 2. You may also cut the wire and solder the other wire on the opposite pin from the diode. I1 to Q1 etc. Make this connection on the inside of the car if possible. See option 1. Note that the negative board gets a positive from the power relay pin 87 on R2+ point. We use the same boards for positive and negative drivers. Only the diodes are connected the other way round and the R2+ point is different.


Engine Information

Before you can set yourself or a customer up with a product, you need to get some critical information from the engine. Firmware and hardware is designed as universal devices but it may require specific firmware of hardware attachments. The following items influences the product.

1. Engine Type: (e.g. Toyota 1UZ non VVTI)

Not critical but it may save you time if you need some information on the web or have done this type before.

2. Number of cylinders: (e.g. V8, Straight 6)

This will select the type of firmware.

3. Number and Type of coils: (e.g. 1 x Distributor, 2 x Distributor, 2 x W.S, 8 x COP)

This will indicate if the specific product can handle all the coils and will influence what group of firmware to select next.

4. Does the coil or coils have built in drivers or not?

Orion has up to 6 coil drivers while Mercury2 has none. It uses external coil drivers.

5. Crank Trigger Type and Pattern

(e.g. Standard Pulses Distributor with Hall Sensor, Crank Trigger 60-2 pattern with Wheel Magnetic Sensor, 24+TDC Distributor with magnetic sensors). This is very important as firmware are grouped according to crank trigger pattern.

6. Cam Trigger Type and Pattern: (e.g. 2 x Teeth with Magnetic Sensor, 1 x Teeth with Hall Sensor)

This does not necessary change the firmware and are adjustable in most cases. Some firmware may be developed for a specific engine which means it is preprogrammed.

7. Turbo or Normally aspirated and what is the maximum boost pressure.

This is important as units are shipped with a 2.5Bar sensor. If you require more than 1.5Bar boost, then you need the next level sensor.

8. Idle control and type (e.g. 2 pin idle valve, 4 pin GM stepper, 6 pin Toyota stepper)

Stepper motors require a separate module to be connected

9. VVT or VVTI Camshafts (e.g. 1 VVT cam, 2 VVTI cams with sensors, Vanos or V-Tech)

Cam control is done in open loop and can be done with GP2 or the cam blocks in the software.

10. Throttle by wire or a petrol cable (e.g. Cable, TxW)

TxW require an external device to control. It is not done by the engine ECU.

11. Automatic Transmission (e.g. 4 Speed 4L60E, 5 Speed 5HP24 or 4 Peed Jatco RE4R01A)

Transmissions also require and external device to control it. See the TCU part in the manual.

12. Does the installer know how to fit and Tune Spitronics Devices?

This point will indicate the level of support required by the customer and then ultimately the price to the customer.

Firmware File names

Now you can select the firmware. Below is a Typical firmware file name and the description of it. Notice that Mercury2 has HEX files and Orion has Firm files. This is due to Mercury2 that requires a programmer to load the files and Orion uses a boot loader which is imbedded in the Hyperspace software.

Mercury2 ECU Combo 28 60-2 4Cyl Ver 3.5E 16_04_2019.HEX

Orion ECU Combo 28 60-2 4Cyl Ver 3.5E 16_04_2019.Firm

Mercury2 / Orion - The firmware always starts with the product name and they cannot be mixed.

ECU / TCU / TxW - Description of the type of firmware.

Combo - The Class of the firmware. Combo means it will run on different hardware classes like Advance, Intermediate etc. but with limited features in the lower classes.

60-2 - Crank Trigger Pattern

Ver 3.5E - Version number. Note that on the GP layout version numbers are important as they may differ in wiring layout.

Date - Indication of file age. Some fixes may only change the date so make sure you always use the latest versions on our Website.


Harness Level Discription

Help > ECU Engine Managment > ECU Hardware Description >

Harness Level description

To make ordering easier we categorize harness's in different groups. The price increases as the categorization level increases, however the installer will save time while carrying out the installation by opting for the more expensive Harness.

Level 1

Basic harnesses. These harness's come with a connector and the wires that go in them and predetermined lengths. The wires are marked and the colors are found on the drawings. Each installer will customize these harnesses in the car to his liking. He will add relays and fuse box wiring himself and supply all the power wires to the components like coils, injectors, fuel pump etc.

Advantages

· Cheapest option.

· Easy to customize in the car

Disadvantages

· No fuse boxes included

· No power wires included

· Long install time

Level 2

Premade complete loom untidy. These harness's come with all the connectors and the wires in one loom with predetermined lengths. The wires are marked and the colors are found on the drawings. Relays and fuses are wired into the loom which will save installation time. The loom is not tidied up yet to leave the installer the option to reroute GP output wires to different locations. The heat shrink on the connectors are supplied loosely to be tidied afterwards. There is also a roll of cloth tape provided to cover all wires neatly.

Advantages

· Easy to preparation for a customer

· Easy to customize in the car

· Saves time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher

· There is still a bit of work to tidy the harness.

Level 3

Premade complete loom tidied. These harness's are the same as level 2 but have been tidied-up for the customer. The dealer prepares the GP outputs and marks them. The heat shrink is shrunk and the loom is neatly wrapped on the open sides with cloth tape. All the customer needs to do is solder and neaten up his connectors.

Advantages

· Easy to install in the car

· Saves time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher

· Connectors need to be soldered on.

Level 4

Plug & Play loom. These harness's are the same as level 3 but has the connectors soldered on. Now this may be new connectors or the ones supplied from that engine. Not all looms will come like this as there are a big variation in connector types.

Advantages

· Easy to install in the car

· Saves time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher


Transmission Information

Before you can set yourself or a customer up with a product, you need to get some critical information on the transmission. The hardware is designed as universal devices but the firmware is specific for a certain model of transmission. The following items influences the product.

1. Transmission Model Number: (e.g. 4 Speed 4L60E, 5 Speed 5HP24 or 4 Speed Jatco RE4R01A)

If you can't get a model number, you may send photos of the case connectors or harness connector of that transmission so we may be able to identify it for you. Or you may browse through all our drawings and see if you can find a match there.

2. Stand Alone application or use with ECU application

This will select the type harness required.

3. Application details for setting up a Startup Map

This will help the customer to set up his TCU quickly. There is a Tyre calculator that helps to determine shift points.

Number of engine Cylinders

Max Speed

Max RPM

Idle RPM

Stall Speed

Tire Size - Width/Aspect/Rum

Diff Ratio

4. Does the installer know how to fit and Tune Spitronics Devices?

This point will indicate the level of support required by the customer and then ultimately the price to the customer.

Firmware File names

Now you can select the firmware. Below is a Typical firmware file name and the description of it. Notice that Mercury2 has HEX files and Orion has Firm files. This is due to Mercury2 that requires a programmer to load the files and Orion uses a boot loader which is imbedded in the Hyperspace software.

Mercury2 TCU Combo 1 Lexus A343E Ver 3.3D 16_09_2019.HEX

Orion TCU Combo 1 Lexus A343E Ver 3.3C 16_09_2019.Firm

Mercury2 / Orion - The firmware always starts with the product name and they cannot be mixed.

ECU / TCU / TxW - Description of the type of firmware.

Combo - The Class of the firmware. Combo means it will run on different hardware classes like Advance, Intermediate etc. but with limited features in the lower classes.

Lexus A343E - Transmission Model number

Ver 3.3D - Version number. Note that on the GP layout version numbers are important as they may differ in wiring layout.

Date - Indication of file age. Some fixes may only change the date so make sure you always use the latest versions on our Website.


Harnes Levels

Help > TCU Transmission Management > TCU Hardware Description > Harness Layout >

Harness Level description

To make ordering easier we categorize harness's in different groups. The price increase as level increase but the installer will save time on his side. Spitronics mostly supply Level 1 and 2 due to the product being sold in the DIY category. Some third party dealers may supply the Level 3 & 4 but Spitronics will not carry the guarantee on workmanship.

Level 1

Basic harnesses. These harnesses' come with a connector and the wires that go in them and predetermined lengths. The wires are marked and the colors are found on the drawings. Each installer will customize these harnesses in the car to his liking. He will add relays and fuse box wiring himself and supply all the power wires to the components like coils, injectors, fuel pump etc.

Advantages

· Cheapest option.

· Easy to customize in the car

Disadvantages

· No fuse boxes included

· No power wires included

· Long install time

Level 2

Premade complete loom untidy. These harnesses' come with all the connectors and the wires in one loom with predetermined lengths. The wires are marked and the colors are found on the drawings. Relays and fuses are wired into the loom which will save installation time. The loom is not tidied up yet to leave the installer the option to reroute GP output wires to different locations. The heat shrink on the connectors are supplied loosely to be tidied afterwards. There is also a roll of cloth tape provided to make all wires neatly covered.

Advantages

· Easy to preparation for a customer

· Easy to customize in the car

· Save time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher

· There is still a bit of work to tidy the harness.

Level 3

Premade complete loom tidied. These harness's is the same as level 2 but it is tidied up for the customer. The dealer prepares the GP outputs and mark them. The heat shrink is shrunk and the loom is neatly wrapped on the open sides with cloth tape. All the customer needs to do is solder and neaten up his connectors.

Advantages

· Easy to install in the car

· Save time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher

· Connectors need to be soldered on.

Level 4

Plug & Play loom. These harness's is the same as level 3 but it also has the connectors soldered on. Now this may be new connectors or the ones supplied from that engine. Not all looms will come like this as there are a big variation in connector types.

Advantages

· Easy to install in the car

· Save time during installation in the car

· Eliminate errors in wiring

Disadvantages

· Price is higher


Harness Part Number Explanation

Help > TCU Transmission Management > TCU Hardware Description > Harness Layout >

Harness Part Number Explanation

 | Product |  | Type |  | Description |  | Description |  | Class |  | Model |  | Level
M | Mercury2 | E | ECU |  |  |  |  | X | Export | 02 | Number | 2 | Level
 |  | T | TCU | W | With ECU |  |  | X | Export | 02 | Number |  |
 |  |  |  | S | Standalone |  |  | X | Export | 02 | Number |  |
 |  | I | Injector | S | Straight | 4 | 4Cyl | X | Export | 1 | Number | 2 | Level
 |  |  |  | V | V-Type | 6 | 6Cyl |  |  |  |  |  |
 |  |  |  |  |  | 8 | 8Cyl |  |  |  |  |  |
 |  | C | Coil | S | Straight | 4 | 4Cyl | X | Export | 1 | Number | 2 | Level
 |  |  |  | V | V-Type | 6 | 6Cyl |  |  |  |  |  |
 |  |  |  |  |  | 8 | 8Cyl |  |  |  |  |  |


Harness Part Number Selection

Help > TCU Transmission Management > TCU Hardware Description > Harness Layout >

Harness Part Number Selection

Level 2 Main product harness

Easy Install Harness
 | ECU | TCU with ECU * | TCU Stand-Alone **
Mercury2 | MEX02-2 | MTWX02-2 | MTSX02-2

* This unit is used with an ECU. The TPS and RPM input wires are single wires and must be connected on the ECU signals inside the car.

** This unit is used on diesels or where no ECU signals are present. The TPS and RPM sensor wires have power and earth in a screen wire and is connected in the engine bay on separate sensors.

Mercury2 ECU Level 2 Add-on harness

Mercury2 ECU Add On Harness
 | Str 4 | Str 6 | V6 | V8
Injectors | IS4X01-2 | IS6X01-2 | IV6X01-2 | IV8X01-2
Coils | CS4X01-2 | CS6X01-2 | CV6X01-2 | CV8X01-2


ECU Comparisson Chart

ECU Features Comparison Chart

 | Orion | Mercury2 |
Hardware Inputs |  |  |
Map Sensor | 1 | 1 |
TPS Sensor | 1 | 1 |
Built In Altitude/Map Sensor (Optional) | 1 |  |
External Altitude Sensor |  | 1 |
Water Temp Sensor 2K NTC | 1 | 1 |
Air Temp Sensor 10K NTC | 1 | 1 |
Lambda | 1 | 1 |
Tuning Pot | 1 | 1 | Note 2
Fuel Pressure Sensor |  | 1 |
Dual Map Switch | 1 |  | Note 2
Battery Volts | 1 | 1 |
Crank Angle | 1 | 1 | Note 1
Cam/Home | 1 | 1 | Note 1
VVTI Cam 1 |  | 1 | Note 1
VVTI Cam 2 |  | 1 | Note 1
USB/Programmer 6Pin Molex | 1 | 1 |
Hardware Outputs |  |  |
Injector Drivers Negative Out | 4 | 8 | Note 2
Internal Coil Drivers Negative Out | 6 |  | Note 2
External Coil Triggers Positive Out |  | 8 |
RPM Output | 1 | 1 |
Electronic Relay Output |  | 1 |
Relay Output | 1 | 1 |
GP Outputs | 4 | 2 | Note 2
Features |  |  |
Graph Tuning | 1 | 1 |
Matrix Tuning | 1 | 1 |
Idle Control | 1 | 1 | Note 3
Dual Maps | 1 | 1 |
Micro Fueling or Fazed Injector |  | 1 |
Full Sequential Injector Control |  | 1 |
Injector Trimming |  | 1 |
Fuel Pressure Control |  | 1 |
V-Tech Cam Control | 1 | 1 |
VVTI Cam Control |  | X |
Launch control | 1 | 1 |
Anti-Lag control |  | X |
Flat-Shift control | 1 | X |
Boost control |  | X |
Throttle x Wire control |  | X |
RPM Calibration | 1 | 1 |
Power Management |  | 1 |
Epoxy filed |  | 1 |
Can be Epoxy filed | 1 |  |

Notes

Note 1 - Only magnetic sensors directly - Requires an external Pull-up Resistor for Hall or Optic Sensors. Cam 1 input may be used for Dual Map selection.

Note 2 - There are 6 drivers that are shared by the injectors and coils.

Note 3 - For Stepper motors external hardware is required

X - Capable - Firmware not yet developed or freely available in your country


ECU How to Choose

Help > Product Selection > Mercury2 Aplication Selection > ECU Application >

How to choose the right ECU

Choosing the right ECU the first time is important to save time and confidence. Please read this part with an open mind to help you choose wisely. Sometimes the cheapest option is not the best one and it may end up costing u more. There are two group choices to be made. Firstly, which product to choose and secondly which hardware class to choose for that product. Work through each point and narrow down your final choice.

Product Choice.

1. You need to consider your budget. Spitronics has the economy Orion and the high quality Mercury2. Mercury2 is more expensive due to protected drivers, epoxy filled enclosure, more inputs and outputs and external firing modules for coils with no intelligence. Some applications are only available in Mercury due to the complexity of the number of sensors and drive items. Orion also has a bootloader and can be reprogrammed with firmware without the need of a programmer.

2. If you have people installing the unit that does not have lots of experience, Mercury2 is definitely the choice. It does not damage easily if short circuits are made. If installed properly, Orion performs just as well as the Mercury2.

3. If you are abroad or far from Spitronics' home base, it is also best to go for the Mercury2 option. Courier and time lost could be far more expensive than the money saved with the low cost products.

4. If you require the unit to be installed under harsh conditions like an off-road vehicle with lots of vibration and dampness it is best to go for the Mercury2 unit. It is epoxy-filled for vibration and moisture. Orion can be epoxy-filled by yourselves after tuning and setting the jumpers inside should you require to do so.

5. If it is a complex engine with lots of drivers and sensors the economy range may not be adequate and you need the Mercury2 anyway. Browse through the product comparison chart to see if the product will be the right one.

6. The Orion unit, depending on the type of damage, are repairable as these units are not sealed. We do have a one year reduced exchange rate guarantee should any of the ECU's or TCU's be damaged. See the pricelist for more info or contact our dealers.

7. Coils also need to be considered. If you go for Mercury2, coils with built-in drivers are connected directly. Coils without built-in drivers require the Mercury2 Coil Driver. See how many coils you have and buy the right combination of the Coil Driver. If you decide on Orion which has built-in coil drivers, it can connect to coils with or without built-in drivers directly. Not that the connections for the different types of coils is on different wires in the harness.

Hardware Class Choice

1. If your engine has more than 1 coil or a wasted spark coil pack, you will require an Advance or Ultimate ECU. If not your engine should house a distributor with rotor to distribute the spark. Mostly older type engines.

2. If it has a distributor and more than 4 cylinders you need the Intermediate ECU for correct fuel distribution with Split-Sequential or Full-Sequential delivery. A 3 cylinder will also require the Intermediate. If you are really on a tight budget you may use a Standard system and share the injectors on the 2 drivers. Note that there is a different way to connect low and high impedance injectors. Note also that standard systems can only do trigger per event signals.

3. If your trigger in the distributor is one pulse per spark event, then you may use the Standard or Intermediate. If it has a crank trigger with TDC slot or complex distributor signal with Home pulse you will require the Intermediate ECU.

4. Make sure that there is firmware for your application for the specific ECU. Some firmware requires the abilities of Mercury2 and is not available on Orion.

5. Should you plan to do upgrades in the future buy the Advance or Ultimate ECU. You may also consider the programmer to change the firmware in the future for Mercury2.

6. Note that higher class ECU's will operate with lower class firmware for the same product. So if you buy an Advance ECU, you may start off with Standard or Intermediate firmware.

7. These hardware classes could be changed over the internet in the future following an upgrade payment. So you may buy a Standard ECU and upgrade it later to an Advance ECU. You may also consider the programmer to change the firmware in the future for Mercury2.


TCU How to Choose

Help > Product Selection > Mercury2 Aplication Selection > TCU Application >

How to choose the right TCU

Choosing the right TCU first time is important to save time and confidence. Please read this part with an open mind to help you choose wisely as sometimes the cheapest option is not the best one and may end up costing you more. There are two choices that you can make. Which product and options and which hardware class is required for that specific product and its features. Work through each point and narrow down your optimal choice.

Product Choice:

1. You need to consider your budget, Spitronics has the economy Orion and the high quality Mercury2. Mercury2 being the more expensive due to protected drivers, epoxy filled enclosure and consisting of more input and outputs. Some applications are only available in Mercury due to the complexity of the number of sensors and drive items. Orion also has a bootloader and can be reprogrammed with firmware without the need of a programmer.

2. If you have people installing the unit that does not have lots of experience, Mercury2 is definitely the choice. It does not damage easily if short circuits are made. If installed properly, Orion performs just as well as the Mercury2.

3. If you are abroad or far from Spitronics' home base, it is also best to go for the Mercury2 option. Courier and time lost could be far more expensive than the money saved with the low cost products.

4. If you require the unit to be installed under harsh conditions like an off-road vehicle with lots of vibration and dampness it is best to go for the Mercury2 unit. It is epoxy-filled for vibration and moisture. Orion can be epoxy-filled by yourselves after tuning and setting the jumpers inside should you require to do so.

5. If it is a complex transmission with lots of drivers and sensors the economy range may not be adequate and you'd need to consider the Mercury2. Browse through the product comparison chart to see if the product will be sufficient.

6. The Orion unit, depending on the type of damage, are repairable as these units are not sealed. We do have a one year reduced exchange rate guarantee should any of the ECU's or TCU's be damaged. See the pricelist for more info or contact our dealers.

7. The best way to choose your product is to see is if the unit can handle the transmissions and if there is firmware available for it. Transmissions differ more than engines and some have complicated operations. They also have different harnesses that has built in components to make installation easier for the customer.

Hardware Class Choice:

1. Only the Orion is sold in Standard Intermediate or Advance configuration, to make a low cost solution for the very common transmissions like A343E found on the 1UZ. The Standard can do 4 solenoids and does not have a speedo output for speedo calibration. The Intermediate can do 6 solenoids and speedo calibration. Advance can measure oil temperature and do line pressure compensation for temperature.

2. Mercury2 can do up to 12 solenoids with speedo calibration. It is only sold in Intermediate and Advance firmware.

3. Make sure that firmware is available for your application regarding the specific TCU. Some firmware requires the abilities of Mercury2 and is not available on the Orion.

4. Should you plan to do upgrades in the future, the Advance TCU is the obvious choice. You may also consider the programmer to change the firmware in the future for Mercury2.

5. Higher class TCU's will operate with lower class firmware for the same product. So if you buy an Intermediate TCU, you may start off with Standard firmware.

6. These hardware classes could be changed over the internet in the future following an upgrade payment. So you may buy a Standard TCU and upgrade it later to an Intermediate TCU. You may also consider the programmer to change the firmware in the future for Mercury2.


How to install and set up the Spitronics USB Driver

We used Google Chrome for the example.

1. Guide yourself to our current website www.spitronics.co.za

2. Please click on the 'Downloads' link.

3. Please Click on the 'USB Driver' link.

4.Here you can decide in which format you would want your driver. If you are unsure then click on the 'Spitronics USB Drivers.zip'.

5. On Chrome it should look like this if the download has started and finished.

6. Once the Download is done you can click on the 'Show in folder' option to navigate to the folder where it has downloaded to.

7. If you do not have a zip/rar file handler, you can find the link to a freeware application that opens the drivers. See the example below.

7.1. Most Windows' laptops should work with the 32 Bit version but if you have the 64 Bit windows installed it would be recommended to download the 64 Bit version.

If you are unsure, start with the 32 Bit version.

8. If you already have a zip/rar application installed you can skip step 7.

You can now open the zip/rar file and it should show you the content of the current open file.

9. Click on the 'extract' button to choose where you want to put the USB Drivers, so that we can install them.

10. This will allow you to save the contents of the USB DRIVERS.zip to a folder. We would recommend saving the content to a folder on your desktop and to delete it after installation.

11. Once the .zip file was extracted you can double click on the CP210xVCPInstaller_x86.exe.

If you are using 64 bit windows the installer will tell you that your windows is 64 bit and won't install. Run the CP210xVCPInstaller_x64.exe and it should install.


TCU Features Comparison Chart

 | Orion | Mercury2 | Notes
Hardware |  |  |
TPS Sensor | 1 | 1 |
RPM Sensor | 1 | 1 |
Speed Sensor | 1 | 1 |
Oil Temp Sensor | 1 | 1 |
Low Range Sensor | 1 | 1 |
Shifter Selection Switch | 1 | 1 |
Tuning Maps Selection Switch | 1 | 1 |
Tiptronic Up Switch | 1 | 1 |
Tiptronic Down Switch | 1 | 1 |
GP Outputs | 2 | 2 | Note 1
Solenoid Drivers Negative Out | 6(10) | 8 | Note 2
Solenoid Drivers Positive Out | (0)4 | 8 | Note 2
Speedo Output | 1 | 1 | Note 1
Electronic Relay Output |  | 1 |
Relay Output | 1 | 1 |
Battery Volts | 1 | 1 |
Features |  |  |
Tiptronic Function | 1 | 1 |
4 Tuning Maps | 1 | 1 |
Individual Gear Shift Profiles | 1 | 1 |
Duty Cycle Control | 1 | 1 |
Speedo Calibration | 1 | 1 |
Lockup Control | 1 | 1 |
Lockup Selectable / Gear | 1 | 1 |
Transfer Box Ratio Adjustments | 1 | 1 |
Retard Request | 1 | 1 | Note 1
Number of Gears Capable | 10 | 10 |
Power Management |  | 1 |
Epoxy filed |  | 1 |
Can be Epoxy filed | 1 |  |

Notes

Note 1 - Depends on features selected

Note 2 - These drivers are shared outputs